Руководство пользователя

Версия 2.5

ООО "Комплекс Софт"

( Телефон: +7 (863) 9281098696
* Адрес: 344012, г. Ростов-на-Дону, пр. Буденновский, 103Г
@ E-mail: sales@complexsoft.ru; support@complexsoft.ru;
: Адрес в Интернете: http://www.complexsoft.ru
: Адрес приложения: http://www.actuary.complexsoft.ru


Введение

Лирическое отступление

"Дока – специалист, знаток, мастер своего дела".
(Словарь русского языка)

Любому пользователю компьютерной техникой знакома ситуация лихорадочного поиска документа, срочно затребованного руководителем… Документ готовился в спешке несколько месяцев назад, исполнен был в одном экземпляре и казалось бы больше никогда не пригодится, поэтому был где-то сохранен и забыт. А сейчас это оказался ОЧЕНЬ ВАЖНЫЙ ДОКУМЕНТ и найти его равноценно заключению контракта на $ 1 000 000.

Обычно мы рассуждаем так: "Ничего, на моем компьютере 100-150 папок с документами, сейчас найдем… А если не на моем, а в сети… А в сети 25 (35 или 50) компьютеров с выделенными в общее пользование дисками… А может он не на общем диске, а у секретаря… или у юриста (менеджера, делопроизводителя, консультанта…). А он сейчас в отпуске (командировке, на Канарах …)". Хорошо, если где-то сохранилась "твердая копия" и документ можно сканировать или попросту перепечатать, а если оставалась только "мягкая"? Обычно исполнитель поиска (как правило, системный администратор) в такой ситуации в лучшем случае седеет, а в худшем получает сердечное заболевание (что лучше – выберите сами).
Далее следуют организационные выводы, приказания срочно навести порядок, через некоторое время все забывается, а на следующий день… см. абзац № 1.

Разрабатывая нашу автоматизированную информационную систему (АИС), мы старались избегать такого термина, как документооборот. Документооборот – это очень большая ответственность. Ответственности мы не боимся, но на настоящем этапе развития приложения, а также с учетом достаточного понимания смысла этого гордого слова включать его в название программы не стали. Пока…

Итак, что такое "Дока"? На сегодняшний день это система регистрации, хранения и контроля документов предприятия с учетом перечисленных выше недостатков. Специалистам по информационным технологиям известно, что наиболее удобным, надежным местом и способом хранения информации является база данных. Во-первых, она находится в одном месте и все, кто с ней работают, оставляют свою информацию именно здесь. Во-вторых, база данных нуждается в администрировании, т.е. регулярном обслуживании (копировании, восстановлении и ряде других сервисных мероприятий), следовательно ее поддержкой занимается квалифицированный специалист, а значит вероятность утраты информации сводится к минимуму. Вывод: для того, чтобы документы хранились в одном месте, пользователям необходимо запустить всего одно приложение. Удобное структурирование информации, ее поиск, печать, импорт, экспорт и контроль за сроками исполнения документов берет на себя "Дока"!

Конечно, возможны ситуации, когда Вы не обнаружите в системе нужной информации, но такой случай означает, что ее там никогда не было, ибо девизом всех СУБД является: "Что положишь, то и возьмешь!"
На самом деле "Дока" – не просто система регистрации и хранения документов. Почему? А вот с этого момента давайте поподробнее…


Основные термины и определения

Объект – любые здания, сооружения, комплексы зданий и сооружений, объекты инфраструктуры (железная дорога, автодорога, трамвайный путь, проезд, квартал), объекты коммуникаций (узел связи, линия связи), объекты кадастрового учета (земельный участок), всевозможные сети (ЛЭП, газопровод, нефтепровод, канализация), гидротехнические сооружения (плотина, дамба, пристань, док, пруд), объекты зеленых насаждений (парк, сад, сквер, цветник, лесополоса), отдельные помещения или встроенные объекты (цех, офис, квартира, комната) (в АИС могут являться неотъемлемой частью одного из перечисленных выше объектов и не существовать самостоятельно). Проще говоря, объектом в системе может быть абсолютно любой объект реального мира – товар, оборудование, склад, здание и т.п.

Субъект – любые субъекты. Примеры субъектов: организации, физические лица, предприниматели без образования юридического лица (может быть как организацией, так и отдельным субъектом) и т.д. и т.п.

Документ – любой документ (нормативно-правовой акт, правоприменительный акт, документ, удостоверяющий личность, технический или финансовый документ).

Класс объекта (субъекта, документа) – основной (базовый) признак объекта (субъекта, документа). Например, классы субъектов – юридические или физические лица; классы документов – нормативно-правовые акты, технические или финансовые документы; классы объектов – жилые здания, общественные здания, инженерные сети, дороги и дорожные сооружения и пр. Классы могут иметь подклассы, т.е. допускается вложенность.

Группа объектов (субъектов, документов) – дополнительный признак группировки, предназначенный для визуального структурирования информации. Как и классы, могут иметь вложенные группы (подгруппы).

Классификатор – это способ упорядочивания информация, иерархически систематизированный перечень названий классов, групп и объектов классификации, отобранных по основополагающему признаку;

Внешняя форма - это форма для ввода информации, специфичной для предметной области организации. АИС "Дока" является настраиваемой системой и может быть адаптирована (перестроена) под требования организации, в которой она эксплуатируется.

· Печатная форма - это форма для вывода документа определенного класса на печать с автоматической подстановкой в нее реквизитов связанных объектов базы данных.


Общие сведения

АИС "Дока" базируется на SQL-сервере InterBase (FireBird). Выбор этой платформы обусловлен такими ее отличительными качествами, как:

· высокая производительность и надежность сервера при минимальных требованиях к техническим средствам;
· поддержка стандарта SQL-92, обеспечивающая переносимость приложений;
· относительно низкая стоимость продукта (FireBird разрабатывается по лицензии MPL);
· простота установки и поддержки сервера. Удобный и требующий минимальной специальной подготовки механизм администрирования базы данных.

АИС построена в архитектуре "клиент-сервер", основными особенностями которой являются возможность многопользовательской работы с базой данных, перенос вычислительной нагрузки на сервер баз данных и максимальная разгрузка приложения клиента от вычислительной работы, а также существенное укрепление безопасности данных как от преднамеренных, так и просто ошибочных изменений за счет переноса большей части бизнес-правил на сервер.

Как было сказано выше, АИС не просто предоставляет возможность вести накопление и хранение документов. Наряду с этим она обеспечивает управления связями, обработкой и выводом трех основных объектов реального мира "Объект", "Субъект" и "Документ".
Вместе с тем, объекты, субъекты, документы и связи между ними сами по себе являются объектами базы данных.

Учитывая понятия перечисленных нами терминов, АИС "Дока" позволяет накапливать данные не только о документах, но и об объектах и субъектах, как участниках хозяйственной, финансовой и прочих видах деятельности предприятий и организаций.

Все объекты, субъекты, документы и связи между ними, структурированные и сортированные по классам, группам, статусу, состоянию и другим характеристикам, хранятся в базе данных. При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева объектов и панели списка объектов. Эти сортировки являются виртуальными и настраиваются пользователем по собственному вкусу с помощью классификаторов и справочников. Классификаторы и справочники являются самостоятельными объектами базы данных и могут быть отредактированы под собственные нужды организации.

В АИС разработана и применяется система безопасности данных, позволяющая присваивать конкретным объектам, субъектам, документам и связям между ними права на их использование (по аналогии с правами пользователей на объекты операционной системы Windows NT™). Система назначения прав позволяет сделать "невидимыми" документы, скажем, бухгалтерии для всех остальных сотрудников компании, несмотря на то, что хранятся они в единой базе данных. В зависимости от имеющихся прав пользователь может получить полный доступ к объекту базы данных (изменять, удалять, сохранять), либо лишь возможность просматривать его. В случае отсутствия прав на просмотр, объект базы данных становится невидимым для пользователя.

Разветвленная и гибкая система управления связями между объектами, субъектами и документами позволяет просматривать и отслеживать такие моменты, как, например, наличие у основного договора дополнительного соглашения к нему либо технического задания. В случае установления связей между документом и субъектом становится возможным автоматизировать, например, процесс ведения договоров компании. При этом у конкретного документа "Договор" визуально видны связанные с ним субъекты с их конкретным статусом ("Арендатор" - "Арендодатель" или "Продавец" - "Покупатель"), а при выводе договора на печать реквизиты субъектов автоматически будут подставлены в текст договора. Причем, фамилии, имена и отчества субъектов печатаются в нужном падеже ("Организация" в лице Иванова Александра Петровича). Установив связь документа "Договор" с объектом "Офис" и заполнив необходимые характеристики последнего (площадь, стоимость аренды за 1 кв.м.), получим подставленную в договор сумму за аренду помещения. Зарегистрировав в системе все помещения (объекты), сдаваемые в аренду, легко отслеживать сданные и свободные для арендаторов объекты.

Учитывая такую важную особенность некоторых видов документов, как наличие срока действия (договор, распоряжение и пр.), в системе предусмотрен режим контроля и предупреждения пользователя об истечении срока действия такого документа. В этом случае в строке состояния (статус - строке) приложения выводится информация о наличии таких документов, а у пиктограммы (иконки) самого документа появляется дополнительный значок, привлекающий внимание. В том случае, если пользователь в свойствах документа назначит собственную группу, куда документ должен будет помещен по истечении срока его действия, документ автоматически появится в этой группе (например, "Просроченные"). Об истечении срока действия документа пользователь может быть предупрежден заранее, установив необходимые параметры в настройках приложения.

Для того, чтобы сделать пользователей системы максимально независимыми от разработчиков, предусмотрен режим самостоятельного создания печатных форм для различных классов и типов документов. В АИС "Дока" используется генератор отчетов FastReport™, предоставляющий пользователю удобные средства для разработки внешнего вида печатных форм. Впоследствии эту форму можно сохранить в базе данных и использовать для печати документов. Кроме этого, есть возможность импортировать печатные формы, разработанные другими пользователями, а также экспортировать собственные.

Таким образом, с использованием АИС "Дока" без затруднений могут быть построены различные приложения, предназначенные для централизованного хранения и контроля документов предприятий, накопления информации для подразделений технической инвентаризации, кадастров и ЖКХ и пр. Модульная структура позволяет на общем ядре системы в короткий срок создать приложения необходимого функционального назначения.


Описание работы с приложением

Знакомство с интерфейсом.

Главное окно приложения.

Настройка параметров системы
Настройка ярлыков
Общие
Настройки пользователя

Панели быстрого старта

Классификаторы системы

Справочные таблицы


Знакомство с интерфейсом

Для запуска программы "Дока" необходимо в Проводнике Windows найти исполняемый файл Doka.exe и дважды щелкнуть на нем левой кнопкой мыши (или меню «Пуск – Программы – АИС "Дока"»). После этого на экране появляется окно регистрации пользователя базы данных.

Рис. 1.1

В соответствующие поля окна необходимо ввести имя пользователя, его пароль и роль (если необходимо) в базе данных. Эту информацию можно получить у администратора системы.
После запуска приложения на экране появляется главное окно системы (Рис. 1.2). Вверху главного окна находится область заголовка, которая содержит иконку и название программы. Кроме того, в области заголовка расположены стандартные для всех Windows-приложений кнопки управления окном программы: восстановить, свернуть, закрыть.

Рис. 1.2

Под областью заголовка отображается строка главного меню. Для выполнения определенной команды меню сначала следует щелкнуть мышью на имени меню, а затем в открывшемся меню выбрать необходимую команду.

Под строкой главного меню находится панель инструментов. Щелчок мышью на кнопке панели инструментов приводит к выполнению определенной команды. Кнопки на панели инструментов дублируют некоторые, наиболее часто используемые, пункты меню.

В нижней части главного окна приложения Вы найдете строку состояния (статус-строку), которая, как правило, содержит информацию справочного характера.
После выполнения какой-либо команды меню, на экране появляется рабочее окно. Размер рабочего окна, в большинстве случаев, может изменяться по желанию пользователя как посредством стандартных кнопок управления окном, так и с помощью мыши. Для этого подведите указатель к верхней или нижней границе окна (если требуется изменить высоту окна) или к правой или левой границе окна (если требуется изменить ширину окна). После того как указатель примет форму двунаправленной стрелки, нажмите левую кнопку мыши и, не отпуская ее, «растягивайте» окно до нужного размера. Можно изменить и высоту, и ширину окна одновременно. Для этого подведите указатель мыши к любому из углов окна и, когда указатель примет форму двунаправленной стрелки, «растягивайте» окно, как было описано выше.

Работая с системой, Вы можете допустить ошибку, т.е. попытаться выполнить какое-то недопустимое действие. Например, не введете значение в обязательное поле или введете значение несоответствующее типу поля. Подобных ошибок может быть много, и предугадать (учесть) их все Вы не сможете. Поэтому система сама контролирует выполнение всех необходимых ограничений в работе, т.е. сама «страхует» себя от появления ошибок.

Каждый раз, когда Вы допускаете ошибку, система выдает звуковой сигнал и выводит на экран сообщение об ошибке (Рис. 1.3).

Рис. 1.3

После того, как выведено сообщение, система переходит в режим «ожидания ответа». Т.е. пока Вы не закроете сообщение, система не позволит Вам выполнять никакие другие действия. Чтобы вернуться к работе, закройте сообщение, нажав кнопку «ОК». А затем попытайтесь выполнить соответствующее действие правильно.

Приложение организовано на основе стандартного оконного интерфейса Windows. При выборе пункта главного меню или активизации соответствующей кнопки панели инструментов (Рис. 1.4) открывается соответствующее окно программы.

Рис. 1.4

В зависимости от установленных настроек это окно может быть стыковано (докировано) с главным окном программы, либо открыто независимо от него (Рис. 1.5).

Рис. 1.5
Докированное (слева) и независимое (справа) окна программы.

Стыковать (отстыковать) окно можно вручную. Для стыковки необходимо подвести указатель мыши к области заголовка независимого окна, нажать левую кнопку и, не отпуская ее, переместить это окно на главное окно приложения. Для расстыковки указатель мыши устанавливается на вкладку докированного окна и оно выводится за пределы главного окна программы, либо по вкладке окна производится двойной щелчок левой кнопкой мыши.

С помощью пункта главного меню «Окно» Вы можете активизировать необходимое открытое окно приложения. При этом текущее активное окно помечается «галочкой» (Рис. 1.6).

Рис. 1.6
Меню «Окна»


Главное окно приложения

Главное окно содержит основные элементы управления приложением (Рис. 2.1).

Рис. 2.1

Отсюда осуществляется доступ к рабочим окнам основных объектов базы данных, изменениям параметров системы, настройкам классификаторов и справочных таблиц, а также управление внешним видом панелей главного окна.

В левой части главного окна приложения расположена панель с деревом объектов базы данных. При выборе одного из них (на Рис. 2.1 выбраны Документы) на правой панели отображается список открытых рабочих окон. Система позволяет открывать одновременно несколько таких окон, перемещение по которым осуществляется из главного окна приложения путем двойного щелчка левой кнопки мыши на выбранной пиктограмме (Документы2). Кроме этого, по щелчку правой кнопки мыши на выбранном элементе открывается контекстное меню, из которого возможно открыть новое окно, перейти к выбранному либо закрыть рабочее окно из главного окна приложения (Рис. 2.1).

Рис. 2.2

В том случае, если рабочие окна докированы (пристыкованы) к главному окну приложения (Рис. 2.2), они отображаются на главном окне закладками. Открывать ту или иную закладку можно щелчком левой кнопки мыши на ней. Кроме того, перемещаться по закладкам также возможно нажатием комбинации клавиш <Ctrl+Tab> (удерживая нажатой клавишу <Ctrl> нажимать клавишу <Tab> до момента открытия нужной закладки) или <Shift+Ctrl+Tab>.

Если произвести щелчок правой кнопки мыши на ярлыке активной (открытой) закладки, то в открывшемся контекстном меню можно осуществлять навигацию по закладкам, либо закрыть текущую (Рис. 2.2).
Еще одной особенностью работы с докированными окнами является то, что при стыковке рабочего окна с главным окном приложения их главные меню объединяются и при выборе той или иной закладки в главном меню появляются пункты меню соответствующего рабочего окна (сравните меню на Рис. 2.1 и Рис. 2.2).

В левой части строки состояния главного окна приложения находится панель индикации. Появление на этой панели пиктограммы [image] означает, что в системе имеются документы, у которых закончился срок действия. Действия пользователя в этом случае будут описаны в главе «Работа с документами». Двойной щелчок мышью по иконке откроет окно документов (или перейдет к первому открытому окну), переведет это окно в режим поиска документов, после чего будут найдены все документы, у которых закончился срок их действия.

На правой панели строки состояния отображается путь к базе данных, работа с которой ведется в текущий момент.


Настройка параметров системы

Меню "Сервис" (Рис. 2.3) предоставляет доступ к настройке основных элементов системы. Рассмотрим работу с настройками параметров приложения.

Рис. 2.3

С помощью этой команды задаются настройки для пользователя базы данных АИС "Дока".

Рис. 2.4

Для настройки параметров пользователя выберите пункт меню «Сервис–Параметры» (Рис. 2.3). В результате будет вызвано диалоговое окно, показанное на рисунке (Рис. 2.4). Окно настроек содержит в левой части дерево объектов настройки. При выборе каждого из объектов можно задавать или изменять различные настройки пользователя.


Настройка ярлыков

Настройка ярлыков для работы с различными базами данных

При работе с несколькими базами данных удобно создать отдельные ярлыки для подключения к конкретной базе данных при запуске АИС «Дока».

Настройка локального подключения к базе данных

· На рабочем столе щелкните правой кнопкой мыши и выберите в меню «Создать -> Ярлык».
· Нажмите кнопку «Обзор» в диалоговом окне выберите «Мой компьютер -> Локальный диск С: -> Program Files -> Complex Soft -> Doka -> Doka.exe».
· Нажмите кнопку «Далее», введите имя ярлыка (например, «Дока - пример базы данных») и нажмите «Готово». На рабочем столе появится ярлык «Дока - пример базы данных»
· Щелкните на нем правой кнопкой мыши и выберите в меню пункт «Свойства».

· Если база данных находится в той же папке, что и исполняемый файл Doka.exe, то в поле ярлыка «Объект» в конце строки добавьте пробел и текст –D Dokaexample.gdb. Нажмите ОК.
· Если база данных находится в другой папке или на другом диске компьютера (например, на диске Е в папке Базы данных), то в поле ярлыка «Объект» в конце строки добавьте пробел и текст –D "E:\Базы данных\Doka\Dokaexample.gdb" (кавычки используются в том случае, если путь к базе данных содержит пробелы). Нажмите ОК.

При двойном щелчке на этом ярлыке будет открыто приложение «АИС Дока» и выполнено подключение к базе данных с примерами (Dokaexample.gdb).

Настройка сетевого подключения к базе данных

В том случае, если база данных находится на другом (сетевом) компьютере, то настройка ярлыка производится несколько иначе.

Предположим, что база данных DOKA.GDB находится на компьютере с сетевым именем PTO на диске C в папке Bases. В этом случае дополнительный текст, вводимый в поле ярлыка «Объект», будет выглядеть следующим образом:

-D PTO:C:\Bases\DOKA.GDB (т.е. вводится путь к базе данных относительно компьютера РТО).

Именно таким образом можно произвести настройку сетевого подключения нескольких пользователей к единой базе данных для совместной работы.


Общие

На этой вкладке устанавливаются параметры, применяемые для всех пользователей базы данных (Рис. 2.4), за исключением пункта «Месторасположение базы данных системы». Этот пункт определяет, с какой базой данных будет работать приложение. Однако и в этом случае подразумевается, что с этой базой данных будут работать все пользователи, запустившие программу на этом компьютере и в этой сессии.

Месторасположение базы данных системы. Пользователь может воспользоваться этим пунктом в нескольких случаях:
· если ему понадобиться подключится к другой базе данных, не заканчивая работу с приложением. В этом случае он должен нажать кнопку [image] справа от поля ввода пути к базе данных. В открывшемся стандартном диалоговом окне необходимо найти новый файл базы данных, выбрать его левой кнопкой мыши и нажать кнопку «Открыть». В поле ввода появится путь к новой базе данных. После нажатия кнопок «ОК» или «Применить» появится окно регистрации пользователя базы данных (Рис. 1.1), в котором необходимо ввести имя пользователя и пароль. В случае, если данные введены правильно, система подключится к новой базе данных;
· если при регистрации введены неправильные имя пользователя или пароль. В этом случае система выводит предупреждающее сообщение (Рис. 1.3) и после нажатия кнопки «ОК» открывает главное окно приложения.

Рис. 2.5
Блокированные пункты меню

При этом в главном меню и на панели инструментов пункты и кнопки открытия рабочих окон объектов базы данных недоступны (Рис. 2.5). В этом случае пользователь должен открыть окно настройки параметров системы и произвести действия в соответствии с предыдущим подпунктом.


Общие настройки

Параметры - «Общие - Общие настройки»

На этой вкладке устанавливаются следующие параметры (Рис. 2.6):

Рис. 2.6

· периодичность проверки времени действия (минут) – числовое значение, устанавливающее промежуток времени, через который система просматривает документы для проверки срока их действия и информирования пользователя об истечении этого срока.


Адресная система

Параметры – «Общие – Адресная система»

На этой вкладке устанавливаются параметры адресной системы (Рис. 2.7). Наряду с тремя основными объектами базы данных «Документы», «Субъекты» и «Объекты» в системе используется т.н. «Адресная система» (рабочее окно «Адреса»). Ее назначение – правильное формирование адресов, на которые ссылаются основные объекты БД. Структура адреса основывается на классификаторе адресов, который представляет собой систематизированный перечень названий объектов административно-территориального деления, созданный на основе соответствующего общероссийского классификатора (ОКАТО).

Рис. 2.7
Параметры адресной системы

Данные параметры задаются для облегчения настройки адресной системы. Вы можете использовать собственный классификатор адресов, если Вас по каким-то причинам не устраивает предложенный. Для корректного функционирования системы необходимо указать, какие именно классы адресов относятся к населенным пунктам, улицам и т.п. В стандартной поставке используется следующая интерпретация настроек: например, населенными пунктами являются те классы, которые вложены в указанный класс, не являются папками и лежат на уровне на один ниже указанного.

Как это выглядит в реальности? В пункте «Виды населенных пунктов» выбран класс 1.02.01 – «Населенные пункты» (уровень 2 классификатора, является папкой)
При создании населенного пункта для выбора его типа будут отобраны классы, начинающиеся с 1.02.01., не являющиеся папками, лежащие на уровне 3. Таковыми являются: класс 1.02.01.04 – «город», 1.02.01.14 – «деревня» и т.д. Классы, относящиеся к этому уровню (3) и являющиеся папками будут проигнорированы, например, класс 1.02.01.02 – «Геоним» не будет отнесен к населенным пунктам.
Таким образом, данная вкладка служит для выбора и сопоставления соответствующих классов адресной системы.

Примечание: Геоним (geoname) – в буквальном переводе географическое название. В данном контексте название типов улиц или площадей и т.п.: улицы, переулки, проспекты, проезды, площади и т.п.

При нажатии кнопки [image] открывается диалоговое окно выбора класса объекта адресной системы (Рис. 2.8). Необходимо найти нужный параметр и нажать кнопку «Выбрать».

Рис. 2.8


Субъекты

Параметры – «Общие – Субъекты»

На этой вкладке устанавливаются параметры, связанные с особенностями создания уникальных кодов субъектов, хранимых в базе данных (Рис. 2.9).

Рис. 2.9
Параметры субъектов

Установленные пользователем параметры не влияют на режим отображения субъектов в рабочих окнах либо их взаимосвязи с остальными объектами базы данных. Они определяют внутреннюю организацию структуры хранения субъектов в базе данных, а именно обеспечивают уникальность записи о субъекте

· Генерировать код автоматически – уникальный код формируется системой;
· Генерировать код на основе ИНН (КПП) – уникальный код формируется на основе ИНН (КПП) субъекта;
· Генерировать код с помощью DLL – уникальный код формируется во внешней форме (используется только в версиях «Профессиональная» или «Разработчик») и может быть сформирован по любому желаемому алгоритму
· Использовать «Личный код» - уникальный код формируется на основе личного кода физического лица (если таковой имеется…, см. например, паспорт гражданина РФ).


Классификаторы

Параметры – «Общие – Классификаторы»

На этой вкладке устанавливаются параметры классификаторов основных объектов базы данных (Рис. 2.10).

Рис. 2.10
Параметры классификаторов

· Разделитель классификатора – может использоваться только для визуального представления разделителя. По умолчанию в классификаторах как разделитель используется точка.
· Корневой класс – параметр, влияющий на особенности отображения элементов классификатора при работе с объектами базы данных. Например, если необходимо работать только с финансовыми документами, то может быть установлен в качестве корневого класса класс «Финансовые документы» (Рис. 2.11).

Рис. 2.11
Выбор корневого класса документов

Впоследствии при создании новых документов пользователям будут доступны только финансовые документы, т.е. не будет необходимости искать требуемый класс документа по всему классификатору. Если не указано никакого класса, будет загружаться весь классификатор. То же самое относится к остальным классификаторам.


Переменные

Параметры – «Общие – Переменные»

На этой вкладке администратор может назначить собственные переменные, используемые для тонкой настройки системы (Рис. 2.12).

Рис. 2.12

Настройка этих параметров требует знаний внутренней структуры базы данных и не может быть выполнена неподготовленным пользователем. Если Вы не вполне понимаете назначение этих параметров, то не изменяйте настройки системы, установленные по-умолчанию.


Настройки пользователя

Параметры – «Настройки пользователя»

Все параметры, относящиеся к этой вкладке и вложенным уровням, определяют настройки для конкретного пользователя, работающего с базой данных. То есть, для остальных пользователей эти параметры могут отличаться. Непосредственно на этой вкладке устанавливается всего один параметр – «Язык по умолчанию».

Рис. 2.13
Настройка языка по умолчанию

Система может использоваться в многоязычной среде, и этот параметр следует выбирать исходя из наиболее часто используемых языков, на котором исполняется документ. Параметр информационный и не влияет на отображение, как документов, так и внешнего вида приложения. При создании нового документа язык документа будет установлен в зависимости от языка, выбранного и установленного пользователем на этой вкладке.

Язык документа выбирается из выпадающего списка путем прокрутки его с помощью мыши или стрелок управления курсором <Вверх> и <Вниз>. Для ускорения поиска можно набрать на клавиатуре первые буквы языка и нажать клавишу <Enter>. Если поиск по списку не производится, проверьте текущую раскладку клавиатуры.


Вид

Параметры – «Настройки пользователя – Вид»

Это параметры настройки внешнего вида приложения (Рис. 2.14).

Рис. 2.14
Настройка внешнего вида приложения

· Показывать архивы, как вложенные папки – в данной версии не используется. Предполагается использование данной настройки в будущем;
· Стыкуемые окна – этот параметр определяет возможность стыковки рабочих окон с главным окном программы. При необходимости пользователь может вручную изменять этот параметр для любого конкретного рабочего окна приложения. Для этого на любом рабочем (не главном) окне программы необходимо произвести щелчок левой кнопкой мыши на иконке в области заголовка окна (Рис. 2.15).

Рис. 2.15
Системное меню окна программы

В открывшемся системном меню необходимо снять «галочку» с пункта «Стыкуемое». После этого рабочее окно не может быть стыковано с главным окном.

· Автоматически стыковать окна – при установке этого параметра все вновь открываемые рабочие окна приложения будут автоматически стыкованы с главным окном программы, как на Рис. 2.2.
· Стиль отображения – это установка внешнего вида по умолчанию отображения объектов базы данных в рабочих окнах приложения. По аналогии с «Проводником» Windows так же может быть установлен из панели инструментов любого окна программы (Рис. 2.16).

Рис. 2.16


Объекты

Параметры – «Настройки пользователя – Объекты»

Это параметры настройки рабочего окна «Объекты».

Рис. 2.17

· Показать – параметр устанавливает возможность показа связанных объектов базы данных;
· Загрузка объектов – устанавливает режим группировки объектов, который будет установлен при открытии рабочего окна;
· Объект по умолчанию – устанавливает, какой объект будет выделен при открытии рабочего окна;
· Класс объекта по умолчанию – параметр устанавливает класс объекта, который будет активен в окне классификатора при создании нового объекта.


Субъекты

Параметры – «Настройки пользователя – Субъекты»

На этой вкладке производится настройка рабочего окна «Субъекты» для текущего пользователя.

· Показать – параметр устанавливает возможность показа связанных объектов базы данных.
· Загрузка субъектов – устанавливает режим группировки субъектов, который будет установлен при открытии рабочего окна.
· Субъект по умолчанию – устанавливает какой субъект будет выделен при открытии рабочего окна.
Класс субъекта по умолчанию – параметр устанавливает класс субъекта, который будет активен в окне классификатора при создании нового субъекта.

Рис. 2.18


Документы

Параметры – «Настройки пользователя – Документы»

На этой вкладке производится настройка рабочего окна «Документы» для текущего пользователя:

Рис. 2.19

· Показать – параметр устанавливает возможность показа связанных объектов базы данных. Панель просмотра OLE – это панель показа внедренного внешнего объекта (документа, рисунка и пр.).
· Документ по умолчанию – устанавливает какой документ будет выделен при открытии рабочего окна.
· Класс документа по умолчанию – параметр устанавливает класс документа, который будет активен в окне классификатора при создании нового документа.
· Уведомлять об истечении срока действия за … – при включении параметра указывается количество дней, оставшееся до завершения срока действия документов, для заблаговременного информирования пользователя.
· Переводить просроченный документ в состояние – устанавливает состояние документа, в которое он будет автоматически переведен по окончании срока действия (действующий, отменен, просроченный и пр.).
· Загрузка документов – устанавливает режим группировки документов, который будет установлен при открытии рабочего окна.


Связи

Параметры – «Настройки пользователя – Связи»

Вкладка параметров настройки связей объектов базы данных.

Применять строгие правила для связей – устанавливает, что при создании связей между объектами базы данных будет применяться система ограничений, основанная на строгом использовании допустимых связей между объектами базы данных.

Рис. 2.20
Настройка параметров связей документов

Далее вводятся предпочтительные настройки для выбора классов связей при их создании. Если в настройках не указано никакого класса, то при создании связи в окне выбора класса будет выведен весь классификатор связей. Если указан предпочтительный класс связи, то в окне классификатора будут загружены только вложенные классы, начиная с указанного класса.

· Документ – Субъект – предпочтительные классы для связи документов с субъектами;
· Документ – Объект – предпочтительные классы для связи документов с объектами;
· Документ – Документ – предпочтительные классы для связи документов (в данной версии не используется, предполагается использовать в будущем);

Рис. 2.21
Настройка параметров связей субъектов

· Субъект – Документ – предпочтительные классы для связи субъектов с документами
· Субъект – Субъект – предпочтительные классы для связи субъектов;
· Субъект – Объект – предпочтительные классы для связи субъектов с объектами (в данной версии не используется, предполагается использовать в будущем);

Рис. 2.22
Настройка параметров связей объектов

· Объект – Документ – предпочтительные классы для связи объектов с документами;
· Объект – Субъект – предпочтительные классы для связи объектов с субъектами (в данной версии не используется, предполагается использовать в будущем);
· Объект – Объект – предпочтительные классы для связи объектов (в данной версии не используется, предполагается использовать в будущем).


Адреса

Параметры – «Настройки пользователя – Адреса»

Вкладка параметров настройки рабочего окна «Адреса» (Рис. 2.23).

Наряду с тремя основными объектами базы данных «Документы», «Субъекты» и «Объекты» в системе используется т.н. «Адресная система» (рабочее окно «Адреса»). Ее назначение – правильное формирование адресов, на которые ссылаются основные объекты БД. Структура адреса основывается на классификаторе адресов, который представляет собой систематизированный перечень названий объектов административно-территориального деления, созданный на основе соответствующего общероссийского классификатора (ОКАТО)

Рис. 2.23

· Корневой адрес – параметр, влияющий на особенности отображения адресов при работе с адресами в окне выбора. Выбранным значением будет ограничен верхний уровень, доступный пользователю. В случае выбора пункта «Все адреса» в меню «Вид» адресной системы или окна выбора адресов, этот параметр игнорируется.
· Адрес по умолчанию - параметр устанавливает адрес, который будет активен при открытии окна «Адреса»;
· Загрузка адресов - устанавливает режим группировки адресов, который будет установлен при открытии рабочего окна.
· Показать – устанавливает режим отображения объектов или субъектов, расположенных по адресу, выделенному в дереве адресов.


Панели быстрого старта

Параметры – «Панели быстрого старта»

Этот раздел настройки параметров используется для создания в рабочих окнах приложения дополнительных панелей инструментов, предназначенных для быстрого вызова форм создания новых объектов, субъектов, документов и адресов, наиболее часто используемых пользователем.

Все вкладки имеют единый интерфейс и элементы управления, поэтому рассмотрим настройку панели быстрого старта для рабочего окна "Объекты" (Рис. 2.25).

Рис. 2.25

Вкладка имеет окно со списком классов объектов (субъектов, документов, адресов) и кнопки управления списком ( [image] - Добавить, [image] - Изменить, [image] - Удалить, [image] / [image] - Вверх/Вниз). Нажатие кнопки "Добавить" вызывает окно выбора классов, в котором пользователь должен выбрать нужный ему класс объектов. Этот класс появляется в окне списка. При необходимости добавления новых классов операцию необходимо повторить.

После сохранения параметров в рабочем окне "Объекты" ("Субъекты", "Документы", "Адреса") появится новая панель инструментов с кнопками быстрого вызова форм создания соответствующих классов объектов (Рис. 2.24). Если соответствующее окно уже было открыто, для появления панелей (или их обновления) необходимо закрыть окно и затем снова открыть.

Рис. 2.24

Примечание: настройки панелей быстрого вызова сохраняются в базе данных индивидуально для каждого пользователя.


Классификаторы системы

Пункт меню «Сервис - Классификаторы» (или кнопка панели инструментов [image]) открывает доступ к настройке классификаторов системы (Рис. 2.26).

Согласно принятым нами терминам, классификатор - это иерархически систематизированный перечень названий классов, групп и объектов классификации, отобранных по основополагающему признаку. Классификаторы предназначены для структурирования информации, накапливаемой в базе данных.

Рис. 2.26
Выбор пункта меню "Классификаторы"

В системе разработаны стандартные классификаторы:

· «Документы» - систематизированный перечень документов, созданный на основе общероссийского классификатора управленческой документации (ОКУД);
· «Объекты» - систематизированный перечень объектов. Заполняется в соответствии с направлением деятельности организации. Например, классификатор "Здания и сооружения", созданный на основе СНиП «Здания и сооружения»;
· «Субъекты» - систематизированный перечень типов субъектов;
· «Адресный» - систематизированный перечень названий объектов административно-территориального деления, созданный на основе соответствующего общероссийского классификатора (ОКАТО);
· «Связей» - систематизированный перечень типов связей;
· «ОКВЭД» - систематизированный перечень видов экономической деятельности, созданный на основе соответствующего общероссийского классификатора (ОКВЭД);
· «Группы документов» - перечень групп документов системы;
· «Группы субъектов» - перечень групп субъектов системы;
· «Группы объектов» - перечень групп объектов системы;
· «Единицы измерения» - систематизированный перечень единиц измерения, созданный на основе соответствующего общероссийского классификатора (ОКЕИ).

Рабочее окно классификатора предназначено для его настройки под конкретную реализацию системы в соответствии с требованиями пользователя.

Все рабочие окна классификаторов имеют единообразный интерфейс, поэтому рассмотрим порядок работы с окном классификатора на примере классификатора «Документы» (Рис. 2.27).


Классификатор документов

Рабочее окно классификатора документов

Рабочее окно классификатора "Документы"

Рис. 2.27

Рабочее окно классификатора имеет стандартный интерфейс, который включает в себя строку главного меню, панель инструментов, панели дерева классов (левая панель) и списка классов (правая панель), а также строку состояния. Дерево классов, в отличие от «Проводника» операционной системы Windows, имеет табличный вид и содержит колонки «Код» и «Уровень», в которых соответственно отображаются код текущего класса и его уровень в классификаторе. Кроме того, при последовательных щелчках левой кнопкой мыши на заголовках столбцов таблицы можно отсортировать в них данные либо по возрастанию, либо по убыванию (для каждого столбца своя сортировка – Рис. 2.28). Направление сортировки показывается рядом с именем столбца. Сортировка производится в пределах текущей ветви дерева.

Рис. 2.28
Сортировка дерева классов

Кнопки панели инструментов дублируют основные пункты главного меню и при задержке на них указателя мыши показывают всплывающие подсказки с их назначением. Кнопки [image] хранят историю действий пользователя при перемещении по классификатору. Кнопка [image] позволяет показывать/скрывать допустимые связи класса в панели списка.

При щелчке правой кнопкой мыши на выбранном классе документов или на пустом месте списка объектов классификации открывается контекстное меню, из которого можно получить доступ к разрешенным действиям над объектами (Рис. 2.27).

В строке состояния показывается наименование выделенного класса документов, если выделен один класс на правой панели, количество выделенных классов, если выделено более одного класса или количество подклассов в классе, который выбран на левой панели (в дереве классов).

При выделении класса в левой панели (дереве классов) в пункте меню «Классификатор» появляется наименование текущего выделенного объекта (Рис. 2.46).

Рис. 2.46
Меню «Классификатор – Текущий (класс) уровень»

Аналогичное контекстное меню появляется при щелчке правой кнопкой мыши на выделенном объекте в дереве классов. При выборе пункта меню «Свернуть»(«Развернуть») текущий уровень классификатора сворачивается (раскрывается) (Рис. 2.47).

Рис. 2.47

Пункт меню «Изменить» открывает диалоговое окно создания (изменения) класса (Рис. 2.30).

При работе с классами в панели списка (правая панель) пользователь может вызвать контекстное меню выбранного объекта (Рис. 2.47). Пункт меню «Открыть» раскрывает текущий уровень, а для самого нижнего уровня – раскрывает текущий класс, показывая имеющиеся у него допустимые связи, внешние и печатные формы. Пункт меню «Свойства» открывает информационное окно свойств класса.

С помощью кнопки [image] или пункта меню «Вид–Показать/скрыть связи» Вы можете управлять отображением допустимых связей на правой панели окна.

Кнопка [image] или пункт меню «Классификатор–Метаданные–Метаданные класса» вызывает окно редактирования метаданных выбранного класса.

При выборе пункта меню «Удалить» открывается диалоговое окно удаления класса документов (Рис. 2.49).

Рис. 2.49
Диалог удаления класса

Будьте внимательны при удалении данных из классификатора!
Удаление класса приводит к необратимым последствиям. Восстановление ошибочно удаленного класса возможно либо путем полного восстановления базы данных из резервной копии, либо созданием нового класса, в зависимости от удаленного элемента. Например, удаление класса документов «Договор» приведет к удалению всех вложенных подклассов (договор аренды, договор банковского счета, договор дарения и пр.), допустимых, связей между классами, разработанных для документов печатных форм, а также всех документов этих классов и их связей.


Создание классов

Создание классов документов

Пункт меню «Классификатор - Создать» открывает выбор для пользователя по созданию нового класса, нового подкласса, печатной и внешней формы документа (Рис. 2.29).

Рис. 2.29
Меню «Классификатор - Создать»

Выбор пункта «Новый класс» приводит к созданию корневого класса в дереве классификатора, «Новый подкласс» создается внутри текущего класса (текущим считается класс, выделенный в дереве). «Печатная форма» предназначена для вывода класса документа на печать на основе разработанных пользователем правил. «Новая внешняя форма» – подключение новых форм (просмотров и панелей поиска) документов, созданных пользователями или разработчиками.

При выборе пункта меню «Создать – Новый класс (подкласс)» открывается форма, состоящая из двух закладок – «Общие» и «Безопасность» (Рис. 2.30).

Закладка «Общие» содержит:
· Наименование – название нового класса – назначается пользователем;
· Код по классификатору – система автоматически подставляет в поле первый свободный код в текущем уровне. На Рис. 2.30а создается новый класс верхнего (корневого) уровня классификатора, на Рис. 2.30б – новый подкласс внутри класса «Документы основные», имеющего код 2. Как видно на рисунке, код класса – владельца (2) не может быть изменен, 69 – это первый свободный код подкласса, доступный пользователю.

а)__________________________________б)
Рис. 2.30
Создание нового класса (а) или подкласса (б)

· Наименование кратко – краткое название нового класса;
· Символы кода – могут быть использованы при формировании кодов объектов (субъектов, документов, адресов)
· Является папкой – флажок, устанавливаемый в том случае, если создаваемый класс может иметь подклассы. Используется для визуализации и при выборе класса – например, папки не могут быть выбраны в качестве класса адреса. Папки выделяются в окне жирным шрифтом;
· Значок – пиктограмма класса, которой он будет показан в панелях классификатора в обычном состоянии и выделенным мышью. Выбирается пользователем из встроенного набора значков системы. Значки класса также используются при загрузке элементов, соответствующих данному классу. Например, документы данного класса в окне документов отображаются соответствующими значками.
· Тип загрузки подклассов – вариант загрузки дочерних документов, вложенных в документ данного класса. Данное поле позволяет сгруппировать дочерние документы, предварительно создав необходимые подгруппы и описав в соответствующих справочниках (Рис. 2.65), какие именно подгруппы будут использованы при загрузке вложенных документов.

Примечание: Параметр «Тип загрузки подклассов» используется не во всех классификаторах идентично. Так же как и для документов, этот параметр используется только для объектов и субъектов. Для адресного классификатора это параметр используется несколько иначе – он описывает, какие именно классы адресов загружаются при выборе адреса редактируемого класса. Например, при загрузке субъектов Российской Федерации можно загрузить населенные пункты и муниципальные образования (тип загрузки подклассов = 0 – по умолчанию), находящиеся в выбранном субъекте. Но Вы можете загрузить только населенные пункты или только муниципальные образовании, задав тип загрузки для класса субъекта РФ равным 1 или 2. Таким образом, тип загрузки для адресной системы выполняет такие же функции, как и для документов (группировку вложенных подклассов), но несколько иным способом. Вариант загрузки адресов определяется в хранимой процедуре Addressses.

Закладка «Безопасность» содержит список пользователей, для которых устанавливаются разрешения на доступ к создаваемому классу (Рис. 2.31).

Рис. 2.31

Управление правами, как правило, осуществляет администратор сервера, который создает новых пользователей системы и производит смену паролей существующих.

Работа с разрешениями для классов описана в разделе "Классификаторы - Безопасность"


Печатные формы

Работа с печатными формами

Классификатор «Документы», в отличие от всех остальных классификаторов, имеет пункт меню «Создать новую печатную форму» (Рис. 2.29). Для создания печатных форм в системе используется визуальный генератор отчетов FastReport™, который позволяет построить большинство отчетов пользуясь только мышью.

При выборе пункта меню «Создать – Новая печатная форма» открывается форма отчета (Рис. 2.35).
Форма отчета представляет собой набор элементов, описывающих то, как должен выглядеть готовый отчет. Для построения формы отчета используется визуальная среда разработки - дизайнер. В FastReport™ дизайнер - это средство разработки отчетов, сочетающее мощь, простоту и удобство использования. Интерфейс дизайнера выполнен на современном уровне с использованием панелей инструментов, расположение которых можно изменять по своему вкусу. В нашей документации мы не описываем порядок работы с генератором отчетов FastReport™. Оригинал документация включается в состав поставки АИС «Дока».

Рис. 2.35
Разработка печатной формы документа

Печатные формы создаются для каждого класса документов, который необходимо выводить на печать. Для того, чтобы создать печатную форму для конкретного класса документов, необходимо выделить его в левой панели рабочего окна (Рис. 2.36).

При этом, в правой панели (панель списка) будут показаны все печатные формы, ранее созданные для этого класса. Щелчок правой кнопки мыши на свободном месте панели списка откроет контекстное меню, из которого необходимо выбрать пункт создания новой печатной формы (Рис. 2.36). Аналогичное меню можно вызвать из главного меню рабочего окна (Рис. 2.29). После этого откроется форма отчета, описанная нами ранее (Рис. 2.35).

Рис. 2.36

После разработки новой формы отчета пользователю необходимо сохранить ее в базе данных, выбрав в дизайнере отчетов пункт меню «Файл - Сохранить». Система выведет диалоговое окно сохранения печатной формы документа, в которой необходимо ввести ее название (Рис. 2.37).

Рис. 2.37
Диалог сохранения печатной формы

При установке флажка «Использовать по умолчанию» эта печатная форма будет использована для вывода документа на печать. В панели списка форма, используемая по умолчанию для вывода на печать, отмечается специальным значком [image] (по аналогии с текущим принтером операционной системы Windows). После этого дизайнер отчетов может быть закрыт.

Ранее подготовленные пользователем печатные формы могут быть изменены. Для работы с имеющейся печатной формой необходимо выделить ее в панели списка и нажать правую кнопку мыши. При этом появится контекстное меню (Рис. 2.38).

Рис. 2.38
Контекстное меню печатной формы

Выбор пунктов меню «Открыть» или «Изменить» приводит к появлению запроса системы (Рис. 2.39).

Рис. 2.39
Диалог открытия печатной формы

При выборе переключателя «Изменить…» будет вызван дизайнер отчетов, в котором можно произвести изменения текущей печатной формы и сохранить ее. Выбор переключателя «Переименовать…» приведет к вызову диалога сохранения формы (Рис. 2.37), в котором можно изменить имя печатной формы.
Выбор пункта меню «Удалить» вызывает диалоговое окно подтверждения удаления печатной формы. После удаления восстановить форму невозможно.

Из контекстного меню можно также назначить печатную форму по умолчанию, загрузить из файла или сохранить в файл на диске. Подготовленные формы сохраняются на диске компьютера в специальном формате FastReport™ (*.fr3).


Внешние формы

Подключение внешних форм

Пункт меню «Классификатор – Создать - Новая внешняя форма» предоставляет возможность использовать в системе формы ввода информации, отличные от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы редактирования класса документа (объекта, субъекта, адреса) необходимо в окне классификатора выделить нужный класс и выбрать пункт меню создания новой внешней формы. На экран будет вызван диалог вида Рис. 2.40

Рис. 2.40

В форме диалога необходимо правильно заполнить поля:

· Наименование класса – автоматически подставляется имя класса, выделенного в классификаторе;
· Описание формы – имя формы, которое появится в панели списка классификатора для класса "Паспорт гражданина РФ";
· Форма (класс Delphi) – название класса формы в среде Delphi;
· Фрейм поиска (класс Delphi) – название класса фрейма поиска в среде Delphi;
· Форма (класс Delphi) для просмотра – название класса формы просмотра в среде Delphi; форма будет использоваться при просмотре класса, запрещенного для редактирования;
· Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма.

После подключения внешней формы "Паспорт гражданина РФ" операция создания нового документа класса "Паспорт" или вызова на редактирование существующего будет вызывать не стандартную форму документа (Рис. 3.5), а новую форму (Рис. 2.41).

Рис. 2.41

С новой формой можно совершать стандартные действия изменять, удалять и т.п. (Рис. 2.42)

Рис. 2.42

Например, выбор пунктов меню «Открыть» и «Изменить» вызовет диалог (Рис. 2.40). Кроме этого, внешнюю форму можно скопировать и вставить для другого класса документа (объекта, субъекта).


Внешние формы свойств

Пункт меню «Классификатор – Создать - Новая внешняя форма свойств» предоставляет возможность использовать в системе формы ввода информации, отличные от стандартных и позволяющие вводить дополнительную многострочную информацию об объектах (субъектах, документах, адресах, связях), например, факты оплаты за услуги, телефоны, сайты и т.п. То есть, такие формы необходимы для ввода информации вида "один-ко многим": для одного дома - много записей об оплате услуг, для одного субъекта - много записей телефонов и пр. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы редактирования класса свойств документа (объекта, субъекта, адреса) необходимо в окне классификатора выделить нужный класс и выбрать пункт меню создания новой внешней формы свойств. На экран будет вызван диалог

Рис. 2.40а
В форме диалога необходимо правильно заполнить поля:

· Наименование класса – автоматически подставляется имя класса, выделенного в классификаторе;
· Форма (класс Delphi) – название класса формы в среде Delphi;
· Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма.
· Название пункта меню, связанного с формой - заголовок пункта меню, помещаемого в раздел меню «Документ–Характеристики документа» при выделении в рабочем окне "Документы" документа соответствующего класса. Для остальных документов эти формы остаются недоступными, и пункт меню и кнопка на соответствующей панели инструментов не появляется.

С новой формой можно совершать стандартные действия изменять, удалять и т.п. Например, выбор пунктов меню «Изменить» вызовет диалог (Рис. 2.40а). Кроме этого, внешнюю форму свойств можно скопировать и вставить для другого класса документа (объекта, субъекта, связи).


Допустимые связи

Работа с допустимыми связями

Пункт меню «Классификатор - Связи» дает возможность добавить для выбранного класса допустимые связи с другими объектами базы данных (Рис. 2.43).

Рис. 2.43

В системе предусмотрен режим, предназначенный для ограничения некорректных действий пользователя при создании связей между объектами базы данных. Этот режим позволяет для заданного класса документа определить допустимый класс связываемых объектов базы данных. Например, для класса «Договор аренды» допустимыми связями могут быть классы субъектов «Арендатор» и «Арендодатель». Применение режима допустимых связей позволит пользователю связать, например, субъекта – физическое лицо с документом «Паспорт», как документом, удостоверяющим личность, и не позволит связать его с документом «Технический паспорт объекта». Для того, чтобы назначить для класса допустимую связь, ее надо предварительно создать в классификаторе взаимосвязей.

При выборе пункта меню «Добавить допустимые связи…» открывается диалоговое окно выбора класса связываемого объекта базы данных (Рис. 2.44).

Рис. 2.44
Выбор класса допустимой связи

Пользователь должен выбрать нужный класс из списка. После закрытия формы выбора класса допустимая связь появляется на панели списка (Рис. 2.36). Классы допустимых связей выглядят в виде пиктограмм соответствующих классов объектов базы данных с добавлением символа ярлыка [image].

При выборе пункта меню «Добавить допустимые связи документ – документ (владелец)» откроется диалоговое окно, аналогичное описанному выше, за исключением того, что Вам будет предложено выбрать класс документа, а не класс связи. Этот тип допустимых связей создается для обеспечения корректности создания вложенных документов при включенном режиме «Применять строгие правила для связей» (см. 2.1.12), а также может быть использован для заполнения меню «быстрого создания» вложенных документов. Во втором случае, необходимо, выбрав созданную связь на правой панели, вызвать контекстное меню и выбрать пункт «Показывать связь в меню» (Рис. 2.45). Класс документа, которому назначаются допустимые связи, будет добавлен в меню «Документ–Создать» рабочего окна «Документы», а также в меню кнопки [image] (см. раздел 3.1.2).

Рис. 2.45

Если установлен режим строгих правил для связей, то при создании документа, вложенного в другой документ, в качестве документа-владельца (т.е. документа в который будет вложен создаваемый документ) можно будет выбрать только документ, имеющий класс, указанный в допустимой связи. Если класс документа не указан как допустимый (т.е. не создана допустимая связь), то Вы не сможете выбрать данный документ в качестве владельца создаваемого документа.


Безопасность

В системе используется система безопасности данных, позволяющая присваивать конкретным объектам, субъектам, документам и связям между ними права на их использование (по аналогии с правами пользователей на объекты операционной системы Windows NT™). Права доступа применяются для пользователей, зарегистрированных на сервере Interbase.

Управление правами, как правило, осуществляет администратор сервера, который создает новых пользователей системы и производит смену паролей существующих.

Для установки разрешений необходимо выделить нужного пользователя (например, USER на Рис. 2.31) и отметить для него в нижней панели, разрешаемые или запрещаемые действия с новым классом, установив соответствующий флажки. После сохранения изменений пользователь, в нашем случае USER, не будет иметь возможности изменять документы, данного класса и удалять их. При установке запрета прав на чтение класса документы данного класса становятся невидимыми для пользователя. Если установить флажок «Применять права ко всем вложенным уровням», то разрешения распространятся на все подклассы редактируемого класса.

Рис. 2.31

Если пользователь, для которого необходимо установить права доступа, отсутствует в списке разрешений, то система предоставляет возможность добавить пользователя в этот список. Для этого надо на закладке «Безопасность» нажать кнопку «Добавить». При этом открывается диалоговое окно выбора пользователя (Рис. 2.32).

Рис. 2.32
Добавление нового пользователя

После ввода имени пользователя и нажатии кнопки «ОК» система выводит окно проверки наличия введенного имени в списке пользователей сервера InterBase (Рис. 2.33).

Рис. 2.33
Проверка имени пользователя

Если отказаться от проверки, то пользователь будет добавлен в список разрешений в любом случае. В том случае, если нажата кнопка «Да», система проверяет список зарегистрированных пользователей сервера InterBase на предмет наличия введенного имени в этом списке. Если введенное имя зарегистрировано на сервере, то оно будет добавлено в список разрешений, в противном случае система выводит предупреждающее сообщение (Рис. 2.34).

Рис. 2.34
Ошибка при добавлении нового пользователя

При этом имеется возможность исправить имя пользователя, если оно было введено неправильно, либо удалить пользователя из списка.

Если имя пользователя, добавленного в список разрешений без проверки, отсутствует в списке пользователей сервера InterBase, то назначенные для него права на доступ к объектам базы данных не будут использоваться в системе до тех пор, пока он не будет зарегистрирован в списке пользователей сервера.

Примечание:

· Если у пользователя есть права на добавление, изменение, удаление документов вообще (т.е. права в базе данных администратор предоставил полные), но не задано никаких прав на класс документа, то это означает, что пользователь не сможет работать с документами данного класса.

· При изменении прав на класс, автоматически изменяются права на все объекты (документы, субъекты, связи) данного класса в соответствии с правами на класс. Это означает, что если были установлены индивидуальные права на некоторые объекты (документы, связи, субъекты), отличные от прав на класс этих объектов (документов, связей, субъектов), то после изменения прав на классы, права на эти объекты (документы, связи, субъекты) будут переназначены на права класса для всех пользователей.

· Пользователи, не добавленные в список, не имеют никаких прав на класс.


Свойства класса

Окно «Свойства» содержит две закладки (Рис. 2.48). Закладка «Общие» (а) выводит информацию о классе (наименование, тип, код класса, владелец). Закладка «Безопасность» (б) содержит список пользователей, для которых установлены разрешения на доступ к текущему классу. Подробно действия пользователя с закладкой «Безопасность» рассмотрены в разделе "Классификаторы - Безопасность".

а)___________________________б)
Рис. 2.48
Свойства класса «Договор»


Метаданные класса

Описание метаданных класса

При создании различных внешних форм в базу данных, как правило, вносятся некоторые изменения, связанные с созданием новых таблиц и просмотров. Для корректной работы с такими таблицами (просмотрами) в системе должна присутствовать информация о них. Так, например, копирование документа (объекта, субъекта, связи, адреса) и последующая его вставка без описания структуры этого документа приведет к копированию и вставке лишь стандартной части документа (объекта, субъекта, связи, адреса). Такая ситуация часто неприемлема, так как пользователю придется заполнять «нестандартную часть» документа вручную. Чтобы избежать такой ситуации, в АИС «Дока» предусмотрена возможность описания структуры добавленных просмотров (таблиц) – метаданных. Кроме того, метаданные служат также для описания дополнительных свойств документов (объектов, субъектов, адресов).

Для описания метаданных класса документа (объекта, субъекта, связи, адреса), выделите класс на любой из панелей окна классификатора и выберите пункт меню «Классификатор–Метаданные–Метаданные класса» или нажмите кнопку [image] на панели инструментов окна. В открывшемся окне (Рис. 2.51) необходимо добавить описание метаданных (дерево метаданных расположено на левой панели окна), выбрав пункт меню «Метаданные-Добавить тип метаданных».

Метаданные могут быть двух типов:
· Описывающие реляционные отношения вида «один-к-одному»;
· Описывающие реляционные отношения вида «один-ко-многим».

Метаданные, описывающие отношения вида «один-к-одному» могут быть созданы только как первый элемент в списке метаданных. Метаданные, описывающие реляционные отношения вида «один-ко-многим» могут быть описаны в любом элементе списка метаданных. Для изменения типа метаданных выберите пункт меню (или аналогичный пункт контекстного меню) «Метаданные–Изменить тип метаданных» и выберите необходимый тип метаданных в открывшемся диалоговом окне (Рис. 2.50).
Выберите метаданные, которые Вы хотите описать (на рисунке «Метаданные») в дереве метаданных на левой панели окна щелчком левой кнопки мыши. В поле «Источник» необходимо описать, откуда (из какой таблицы или просмотра) будут получены данные для копирования в буфер документа выбранного класса, а в поле «Приемник», – в какую таблицу (просмотр) будут эти данные вставлены. В таблице задается соответствие полей таблиц источника и приемника данных. Если количество полей в источнике больше количества полей в приемнике, то при копировании в буфер будут скопированы все поля источника, а при вставке из буфера в базу данных будут вставлены только те данные, которые связаны с данными приемника. Другие скопированные данные могут быть вставлены только в текстовый документ.

Рис. 2.50

Вы можете также задать псевдоним поля источника данных, в том числе на русском языке. Этот псевдоним будет использован при вставке скопированных данных как текста, например, в текстовые документы. Необходимо также выбрать ключевое поле приемника данных. Это необходимо сделать во избежание ошибки при вставке. Ключевое поле генерируется автоматически и если не указать, какое поле является ключевым, то будет вставлен документ с точно таким же кодом, что и скопированный, а это в свою очередь приведет к ошибке сервера – не уникальности ключа. При работе с метаданными типа «один-к-одному» достаточно указать лишь первичный ключ таблицы. При работе с метаданными типа «один-ко-многим» кроме первичного ключа необходимо указывать и вторичный ключ для корректной вставки информации.

Рис. 2.51
Описание метаданных документа (пример: паспорт гражданина РФ)

В поле «Скрипт генерации кода» Вы можете задать скрипт на языке SQL для формирования кода ключевого поля документа. Если это поле не заполнено, при вставке документа из буфера его код будет сгенерирован автоматически по алгоритму АИС «Дока».
В поле «Примечание» может быть занесена любая вспомогательная информация о метаданных. Эта информация используется только для описания и не используется ни при копировании, ни при вставке документа.
Метаданные класса могут быть скопированы и перенесены на другой класс, а также удалены. Для копирования метаданных выберите пункт меню «Классификатор –Метаданные–Копировать метаданные». Для вставки метаданных используется стандартная вставка из буфера (кнопка [image], если до этого в буфер обмена были скопированы метаданные). Для удаления метаданных класса выберите пункт меню «Классификатор–Метаданные–Удалить метаданные».


Другие классификаторы

Классификаторы субъектов и объектов предназначены для структурирования субъектов и объектов базы данных.

Рис. 2.51
Классификатор объектов

Рис. 2.52
Классификатор субъектов

Классификатор адресный включает в себя перечень названий объектов административно-территориального деления и предназначен для создания правильной структуры адресов объектов базы данных.

Примечание. До начала ввода в эксплуатации системы необходимо проверить и настроить адресный классификатор. Это важно для последующего правильного формирования адресов для объектов базы данных.

Рис. 2.53
Классификатор адресов

Классификатор связей предназначен для управления связями объектов базы данных. Здесь создаются допустимые связи, классы и подклассы, описывающие статус объектов базы данных по отношению друг к другу.

Рис. 2.54
Классификатор связей

Классификатор ОКВЭД включает в себя перечень видов экономической деятельности предприятий.

Рис. 2.55

Классификатор групп документов предназначен для создания пользовательских групп, обеспечивающих удобное структурирование документов по группам. Здесь можно создать структуру предприятия для группировки документов по подразделениям, либо удобную структуру группировки документов по тематике, либо и то и другое одновременно.

Рис. 2.56

Классификатор групп субъектов предназначен для создания пользовательских групп, обеспечивающих удобное структурирование субъектов.

Рис. 2.57

Классификатор групп объектов предназначен для создания пользовательских групп, обеспечивающих удобное структурирование объектов.

Рис. 2.58

После создания пользовательских групп документов, субъектов и объектов при выборе в соответствующем рабочем окне пункта меню «Сортировать по группе» объекты базы данных распределяются по самоорганизующимся группам, появляющимся в панелях дерева и списка. Естественно, для этого каждому документу, объекту и субъекту должен быть назначена принадлежность к конкретной группе. Названия групп берутся из соответствующих классификаторов.


Объединение классификаторов

Для удобства работы пользователя в системе предусмотрена возможность объединения нескольких классификаторов в одном рабочем окне с помощью технологии drag&drop. Для этого пользователь должен открыть два классификатора, которые он хочет объединить и убедиться, что их рабочие окна являются стыкуемыми (Рис. 2.15). Затем подвести указатель мыши к области заголовка одного из рабочих окон классификатора, нажать левую кнопку мыши и не отпуская ее переместить это окно на рабочее окно другого классификатора в область панели «Папки». При этом вокруг панели «Папки» появляется серая рамка, показывающая место стыковки окон. После отпускания левой кнопки мыши система выводит диалог подтверждения (Рис. 2.59).

Рис. 2.59
Подтверждение объединения классификаторов

При положительном ответе на запрос системы два классификатора будут показаны в одном рабочем окне (Рис. 2.60). Дальнейшая работа с объединенными классификаторами ничем не отличается от описанной нами ранее. Таким образом, можно объединить в одном окне сколько угодно классификаторов, причем порядок объединения не имеет значения (один классификатор добавить к группе или наоборот). Однако, если Вы попытаетесь добавить к группе уже имеющийся там классификатор, то после подтверждения стыковки рабочее окно добавляемого классификатора останется изолированным и классификатор не будет добавлен вторично.

Рис. 2.60
Объединенные классификаторы «Субъекты» и «Документы»


Окно выбора класса

Для выбора классов в системе используется окно, показанное на Рис. 2.61.

Рис. 2.61

Окно выбора классов имеет стандартные элементы управления, доступные через строку главного меню, контекстное меню или панель инструментов. Работа с этими элементами аналогична действиям, описанным в разделе Руководства Классификатор «Документы».

Выбор классов производится выделением требуемого класса (или нескольких классов, если это допускается) в дереве классификатора и нажатием кнопки «Выбрать». Выделение класса в дереве происходит лишь в том случае, когда установлены соответствующие настройки. Например, снят флажок «Применять строгие правила для связей» в настройках пользователя, или, если этот флажок установлен, и класс связи соответствует допустимой связи. В противном случае выделения (и соответственно выбора) класса не происходит.

Поиск требуемого класса можно производить путем просмотра дерева, отсортировав его по столбцу поиска, либо с помощью строки адреса и нажатии кнопки [image] (Рис. 2.62 а).

а)______________________________б)
Рис. 2.62

В строке «Адрес» введите путь к искомому классу (не чувствительно к регистру) или код класса в формате ::xx.xx, где xx искомые коды, а :: служебные символы. Например, класс 3.1.1 «Вид на жительство» можно найти, набрав в строке поиска: «Документы, удостоверяющие личность\Личные документы\Вид на жительство\», или набрав в этой же строке его код: ::3.1.1.
Кроме этого, при нажатии на кнопку [image] панели инструментов окна выбора классов открывается панель поиска Рис. 2.62 б. Здесь необходимо задать поисковые характеристики и нажать кнопку «Найти». Найденный класс будет отображен в окне выбора.


Справочные таблицы

Пункт меню «Сервис – Справочные таблицы» (или кнопка панели инструментов [image]) открывает доступ к настройке справочных таблиц системы. При работе с приложением используется ряд справочников, описывающих отдельные свойства основных объектов базы данных. Перечень таблиц включает в себя:

· Языки;
· Валюты;
· Национальности;
· Организационно-правовые формы;
· Типы телефонных номеров;
· Состояние документа;
· Состояние субъекта;
· Состояние объекта;
· Фамилии;
· Имена;
· Отчества;
· Приоритеты документов;
· Типы загрузки объектов;
· Типы загрузки субъектов;
· Типы загрузки документов.

С учетом конкретной реализации базы данных или других условий реальной жизни, пользователь может добавлять, изменять, либо удалять данные в этих таблицах. Работа с таблицами интуитивно понятна и не требует специального описания. Исключение составляют таблицы «Фамилии», «Имена» и «Отчества».


Рабочее окно

Рабочее окно справочной таблицы

Работа со справочными таблицами интуитивно понятна и не требует специального описания. Остановимся лишь на основных моментах.
Добавление нового элемента производится путем нажатия на кнопку [image] панели инструменто или выбором соответствующего пункта меню (на рисунке "Язык-Добавить")
Изменение элемента производится путем нажатия на кнопку [image] панели инструменто или выбором соответствующего пункта меню (на рисунке "Язык-Изменить").
Удаление элемента производится путем нажатия на кнопку [image] панели инструменто или выбором соответствующего пункта меню (на рисунке "Язык-Удалить").
Для обновления информации содержащейся в таблице, необходимо нажать кнопку на панели инструментов или выбрать пункт меню "Обновить" (на рисунке "Язык-Обновить")

При активном окне можно осуществлять контестный инкрементный поиск путем набора на клавиатуре первых символов искомого слова. Например, при поиске русского языка, начните набирать на клавиатуре "р"-"у"-"с"... Курсор автоматически переместится к искомому языку - "Русский".


Фамилии

Работа со справочной таблицей "Фамилии"

Система поставляется с заранее подготовленным набором наиболее распространенных фамилий (около 4500), имен (около 900) и отчеств (около 1300), которые используются в работе с субъектами – физическими лицами. Каждая из фамилий, имен или отчеств хранится в базе данных системы в виде набора данных, заполненных с учетом падежей русского языка (мужские и женские). Это сделано для того, чтобы при выводе на печать подготовленной формы документа реквизиты субъектов подставлялись в выходной документ в удобочитаемом виде. Обычно при работе с базами данных фамилия, имя и отчество физического лица заполняется в именительном падеже, например, Соколов Виктор Александрович. При таком виде хранения данных при последующем выводе на печать и автоматической подстановке в текст документа реквизитов субъекта мы можем получить выражение вида «Организация «Комплекс Софт» в лице сотрудник а Соколо в Викто р Александрови ч». В нашем же случае мы получим подставленные в текст реквизиты в родительном падеже (в лице сотрудник а Соколо ва Викто ра Александрови ча).

Внешний вид форм справочных таблиц единообразен. При выборе в меню «Сервис – Справочные таблицы - Фамилии» на экране будет представлена форма (Рис. 2.63).

Список фамилий показывается на форме в двух цветах: красном – женские, синим – мужские. Разделение по полу субъекта используется в связи с тем, что мужские и женские фамилии склоняются по-разному (сравните склонение фамилий – Бабурин (муж.) и Бабурина (жен.) или Акопян). Исключениями являются некоторые фамилии, которые для мужчин и женщин склоняются одинаково (например, Бабенко).

Рис. 2.63

Для добавления новой фамилии пользователь должен нажать кнопку [image] панели инструментов, изменения - [image], удаления [image]. При добавлении или изменении фамилии на экран выводится форма (Рис. 2.64).

Рис. 2.64
Изменение фамилии

Пользователь должен ввести фамилию в поле «Именительный». Заполнение остальных полей формы производится автоматически специальной процедурой.

Внимание! В том случае, если фамилия не является распространенной, проставленные системой окончания фамилий могут оказаться неправильными. Пользователь должен ввести правильные значения в поля формы и сохранить изменения.


Типы загрузки объектов

Работа со справочной таблицей "Типы загрузки объектов"

Справочные таблицы «Типы загрузки объектов» (субъектов, документов) определяют вариант загрузки дочерних объектов (субъектов, документов), вложенных в другой объект (субъект, документ). Данные таблицы позволяют описать группировку дочерних объектов (субъектов, документов), назначив корневой класс загрузки подгрупп дочерних объектов (субъектов, документов) (Рис. 2.65), который определит, какие именно подгруппы будут использованы при загрузке вложенных объектов (субъектов, документов).

Рис. 2.65

Например, Вы можете сгруппировать конструктивные элементы и квартиры, входящие в состав объекта здание как дочерние по разным группам. Без группировки все вложенные объекты будут загружены в порядке создания, что часто неинформативно. Сгруппировав вложенные объекты по группам, Вы получите более удобный (и логичный) способ описания здания. Подробнее о создании вложенной группировки описано в разделе "Создание вложенной группировки"


Создание вложенной группировки

Пример создания вложенной группировки элементов здания

Для создания структуры группировки элементов здания и ее привязки к конкретному классу объектов необходимо выполнить следующие действия:

· в классификаторе групп объектов создать необходимую Вам группировку (Рис. 1.2);
· в справочной таблице типов загрузки объектов создать новый тип загрузки и указать для него в качестве класса пользовательской группы объектов класс созданной Вами группировки элементов зданий с кодом 3 (Рис. 1.3);

Рис. 1.2

Рис. 1.3

· в классификаторе объектов выбрать класс объекта, для которого создается структура группировки, открыть его для редактирования и ввести в поле «Тип загрузки подклассов» номер созданного Вами типа загрузки (Рис. 1.4).

Рис. 1.4

В последующем при создании нового объекта этого класса в нем автоматически создается вложенная группировка элементов.

Таким образом, средства системы позволяют пользователю вести структурированное накопление информации и легко ориентироваться среди множества разнородных объектов.


Рабочие окна приложения

Меню «Регистрация» (Рис. 3.1) предназначено для открытия рабочих окон основных объектов базы данных.

Рис. 3.1

Система обеспечивает структурированное накопление информации об основных участниках хозяйственной или иной деятельности предприятия и содержит описания объектов реального мира "Объект", "Документ", "Субъект" в соответствии с принятыми нами терминами. Для открытия требуемого рабочего окна необходимо выбрать соответствующий пункт меню «Регистрация», либо нажать аналогичную кнопку панели инструментов главного окна.


Документы

Описание рабочего окна.
Создание нового документа
Копирование / вставка документа
Удаление документа
Вставка внедренного (OLE) или графического объекта
Создание связи документа с другим документом
Создание связи документа с субъектом
Создание связи документа с объектом
Печать документов
Предварительный просмотр документов
Поиск документов
Дополнительные характеристики документа
Окно выбора документов
Использование фильтров документов
Дополнительные свойства документа
Импорт документов


Описание рабочего окна

На Рис. 3.2 представлен внешний вид рабочего окна «Документы», а также его основные элементы управления.

Рис. 3.2
Элементы управления окна "Документы"

1. Создать новый документ;
2. Изменить документ;
3. Удалить документ;
4. Свойства документа;
5. Предварительный просмотр;
6. Печать;
7. Показать дерево документов;
8. Поиск документов;
9. История;
10. Настройка стиля отображения панели списка;
11. Включить фильтр;
12. Отключить фильтр;
13. Задать условия фильтрации;
14. Изменить OLE объект;
15. Показывать связи с объектами;
16. Показывать связи с субъектами;
17. Показывать связи с документами;
18. Связать с объектом;
19. Связать с субъектом;
20. Связать с документом;
21. Перейти к предыдущему;
22. Вверх на один уровень;
23. Название столбца (панель сортировки);
24. Количество документов в группе;
25. Дополнительные характеристики документа;
26. Текст документа
27. Панель быстрого запуска.

Левая панель рабочего окна содержит дерево документов базы данных. Если активировать конкретный документ в левой панели, то в правой будет выведен список связанных с ним объектов, субъектов и других документов. Отображаемые элементы зависят от режима отображения. Возможно задавать раздельное отображение связанных документов (меню «Вид – Показать/скрыть связи – Показывать связи с документами»), связанных субъектов («Вид – Показать/скрыть связи – Показывать связи с субъектами») или связанных объектов («Вид – Показать/скрыть связи – Показывать связи с объектами»).

Режим отображения документов при запуске приложения определяется настройками системы (Рис. 2.19).

Кнопки панели инструментов рабочего окна не являются статичными. Их состояние и состав динамически изменяются в зависимости от активности документа и связанных с ним объектов базы данных.

При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил документ в базу данных, а у другого пользователя отсутствует информация об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (F5) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка документов с сервера и обновит ее в рабочем окне. При этом обновятся и все связи.

Для перемещения по списку документов используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки [image] и [image].

На панелях рабочего окна пользователю доступны контекстные меню, вызываемые щелчком правой кнопки мыши (Рис. 3.3).

а)_________________________________б)
Рис. 3.3
Контекстные меню окна "Документы"

Из контекстного меню панели дерева документов (рис.3.3а) пользователь получает возможность изменить активный документ, удалить его или просмотреть и изменить его свойства.

Пункт меню «Группировка документов» дает возможность сортировать документы:

· По классу – в соответствии с классами, назначенными в классификаторе документов, при этом значки классов документов всегда отображаются как папки, а значки документов отображаются в соответствии с классом;
· По группе – в соответствии с пользовательскими группами, назначенными в классификаторе групп документов;
· По состоянию – в соответствии с состояниями документа, назначенными в справочнике состояний документа;
· Отсутствует – без группировки.

При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева объектов и панели списка объектов. Наименования групп выбираются из соответствующих классификаторов и справочников системы.
На Рис. 3.2 в левой панели документы отсортированы по пользовательским группам.

Пункт меню «Свойства» открывает информационное окно свойств документа. Для документов, объектов и субъектов в этом окне содержится информация о владельце – пользователе, создавшем данный объект базы данных.

Контекстное меню панели списка объектов базы данных (Рис. 3.3б) дает возможность:

· Открыть – открыть рабочее окно объекта базы данных, на который указывает связь и перейти в него. Тот же результат будет достигнут, если на связи с объектом БД произвести двойной; щелчок левой кнопкой мыши;
· Изменить – изменить класс связи или связь объекта базы данных;
· Удалить – удалить документ или его связь с объектом базы данных;
· Скрыть/показать панель просмотра внедренного объекта (OLE);
· просмотреть и изменить свойства документа или связи с объектом базы данных.

Панель дерева документов имеет табличную структуру. Щелчком левой кнопки мыши на выбранном столбце можно отсортировать в нем данные по возрастанию, либо по убыванию (выноска 23 Рис. 3.2). В столбце «Номер» показывается номер текущего документа. Для группы документов в этом столбце в угловых скобках указывается количество документов в соответствующей группе (выноска 24 Рис. 3.2).

Документ с истекшим сроком действия маркируется специальным значком [image], привлекающим внимание пользователя (см. активный документ на Рис. 3.2). Наличие этого значка в строке состояния рабочего окна означает, что в системе имеются документы, у которых истек срок действия. Быстрый доступ к таким документам можно получить, дважды щелкнув кнопкой мыши на этом значке, либо отсортировав документы «По состоянию» (Рис. 3.3). Все документы с истекшим сроком действия будут автоматически сгруппированы в группе «Просроченные», если это задано в параметрах пользователя.

На панели инструментов окна «Документы» расположена адресная строка. В строке редактирования «Адрес» показан текущий уровень документа в виде строки, в которой уровни документов перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» строку, описывающую путь к другому документу, и, нажав кнопку «Перейти», Вы попадете на заданный документ. В случае ошибки во введенной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому документу не произойдет.


Создание документа

Создание (изменение) документа

Добавить новый документ пользователь может выбором пункта меню рабочего окна «Документ – Создать – Новый документ» либо нажатием кнопки [image] на панели инструментов. Пользователю будет предложено выбрать класс создаваемого документа по классификатору (Рис. 3.4).

Рис. 3.4
Выбор класса документа

После выбора класса документа на экран будет вызвано соответствующее диалоговое окно. Это же окно будет вызвано при изменении документа. Если нет внешних форм для данного класса документа, то будет вызвано стандартное диалоговое окно (Рис. 3.5), состоящее из трех закладок.

Рис. 3.5
Новый документ – Общие сведения

На закладке «Общие» пользователь должен ввести в соответствующие поля окна сведения о дате и номере документа, его полном и кратком наименовании, определить тип документа по классификатору, а также период его действия.

Если поля периода действия документа не будут заполнены, то система не будет отслеживать истечение срока действия документа и предупреждать об этом пользователя. Флажок «Завершен» устанавливается в том случае, когда пользователь принимает решение снять просроченный документ с контроля (например, завершенный договор).

Использование поля «Документ является неотъемлемой частью документа» производится в том случае, когда регистрируемый документ не может существовать самостоятельно (например, приложение к договору). В этом случае необходимо нажать кнопку [image] и выбрать главный документ (владелец).

Примечание. Использование подчиненных документов влечет за собой некоторые ограничения. Например, нельзя выбрать разные группы для главного и подчиненного документов, при сортировке по классу документа, сортировка всегда производится только по классу главного документа и т.п. Если Вам необходимо, чтобы два документа были в разных группах (например, группа «Документы 2005 года» и «Документы 2006 года»), то не подчиняйте документы друг другу, а воспользуйтесь возможностью сослаться на документ. С помощью ссылок Вы всегда сможете найти связанный документ.

Рис. 3.6
Подчиненный документ

Подчиненный документ будет отображен в дереве документов и «привязан» к главному документу (Рис. 3.6).

Закладка «Дополнительно» (Рис. 3.7) предоставляет возможность:

Рис. 3.7
Новый документ – Дополнительно

· Установить состояние документа путем выбора из выпадающего списка. Новое состояние документа можно создать, вызвав справочник состояний документа нажатием кнопки [image];
· Установить принадлежность документа к пользовательской группе. Для этого необходимо нажать кнопку [image] и в открывшемся окне выбрать группу из классификатора групп документов (Рис. 3.8);

Рис. 3.8
Выбор группы документов

Для удаления принадлежности документа к группе необходимо установить курсор в поле «Принадлежит к группе» и нажать клавишу <Delete>;

· Установить язык документа. В том случае, если язык документа установлен в параметрах системы (Рис. 2.13), то это поле заполняется автоматически;
· Установить приоритет документа. Новый приоритет документа можно создать, вызвав справочник приоритетов документа нажатием кнопки [image];
· Местонахождение документа – текстовое поле, в котором указывается место хранения оригинала документа;
· Комментарий – поле для заметок пользователя.

Закладка «Безопасность» позволяет установить права доступа к создаваемому документу.

Создавать документы можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.


Изменение документов

В случае, когда Вам необходимо изменить параметры сразу нескольких документов, выделите их на правой панели рабочего окна (рис. 3.2) с помощью мыши и клавиш клавиатуры (Shift, Ctrl). Затем, нажмите кнопку [image] или выберите пукнт меню "Документ - Изменить". В открывшемся диалоговом окне, Вы можете изменить сразу несколько параметров, имеющихся у всех документов: класс, группу, дату, приоритет, состояние или принадлежность какому-либо документу, даты начала и окончания и т.п.

Вы можете изменить только одно свойство или сразу несколько. Для того, чтобы значение параметра было изменено на заданное Вами, необходимо включить флажок "Заменить" напротив изменяемого параметра. В качестве эталонного свойства принимается свойство одного из изменяемых документов, загруженного в базу данных раньше остальных выделенных. Как правило, это первый по алфавиту документ. В любом случае, Вы можете изменить значение свойства по своему усмотрению.
Если Вы ошиблись и выбрали больше, чем требовалось субъектов, это можно сделать на закладке "Список изменяемых документов".

Для удаления из списка, выделите в списке документ, который необходимо удалить и нажмите кнопку [image] на панели инструментов диалогового окна. После предупреждения, документ будет удален из списка изменяемых.
Внимание!
1. Документ не удаляется при этом из базы данных. Удаление из списка не влечет за собой никаких последствий, кроме того, что свойства этого документа не будут изменены.
2. Если у пользователя отсутсвовали права на изменение одного из документов, свойства этого документа не будут изменены, несмотря на то, что он присутствовал в списке изменяемых.


Копирование / вставка документа

Любой выделенный пользователем документ может быть скопирован в буфер обмена и затем вставлен в базу данных. Эта возможности системы полезна в тех случаях, когда пользователь обрабатывает множество однотипных документов, мало отличающихся друг от друга.

Примечание: Если Вы используете нестандартные формы документов (Паспорт, Диплом и пр.), то перед использованием этой возможности Вам необходимо создать метаданные для этих классов документов (подробно см. соответствующий раздел Руководства).

Режим копирования/вставки ничем не отличается от действия пользователя при работе с приложением «Проводник» (Explorer) операционной системы Windows. Для копирования (вырезания) документа необходимо выделить его в панели дерева или списка документов и в контекстном меню или панели инструментов выбрать кнопку «Копировать» («Вырезать») Рис. 3.10.

Рис. 3.10
Копирование документа в буфер обмена

Вставка документа происходит аналогичным образом, однако имеет некоторые особенности:

· При примененной группировке документов «по группе» или «по состоянию» и выборе пользователем конкретной группы в качестве нового местоположения документа он будет вставлен в выбранную группу и автоматически получит принадлежность к новой группе или новое состояние;
· Если перед вставкой был выделен какой-либо документ, то новый документ будет вставлен в виде вложенного в него документа;
· Если документ был вырезан, то при вставке в новое местоположение он удаляется с прежнего места.
· При вставке документа вставляется не только копия документа, но и копии его характеристик и связей.

Вы можете ограничить вставку только необходимыми элементами. Например, Вам необходимо вставлять только сам документ, но нет необходимости копировать все его связи, или, наоборот, Вам необходимо вставить только связи документа и т.п. Для этого служит пункт меню «Правка–Специальная вставка…». При выборе названного пукнта меню Вам будут предложены варианты вставки (Рис. 3.11).

Рис. 3.11

· Выбор варианта «Всё» приведет к вставке копии документа, его связей и характеристик (полностью аналогичен выбору пункта меню «Правка–Вставить»);
· При выборе пункта «Документ» будет вставлена только копия документа;
· Выбор пунктов «Связи» и «Характеристики» приведет к вставке только связей или только харакетристик соотвественно;
· При выборе пункта «Свойства документа» свойства скопированного документа будут полностью перенесены на текщий, выделенный документ. Если были описаны метаданные класса, то все свойства будут полностью перенесены с учетом метаданных.

Внимание!
При переносе свойств документа на другой документ будьте внимательны! Если документы имеют разные классы и, тем более, разные метаданные, это может привести к некорректной работе программы. Результат такого действия может существенно отличаться от того, что Вы ожидали увидеть. Если Вы хотите изменить свойства документа, сначала измените его класс на требуемый, после чего можете вставлять скопированные свойства.


Удаление документа

Документ, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить документ, нужно выполнить следующие действия:

· Выделить документ, который Вы хотите удалить, в дереве документов на левой панели рабочего окна;
· Нажать кнопку [image] на панели инструментов, выбрать пункт меню «Документ – <Текущий документ> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном документе);
· После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Возможно также удаление группы документов, когда они сгруппированы по какому-либо из параметров - состоянию, классу или пользовательской группе. Для удаления, выделите группу документов на левой панели рабочего окна и нажмите кнопку [image], в результате чего будет выведено диалоговое окно

Если вы хотите только вывести документы из группы, не удаляя самих документов, выберите пункт "Удалить только группу". Если же Вы хотите удалить и группу и все документы, находящиеся в ней, выберите пункт "Удалить группу и все документы в группе". Если Вы передумали удалять группу документов, нажмите кнопку "Отменить".

Внимание!
После удаления, восстановление документа(ов) будет невозможно. Кроме того, удалятся все связи этого документа с объектами, субъектам и другими документами. Если Вы не уверены в правильности Ваших действий, не удаляйте документ.


Безопасность

Закладка «Безопасность» (Рис. 3.9) позволяет установить права доступа к создаваемому документу.

Рис. 3.9
Новый документ – Безопасность

Подробно установка параметров безопасности для класса документа рассмотрена нами в разделе "Классификаторы - Безопасность". Права на текущий документ выставляются абсолютно идентично правам на классы.

При создании документа для его создателя (т.е. пользователя, создавшего документ) предоставляются все права на этот документ. Для остальных пользователей права на созданный документ будут предоставлены в соответствии с правами на класс документа. Вы можете предоставлять индивидуальные права на документ, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права документа этого класса полностью заменяются правами на класс.


Свойства документа

Свойства документа (субъекта, объекта)

Закладка «Общие» выводит информацию о документе (наименование, тип (класс документа), владелец).

Закладка «Безопасность» содержит список пользователей, для которых установлены разрешения на доступ к текущему документу. Подробно действия пользователя с закладкой «Безопасность» рассмотрены в разделе "Документы-Безопасность".


Внедренные объекты

Внедренные объекты удобны для хранения так называемой истории объекта. Например, у объекта – жилое здание с течением времени могут меняться некоторые его важные свойства (жилая площадь – вследствие перевода жилых помещений в офисные и пр.). Эти изменения отражаются в базе данных и технический паспорт объекта на текущий момент будет содержать последние измененные данные. Для сохранения старого технического паспорта, актуального на определенную дату до момента изменений, можно вставить его в OLE – контейнер. Внедренный объект можно изменять или удалять из базы данных.

Кроме того, внедрение может использоваться как база данных существующих документов. Вам не обязательно переводить все существующие документы в формат "Дока", гораздо эффективнее создать как бы их заголовки или карточки картотеки (документы АИС "Дока") и внедрить в них документ. Это позволит с наименьшими затратами времени перенести Вашу документацию в базу данных, что существенно повысит безопасность и надежность работы с ней, не говоря уже об удобствах.

В качестве альтернативы внедренным объектам пользователь может использовать дополнительное свойство "Текст документа".


Вставка внедренного объекта

Вставка внедренного (OLE) или графического объектов

Система позволяет хранить оригиналы документов в базе данных с использованием стандартной технологии Windows – OLE 2.0. В качестве OLE-объекта в документ может быть вставлен любой объект – рисунок, документ Word или Excel, документ САПР или ГИС и пр. Для вставки OLE-объекта пользователь должен активизировать нужный документ щелчком левой кнопки мыши, выбрать пункт меню «Документ – изменить объект (OLE)» или нажать соответствующую кнопку панели инструментов (выноска 14 рис.Рис. 3.2). На экран будет выведен диалог выбора типа внедряемого объекта (Рис. 3.11).

Рис. 3.11

Пользователь имеет возможность выбрать тип объекта:

· Внедрить OLE-объект – объект, ассоциированный с каким-либо приложением операционной системы. Одной из «неприятных» особенностей внедрения такого типа объектов является то, что они будут недоступны на компьютере, не имеющем установленного приложения, с которым были ассоциированы;
· Внедрить графический объект – графические файлы форматов: jpg, bmp, ico, emf, wmf;
· Внедрить файл – любой файл.

Для вставки OLE-объекта на экран выводится форма (Рис. 3.12).

Рис. 3.12
Панель вставки OLE-объекта

Выбор пункта меню «OLE объект - Вставить» или нажатие кнопки [image] панели инструментов вызывает форму вставки объекта (Рис. 3.13).

Рис. 3.13
Вставка OLE-объекта

Для выбора нужного объекта, сохраненного на диска компьютера, необходимо включить флажок «Создать из файла», нажав кнопку «Обзор», найти в диалоге выбора необходимый объект (например, документ Word), выбрать его и нажать кнопку «ОК». Объект будет открыт в ассоциированном приложении (Рис. 3.14).

Рис. 3.14

После выбора пункта меню «OLE объект – Завершить редактирование» и подтверждения сохранить изменения объект будет сохранен в базе данных и появится в панели просмотра OLE (Рис. 3.2).

Для вставки графического объекта на экран выводится форма (Рис. 3.15).

Рис. 3.15

Графический объект может быть загружен из файла или вставлен из буфера обмена. После нажатия кнопки «Сохранить» он появится в панели просмотра OLE. В отличие от внедренного OLE – объекта графический объект может быть сохранен (выгружен) в файл.

В качестве альтернативы внедренным объектам пользователь может использовать дополнительное свойство "Текст документа".


Связь документа с документом

Создание связи документа с другим документом

Для установления связей между документами базы данных пользователь должен произвести следующие действия:

· На левой панели дерева документов найти документ, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
· Выбрать пункт меню рабочего окна «Документ – Связи – Связать с документом» или нажать кнопку [image] на панели инструментов (выноска 20 Рис. 3.2);
· В открывшемся окне «Выбор документа» найти документ, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Связанный документ будет отображен в правой панели списка среди других связанных объектов БД. Если связываемый документ еще не был внесен в базу данных, то в окне «Выбор документа» можно создать новый документ, а затем выбрать его вышеописанным способом.

Прямые и обратные связи документов отображаются в панели списка различными значками. На Рис. 3.2 у активного документа «Договор аренды» установлена связь с документом «Доп. соглашение к договору» («Договор аренды» ссылается на «Доп. соглашение» - прямая связь).

Если в панели дерева документов сделать активным документ «Доп. соглашение к договору», то на Рис. 3.6 можно увидеть отличие в отображении связей (на «Доп. соглашение» ссылается «Договор аренды» - обратная связь).

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Документ – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между документами будет разорвана. Сами документы при этом не удаляются.

Если Вы хотите быстро найти документ, связанный с активным документом, то выделите связь с искомым документом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». Связанный документ будет открыт и выделен в панели дерева документов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным документом все необходимые действия (изменение, удаление и пр.).


Связь документа с субъектом

Создание связи документа с субъектом

Для установления связей между документами и субъектами базы данных пользователь должен произвести следующие действия:

· На левой панели дерева документов найти документ, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
· Выбрать пункт меню рабочего окна «Документ – Связи – Связать с субъектом» или нажать кнопку [image] на панели инструментов (выноска 19 Рис. 3.2);
· В открывшемся окне «Выбор класса – Связь документа с субъектом» выбрать статус субъекта по отношению к документу, с которым происходит связывание. Добавление класса связей (статуса) субъектов производится в классификаторе взаимосвязей;
· В открывшемся окне «Выбор субъекта» найти конкретного субъекта, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска в данном окне можно отсортировать данные. Если связываемый субъект еще не был внесен в базу данных, то в окне «Выбор субъекта» можно создать нового субъекта, а затем выбрать его вышеописанным способом;
· Связанный субъект будет отображен в правой панели списка среди других связанных объектов БД.

Внимание!
Один и тот же субъект может быть неоднократно связан с документом, но только при условии, что его статус будет различным для каждой из связей. Если же субъект с таким статусом уже связан с данным документом, никаких действий не будет произведено, т.е. повторная связь не будет образована.
Связь документ-субъект является универсальной, т.е. название связи со стороны документа звучит так же, как и со стороны субъекта. Например, связь «Документ, удостоверяющий личность» будет так называться и в окне документов и в окне субъектов.

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Документ – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между документом и субъектом будет разорвана. Сами документ и субъект при этом не удаляются.

Если Вы хотите быстро найти субъект, связанный с активным документом, то выделите связь с искомым субъектом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Субъекты», в котором связанный с документом субъект будет открыт и выделен в панели дерева субъектов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным субъектом все необходимые действия (изменение, удаление и пр.).


Связь документа с объектом

Создание связи документа с объектом

Для установления связей между документами и объектами базы данных пользователь должен произвести следующие действия:

· На левой панели дерева документов найти документ, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
· Выбрать пункт меню рабочего окна «Документ – Связи – Связать с объектом» или нажать кнопку [image] на панели инструментов (выноска 18 Рис. 3.2);
· В открывшемся окне «Выбор класса – Связь документа с объектом» выбрать статус объекта по отношению к документу, с которым происходит связывание. Добавление класса связей (статуса) объектов производится в классификаторе взаимосвязей;
· В открывшемся окне «Выбор объекта» найти конкретный объект, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска в данном окне можно отсортировать данные. Если связываемый объект еще не был внесен в базу данных, то в окне «Выбор объекта» можно создать новый объект, а затем выбрать его вышеописанным способом;
· Связанный объект будет отображен в правой панели списка среди других связанных объектов БД.

Внимание!
Один и тот же объект может быть неоднократно связан с документом, но только при условии, что его статус будет различным для каждой из связей. Если же объект с таким статусом уже связан с данным документом, никаких действий не будет произведено, т.е. повторная связь не будет образована.
Связь документ-объект является универсальной, т.е. название связи со стороны документа звучит так же, как и со стороны объекта. Например, связь «Предмет договора» будет так называться и в окне документов и в окне объектов.

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Документ – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между документом и объектом будет разорвана. Сами документ и объект при этом не удаляются.

Если Вы хотите быстро найти объект, связанный с активным документом, то выделите связь с искомым объектом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Объекты», в котором связанный с документом объект будет открыт и выделен в панели дерева объектов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным объектом все необходимые действия (изменение, удаление и пр.). При удалении документа (или связанного с ним объекта) связи удаляются автоматически.


Печать документов

На печать можно отправить только документы, для которых созданы печатные формы (см. п. Работа с печатными формами). По этой причине при выделении документа, для которого нет доступных печатных форм, пункты меню и кнопки панели инструментов, связанные с печатью документа, становятся неактивными.

Для того чтобы напечатать документ, выделите его в панели дерева документов или панели списка рабочего окна, нажмите кнопку [image] на панели инструментов или выберите пункт главного меню «Документ–Печать…». При нажатии кнопки на панели инструментов документ будет отправлен на печать с использованием печатной формы, установленной по умолчанию. В том случае, если для документа разработано несколько печатных форм, необходимо воспользоваться пунктом главного меню «Документ – Печать…» (Рис. 3.16).

Рис. 3.16
Выбор печатной формы документа

Сначала необходимо выбрать печатную форму, которую мы будем использовать для печати, из списка доступных (будет помечена «галочкой»), затем отправить документ на печать.

Кроме того, Вы можете также напечатать внедренный (OLE) документ. Для этого откройте окно редактирования OLE-объекта и выберите пункт меню "OLE объект - Изменить". Будет вызвано приложение, ассоциированное с внедренным документом, и Вы сможете с его помощью напечатать этот документ. Естественно приложение, с которым ассоциирован внедренный документ, должно быть установлено на Вашем компьютере.


Предварительный просмотр документов

Окно предварительного просмотра показывает внешний вид документа, выводимого на печать (Рис. 3.17).

Рис. 3.17
Окно предварительного просмотра документа

Для просмотра документа пользователь должен нажать кнопку [image] на панели инструментов рабочего окна либо выбрать пункт главного меню «Документ – Печать - Предварительный просмотр». Окно предварительного просмотра интуитивно понятно. В нем можно вести поиск текста, изменять параметры страницы, добавлять и удалять страницы выходного документа, изменять режим просмотра. Наряду с прочими возможностями, отсюда возможно экспортировать документ в один из доступных форматов (Рис. 3.17). При нажатии кнопки [image] окна просмотра выводимый на печать документ может быть дополнительно отредактирован. Для редактирования вызывается дизайнер FastReport™, в котором на изменение вызывается текущая страница документа. После завершения редактирования, нажатия кнопки [image] дизайнера и подтверждения сохранения измененный документ может быть напечатан. Подробнее смотрите документацию FastReport™.


Поиск документов

При большом количестве документов поиск необходимого документа в списке существенно затруднен. Для того, чтобы найти нужный документ, в программе предусмотрены развитые средства поиска. Для поиска документа нажмите клавишу <F3> (или <Ctrl+F>) на клавиатуре или нажмите кнопку [image] на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.18), в которой необходимо задать требуемые параметры поиска.

а)________________________________б)
Рис. 3.18
Панель поиска документов

Панель поиска состоит из двух закладок: общие (Рис. 3.18а) и дополнительно (Рис. 3.18б).

На панели поиска имеются поля, формирующие условия поиска:

Начальные:
· Равно;
· Не равно;
· Меньше;
· Меньше/равно;
· Больше;
· Больше/равно;
· Похожее на;
· Начинается с;

Промежуточные:
· «И»;
· «ИЛИ».

Для поиска документа необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

Формирование поисковой строки по текстовому или числовому полю.
В поле поиска необходимо ввести текст или число, которые Вы желаете найти в этом поле документа. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы (см. рис.3.16а).

Начальные условия поиска имеют следующие значения:

· Равно – найти значения, точно соответствующие поисковой строке;
· Не равно – найти любые значения, не равные поисковой строке;
· Меньше – найти значения, меньшие, чем указаны в поисковой строке;
· Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
· Больше – найти значения, большие, чем указаны в поисковой строке;
· Больше/равно - найти значения, большие или равные указанным в поисковой строке;
· Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа % (см. рис.3.16а);
· Начинается с – найти значения, с которых начинается поисковая строка.

Промежуточные условия поиска применяются в том случае, когда необходимо найти документ более чем по одному полю. Например: Название ПОХОЖЕЕ НА Акт обслед% И дата БОЛЬШЕ/РАВНО 07.12.2005 (см. рис.3.16а).

Формирование поисковой строки по полю типа «Дата»

Выбрать из выпадающего календаря поисковое значение и задать начальное и промежуточное условия. Для того, чтобы очистить поле поиска типа «Дата», необходимо снять флажок в ячейке, находящейся рядом с поисковой датой.

Для поля «Класс документа» поисковое значение выбираются из классификатора документов и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска).

Для поиска документов «Завершенные» или «Незавершенные» (закладка «Дополнительно») установите флажок в соответствующем поле.

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти документы, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Документ», «документ», «ДОКУМЕНТ», «дОкумент» и т.п.

После того, как документ будет найден, Вы можете перейти к нему, дважды щелкнув по документу на правой панели или выбрав пункт контекстного меню «Открыть».


Дополнительные характеристики документа

Это дополнительное свойство документа, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Например, в договоре аренды обычно оговаривается арендная плата за 1 кв.м., стоимость коммунальных услуг, плата за пользование телефоном и пр. Указанные характеристики могут быть добавлены, как дополнительная информация, и использованы в печатной форме для детализации условий договора аренды. Для добавления дополнительных характеристик пользователь должен найти в панели дерева документов нужный документ, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку [image] на панели инструментов (выноска 25 Рис. 3.2). На экран будет выведена форма дополнительных характеристик выбранного документа (Рис. 3.19).

Рис. 3.19
Дополнительная информация о документе

Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретный документ. При выборе добавления или изменения характеристики на экран выводится окно редактирования (Рис. 3.20).

Рис. 3.20
Добавление характеристики

Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).


Текст документа

Это дополнительное свойство документа, которое предназначено для хранения текста. Его можно использовать в качестве альтернативы внедренным объектам, а также для дополнительного описания связанных объектов базы данных.

Для добавления текста документа пользователь должен найти в панели дерева документов нужный документ, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку [image] на панели инструментов (выноска 26 Рис. 3.2). На экран будет выведена форма ввода текста документа.

Она представляет из себя простой редактор для ввода форматированного текста со стандартной строкой меню и панелью инструментов (в Windows используется аналогичный текстовый редактор WorkPad). Текст документа может быть вставлен из буфера обмена, размер текста не ограничен.


Окно выбора документов

При создании связей субъектов, объектов с документами или документов с другими документами, используется окно «Выбор документов» (Рис. 3.21). Выбор документа происходит путем выделения искомого документа в дереве документов. В случае группировки, группы документов не выделяются! Вы можете выделить только непосредственно документ или несколько документов (если это возможно по условиям выбора). Однако Вы можете входить в группы и выделять документы в них.

Для выделения более чем одного документа, можно использовать клавиши <Ctrl> и <Shift>. Действия с этими клавишами абсолютно идентичны действиям при работе с программой «Проводник» Windows™. Например, нажав и удерживая на клавиатуре клавишу <Ctrl> , Вы можете выделить документы, расположенные в разных частях списка (через один, или первый и последний).

Строка «Адрес» предназначена для быстрого поиска документов по их вложенности. Например, Вы знаете, что Ваш документ класса «Акт обследования жилого дома». Сгруппируйте документы по классу, а затем наберите в строке «Адрес»: Технические документы\Акт\Акт обследования технического состояния\Акт обследования жилого дома. Откроется папка «Акт обследования технического состояния» в которой и будет находиться искомый документ.

Рис. 3.21

Кроме этого, при нажатии на кнопку [image] панели инструментов окна выбора классов открывается панель поиска. Здесь необходимо задать поисковые характеристики и нажать кнопку «Найти». Найденный класс будет отображен в окне выбора.

Для ускорения поиска документов определенного класса в окне выбора так же удобно использовать фильтры документов ( [image]). Работа с фильтрами подробно описана в разделе "Использование фильтров документов".

В окне выбора документов с текущим документом можно производить все действия, описанные ранее (т.е создание, изменение, удаление, поиск, фильтрация).

Внимание!

Будьте внимательны при обновлении списка. Если был выделен хотя бы один документ и после этого была перегруппировка документам по группе (документы сгруппированы или перегруппированы по другой группе), будет выделен не только документ(ы), но и группы в которых они расположены! Для снятия выделения, просто щелкните по любому документу (клавиши <Ctrl> и <Shift> должны быть отжаты)


Фильтры документов

Использование фильтров документов

В системе имеется возможность применения ограничений для показа в панелях дерева и списка объектов базы данных, а также в окнах выбора документов определенного класса, назначаемых пользователем (т.н. фильтрация, см. выноски 11-13 Рис. 3.2). Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна Рис. 3.22.

Рис. 3.22

В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации». Если для рабочего окна не было задано ни одного фильтра, то нажатие на первую и третью кнопки панели инструментов будут приводить к вызову окна диалога фильтров документов (Рис. 3.23). Если какие-либо фильтры были назначены ранее, то нажатие на первую кнопку приведет к включению фильтра и, соответственно, к изменению отображения в дереве и списке объектов.

Рис. 3.23

При нажатии на кнопку, [image] «Добавить фильтр» Рис. 3.23 пользователю будет предложено задать название для нового фильтра (Рис. 3.24).

Рис. 3.24

После нажатия кнопки «ОК» вызывается окно фильтра документов (Рис. 3.25).

Рис. 3.25

При нажатии на кнопку [image] «Добавить в фильтр» будет открыто окно выбора классов документов, в котором пользователь должен выбрать документы, для которых будет применяться фильтрация (допускается множественный выбор с использованием клавиш «Ctrl» или «Shift»). Выбранные документы будут добавлены в окно фильтра.

Переключатель «Фильтрация объектов» окна Рис. 3.25 позволяет выбрать способ отображения отфильтрованных объектов после включения фильтра:

· Показывать выбранные – в окне дерева объектов будут показаны только объекты, добавленные в окно фильтра;
· Не показывать выбранные - в окне дерева объектов будут показаны все объекты за исключением добавленных в окно фильтра.

При выборе закладки «Текст фильтра» пользователь может вручную отредактировать SQL-запрос (Рис. 3.26).

Рис. 3.26

После задания фильтров окно Рис. 3.23 приобретет вид (Рис. 3.27).

Рис. 3.27

Нажатие кнопки «Выбрать» приведет к выбору фильтра «Договоры аренды» и его включению. Состояние отображения объектов в панели дерева изменится в соответствии с изложенными выше правилами.

В окне фильтров пользователь может добавлять новые фильтры, удалять и переименовывать существующие, задавать или изменять условия фильтрации для выбранных фильтров. Кроме этого, возможно сохранить набор фильтров в базе данных и загрузить его.

После назначения нескольких фильтров пользователь может динамически переключаться между ними в ходе работы с объектами (Рис. 3.28).

После выбора фильтра «Документы, удостоверяющие личность» произойдет его включение, что приведет к изменению отображения объектов, выбранных для этого фильтра.

Рис. 3.28


Дополнительные свойства документов

Дополнительные свойства могут быть добавлены для класса документа. Добавление дополнительных свойств документа производится по аналогии с внешними формами:

· создается форма свойств документа в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и «Разработчик»);
· Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);
· После загрузки документа выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна документов, на панели инструментов «Свойства документа» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств пункт в меню «Документ–Характеристики документа». Для остальных документов эти формы остаются недоступными, и кнопка на соответствующей панели не появляется.


Импорт документов

Как правило, в организациях, использующих компьютерную технику, всегда имеется множество документов, созданных различными сотрудниками (обычно в формате MS Office – Word, Excel, рисунки, схемы и пр.). В этом случае для быстрого наполнения базы данных АИС «Дока» удобно использовать такую функцию, как «Импорт документов» (Рис. 3.29). Импортированные документы помещаются в базу данных в виде OLE-объектов. По своей сути импорт документов – это автоматизированнный процесс создания новых документов и внедрения в них вложенных (OLE) объектов (см. Вставка внедренного объекта).

Рис. 3.29

Для импорта документов необходимо открыть рабочее окно «Документы» и выбрать пункт главного меню «Документ – Импортировать документы».

Импорт осуществляется с помощью Мастера (Wizard), помогающего пользователю правильно осуществить эту операцию. Начальное окно Мастера импорта показано на Рис. 3.30. На диалоговом окне находится панель списка файлов документов. С помощью кнопок «Добавить...» и «Удалить» пользователь управляет списком документов для импорта.

Рис. 3.30

Флажок «Обрабатывать каждый документ отдельно» позволяет пользователю назначить индивидуальные свойства для каждого импортируемого документа. Если этот флажок не установлен, то для всей группы документов, выбранной в панели списка, будут установлены одинаковые свойства.
Для продолжения импорта необходимо нажать кнопку «Далее».

Рис. 3.31

На втором окне Мастера импорта пользователю дается возможность установить или изменить стандартные свойства конкретного импортируемого документа (наименование документа не может быть изменено, оно формируется из имени файла документа).

Если пользователь на предыдущем шаге импорта установил флажок «Обрабатывать каждый документ отдельно», то нажатие кнопки «Далее» выводит на окно мастера следующий документ из списка выбранных файлов, а общий ход импорта отображается в нижней части окна.

Нажатие кнопки «Пропустить» позволяет пользователю исключить из импорта текущий отображенный в окне документ.

Если флажок индивидуальной обработки файлов не был установлен, то для всех файлов списка будут установлены одни и те же свойства, а нажатие кнопки «Далее» приведет к завершению импорта.


Субъекты

Описание рабочего окна.
Создание нового субъекта
· физическое лицо
· юридическое лицо
· банк
Дополнительные реквизиты субъекта
· телефоны
· электронная почта
· ОКВЭД
· расчетные счета
Копирование / вставка субъекта
Удаление субъекта
Создание связи субъекта с документом
Создание связи субъекта с другим субъектом
Поиск субъектов
Дополнительные характеристики субъекта
Окно выбора субъектов
Использование фильтров субъектов
Дополнительные свойства субъекта


Описание рабочего окна

На Рис. 3.32 представлен внешний вид рабочего окна «Субъекты», а также его основные элементы управления.

Рис. 3.32
Элементы управления окна "Субъекты"

1. Создать нового субъекта;
2. Изменить субъекта;
3. Удалить субъекта;
4. Свойства субъекта;
5. Показать панель дерева субъектов;
6. Поиск субъектов;
7. История;
8. Настройка стиля отображения панели списка;
9. Обновить;
10. Включить фильтр;
11. Отключить фильтр;
12. Задать условия фильтрации;
13. Показывать связи с объектами;
14. Показывать связи с документами;
15. Показывать связи с субъектами;
16. Связать с документом;
17. Связать с субъектом;
18. Телефоны субъекта;
19. Электронная почта субъекта;
20. ОКВЭД субъекта;
21. Расчетные счета субъекта;
22. Перейти к предыдущему (следующему);
23. Вверх на один уровень;
24. Название столбца (панель сортировки);
25. Количество субъектов в группе;
26. Дополнительные характеристики субъекта;
27. Панель быстрого запуска.

Левая панель рабочего окна содержит дерево субъектов базы данных. Если активировать конкретный субъект в левой панели, то в правой будет выведен список связанных с ним объектов, документов и других субъектов. Отображаемые элементы зависят от режима отображения. Возможно задавать раздельное отображение связанных документов (меню «Вид – Показать/скрыть связи – Показывать связи с документами»), связанных субъектов («Вид – Показать/скрыть связи – Показывать связи с субъектами») или связанных объектов («Вид – Показать/скрыть связи – Показывать связи с объектами»).

Режим отображения субъектов при запуске приложения определяется настройками системы.

Кнопки панели инструментов рабочего окна не являются статичными. Их состояние и состав динамически изменяются в зависимости от активности субъекта и связанных с ним объектов базы данных.

При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил субъекта в базу данных, а у другого пользователя отсутствует информация об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (F5) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка субъектов с сервера и обновит ее в рабочем окне. При этом обновятся и все связи.
Для перемещения по списку субъектов используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки [image] и [image].

На панелях рабочего окна пользователю доступны контекстные меню, вызываемые щелчком правой кнопки мыши (Рис. 3.33).

а)____________________________________б)
Рис. 3.33
Контекстные меню окна "Субъекты"

Из контекстного меню панели дерева субъектов (Рис. 3.33 а) пользователь получает возможность изменить регистрационные данные активного субъекта, удалить его или просмотреть и изменить его свойства. Кроме этого, субъект может быть скопирован в буфер обмена и вставлен из буфера в базу данных (по аналогии с копированием/вставкой документов).

Пункт меню «Группировка субъектов» дает возможность сортировать субъектов:

· По классу – в соответствии с классами, назначенными в классификаторе субъектов;
· По группе – в соответствии с пользовательскими группами, назначенными в классификаторе групп субъектов;
· По состоянию – в соответствии с состояниями субъектов, назначенными в справочной таблице состояний субъектов;
· Отсутствует – без группировки;

При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева и панели списка объектов базы данных. Наименования групп выбираются из соответствующих классификаторов и справочников системы.
На Рис. 3.32 в левой панели субъекты отсортированы по пользовательским группам.

Пункт меню «Свойства» открывает информационное окно свойств субъекта. Для документов, объектов и субъектов в этом окне содержится информация о владельце – пользователе, создавшем данный объект базы данных.

Контекстное меню панели списка объектов базы данных (Рис. 3.33б) дает возможность:

· Открыть – открыть рабочее окно объекта базы данных, на который указывает связь и перейти в него. Тот же результат будет достигнут, если на связи с объектом БД произвести двойной; щелчок левой кнопкой мыши;
· Изменить – изменить класс связи или связь объекта базы данных;
· Удалить – удалить субъекта или его связь с объектом базы данных;
· просмотреть и изменить свойства субъекта или его связи с объектом базы данных.

Панель дерева субъектов имеет табличную структуру. Щелчком левой кнопки мыши на выбранном столбце можно отсортировать в нем данные по возрастанию, либо по убыванию (выноска 24 Рис. 3.32). В столбце «Количество в группе» показывается количество субъектов в соответствующей группе (выноска 25 Рис. 3.32).

Особое внимание необходимо обратить на связи объектов с субъектами в панели списка. Если взглянуть на свойства такой связи, то можно увидеть одну особенность (Рис. 3.34).

Рис. 3.34
Свойства связи Субъект – Объект

В строке «Информация» указано, что это опосредованная связь субъекта с объектом через документ. Такая связь назначается автоматически и вручную не может быть ни изменена, ни удалена. Т.е. эта связь только для чтения.

На панели инструментов окна «Субъекты» расположена адресная строка. В строке редактирования «Адрес» показан текущий уровень субъекта в виде строки, в которой уровни субъектов перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» строку, описывающую путь к другому субъекту, и, нажав кнопку «Перейти», Вы попадете на заданный субъект. В случае ошибки во введенной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому субъекту не произойдет.


Создание субъекта

Создание (изменение) субъекта

Добавить нового субъекта пользователь может выбором пункта меню рабочего окна «Субъект – Создать – Новый субъект» либо нажатием кнопки [image] на панели инструментов. Пользователю будет предложено выбрать класс создаваемого субъекта по классификатору (Рис. 3.35).

Рис. 3.35
Выбор класса субъекта

Правильный выбор класса создаваемых субъектов важен для последующей корректной организации взаимосвязей между ними. Кроме того, для различных классов субъектов заполняются разные реквизиты. Далее будут описаны формы, входящие в поставку во всех вариантах, за исключением демонстрационной версии.

Такая же диалоговая форма, как и при создании субъекта, будет вызвана при его изменении (кнопка [image] на панели инструментов или пункт меню "Субъект-Изменить"). Для субъектов, у которых отсутствует внешняя форма при добавлении и изменении субъекта вызывается стандартное диалоговое окно:

Рис. 3.40
Субъект – стандартное диалоговое окно

Форма состоит из двух закладок и интуитивно понятна. Обратим внимание лишь на пункт «Субъект является неотъемлемой частью субъекта». Здесь Вы можете указать на другой субъект, который будет для создаваемого (изменяемого) субъекта – главным. Т.е. созданный таким образом субъект будет подчиненным субъектом и не может существовать самостоятельно. Работа с вкладкой «Безопасность» идентична работе с такой же вкладкой в окне «Документ - безопасность».

Закладка «Безопасность» позволяет установить права доступа к создаваемому субъекту. Подробно установка параметров безопасности для классов рассмотрена нами ранее . По аналогии с документами, при создании субъекта для его создателя (т.е. пользователя, создавшего субъект) предоставляются все права на этот субъект. Для остальных пользователей права на созданный субъект будут предоставлены в соответствии с правами на класс субъекта. Вы можете предоставлять индивидуальные права на субъект, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права субъекта этого класса полностью заменяются правами на класс

Примечание. Использование подчиненных субъектов влечет за собой некоторые ограничения. Например, нельзя выбрать разные группы для главного и подчиненного субъектов, при группировке по классу субъекта, группировка всегда производится только по классу главного субъекта и т.п. Если Вам необходимо, чтобы два субъекта были в разных группах (например, группа «Партнеры» и «Дочерние предприятия партнеров»), то не подчиняйте субъекты друг другу, а воспользуйтесь возможностью сослаться на субъект. С помощью ссылок Вы всегда сможете найти связанный субъект.

Создавать субъектов можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.


Физическое лицо

Для субъекта – физическое лицо пользователю необходимо заполнить форму показанную на Рис. 3.36.

Форма состоит из четырех закладок, на которых логически сгруппированы реквизиты физического лица. При заполнении полей «Фамилия», «Имя» и «Отчество» данные автоматически подставляются из базы данных из списков фамилий, имен и отчеств. Если вводимая фамилия (имя, отчество) отсутствует в списке, система выдает запрос (Рис. 3.37).

Рис. 3.36
Субъект – физическое лицо

Рис. 3.37
Запрос на добавление фамилии

Добавление новой фамилии рассмотрено ранее (см. Работа со справочными таблицами). На закладке «Адреса» вводятся регистрационные данные субъекта о месте рождения, регистрации и жительства.

Закладка «Документы» позволяет выбрать документ, удостоверяющий личность субъекта (как правило, паспорт гражданина РФ). Документ «Паспорт» является стандартным документом системы и должен быть создан и заполнен самостоятельно. После выбора паспорта и сохранения формы физического лица с документом «Паспорт» автоматически создается связь типа «Субъект – Документ».

На закладке «Дополнительно» вводятся данные о национальности и гражданстве субъекта, его принадлежности к группе, а также личные коды (ИНН, ПФР и т.п.).


Юридическое лицо

Для субъекта – юридическое лицо пользователю необходимо заполнить форму, показанную на Рис. 3.38.

Форма состоит из пяти закладок, на которых логически сгруппированы реквизиты юридического лица. Дополнительного описания работа с данной формой не требует, отметим лишь, что обязательными полями для заполнения являются «Полное наименование» и «Хранить как…».

Рис. 3.38
Субъект – юридическое лицо

На закладке "Коды" вводятся регистрационные коды юридического лица.

На закладке "ИФНС" вводится информация о налоговом органе, в котором состоит на учете предприятие.

На закладке "Учредительные сведения" вносится информация об уставном фонде предприятия.

На закладке "Дополнительно" вводится информация о группе субъекта, его состоянии, юридическом и почтовом адресе.


Частный предприниматель

Предприниматель без образования юридического лица

Для субъекта – предпринимателя без образования юридического лица пользователю необходимо заполнить форму показанную на Рис. 3.39. Форма состоит из пяти закладок, на которых логически сгруппированы реквизиты ПБОЮЛ.

Рис. 3.39
Субъект – ПБОЮЛ

Добавление новой фамилии рассмотрено ранее (см. Работа со справочными таблицами). На закладке «Адреса» вводятся регистрационные данные субъекта о месте рождения, регистрации и жительства.

Закладка «Документы» позволяет выбрать документ, удостоверяющий личность субъекта (как правило, паспорт гражданина РФ). Документ «Паспорт» является стандартным документом системы и должен быть создан и заполнен самостоятельно. После выбора паспорта и сохранения формы физического лица с документом «Паспорт» автоматически создается связь типа «Субъект – Документ». Здесь же заполняются данные о персональных кодах ПБОЮЛ: ИНН, ОГРН, регистрация в фондах.

На закладке «ИФНС» вводятся данные о реквизитах документов, подтверждающих регистрацию субъекта в качестве предпринимателя, а также налоговом органе.

На закладке «Дополнительно» вводятся данные о национальности и гражданстве субъекта, его принадлежности к группе, а также состоянии.


Банк

Для субъекта – банк пользователю необходимо заполнить форму показанную на Рис. 3.40.

Рис. 3.40
Субъект – банк

Форма состоит из двух закладок, на которых логически сгруппированы реквизиты банка. Субъект «Банк» используется при хранении данных юридического лица о расчетных счетах.

Если Вам необходимо работать с банком как с юридическим лицом, Вы можете воспользоваться формой "Субъект - Юрдическое лицо", либо создать новую форму.


Изменение субъектов

В случае, когда Вам необходимо изменить параметры сразу нескольких субъектов, выделите их на правой панели рабочего окна (рис. 3.32) с помощью мыши и клавиш клавиатуры (Shift, Ctrl). Затем, нажмите кнопку [image] или выберите пукнт меню "Субъект - Изменить". В открывшемся диалоговом окне, Вы можете изменить сразу несколько параметров, имеющихся у всех субъектов: класс, группу, дату, адреса, приоритет, состояние или принадлежность какому-либо документу.

Вы можете изменить только одно свойство или сразу несколько. Для того, чтобы значение параметра было изменено на заданное Вами, необходимо включить флажок "Заменить" напротив изменяемого параметра. В качестве эталонного свойства принимается свойство одного из изменяемых субъектов, загруженного в базу данных раньше остальных выделенных. Как правило, это первый по алфавиту субъект. В любом случае, Вы можете изменить значение свойства по своему усмотрению.
Если Вы ошиблись и выбрали больше, чем требовалось субъектов, это можно сделать на закладке "Список изменяемых субъектов".

Для удаления из списка, выделите в списке субъект, который необходимо удалить и нажмите кнопку [image] на панели инструментов диалогового окна. После предупреждения, субъект будет удален из списка изменяемых.
Внимание!
1. Субъект не удаляется при этом из базы данных. Удаление из списка не влечет за собой никаких последствий, кроме того, что свойства этого субъекта не будут изменены.
2. Если у пользователя отсутсвовали права на изменение одного из субъектов, свойства этого субъекта не будут изменены, несмотря на то, что он присутствовал в списке изменяемых.


Дополнительные реквизиты

Дополнительные реквизиты субъекта

Дополнительные реквизиты предназначены для хранения данных субъекта о телефонах, электронной почте, ОКВЭДах и расчетных счетах. Для заполнения дополнительных реквизитов необходимо выбрать нужный субъект, сделать его активным щелчком левой кнопки мыши и выбрать соответствующую кнопку панели инструментов [image] (выноски 18-21 Рис. 3.32).


Телефоны

Для работы со списком телефонов субъекта на экран выводится форма (Рис. 3.41).

Рис. 3.41
Список телефонов субъекта

Здесь можно добавить или редактировать все телефоны, используемы субъектом. Для добавления или изменения телефона на экран выводится форма (Рис. 3.42).

Рис. 3.42
Добавление телефона

Пользователь должен заполнить соответствующие поля и сохранить изменения.


Электронная почта

Для работы с электронной почтой субъекта на экран выводится форма (Рис. 3.43).

Рис. 3.43
Электронная почта субъекта

Здесь можно добавить или редактировать названия всех электронных почтовых ящиков, используемы субъектом. Работа по добавлению или изменению электронной почты аналогична работе с телефонами Руководства.


ОКВЭД

Для работы со списком ОКВЭД субъекта на экран выводится форма (Рис. 3.44).

Рис. 3.44

Здесь можно добавлять или удалять виды экономической деятельности, используемые субъектом. Виды экономической деятельности добавляются в список из классификатора ОКВЭД. При добавлении нового вида на экран выводится форма (Рис. 3.45).

Рис. 3.45
Выбор ОКВЭД

После поиска и выделения нужного кода в списке необходимо нажать кнопку «Выбрать». Новый код ОКВЭД будет добавлен в список.


Расчетные счета

Для работы со списком расчетных счетов субъекта на экран выводится форма (Рис. 3.46).

Рис. 3.46
Список расчетных счетов субъекта

Здесь можно добавить или редактировать расчетные счета, используемы субъектом. Для добавления или изменения расчетного счета на экран выводится форма (Рис. 3.47).

Рис. 3.47

Пользователь должен заполнить соответствующие поля формы, а также выбрать банк, в котором открыт счет. Банк выбирается из списка субъектов. Если такой субъект в списке отсутствует, то он должен быть создан и сохранен.

При наличии у субъекта нескольких расчетных счетов можно установить флажок «Счет по умолчанию». В этом случае в выходные документы автоматически будет подставляться выбранный счет (в списке расчетных счетов счет по умолчанию выделяется синим цветом).


Сайты

Для добавления/изменения сайтов субъекта (юридического, физического лица, предпринимателя и др.) используется форма показанная на рисунке

Рис. 3.48
При нажатии на кнопку [image] будет предпринята попытка открыть выделенный в списке сайт в окне Internet Explorer или иного интернет-браузера, установленного на Вашем компьютере и используемого по умолчанию.

Форма добавления/изменения записи о ресурсе в сети Интернет (рис. ) позволяет записать адрес (URL), название сайта, а также его описание или иную информацию, позволяющую кратко описать данный сайт.

Рис. 3.49


Контакты

Хроника контактов с субъектом ведется в окне, показанном на рисунке 3.50

Рис. 3.50
Внесение данных о контакте с выбранным субъектом производится с помощью диалогового окна (рис. 3.51)

Рис.3.51
После заполнения всей доступной информации, можно также запланировать встречу или звонок, нажатием кнопки "Запланировать". В результате этого будет вызвано окно Коммуникатора "Задачи", в котором можно указать время, дату и необходимость периодического оповещения о запланированном событии.
Для внесения дополнительной информации о том, что наиболее интересует субъект, с которым ведутся переговоры, используется форма, показанная на рисунке 3.52

Рис. 3.52


Копирование / вставка субъекта

Любой выделенный пользователем субъект может быть скопирован в буфер обмена и затем вставлен в базу данных. Эта возможности системы полезна в тех случаях, когда пользователь обрабатывает множество однотипных субъектов, мало отличающихся друг от друга. Режим копирования/вставки подробно описан в п. "Копирование/вставка документа".

Примечание: Если Вы используете нестандартные формы субъектов, то перед использованием этой возможности Вам необходимо создать метаданные для этих классов документов (см. подробно).


Удаление субъекта

Субъект, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить субъект, нужно выполнить следующие действия:

· Выделить субъект, который Вы хотите удалить, в дереве субъектов на левой панели рабочего окна;
· Нажать кнопку [image] на панели инструментов, выбрать пункт меню «Субъект – <Текущий субъект> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном субъекте);
· После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Возможно также удаление группы субъектов, когда они сгруппированы по какому-либо из параметров - состоянию, классу или пользовательской группе. Для удаления, выделите группу субъектов на левой панели рабочего окна и нажмите кнопку [image], в результате чего будет выведено диалоговое окно

Если вы хотите только вывести субъекты из группы, не удаляя самих субъектов, выберите пункт "Удалить только группу". Если же Вы хотите удалить и группу и все субъекты, находящиеся в ней, выберите пункт "Удалить группу и все субъекты в группе". Если Вы передумали удалять группу субъектов, нажмите кнопку "Отменить".

Внимание!

После удаления, восстановление субъекта будет невозможно. Кроме того, удалятся все связи этого субъекта с объектами, субъектами и документами. Если Вы не уверены в правильности Ваших действий, не удаляйте субъект.


Связь субъекта с документом

Создание связи субъекта с документом

Для установления связей между субъектами и документами базы данных пользователь должен произвести следующие действия:

· На левой панели дерева субъектов найти субъект, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
· Выбрать пункт меню рабочего окна «Субъект – Связи – Связать с документами» или нажать кнопку [image] на панели инструментов (выноска 16 Рис. 3.32);
· В открывшемся окне «Выбор класса – Связь Субъект - Документ» выбрать класс связи. Добавление классов связей документов производится в классификаторе взаимосвязей;
· В открывшемся окне «Выбор документа» найти конкретный документ, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска в данном окне можно отсортировать данные. Если связываемый документ еще не был внесен в базу данных, то в окне «Выбор документа» можно создать новый документ, а затем выбрать его вышеописанным способом;
· Связанный документ будет отображен в правой панели списка среди других связанных объектов БД.

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Субъект – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между субъектом и документом будет разорвана. Сами субъект и документ при этом не удаляются.

Если Вы хотите быстро найти документ, связанный с активным субъектом, то выделите связь с искомым документом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Документы», в котором связанный с субъектом документ будет открыт и выделен в панели дерева документов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным документом все необходимые действия (изменение, удаление и пр.).

Связь субъект-документ является универсальной, т.е. название связи со стороны субъекта звучит так же, как и со стороны документа. Например, связь «Арендатор» будет так называться и в окне субъектов и в окне документов.

Примечание:

1. Выбор класса связи можно осуществить в зависимости от настроек пользователя. Если флажок "Применять строгие правила для связей" установлен, то выбрать можно только класс, для которого создана допустимая связь. Если флажок сброшен возможен выбор любого класса связи.

2. В окне выбора класса связи корневым классом будет класс, установленный в настройках пользователя в строке "Субъект-Документ".


Связь субъекта с субъектом

Создание связи субъекта с другим субъектом

Для установления связей между субъектами базы данных пользователь должен произвести следующие действия:

· На левой панели дерева субъектов найти субъект, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
· Выбрать пункт меню рабочего окна «Субъект – Связи – Связать с субъектами» или нажать кнопку [image] на панели инструментов (выноска 17 Рис. 3.32);
· В открывшемся окне «Выбор класса – Связь Субъект - Субъект» выбрать класс связи. Добавление класса связей субъектов производится в классификаторе взаимосвязей;
· В открывшемся окне «Выбор субъекта» найти конкретный субъект, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска в данном окне можно отсортировать данные. Если связываемый субъект еще не был внесен в базу данных, то в окне «Выбор субъекта» можно создать новый субъект, а затем выбрать его вышеописанным способом;
· Связанный субъект будет отображен в правой панели списка среди других связанных объектов БД.

Внимание!

Один и тот же субъект может быть неоднократно связан с другим субъектом, но только при условии, что его статус будет различным для каждой из связей. Если же субъект с таким статусом уже связан с данным субъектом, никаких действий не будет произведено, т.е. повторная связь не будет образована.

Связь субъект-субъект является двунаправленной, т.е. связь субъекта 1 с субъектом 2 отличается от связи субъекта 2 с субъектом 1. Например, если Вы сделали активным субъект «Иванов» и есть связь с субъектом «Петрова» класса «жена». При выделении субъекта «Петрова» эта связь будет отображена специальным значком (зеленая стрелка), тип связи будет также «жена», однако название связи будет «Иванов» при подсветке (Hint) будет выведено сообщение «Ссылается объект: Иванов (жена)». Что означает: на субъект «Петрова" ссылается субъект «Иванов», тип ссылки «жена»,т.е. Петрова является женой Иванова. Если Вам нужна ссылка «муж», то Вы должны создать такую ссылку, естественно выделив сначала субъект «Петрова», создав связь касса «муж» и указав на субъект «Иванов».

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Субъект – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между субъектами будет разорвана. Сами субъекты при этом не удаляются.

Если Вы хотите быстро найти связанный субъект, то выделите связь с искомым субъектом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Субъекты» (если Вы находитесь в этом окне, то новое окно не открывается), в котором связанный субъект будет открыт и выделен в панели дерева субъектов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным субъектом все необходимые действия (изменение, удаление и пр.). При удалении субъектов их связи также удаляются.

Примечание:

1. Выбор класса связи можно осуществить в зависимости от настроек пользователя. Если флажок "Применять строгие правила для связей" установлен, то выбрать можно только класс, для которого создана допустимая связь. Если флажок сброшен возможен выбор любого класса связи.

2. В окне выбора класса связи корневым классом будет класс, установленный в настройках пользователя в строке "Субъект-Субъект".


Поиск субъектов

При большом количестве субъектов поиск необходимого субъекта в списке существенно затруднен. Для того, чтобы найти субъект, в программе предусмотрены развитые средства поиска. Для поиска документа нажмите клавишу <F3> на клавиатуре или нажмите кнопку [image] на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.53), в которой необходимо задать требуемые параметры поиска.

На панели поиска имеются поля, формирующие условия поиска:

Начальные:
· Равно;
· Не равно;
· Меньше;
· Меньше/равно;
· Больше;
· Больше/равно;
· Похожее на;
· Начинается с;

Промежуточные:
· «И»;
· «ИЛИ».

Рис. 3.53
Панель поиска субъектов

Для поиска субъекта необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

Формирование поисковой строки по текстовому полю.

В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле субъекта. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

Начальные условия поиска имеют следующие значения:

· Равно – найти значения, точно соответствующие поисковой строке;
· Не равно – найти любые значения, не равные поисковой строке;
· Меньше – найти значения, меньшие, чем указаны в поисковой строке;
· Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
· Больше – найти значения, большие, чем указаны в поисковой строке;
· Больше/равно - найти значения, большие или равные указанным в поисковой строке;
· Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
· Начинается с – найти значения, с которых начинается поисковая строка.

Промежуточные условия поиска применяются в том случае, когда необходимо найти субъекта более чем по одному полю. Например: Наименование ПОХОЖЕЕ НА Петров% И группа РАВНО Сотрудники.
Для полей «Класс субъекта» и «Адреса» поисковые значения выбираются из соответствующих классификаторов и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска).

Для полей юридический адрес и фактический адрес строка поиска формируется в отдельном окне после нажатия на соответствующую кнопку. После формирования строки поиска по юридическому (фактическому) адресу в поле поиска «Юридический адрес» («Фактический адрес») будет описано это условие. Поиск субъектов будет осуществляться по всем адресам, соответствующим заданным условиям.

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти субъекты, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Комплекс Софт», «комплекс софт», «КОМПЛЕКС СОФТ», «Комплекс софт» и т.п.

После того, как субъект будет найден, Вы можете перейти к нему, дважды щелкнув по документу на правой панели или выбрав пункт контекстного меню «Открыть».


Дополнительные характеристики субъекта

Это дополнительное свойство субъекта, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Дополнительные характеристики могут быть добавлены, как вспомогательная информация, и использованы в печатных формах. Для добавления дополнительных характеристик пользователь должен найти в панели дерева субъектов нужного субъекта, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку [image] на панели инструментов (выноска 12 Рис. 3.32). Работа с дополнительными характеристиками описана в разделе Руководства (Дополнительные характеристики документа).

Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретного субъекта. Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).


Заметки о субъекте

Если необходимо внести записи, которые невозможно структурировать в соответствии с базой данных или просто записать некоторую информацию о субъекте, можно использовать специальное окно "Заметки" (рис. 3.54). Вызвать данное окно можно через панель инструментов, нажатием кнопки [image], или с помощью меню Субъект-Характеристики субъекта - Заметки.

Рис. 3.54
По своей сути данное окно представляет собой встроенный текстовый редактор с возможностью форматирования текста (rich text format), полностью аналогичный редактору "Текст документа"


Окно выбора субъектов

При создании связей документов, объектов с субъектами или субъектов с другими субъектами, используется окно «Выбор субъекта» (Рис. 3.55).

Рис. 3.55

Выбор субъектов, а также другие действия в окне выбора субъекта производятся также как и в окне «Выбор документа». В окне выбора субъектов с текущим субъектом можно производить все действия, описанные ранее (т.е создание, изменение, удаление, поиск, фильтрация, заполнение свойств).
Основное отличие заключается в возможности показа субъектов, связанных с выделенным в дереве. Субъекты связанные с выделенным в дереве субъектом показываются как вложенные субъекты с дополнительным значком [image]. Данный значок служит отличительным знаком, указывающим на то, что субъект с таким значком является не вложенным, а связанным с выделенным субъектом. Это позволяет быстро находить необходимые субъекты, если, например, Вы знаете название организации, но не помните ее директора, а Вам необходимо выбрать именно директора.


Фильтры субъектов

Использование фильтров субъектов

В системе имеется возможность применения ограничений для показа в панелях дерева и списка объектов базы данных субъектов определенного класса, назначаемых пользователем (т.н. фильтрация, см. выноски 10-12 Рис. 3.32). Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна Рис. 3.56.

Рис. 3.56

В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации».

Подробно работа по настройке фильтров описана в п. "Использование фильтров документов".


Дополнительные свойства субъекта

Дополнительные свойства могут быть добавлены для класса субъекта. Добавление дополнительных свойств субъекта производится по аналогии с внешними формами:

· Создается форма свойств субъекта в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и «Разработчик»);
· Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);

После загрузки субъекта выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна субъектов, на панели инструментов «Свойства субъекта» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств и пункт в меню «Субъект–Реквизиты субъекта». Для остальных субъектов эти формы остаются недоступными, и кнопка на соответствующей панели и пункт в меню не появляется.


Объекты

Описание рабочего окна
Создание нового объекта
Копирование / вставка объекта
Удаление объекта
Создание связи объекта с документом
Поиск объектов
Дополнительные характеристики объекта
Окно выбора объектов
Использование фильтров объектов
Дополнительные свойства объекта


Описание рабочего окна

На Рис. 3.57 представлен внешний вид рабочего окна «Объекты», а также его основные элементы управления.

Особенности рабочего окна конфигурации "Управление недвижимостью" описано здесь.

Особенности рабочего окна конфигурации "Лицевой счет жилого дома" описано здесь.

Рис. 3.57
Элементы управления окна "Объекты"

1. Создать новый объект;
2. Изменить объект;
3. Удалить объект;
4. Свойства объекта;
5. Показать панель дерева объектов;
6. Поиск объектов;
7. История;
8. Настройка стиля отображения панели списка;
9. Обновить;
10. Включить фильтр;
11. Отключить фильтр;
12. Задать условия фильтрации;
13. Показывать связи с документами;
14. Показывать связи с субъектами;
15. Выбрать объект - владелец;
16. Связать с документом;
17. Перейти к предыдущему (следующему);
18. Вверх на один уровень;
19. Название столбца (панель сортировки);
20. Количество объектов в группе;
21. Дополнительные характеристики объекта;
22. Панель быстрого запуска объектов.

Левая панель рабочего окна содержит дерево объектов базы данных. Если активировать конкретный объект в левой панели, то в правой будет выведен список связанных с ним субъектов, документов и других объектов. Отображаемые элементы зависят от режима отображения. Можно задавать раздельное отображение связанных документов (меню «Вид – Показать/скрыть связи – Показывать связи с документами»), связанных субъектов («Вид – Показать/скрыть связи – Показывать связи с субъектами»). Режим отображения объектов при запуске приложения определяется настройками системы.

Кнопки панели инструментов рабочего окна динамически изменяются в зависимости от активности субъекта и связанных с ним объектов базы данных.

При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил объект в базу данных, а у другого пользователя отсутствует информация об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (<F5>) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка объектов с сервера и обновит ее в рабочем окне. При этом обновятся и все связи.

Для перемещения по списку объектов используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки [image] и [image].

На панелях рабочего окна пользователю доступны контекстные меню, вызываемые щелчком правой кнопки мыши (Рис. 3.58).

а)____________________________________________________б)
Рис. 3.58
Контекстные меню окна "Объекты"

Из контекстного меню панели дерева объектов (Рис. 3.58а) пользователь получает возможность изменить регистрационные данные активного объекта, удалить его или просмотреть и изменить его свойства.

Кроме этого, объект может быть скопирован в буфер обмена и вставлен из буфера в базу данных (по аналогии с копированием / вставкой документов).

Пункт меню «Группировка объектов» дает возможность сортировать субъектов:

· По классу – в соответствии с классами, назначенными в классификаторе объектов;
· По группе – в соответствии с пользовательскими группами, назначенными в классификаторе групп объектов;
· По состоянию – в соответствии с состояниями объектов, назначенными в справочной таблице состояний объектов;
· По адресу - в соответствии с адресами, назначенными в адресной системе;
· Отсутствует – без группировки.

При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева и панели списка объектов базы данных. Наименования групп выбираются из соответствующих классификаторов и справочников системы.

На Рис. 3.51 в левой панели объекты отсортированы по пользовательским группам.

Пункт меню «Свойства» открывает информационное окно (Рис. 2.48). Для документов, объектов и субъектов в этом окне содержится информация о владельце – пользователе, создавшем данный объект базы данных.

Контекстное меню панели списка объектов базы данных (Рис. 3.58б) дает возможность:

· Открыть – открыть рабочее окно объекта базы данных, на который указывает связь и перейти в него. Тот же результат будет достигнут, если на связи с объектом БД произвести двойной щелчок левой кнопкой мыши;
· Изменить – изменить класс связи или связь объекта базы данных;
· Удалить – удалить объект или его связь с объектом базы данных;
· Просмотреть и изменить свойства объекта или его связи с объектом базы данных.

Панель дерева объектов имеет табличную структуру. Щелчком левой кнопки мыши на выбранном столбце можно отсортировать в нем данные по возрастанию, либо по убыванию (выноска 19 Рис. 3.57). В столбце «Количество в группе» показывается количество объектов в соответствующей пользовательской группе (выноска 20 Рис. 3.57).

Особое внимание необходимо обратить на связи объектов с объектами в панели списка. Если взглянуть на свойства такой связи, то можно увидеть одну особенность (Рис. 3.59).

Рис. 3.59
Свойства связи Объект – Субъект

В строке «Информация» указано, что это опосредованная связь объекта с субъектом через документ. Такая связь создается автоматически и вручную не может быть ни изменена, ни удалена. Т.е. данная связь только для чтения.

На панели инструментов окна «Объекты» расположена адресная строка. В строке редактирования «Адрес» показан текущий уровень объекта в виде строки, в которой уровни объектов перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» строку, описывающую путь к другому объекту, и, нажав кнопку «Перейти», Вы попадете на заданный объект. В случае ошибки во введенной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому объекту не произойдет.


Создание объекта

Создание (изменение) объекта

Добавить новый объект пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки [image] на панели инструментов. Пользователю будет предложено выбрать класс создаваемого объекта по классификатору (Рис. 3.60).

Рис. 3.60

После выбора класса объекта на экран будет вызвано соответствующее диалоговое окно. Реквизиты уже введенного объекта можно изменить. Для того чтобы изменить объект, нужно выполнить следующие действия: выделить объект, который Вы хотите изменить, в дереве объектов на левой панели рабочего окна, нажать кнопку [image] на панели инструментов или выбрать пункт меню «Объект – <Текущий объект> - Изменить» или выбрать пункт контекстного меню «Изменить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте). Для изменения объекта будет вызвано такое же диалогове окно, как и для добавления.

Если внешние формы для данного класса объектов не заданы, то будет вызвано стандартное диалоговое окно (Рис. 3.61), состоящее из двух закладок.

Рис. 3.61

На закладке «Общие» пользователь должен ввести в соответствующие поля окна сведения о полном и кратком наименовании объекта, его принадлежность к пользовательской группе и адресе.
Использование поля «Объект является неотъемлемой частью объекта» производится в том случае, когда регистрируемый объект не может существовать самостоятельно (например, квартира или офис в здании). В этом случае необходимо нажать кнопку [image] и выбрать главный объект (владелец).

Рис. 3.62

Подчиненный объект будет отображен в дереве объектов на уровень ниже главного объекта (Рис. 3.62).

Примечание. Использование подчиненных объектов влечет за собой некоторые ограничения. Например, нельзя выбрать разные группы для главного и подчиненного объектов, при группировке по классу объекта, группировка всегда производится только по классу главного объекта и т.п. Если Вам необходимо, чтобы два объекта были в разных группах (например, группа «Продажа» и «Проданы»), то не подчиняйте объекты друг другу.

Закладка «Безопасность» позволяет установить права доступа к создаваемому объекту. Подробно установка параметров безопасности для классов рассмотрена нами ранее. По аналогии с документами и субъектами, при создании объекта для его создателя (т.е. пользователя, создавшего объект) предоставляются все права на этот объект. Для остальных пользователей права на созданный объект будут предоставлены в соответствии с правами на класс объекта. Вы можете предоставлять индивидуальные права на объект, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права объекта этого класса полностью заменяются правами на класс.

Создавать объекты можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.


Изменение объектов

В случае, когда Вам необходимо изменить параметры сразу нескольких объектов, выделите их на правой панели рабочего окна (рис. 3.57) с помощью мыши и клавиш клавиатуры (Shift, Ctrl). Затем, нажмите кнопку [image] или выберите пукнт меню "Объект - Изменить". В открывшемся диалоговом окне, Вы можете изменить сразу несколько параметров, имеющихся у всех объектов: класс, группу, дату, адрес, приоритет, состояние или принадлежность какому-либо объекту (например, дому).

Вы можете изменить только одно свойство или сразу несколько. Для того, чтобы значение параметра было изменено на заданное Вами, необходимо включить флажок "Заменить" напротив изменяемого параметра. В качестве эталонного свойства принимается свойство одного из изменяемых объектов, загруженного в базу данных раньше остальных выделенных. Как правило, это первый по алфавиту объект. В любом случае, Вы можете изменить значение свойства по своему усмотрению.
Если Вы ошиблись и выбрали больше, чем требовалось объектов, это можно сделать на закладке "Список изменяемых объектов".

Для удаления из списка, выделите в списке объект, который необходимо удалить и нажмите кнопку [image] на панели инструментов диалогового окна. После предупреждения, объект будет удален из списка изменяемых.
Внимание!
1. Объект не удаляется при этом из базы данных. Удаление из списка не влечет за собой никаких последствий, кроме того, что свойства этого объекта не будут изменены.
2. Если у пользователя отсутсвовали права на изменение одного из объектов, свойства этого объекта не будут изменены, несмотря на то, что он присутствовал в списке изменяемых


Копирование / вставка объекта

Любой выделенный пользователем объект может быть скопирован в буфер обмена и затем вставлен в базу данных. Режим копирования/вставки подробно описан ранее.

Примечание: Если Вы используете нестандартные формы объектов, то перед использованием этой возможности Вам необходимо создать метаданные для этих классов объектов (см. подробно).

Возможность копирования удобно использовать для создания однородных объектов (зданий, отличающихся друг от друга, например, адресом).

Для копирования объекта необходимо:
· выбрать его в списке дерева объектов (левая панель);
· нажать правую кнопку мыши и в контекстном меню выбрать пункт "Копировать".

Для вставки объекта необходимо:
· правой кнопкой мыши нажать на панели списка (правая панель, при этом снимается выделение с объекта на левой панели);
· в контекстном меню выбрать пункт "Вставить".

Если Вы нажмете правой кнопкой мыши на левой панели и выберите "Вставить", то объект будет вставлен внутрь выделенного объекта. При этом вложенные объекты вставлены не будут.

Для копирования - вставки вложенного объекта необходимо:
· выбрать на левой панели в существующем объекте (здании) вложенный объект (например, квартира);
· нажать на нем правую кнопку мыши и в контекстном меню выбрать пункт "Копировать".
· выбрать на левой панели нужное здание, в которое необходимо вставить скопированный объект;
· правой кнопкой мыши нажать на выбранном здании и в контекстном меню выбрать пункт "Вставить".


Удаление объекта

Объект, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить объект, нужно выполнить следующие действия:

· Выделить объект, который Вы хотите удалить, в дереве объектов на левой панели рабочего окна или в панели списка;
· Нажать кнопку [image] на панели инструментов, выбрать пункт меню «Объект – <Текущий объект> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте);
· После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Возможно также удаление группы объектов, когда они сгруппированы по какому-либо из параметров - состоянию или пользовательской группе. Для удаления, выделите группу объектов на левой панели рабочего окна и нажмите кнопку [image], в результате чего будет выведено диалоговое окно

Если вы хотите только вывести объекты из группы, не удаляя самих объектов, выберите пункт "Удалить только группу". Если же Вы хотите удалить и группу и все объекты, находящиеся в ней, выберите пункт "Удалить группу и все объекты в группе". Если Вы передумали удалять группу объектов, нажмите кнопку "Отменить".

Внимание!

После удаления, восстановление объекта будет невозможно. Кроме того, удалятся все связи этого объекта с объектами, субъектам и документами. Если Вы не уверены в правильности Ваших действий, не удаляйте объект.


Связь объекта с документом

Создание связи объекта с документом

Для установления связей между объектами и документами базы данных пользователь должен произвести следующие действия:

· На левой панели дерева объектов найти объект, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
· Выбрать пункт меню рабочего окна «Объект – Связи – Связать с документами» или нажать кнопку [image] на панели инструментов (выноска 16 Рис. 3.57);
· В открывшемся окне «Выбор класса – Связь Объект - Документ» выбрать класс связи. Добавление классов связей документов производится в классификаторе взаимосвязей;
· В открывшемся окне «Выбор документа» найти конкретный документ, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска в данном окне можно отсортировать данные. Если связываемый документ еще не был внесен в базу данных, то в окне «Выбор документа» можно создать новый документ, а затем выбрать его вышеописанным способом;
· Связанный документ будет отображен в правой панели списка среди других связанных объектов БД.

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Объект – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между объектом и документом будет разорвана. Сами объект и документ при этом не удаляются.

Если Вы хотите быстро найти документ, связанный с активным объектом, то выделите связь с искомым документом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Документы», в котором связанный с объектом документ будет открыт и выделен в панели дерева документов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным документом все необходимые действия (изменение, удаление и пр.).

Внимание!

Один и тот же объект может быть неоднократно связан с документом, но только при условии, что его статус будет различным для каждой из связей. Если же объект с таким статусом уже связан с данным документом, никаких действий не будет произведено, т.е. повторная связь не будет образована.

Связь документ-объект является универсальной, т.е. название связи со стороны документа звучит так же, как и со стороны объекта. Например, связь «Техническая документация» будет так называться и в окне документов и в окне объектов.

Примечание:

1. Выбор класса связи можно осуществить в зависимости от настроек пользователя. Если флажок "Применять строгие правила для связей" установлен, то выбрать можно только класс, для которого создана допустимая связь. Если флажок сброшен возможен выбор любого класса связи.

2. В окне выбора класса связи корневым классом будет класс, установленный в настройках пользователя в строке "Объект-Документ".


Связь объекта с субъектом

Создание связи объекта с субъектом

Этот тип связи нельзя создать. Эта связь по сути является просмотром опосредованных связей объектов с субъектами - через документы. Т.е. если есть связь объекта с документом и этот же документ, связан с какими либо субъектами, то будет показана связь объекта сэтими субъектами. Такая связь создается автоматически и вручную не может быть ни изменена, ни удалена. Таким образом, данная связь только для чтения.

Свойства связи Объект – Субъект

Например, объект "Офис" связан с документом "Договор купли-продажи". Договор в свою очередь связан с субъектами "Иванов" и "Петров". При просмотре связей объекта с субъектами с объектом "Офис" будут связаны субъекты "Иванов" и "Петров".


Поиск объектов

При большом количестве объектов поиск необходимого объекта в списке существенно затруднен. Для того чтобы найти нужный объект, в программе предусмотрены развитые средства поиска. Для поиска объекта нажмите клавишу <F3> на клавиатуре или нажмите кнопку [image] на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.63), в которой необходимо задать требуемые параметры поиска.

В том случае, если для объекта создана нестандартная формы ввода, то при вызове панели поиска на ней появляется еще одна кнопка «Дополнительно» (Рис. 3.63). При нажатии на эту кнопку появляется расширенная панель поиска с полями, описывающими свойства этого объекта (на Рис. 3.64 показана панель поиска для объекта «Здание»).

Рис. 3.63
Стандартная панель поиска объектов

Рис. 3.64
Расширенная панель поиска объектов

На панели поиска имеются поля, формирующие условия поиска:

Начальные:
· Равно;
· Не равно;
· Меньше;
· Меньше/равно;
· Больше;
· Больше/равно;
· Похожее на;
· Начинается с;

Промежуточные:
· «И»;
· «ИЛИ».

Для поиска объекта необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

Формирование поисковой строки по текстовому полю.

В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле объекта. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

Начальные условия поиска имеют следующие значения:
· Равно – найти значения, точно соответствующие поисковой строке;
· Не равно – найти любые значения, не равные поисковой строке;
· Меньше – найти значения, меньшие, чем указаны в поисковой строке;
· Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
· Больше – найти значения, большие, чем указаны в поисковой строке;
· Больше/равно - найти значения, большие или равные указанным в поисковой строке;
· Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
· Начинается с – найти значения, с которых начинается поисковая строка.

Промежуточные условия поиска применяются в том случае, когда необходимо найти объект более чем по одному полю. Например: Наименование ПОХОЖЕЕ НА %дом% И название группы РАВНО Продажа.

Для поля «Класс объекта» поисковые значения выбираются из соответствующего классификатора и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска «Класс объекта»).

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти объекты, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Объект», «объект», «ОБЪЕКТ», «ОбъЕкт» и т.п.

После того, как объект будет найден, Вы можете перейти к нему, дважды щелкнув по объекту на правой панели или выбрав пункт контекстного меню «Открыть».


Дополнительные характеристики объекта

Это дополнительное свойство объекта, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Дополнительные характеристики могут быть добавлены, как вспомогательная информация, и использованы в печатных формах. Для добавления дополнительных характеристик пользователь должен найти в панели дерева объектов нужный объект, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку [image] на панели инструментов (выноска 21 Рис. 3.57). Работа с дополнительными характеристиками описана ранее (Рис. 3.19).

Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретный объект. Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).


Окно выбора объектов

При создании связей документов или субъектов с объектами, используется окно «Выбор объекта» (Рис. 3.65).

Рис. 3.65

Выбор объектов, а также другие действия в окне выбора объекта производятся также как и в окне выбора документов.


Фильтры объектов

В системе имеется возможность применения ограничений для показа в панелях дерева и списка объектов базы данных объектов определенного класса, назначаемых пользователем (т.н. фильтрация, см. выноски 10-12 Рис. 3.57). Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна Рис. 3.66.

Рис. 3.66

В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации».

Подробно работа по настройке фильтров описана в п. "Использование фильтров документов".


Дополнительные свойства объекта

Дополнительные свойства могут быть добавлены для класса объекта. Добавление дополнительных свойств объекта производится по аналогии с внешними формами:

· Создается форма свойств объекта в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и «Разработчик»);
· Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);

После загрузки объекта выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна объектов, на панели инструментов «Свойства объекта» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств пункт в меню «Объект–Характеристики объекта». Для остальных объектов эти формы остаются недоступными, и кнопка на соответствующей панели не появляется.


Адреса

Описание рабочего окна

Добавление элементов адресов

Создание (изменение) адреса
Создание (изменение) государства
Создание (изменение) субъекта РФ
Создание (изменение) муниципального образования
Создание (изменение) адреса субъекта РФ
Создание (изменение) населенного пункта
Создание (изменение) геонима
Создание (изменение) района населенного пункта
Создание (изменение) адреса населенного пункта
Создание (изменение) адреса

Удаление элементов адресов

Создание связи адреса с объектами и субъектами

Поиск адреса

Окно выбора адреса

Использование фильтров адресов


Описание рабочего окна

На рисунке представлен внешний вид рабочего окна «Адреса», а также его основные элементы управления.

Рис. 3.67
Элементы управления окна "Адреса"

Адреса выводятся на просмотр в виде дерева объектов. Верхний уровень устанавливается в настройке параметров системы.

Настройки адресной системы существенно зависят от внешних форм и настроек, описанных в разделе «Параметры – «Общие – Адресная система».

В зависимости от уровня дерева адресов Вы можете добавить различные элементы – субъект Российской Федерации, населенный пункт, геоним, адрес и т.п.

Все Ваши действия по добавлению элементов адресов будут связаны с уровнем, выделенным на дереве (левая панель окна). Например, если Вы добавляете геоним (улицу, переулок, проспект и т.п.), он будет добавлен в населенный пункт, выделенный в дереве объектов на левой панели. В поставке без внешних форм необходимо выбирать класс адреса, вводить его название и адрес-родитель (например, для геонимов адресом-родителем может быть населенный пункт). В поставке с внешними формами вызываются соответствующие формы, в которых необходимо правильно заполнять соответствующие поля.

На панели инструментов окна «Адреса» расположена адресная строка. В строке редактирования «Адрес» показан текущий адресный уровень в виде строки, в которой уровни адреса перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» адресную строку, описывающую путь к другому адресу, и, нажав кнопку «Перейти», Вы попадете в заданный адрес. В случае ошибки во введенной адресной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому адресу не произойдет.

Кнопки [image] и [image] перемещают Вас по списку сохраненных адресов назад и вперед соответственно. Кнопка [image] или пункт меню «Вид–Перейти–Вверх на один уровень» позволяет подняться на предыдущий уровень.

Кнопка [image] панели инструментов позволяет добавлять и редактировать синонимы адресов. Синонимы можно использовать в том случае, когда какой-либо элемент адреса описывается неоднозначно, либо наряду с официальным имеется исторически сложившееся название и т.д. Например, официальное название улицы: «Веры Пановой». Но существует второе официальное название «В. Пановой», а также часто употребляется «Пановой» – в системе эти названия могут быть записаны как синонимы адреса улица «Веры Пановой». Впоследствии возможно вести поиск этого адреса не только по его названию, но и по его синонимам.


Добавление элементов адресов

В окне «Адреса» Вы можете добавить любые элементы адресной системы, выбрав соответствующий класс адреса. Возможный вариант добавления адреса существенно зависят от внешних форм, настроек, описанных в разделе «Параметры – «Общие – Адресная система», а также от классификатора адресов. В справочной системе описаны настройки, соответствующие стандартной поставке АИС «Дока» (варианты «Персональная», «Стандартная», «Профессионал», «Разработчик»). В демонстрационной версии отсутствует несколько внешних форм. Если Вы самостоятельно настроили адресную систему, дальнейшее описание может отличаться от Ваших настроек


Создание (изменение) адреса

Варианты создания нового адреса зависят от классификатора адресов и от того, какой именно адрес выделен в момент создания. Рассмотрим некоторые из них.

Если не выделено ни одного адреса, ни в дереве адресов на панели слева (точнее, дерево адресов не активно), ни в списке адресов на панели справа, то при создании адреса сначала будет вызвано диалоговое окно выбора класса адреса (Рис. 3.68). После выбора класса адреса будет вызвано диалоговое окно, соответствующее классу. Если не задано внешних форм для выбранного класса адреса, будет вызвано стандартное диалоговое окно адреса (Рис. 3.69). В этом окне необходимо ввести код адреса (система автоматически формирует код исходя из поля «символы кода» классификатора адресов и адреса-родителя, но Вы можете ввести любой другой код), название адреса, его краткое наименование (если есть), класс адреса (Вы уже выбрали класс, однако можете изменить свой выбор), адрес-родитель (если есть), а также второй адрес-родитель. После ввода всех параметров адреса и нажатия кнопки <ОК>, адрес будет записан в базу данных и автоматически выделен в дереве адресов на левой панели.

Если выделен адрес на левой панели окна «Адреса», а также дерево адресов на этой панели активно, выбор варианта создания нового адреса зависит от классификатора адресов.

Рис. 3.68

Рис. 3.69

Возможные варианты создаваемых адресов будут перечислены в меню «Адреса–Создать» и в выпадающем меню выбора кнопки [image]. В качестве вариантов адресов загружаются классы адресов, находящиеся на одном уровне с классом выделенного адреса и являющиеся при этом папками. Например, в дереве объектов выделен субъект РФ «Ростовская область»). Тогда меню создания адреса будет выглядеть так, как показано на Рис. 3.70. Если Вы обратите внимание на классификатор адресов (Рис. 3.68), то Вы увидите, что перечисленные в меню классы находятся на том же уровне, что и класс «область» (уровень 2), но являются папками (выделены жирным шрифтом). Исключение составляет пункт меню «Новый адрес». Его в классификаторе, естественно, нет. Выбор этого пункта меню означает автоматический выбор первого варианта и соответствует нажатию кнопки [image].

Рис. 3.70

Дальнейшие действия зависят от настроек системы.

Закладка «Безопасность» позволяет установить права доступа к создаваемому адресу. Подробно установка параметров безопасности для классов рассмотрена нами ранее. По аналогии с документами и субъектами, при создании адреса для его создателя (т.е. пользователя, создавшего адрес) предоставляются все права на этот адрес. Для остальных пользователей права на созданный адрес будут предоставлены в соответствии с правами на класс адреса. Вы можете предоставлять индивидуальные права на адрес, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права адреса этого класса полностью заменяются правами на класс.

Создавать адреса можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.


Создание государства

Создание (изменение) государства

Если Вами выбраны классы, находящиеся на 1 уровне классификатора и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) страны (государства), показанная на Рис. 3.71.

Рис. 3.71

· Код страны формируется автоматически, однако может быть на любой другой код и служит для идентификации страны в адресной системе (код должен быть уникальным для всех адресов, а не только для стран).
· Тип страны, по сути, является классом адреса. Варианты типов стран загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".
· Название страны может быть не уникальным (но обязательно для заполнения).
· Краткое название может быть не заполнено.
· Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это название уже не существующего государства (к таковому можно отнести СССР…), но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.


Создание субъекта РФ

Создание (изменение) субъекта РФ

Если Вами выбраны классы, находящиеся на 2 уровне классификатора, класс который начинается с «1.02.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) субъекта РФ, показанная на Рис. 3.72

Рис. 3.72

· Код субъекта РФ формируется автоматически на основе кода страны (Российская Федерация), кодов символов класса субъекта государства и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации субъекта РФ в адресной системе (код должен быть уникальным для всех адресов, а не только для субъектов РФ).
· Тип субъекта РФ, по сути, является классом адреса. Варианты типов субъектов (т.е. возможные классы субъектов РФ) загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".
· Название субъекта РФ может быть не уникальным (но обязательно для заполнения). Краткое название может быть не заполнено.
· Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это название уже не существующего субъекта, но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.


Создание муниципального образования

Создание (изменение) муниципального образования

Если Вами выбраны классы, находящиеся на 3 уровне классификатора, класс который начинается с «1.02.02.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) муниципального образования, показанная на Рис. 3.73

Рис. 3.73

· Код муниципального образования формируется автоматически на основе кода субъекта РФ, кодов символов класса муниципального образования и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации муниципального образования в адресной системе (код должен быть уникальным для всех адресов, а не только для муниципальных образований).
· Тип муниципального образования, по сути, является классом адреса. Возможные классы муниципальных образований загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".
· Название муниципального образования может быть не уникальным (но обязательно для заполнения).
· Краткое название может быть не заполнено.
· Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это название уже не существующего муниципального образования, но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.


Создание адреса субъекта РФ

Создание (изменение) адреса субъекта РФ

Если Вами выбраны классы, находящиеся на 3 уровне классификатора, класс который начинается с «1.02.03.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) адреса субъекта РФ, показанная на Рис. 3.74

Рис. 3.74

К адресам субъекта РФ можно отнести объекты, которые не имеют точного адреса или привязки в населенном пункте, однако требуют идентификации в пределах субъекта РФ, например, пикеты дорог федерального значения, железнодорожные дома, протяженные объекты (газопроводы, электросети и т.п.).

Действия по заполнению полей формы адреса субъекта РФ абсолютно идентичны действиям, описанным в предыдущем разделе "Создание (изменение) муниципального образования".


Создание населенного пункта

Создание (изменение) населенного пункта

Если Вами выбраны классы, находящиеся на 3 уровне классификатора, класс который начинается с «1.02.01.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) населенного пункта, показанная на рисунке

Действия по заполнению полей формы населенного пункта абсолютно идентичны действиям, описанным в разделе Создание (изменение) муниципального образования.

Отметим лишь поле «Мунцип. образование». Это поле может быть выбрано из списка доступных муниципальных образований указанного субъекта РФ. Вы можете не указывать принадлежности населенного пункта к муниципальным образованиям. Если Вы уже выбрали муниципальное образование, но хотите отказаться от этого, нажмите клавишу <DELETE> на активном списке выбора муниципальных образований.


Создание геонима

Созданием (изменение) геонима

Если Вами выбраны классы, находящиеся на 4 уровне классификатора, код которых начинается с «1.02.01.02.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) геонима (улицы, переулка, проспекта и т.п.), показанная на Рис. 3.75

Рис. 3.75

Код геонима формируется автоматически на основе кода населенного пункта, кодов символов класса геонима и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации геонима в адресной системе (код должен быть уникальным для всех адресов, а не только для геонимов). Тип геонима, по сути, является классом адреса. Возможные классы геонимов загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код геонима», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Название геонима может быть не уникальным (но обязательно для заполнения). Краткое название может быть не заполнено.

Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это уже не существующее название улицы, но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.


Создание района населенного пункта

Создание (изменение) района населенного пункта

Если Вами выбраны классы, находящиеся на 4 уровне классификатора, код которых начинается с «1.02.01.01.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) района населенного пункта, показанная на рисунке 3.76

Рис. 3.76

Действия по заполнению полей формы района абсолютно идентичны действиям, описанным в разделе Создание (изменение) геонима.

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код района», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Поле «Название кратко» можно не заполнять.


Создание адреса населенного пункта

Создание (изменение) адреса населенного пункта

Если Вами выбраны классы, находящиеся на 4 уровне классификатора, код которых начинается с «1.02.01.03.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) адреса населенного пункта, показанная на Рис. 3.77

Рис. 3.77

К адресам населенных пунктов можно отнести адреса, которые нельзя описать традиционным способом, например, абонентские ящики или описательный адрес (южная окраина города) и т.п.

Действия по заполнению полей формы адреса идентичны действиям, описанным в разделе Создание (изменение) геонима.

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код адреса», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Поле «Почтовый индекс» можно не заполнять.


Создание адреса

Создание (изменение) адреса

Если Вами выбраны классы, находящиеся на 5 уровне классификатора, код которых начинается с «1.02.01.02.01.» и не являющиеся папками, то при добавлении (изменении) адреса будет вызвана форма добавления (изменения) традиционного адреса, показанная на рисунке

Рис. 3.78

Код адреса формируется автоматически на основе кода геонима, кодов символов класса адреса и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации геонима в адресной системе (код должен быть уникальным для всех элементов - геонимов, населенных пунктов и т.п., а не только адресов).

Действия по заполнению полей формы адреса идентичны действиям, описанным в разделе Создание (изменение) геонима.

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код адреса», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Поле «Почтовый индекс» можно не заполнять. Дополнительно можно выбрать район населенного пункта в котором расположен адрес.

Для удаления выбранного района, нажмите клавишу <Delete> на активном списке выбора района.


Удаление элементов адресов

Адрес, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить адрес, нужно выполнить следующие действия:

· Выделить элемент адреса, который Вы хотите удалить, в дереве адресов на левой панели рабочего окна;
· Нажать кнопку [image] на панели инструментов, либо выбрать пункт меню «Адреса – <Текущий адрес> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном адресе);
· После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Внимание!

После удаления, восстановление адреса будет невозможно. Кроме того, удалятся все связи этого адреса с объектами и субъектами, а также вложенные адреса (например, удаление населенного пункта приведет к удалению всех улиц, районов и адресов этого населенного пункта). Если Вы не уверены в правильности Ваших действий, не удаляйте адрес.


Связи адреса с объектами и субъектами

В системе предусмотрена возможность просмотра объектов и субъектов, имеющих адреса, в окне «Адреса».
Для просмотра связей адресов с объектами и субъектами базы данных пользователь должен произвести следующие действия:

· Нажать кнопку [image] или выбрать пункт меню «Вид – Показать/скрыть связи – Показать связанные объекты» для просмотра объектов, находящихся по выделенному адресу.
· Нажать кнопку [image] или выбрать пункт меню «Вид – Показать/скрыть связи – Показать связанные субъекты» для просмотра субъектов, находящихся по выделенному адресу

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Адреса – Удалить» или контекстного меню «Удалить», либо нажать кнопку [image] на панели инструментов. После подтверждения удаления, связь между объектом (субъектом) и адресом будет разорвана. Сам объект (субъект) при этом не удаляются, очищается адрес в свойствах объекта (субъекта). Изменение связи из окна «Адреса» невозможно. Для изменения связи объекта с адресом (по сути адреса объекта), найдите объект, откройте его на редактирование (изменение) и измените адрес объекта. В случае с субъектом, измените требуемый адрес субъекта (почтовый или адрес регистрации).

Если Вы хотите быстро найти объект (субъект), находящийся по выбранному адресу, то выделите связь с искомым объектом (субъектом) в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Объекты» («Субъекты»), в котором искомый объект (субъект) будет открыт и выделен в панели дерева объектов (субъектов). Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным объектом (субъектом) все необходимые действия (изменение, удаление и пр.).


Поиск адреса

При большом количестве адресов поиск необходимого адреса в списке существенно затруднен. Для того чтобы найти нужный адрес, в программе предусмотрены развитые средства поиска. Для поиска адреса нажмите клавишу <F3> (или <CTRL+F>) на клавиатуре или нажмите кнопку [image] на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.79), в которой необходимо задать требуемые параметры поиска.

Рис. 3.79

На панели поиска имеются поля, формирующие условия поиска:

Начальные:
· Равно;
· Не равно;
· Меньше;
· Меньше/равно;
· Больше;
· Больше/равно;
· Похожее на;
· Начинается с;

Промежуточные:
· «И»;
· «ИЛИ».

Для поиска адреса необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

Формирование поисковой строки по текстовому полю.

В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле адреса. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

Начальные условия поиска имеют следующие значения:
· Равно – найти значения, точно соответствующие поисковой строке;
· Не равно – найти любые значения, не равные поисковой строке;
· Меньше – найти значения, меньшие, чем указаны в поисковой строке;
· Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
· Больше – найти значения, большие, чем указаны в поисковой строке;
· Больше/равно - найти значения, большие или равные указанным в поисковой строке;
· Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
· Начинается с – найти значения, с которых начинается поисковая строка.

Промежуточные условия поиска применяются в том случае, когда необходимо найти адрес более чем по одному полю.

Для поля «Класс адреса» поисковое значение выбираются из классификатора адресов и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле «Класс адреса»).

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти адреса, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Ростов», «ростов», «РОСТОВ», «РостоВ» и т.п.

При выставленном флажке «Искать в синонимах», поиск будет осуществлен также среди синонимов адресов. Например, Вы ищете адрес с названием «Веры Пановой», но не уверены, что именно так называется улица. Если в синонимах улицы есть различные варианты названия улицы (например «В. Пановой»), то можно выставив флажок «Искать в синонимах», попытаться найти эту улицу, набрав «В. Пановой». Использование синонимов адресов может существенно сократить время, поиска адресов.

После того, как адрес будет найден, Вы можете перейти к нему, дважды щелкнув по документу на правой панели или выбрав пункт контекстного меню «Открыть».


Окно выбора адреса

При создании адресов, при выборе адреса месторасположения объектов или субъектов используется окно «Выбор адреса» (рис. 3.80).

Рис. 3.80

Выбор адреса, а также другие действия в окне выбора адреса производятся также как и в окне выбора документов.


Фильтры адресов

В системе имеется возможность применения ограничений для показа в панелях дерева и списка объектов базы данных адресов определенного класса, назначаемых пользователем (т.н. фильтрация). Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна.

В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации».

Подробно работа по настройке фильтров описана в разделе Использование фильтров документов.


Дополнительные свойства адресов

Дополнительные свойства могут быть добавлены для класс адреса. Добавление дополнительных свойств адреса производится по аналогии с внешними формами:

· создается форма свойств адреса в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и «Разработчик»);
· Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);
· После загрузки адреса выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна документов, на панели инструментов «Свойства документа» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств пункт в меню «Адрес–Характеристики Адреса». Для остальных адресов эти формы остаются недоступными, и кнопка на соответствующей панели не появляется.


Связи

Описание рабочего окна
Создание связи
Копирование/вставка связи
Удаление связи
Поиск связи
Дополнительные характеристики связи
Фильтры связей


Описание рабочего окна

Рабочее окно связей предназначено для отображения связей между основными элементами системы (документы, субъекты, объекты), создания, изменения и удаления их, а также для ввода дополнительных характеристик связей (рис.3.81).

Рис. 3.81
В окне связей более удобно осуществлять поиск связанных субъектов и документов по классу связи или её состоянию. Например, если необходимо найти директора предприятия, можно в окне субъектов просмотреть связи с этим предприятием и найти среди них необходимую, либо открыть окно связей и найти связи класса "директор" и среди них найти необходимую.
Левая панель рабочего окна содержит дерево связей базы данных. Если активировать конкретную связь в левой панели, то в правой будет выведен список связанных с ней субъектов, документов или объектов.

Кнопки панели инструментов рабочего окна динамически изменяются в зависимости от активности связи и связанных с нею объектов базы данных.

При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил связь в базу данных, а у другого пользователя отсутствует информация об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (<F5>) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка связей с сервера и обновит ее в рабочем окне. При этом обновятся и все ссылки связи.

Для перемещения по списку связей используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки [image] и [image].


Создание связи

Добавить новую связь пользователь может выбором пункта меню рабочего окна «Связи – Создать – Связь» либо нажатием кнопки [image] на панели инструментов. Пользователю будет предложено выбрать класс создаваемой связи по классификатору (Рис. 3.82).

Рис.3.82
После выбора класса связи на экран будет вызвано соответствующее диалоговое окно. Реквизиты уже введенной связи можно изменить. Для того чтобы изменить связь, нужно выполнить следующие действия: выделить связь, которую Вы хотите изменить, в дереве связей на левой панели рабочего окна, нажать кнопку [image] на панели инструментов или выбрать пункт меню «Связи – <Текущая связь> - Изменить» или выбрать пункт контекстного меню «Изменить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте). Для изменения связи будет вызвано такое же диалогове окно, как и для добавления.

Если внешние формы для данного класса связей не заданы, то будет вызвано стандартное диалоговое окно (Рис. 3.83), состоящее из двух закладок. При этом, будет учтено, в какой группе содается новая связь, т.е. к какому типу она относится: документ->объект, документ->субъект, документ->документ, субъект->субъект или документ->адрес.

Рис. 3.83
На рисунке 3.83 в качестве примера показано создание связи типа документ->субъект. На закладке «Общие» пользователь с помощью кнопок [image] должен будет выбрать документ и субъект, между которыми создается связь. Кроме того, возможно изменение класса содаваемой связи, а также задать состояние связи.
Закладка «Безопасность» позволяет установить права доступа к создаваемой связи. Подробно установка параметров безопасности для классов рассмотрена нами ранее. По аналогии с документами, объектами и субъектами, при создании связи для её создателя (т.е. пользователя, создавшего связь) предоставляются все права на эту связь. Для остальных пользователей права на созданную связь будут предоставлены в соответствии с правами на класс связи. Вы можете предоставлять индивидуальные права на связь, вне зависимости от её класса. Однако следует помнить, что при изменении прав на класс, все права связи этого класса полностью заменяются правами на класс.


Копирование/вставка связи

Любая выделенная пользователем связь может быть скопирована в буфер обмена и затем вставлена в базу данных. Режим копирования/вставки подробно описан ранее.

Примечание: Если Вы используете нестандартные формы связей, то перед использованием этой возможности Вам необходимо создать метаданные для этих классов связей (см. подробно).

Возможность копирования удобно использовать для создания однотипных связей (связей, отличающихся друг от друга, например, только документом).

Для копирования связи необходимо:
· выбрать её в списке дерева связей (левая панель);
· нажать правую кнопку мыши и в контекстном меню выбрать пункт "Копировать", или нажать кнопку на панели инструментов рабочего окна связей

Для вставки связи необходимо:
· правой кнопкой мыши нажать на объекте, субъекте или документе (в зависимости от типа скопированной ранее связи), с которым должна быть создана аналогичная связь, в контекстном меню выбрать пункт "Вставить".


Удаление связи

Связь, созданную ошибочно или ненужную, можно удалить из базы данных. Для того чтобы удалить связь, нужно выполнить следующие действия:

· Выделить связь, которую Вы хотите удалить, в дереве объектов на левой панели рабочего окна или в панели списка;
· Нажать кнопку [image] на панели инструментов, выбрать пункт меню «Связи – <Текущий объект> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте);
· После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Внимание!

После удаления, восстановление связи будет невозможно. Если Вы не уверены в правильности Ваших действий, не удаляйте связь.


Поиск связи

При большом количестве связей поиск необходимой в списке существенно затруднен. Для того чтобы найти нужную связь, в программе предусмотрены развитые средства поиска. Для поиска объекта нажмите клавишу <F3> на клавиатуре или нажмите кнопку [image] на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.84), в которой необходимо задать требуемые параметры поиска.

В том случае, если для связи создана нестандартная формы ввода, то при вызове панели поиска на ней появляется еще одна кнопка «Дополнительно». При нажатии на эту кнопку появляется расширенная панель поиска с полями, описывающими свойства этой связи (аналогично поиску объектов или документов и т.п.).

Рис. 3.84

На панели поиска имеются поля, формирующие условия поиска:

Начальные:
· Равно;
· Не равно;
· Меньше;
· Меньше/равно;
· Больше;
· Больше/равно;
· Похожее на;
· Начинается с;

Промежуточные:
· «И»;
· «ИЛИ».

Для поиска связи необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие. Кроме того, при поиске связей необходимо однозначно указать какой тип связи мы ищем: документ->объект, документ->субъект, документ->документ, субъект->субъект или документ->адрес. Тип выбирается из списка "Искать в связях типа".

Формирование поисковой строки по текстовому полю.

В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле связи. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

Начальные условия поиска имеют следующие значения:
· Равно – найти значения, точно соответствующие поисковой строке;
· Не равно – найти любые значения, не равные поисковой строке;
· Меньше – найти значения, меньшие, чем указаны в поисковой строке;
· Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
· Больше – найти значения, большие, чем указаны в поисковой строке;
· Больше/равно - найти значения, большие или равные указанным в поисковой строке;
· Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
· Начинается с – найти значения, с которых начинается поисковая строка.

Промежуточные условия поиска применяются в том случае, когда необходимо найти объект более чем по одному полю. Например: Название класса ПОХОЖЕЕ НА %исполнит% И класс связи 00.01 (Договорные отношения), включая вложенные классы.

Для поля «Класс связи» поисковые значения выбираются из соответствующего классификатора и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска «Класс связи»).

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти связи, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Исполнитель», «исполнитель», «ИСПОЛНИТЕЛЬ», «ИсПоЛнИтЕлЬ» и т.п.

После того, как связь будет найдена, Вы можете перейти к ней, дважды щелкнув по связи на правой панели или выбрав пункт контекстного меню «Открыть».


Дополнительные характеристики связи

Это дополнительное свойство связи, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Дополнительные характеристики могут быть добавлены, как вспомогательная информация, и использованы в печатных формах. Для добавления дополнительных характеристик пользователь должен найти в панели дерева связей нужную связь, сделать его активной, щелкнув на ней левой кнопкой мыши и нажать кнопку [image] на панели инструментов.Работа с дополнительными характеристиками описана ранее (Рис. 3.19).

Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретную связь. Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).


Фильтры связей

В системе имеется возможность применения ограничений для показа в панелях дерева и списка связей базы данных связей определенного класса, назначаемых пользователем. Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна Рис. 3.85.

Рис. 3.85
В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации».

Подробно работа по настройке фильтров описана в п. "Использование фильтров документов".

Примечание. В версии 2.5 данный функционал заложен, однако до конца не реализован. Реализация данного функционала в ближайших планах компании "Комплекс Софт"


Управление недвижимостью

Конфигурация "Управление недвижимостью"

Настоящее руководство описывает особенности реализации конфигурации АИС "Дока" для предприятий и организаций ЖКХ. Все базовые принципы работы с системой и ее основные понятия описаны в документации «Руководство пользователя АИС «Дока».

Автоматизированная информационная система «Управление недвижимостью» предоставляет возможности обеспечения информацией предприятий муниципальных городских служб, управляющих компаний сферы ЖКХ, руководящих органов ТСЖ-ЖСК. Система предусматривает учет объектов жилищного фонда, благоустройства, инженерной инфраструктуры и т.п., формирование технической документации учитываемых объектов, регламентированных отчетов, пространственный анализ информации и многое другое.


Назначение системы

Основные функциональные возможности системы

Назначение системы Управление недвижимостью:

· Накопление, хранение и выдача информации об объектах коммунального хозяйства:

· жилищного фонда (строения, домовладения, помещения);
· конструктивных элементов (фундамент, стены, перекрытия и пр.);
· инженерных систем различного назначения (водопровод, канализация, электросети и т.п.);
· инфраструктуры обслуживаемого района (малые формы, контейнерные площадки, объекты озеленения);
· земельных участков;
· замощений (покрытий.)

· Хранение информации о технических характеристиках объектов: этажность, год постройки, материал стен, фундаментов, инженерных систем и т.п.;

· Хранение технической, нормативной и иной документации, связанной с процессом управления;

· Хранение связей между объектами, документами и субъектами управления;

· Хранение графической, семантической и любой другой информации об объекте, в том числе компьютерных моделей зданий (Allplan (Nemetschek AG, ФРГ), ArCon (mb-Software AG, ФРГ), speedikon A/X (mb-Software AG, ФРГ), ArchiCAD (Graphisoft, Венгрия) и т.д.), чертежей, фотографий, звуковых файлов, видео и т.п.;

· Распечатка технической документации (технических паспортов зданий, актов обследования и т.п.);

· Формирование документации по заданным алгоритмам с автоматической подстановкой требуемых полей: уведомления о принятии жалобы, рассылки, письма с уведомлением о задолженности и т.п.;

· Отслеживание сроков действия документов с возможностью уведомления и автоматического перевода просроченной документации в заданное состояние;

· Возможность задания различных характеристик для документов: класс документа (договор, акт, жалоба и пр.), приоритет, состояние, группа (группы создаются пользователями, например, относящиеся к ЖЭУ), период действия (дата начала, дата окончания) и другие;

· Возможность гибкого изменения интерфейса программы в процессе ее эксплуатации: добавление новых характеристик объекта при сохранении ранее созданных, изменение формы ввода и т.п.

· Ввод, хранение, редактирование и анализ информации о техническом состоянии объекта;

· Поиск объектов, документов, субъектов (организаций, физических лиц) по различным критериям - названию, классу, состоянию, группе, дате, языку и т.п.;

· Возможность создания специализированных панелей поиска: для физических лиц - поиск по имени, отчеству, фамилии и т.п., для юридических лиц - поиск по ИНН, по названию, форме собственности и т.п.

· Выборка объектов (строений, земельных участков и пр.) и их основных характеристик по заданным критериям (район, форма собственности, техническое состояние, проведенные ремонты и многое другое);

· Печать и экспорт полученных отчетов (поддерживаются форматы MS Word, MS Excel, PDF, HTML, текстовый, текстовый с разделителями (csv), графические форматы (BMP, JPG, GIF));

· Печать отчетов на матричных принтерах;

· Работа с данными с помощью Fast Report Studio и Fast Report Server;

· Поиск и позиционирование объекта на электронной карте (при наличии электронной карты и ГИС-приложения ArcGIS 8.x и выше или ArcView 3.2 или выше);

· Поиск объекта, выделенного на карте, в базе данных (обратная связь с картой);

· Пространственный анализ полученной информации на электронной карте (при наличии электронной карты и ГИС-приложения ArcGIS 8.x и выше или ArcView 3.2 или выше);

· Ввод, хранение и редактирование информации о ремонтах, проведенных на объекте;

· Анализ эффективности проведения ремонтных работ и соблюдения правил и норм эксплуатации;

· Мониторинг технического состояния объекта (сравнение результатов обследования за различные периоды времени) в текстовом и графическом виде;

· Описание технического состояния объекта;

· Моделирование технического состояния объектов на любой заданный отрезок времени с возможностью изменения параметров моделирования (естественное старение, ремонт всех конструктивных элементов, ремонт определенных конструктивных элементов и т.п.);

· Настройка параметров программы с хранением установленных значений для каждого пользователя вне зависимости от его рабочего места-компьютера (настройки сохраняются в базе данных).


Основные термины ЖКХ

Основные термины и определения в области ЖКХ:

Жилищный фонд – совокупность всех жилых помещений независимо от форм собственности, включая жилые дома, специализированные дома (общежития, гостиницы-приюты, дома маневренного фонда, жилые помещения из фондов жилья для временного поселения вынужденных переселенцев и лиц, признанных беженцами, специальные дома для одиноких престарелых, дома-интернаты для инвалидов, ветеранов и другие), квартиры, служебные жилые помещения, иные жилые помещения в других строениях, пригодные для проживания.
Примечание: различают следующие виды жилищного фонда: частный, государственный, муниципальный и общественный.

Жилое здание многоквартирное – жилое здание, в котором квартиры имеют общие внеквартирные помещения и инженерные системы;

Жилое здание секционного типа – здание, состоящее из одной или нескольких секций, отделенных друг от друга стенами без проемов, с квартирами одной секции, имеющими выход на одну лестничную клетку непосредственно или через коридор;

Жилое здание галерейного типа – здание, в котором все квартиры этажа имеют выходы через общую галерею не менее чем на две лестницы;

Жилое здание коридорного типа – здание, в котором все квартиры этажа имеют выходы через общий коридор не менее чем на две лестницы;

Блокированный жилой дом – здание, состоящее из двух квартир и более, каждая из которых имеет непосредственно выход на приквартирный участок;

Приквартирный участок – земельный участок, примыкающий к жилому зданию (квартире) с непосредственным выходом на него;

Этаж надземный – этаж с отметкой пола помещений не ниже планировочной отметки земли;

Этаж подземный – этаж с отметкой пола помещений ниже планировочной отметки земли на всю высоту помещений;

Этаж первый – нижний надземный этаж здания;

Этаж цокольный – этаж с отметкой пола помещений ниже планировочной отметки земли на высоту не более половины высоты помещений;

Этаж подвальный – этаж с отметкой пола помещений ниже планировочной отметки земли более чем наполовину высоты помещений или первый подземный этаж;

Этаж мансардный – этаж в чердачном пространстве, фасад которого полностью или частично образован поверхностью (поверхностями) наклонной, ломаной или криволинейной крыши;

Этаж технический – этаж для размещения инженерного оборудования здания и прокладки коммуникаций, может быть расположен в нижней части здания (техническое подполье), верхней (технический чердак) или между надземными этажами. Междуэтажное пространство высотой 1,8 м и менее, используемое только для прокладки коммуникаций, этажом не является;

Планировочная отметка земли – уровень земли на границе земли и отмостки здания;

Жилищно-коммунальные услуги - услуги исполнителя по поддержанию и восстановлению надлежащего технического и санитарно-гигиенического состояния зданий, сооружений, оборудования, коммуникаций и объектов жилищно-коммунального назначения, вывозу бытовых отходов и подаче потребителям электрической энергии, питьевой воды, газа, тепловой энергии и горячей воды.
Примечание: Под объектами жилищно-коммунального назначения понимают объекты внешнего благоустройства территории городов и населенных пунктов (зеленые насаждения, городские дороги и элементы их благоустройства, пешеходные и велосипедные дорожки, объекты инженерной защиты территории, уличное освещение, объекты санитарной уборки и др.), а также обустроенные площадки, стоянки, участки, устройства и конструкции из различных материалов, размещенные на придомовой территории.

Вид жилищно-коммунальных услуг - совокупность однородных жилищно-коммунальных услуг, характеризующихся общими технологическими признаками.

Элементы здания - конструкции и технические устройства, составляющие здание, предназначенные для выполнения заданных функций.

Неисправность элемента здания - состояние элемента, при котором им не выполняется хотя бы одно из заданных эксплуатационных требований.

Повреждение элемента здания - неисправность элемента здания или его составных частей, вызванная внешним воздействием (событием).

Дефект элемента здания - неисправность (изъян) элемента здания, вызванная нарушением правил, норм и технических условий при его изготовлении, монтаже или ремонте.

Эксплуатационные показатели здания - совокупность технических, объемно-планировочных, санитарно-гигиенических, экономических и эстетических характеристик здания, обуславливающих его эксплуатационные качества.

Физический износ здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - показатель, характеризующий изменение технического состояния здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) по сравнению с первоначальным состоянием (ГОСТ Р 51929-2002).

Физический износ (конструкции, элемента, системы инженерного оборудования и здания в целом) - это утрата ими первоначальных технико-эксплуатационных качеств (прочности, устойчивости, надежности и др.) в результате воздействия природно-климатических факторов и жизнедеятельности человека (ВСН 53-86(р)).

Моральный износ здания - величина, характеризующая степень несоответствия основных параметров, определяющих условия проживания, объем и качество предоставляемых услуг современным требованиям.

Сезонная эксплуатация здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - содержание и ремонт здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения), отражающие особенности оказания жилищно-коммунальных услуг в различные периоды года.
Примечание: Различают зимний (осенне-зимний) и летний (весенне-летний) периоды сезонной эксплуатации.

Ремонт здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - комплекс операций по восстановлению исправности или работоспособности здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) и восстановлению его ресурса или ресурса его составных частей (ГОСТ Р 51929-2002).

Ремонт здания - комплекс строительных работ и организационно-технических мероприятий по устранению физического и морального износа, не связанных с изменением основных технико-экономических показателей здания (ВСН 58-88(р)).

Текущий ремонт здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - ремонт, выполняемый для восстановления исправности или работоспособности здания (сооружения, коммуникаций, объектов жилищно-коммунального назначения), частичного восстановления его ресурса с заменой или восстановлением составных частей ограниченной номенклатуры в объеме, установленном нормативной и технической документацией.

Капитальный ремонт здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - ремонт, выполняемый для восстановления ресурса здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) с заменой или восстановлением любых составных частей, включая базовые. Капитальный ремонт заключается в замене и восстановлении отдельных частей или целых конструкций и инженерно - технического оборудования зданий в связи с их физическим износом и разрушением. В состав капитального ремонта включаются также работы, по характеру относящиеся к текущему ремонту, но выполняемые в связи с производством капитального ремонта.

Комплексный капитальный ремонт (ККР) - ремонт, охватывающий все здание в целом или отдельные его секции, при котором устраняется физический и моральный износ;
Выборочный капитальный ремонт (ВКР) ремонт, охватывающий отдельные конструктивные элементы здания или оборудования, при котором устраняется физический износ.

Кроме того, в зависимости от технического состояния зданий и сооружении, их планировки и степени благоустройства могут проводиться следующие ремонтные работы:

Капитальный ремонт, предусматривающий в основном замену систем инженерного оборудования;
Выборочный капитальный ремонт, при котором производятся необходимые срочные работы, которые не могут быть приурочены к очередному плановому ремонту, в том числе ремонт кровли, фасада, инженерного оборудования;
Аварийный ремонт - выполняется для ликвидации последствий внезапных аварий, повреждений конструкций, вызванных стихийными бедствиями;
Охранно - поддерживающий ремонт - производится в ветхих домах, которые в ближайшее время не могут быть снесены.

Содержание здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - комплекс услуг по техническому обслуживанию, уборке, диагностике, испытаниям и обследованиям здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) и техническому надзору за его состоянием.

Техническое обслуживание здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - операция или комплекс операций по поддержанию работоспособности или исправности здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) при использовании по назначению, ожидании, хранении и транспортировании (ГОСТ Р 51929-2002).

Техническое обслуживание жилого здания - комплекс работ по поддержанию исправного состояния элементов здания и заданных параметров, а также режимов работы его технических устройств (ВСН 58-88(р)).

Реконструкция здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - комплекс операций по переустройству действующего здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) в целях повышения технического уровня, улучшения технико-экономических показателей, условий эксплуатации и охраны окружающей среды (ГОСТ Р 51929-2002).

Реконструкция здания - комплекс строительных работ и организационно-технических мероприятий, связанных с изменением основных технико-экономических показателей (количества и площади квартир, строительного объема и общей площади здания, вместимости или пропускной способности или его назначения) в целях улучшения условий проживания, качества обслуживания, увеличения объема услуг (ВСН 58-88(р)).

Диспетчерское обслуживание здания (сооружения, оборудования, коммуникаций и объектов жилищно-коммунального назначения) - комплекс операций по приему, регистрации, учету заявок потребителей на оказание жилищно-коммунальных услуг и контролю за их исполнением.

Аварийное обслуживание здания (сооружения, оборудования, коммуникаций и объектов жилищно-коммунального назначения) - комплекс первоочередных операций и мероприятий по незамедлительному устранению аварий и неисправностей, сохранению и восстановлению условий, необходимых для жизнеобеспечения и безопасности потребителей.

Услуги по санитарной очистке жилищного фонда и придомовых территорий - услуги исполнителя по поддержанию и восстановлению надлежащего санитарно-гигиенического состояния жилищного фонда и придомовых территорий.

Услуги по содержанию и уходу за зелеными насаждениями придомовых территорий - услуги исполнителя по посеву газонов, устройству цветников, дорожек и площадок, подготовке участков для озеленения, заготовке, посадке деревьев и кустарников, а также по уходу за ними на придомовых территориях.

Услуги инженерной защиты территорий населенных пунктов - услуги исполнителя по содержанию и ремонту водоотводных и дренажных систем, защитных дамб и береговых укреплений, противооползневых и противообвальных сооружений, сооружений и средств защиты инженерных коммуникаций.

Услуги по озеленению и декоративному цветоводству - услуги исполнителя по выращиванию посадочного материала декоративных древесно-кустарниковых, цветочных и травянистых растений, посадке деревьев, посеву газонов, устройству цветников и уходу за ними на территориях населенных пунктов.

Услуги по отлову безнадзорных животных - услуги исполнителя по поддержанию надлежащего санитарно-гигиенического состояния территории населенного пункта посредством поимки безнадзорных животных, содержанию их в пунктах передержки и приютах, утилизации животных.

Услуги по монтажу (ремонту, техническому обслуживанию) средств обеспечения пожарной безопасности зданий (сооружений) - услуги исполнителя по монтажу (ремонту, техническому обслуживанию) оборудования, приборов и коммуникаций, систем противопожарной защиты зданий (сооружений).

Примечание: Основные термины и определение приведены на основании:

· ГОСТ Р 51929-2002 «Услуги жилищно-коммунальные. Термины и определения»;
· МДС 81-6.2000 «Методическое пособие по определению сметной стоимости капитального ремонта жилых домов, объектов коммунального и социально - культурного назначения»;
· МДК 2-03.2003 «Правила и нормы технической эксплуатации жилищного фонда»;
· ВСН 53-86(р) «Правила оценки физического износа жилых зданий»;
· ВСН 58-88(р) «Положение об организации и проведении реконструкции, ремонта и технического обслуживания жилых зданий, объектов коммунального и социально-культурного назначения»;
· СНиП 31-01-2003 «Здания жилые многоквартирные».


Описание работы с приложением

В документации описаны особенности работы с формами ввода для объектов жилищно-коммунального хозяйства и некоторых специфических документов из этой области.

Объекты:
· здание (строение);
· квартира, офис;
· помещение;
· конструктивный элемент;
· земельный участок;
· замощение (покрытие).

Документы:
· акт обследования технического состояния;
· акт выполнения работ;
· жалоба;
· резолюция;
· отчеты.

Учитывая специфику конфигураций для предприятий ЖКХ, в систему добавлены новые классификаторы, такие как «Жалобы», «Классификатор ремонтов».

Классификатор «Жалобы» предназначен для работы с жалобами клиентов по вопросам эксплуатации жилищного фонда и используется в документе «Жалоба».
«Классификатор ремонтов» используется при вводе информации о произведенных ремонтах в акты выполнения работ (ф.2).


Объекты

Описание рабочего окна

На левой панели окна располагается список объектов жилищного фонда с древовидной структурой подчиненных объектов. Корневыми объектами являются здания (Королева, 17 и Королева 5/3).
Внутри зданий расположены вложенные объекты, сгруппированные по пользовательским группам, назначенным в классификаторе «Группы объектов» - Группировка элементов зданий. Вложенными в здание объектами являются элементы благоустройства, квартиры (офисы) и помещения, а также конструктивные элементы (см. раздел справки «Создание вложенной группировки»). Каждый из объектов помимо названия обозначен соответствующим значком (иконкой), показывающим его функциональное назначение.
На панели инструментов для каждого объекта (здания) доступна группа кнопок [image], при нажатии на которые вызываются (слева направо):
· окно работы со списком квартир здания;
· окно работы со списком конструктивных элементов здания;
· окно моделирования нормативного физического износа здания.

Для того, чтобы использовать функции этих кнопок для конкретного здания, необходимо выделить мышью это здание на левой панели рабочего окна.


Здание

Объект "Здание"

Здание является основным объектом учета жилищного фонда управляющей компании.
Добавить новое здание пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки [image] на панели инструментов. После выбора класса создаваемого объекта (здания) из классификатора на экран будет выведена форма ввода Рис. 1.5.

На вкладке «Общие сведения» вводятся данные:

Рис. 1.5
· наименование объекта (при выборе пользователем адреса объекта на вкладке «Дополнительно» в поле автоматически помещается его адрес);
· тип или серия проекта;
· литера;
· год постройки (дата);
· группа капитальности здания;
· принадлежности строения к памятникам архитектуры;
· данные о переоборудовании с указанием даты;
· наличие дополнительных составных частей здания;
· особенности конструкции здания.

На вкладке «Характеристики» Рис. 1.6 вводятся данные:

Рис. 1.6
· количество этажей;
· строительный объем;
· количество подъездов;
· средняя высота помещений;
· количество лестниц;

На вкладке «Площади» Рис. 1.7 вводятся данные:

Рис. 1.7

· сведения об основных и иных площадях здания;

· уборочная площадь лестниц;
· уборочная площадь мест общего пользования;
· сведения о площадях нежилых помещений.

На вкладке «Экономические показатели» Рис. 1.8 вводятся данные:

Рис. 1.8

· сведения о стоимостях здания и моменте времени проведенной оценки;
· сведения о муниципальной доле в составе здания.

На вкладке «Дополнительно» Рис. 1.9 вводятся данные:

Рис. 1.9

· группа объекта (по классификатору групп объектов);
· состояние объекта (по справочной таблице состояний объекта);
· класс объекта (по классификатору объектов);
· адрес строения;
· код на карте (поле, используемое для поиска здания (строения) на электронной карте. Необходимость заполнения этого поля возникает при интеграции системы с ГИС-приложением.

На вкладке «Распределение площадей» Рис. 1.10 вводятся данные:

· сведения о распределении площадей здания.

Рис. 1.10

Вкладка представляет собой редактор с древовидно-табличной структурой и автоматическим суммированием введенных данных по группам.

Вкладка «Помещения и конструктивные элементы» Рис. 1.11 предоставляет пользователю возможность управления составом и структурой здания. Эти действия пользователь может проводить как на данной вкладке, так и в рабочем окне «Объекты», а так же в окнах "Список квартир" и "Список конструктивных элементов".

На этой вкладке можно добавлять составляющие элементы здания: помещения, конструктивные элементы, элементы благоустройства, земельные участки (дворовая и уличная территории), замощения и пр.

Рис. 1.11

В верхней части вкладки расположена стандартная для системы панель инструментов, позволяющая добавить, изменить или удалить объект, обновить дерево объектов и просмотреть (изменить) их свойства. Кнопки панели инструментов дублированы в контекстном меню, вызываемом щелчком правой кнопки мыши на том или ином объекте.

Одной из особенностей добавления новых объектов здания является то, что при нажатии на стрелку, расположенную справа от значка [image], пользователю будет предложен список доступных для ввода объектов, состав которых динамически изменяется в зависимости от того, какой текущий объект здания выделен. Так, например, при выделении, показанном на Рис. 1.11, пользователь увидит выпадающее меню, представленное на Рис. 1.12 (перечислены помещения, которые могут входить в состав квартиры).

Рис. 1.12

Нажатие на кнопку «Добавить» вызовет общий классификатор объектов, в котором пользователь должен будет найти нужный объект.
Настройка описанной выше возможности осуществляется в классификаторе объектов (см. «Руководство пользователя АИС «Дока», Классификатор «Документы» - Работа с допустимыми связями).


Квартира

Объект "Квартира"

Объект «Квартира» («Офис») используется для учета составляющих объектов здания, имеющих в своем составе встроенные помещения.
Добавить новую квартиру (офис) пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки [image] на панели инструментов. После выбора класса создаваемого объекта (квартира) из классификатора на экран будет выведена форма ввода Рис. 1.13.
Сведения, заполняемые в представленной форме, необходимы для формирования технического паспорта квартиры.

На вкладке «Общие сведения» Рис. 1.13 вводятся данные:

Рис. 1.13

· наименование (номер квартиры);
· этаж;
· количество комнат;
· высота помещений;
· физический износ;
· особенности квартиры;
· примечание (дополнительные сведения).

На вкладке «Площади» Рис. 1.14 вводятся данные:

Рис. 1.14

· сведения об основных площадях квартиры.

На вкладке «Стоимость» Рис. 1.15 вводятся данные:

Рис. 1.15

· сведения о стоимости квартиры и моменте времени проведенной оценки;
· сведения о муниципальной доле в составе квартиры.

На вкладке «Дополнительно» Рис. 1.16 вводятся данные:

Рис. 1.16
· группа объекта (классификатор групп объектов – группировка элементов зданий). При выборе группы объекта квартира помещается внутрь вложенной группировки элементов здания (Рис. 1.11);
· состояние объекта (по справочной таблице состояний объекта);
· класс объекта (по классификатору объектов);
· адрес квартиры (создается и выбирается);
· расположена в: - принадлежность квартиры конкретному зданию (строению). Пользователь должен выбрать здание – владелец квартиры в окне выбора объектов.

Вкладка «Помещения и конструктивные элементы» Рис. 1.17 предоставляет пользователю возможность управления составом и структурой квартиры. Эти действия пользователь может проводить как на данной вкладке, так и в рабочем окне «Объекты».

Рис. 1.17

Работа с элементами квартиры аналогична рассмотренной нами на вкладке «Помещения и конструктивные элементы» здания (Рис. 1.11).
Наряду с помещениями, в состав квартиры могут быть добавлены и конструктивные элементы (Рис. 1.17).


Помещение

Объект "Помещение"

Добавить новое помещение пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки [image] на панели инструментов. После выбора класса создаваемого объекта (квартира) из классификатора на экран будет выведена форма ввода Рис. 1.18.
Сведения, заполняемые в представленной форме, необходимы для формирования технического паспорта квартиры.

На вкладке «Общие сведения» вводятся данные:

· наименование помещения (автоматически присваивается имя класса помещения);
· формула расчета (длина и ширина помещения);
· площадь помещения;
· высота помещения;
· сведения об аренде или выкупе.

Рис. 1.18

На вкладке «Дополнительно» Рис. 1.19 вводятся данные:

Рис. 1.19

· группа объекта (по классификатору групп объектов);
· состояние объекта (по справочной таблице состояний объекта);
· класс объекта (по классификатору объектов);
· расположена в: - принадлежность помещения конкретной квартире (офису). Пользователь должен выбрать квартиру – владелец помещения в окне выбора объектов.


Конструктивный элемент

Конструктивные элементы зданий могут иметь специфические характеристики. В данной конфигурации рассмотрены два вида конструктивных элемента:

· Стандартный
· Лифт

Стандартный конструктивный элемент имеет ряд свойств, хараткерных для всех конструктивных элементов и инженерного оборудования здания в соответстствии с ВСН 53-86р (удельный вес элемента (оборудования) в восстановительной стоимости строения, срок его службы, сменяемость элемента и т.п.) и ряд дополнительных свойств, используемых в конфигурации (объем или площадь поверхности элемента, единица измерения, состояние и пр.)


Стандартный

Объект "Конструктивный элемент (инженерное оборудование) стандартный"

Добавить новый конструктивный элемент пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки [image] на панели инструментов. После выбора класса создаваемого объекта (конструктивный элемент) из классификатора на экран будет выведена форма ввода Рис. 1.20.

На вкладке «Общие сведения» вводятся данные:

· наименование (автоматически присваивается имя класса конструктивного элемента);
· удельный вес конструктивного элемента в составе здания;
· срок службы конструктивного элемента (лет);
· класс конструктивного элемента (по классификатору объектов);
· сменяемый элемент – устанавливается для сменяемых конструктивных элементов (например, дверные или оконные заполнения);
· дата последней замены элемента;
· площадь (объем и пр.) – абсолютная величина измеряемого элемента (например, площадь кровли);
· единица измерения для предыдущего пункта – выбирается из классификатора единиц измерений.

Рис. 1.20

На вкладке «Дополнительно» вводятся данные:

Рис. 1.21

· группа объекта (классификатор групп объектов – группировка элементов зданий). При выборе группы объекта конструктивный элемент помещается внутрь вложенной группировки элементов здания (Рис. 1.11);
· состояние объекта (по справочной таблице состояний объекта);
· элемент как часть - принадлежность конструктивного элемента конкретному зданию, квартире или помещению. Пользователь должен выбрать здание – владелец элемента в окне выбора объектов;

На вкладке «Мониторинг техсостояния» (Рис. 1.22) отображаются данные о проведенных обследованиях технического состояния конструктивного элемента.

Рис. 1.22

Это информационная панель, данные для которой автоматически отображаются из связанных актов обследования технического состояния.


Лифт

Объект "Конструктивный элемент "Лифт"

Лифт является специфическим конструктивным элементом с особыми свойствами.

На вкладке «Общие сведения» Рис. 1.23 вводятся данные:

Рис. 1.23

· наименование (автоматически присваивается имя класса конструктивного элемента). При необходимости пользователь может добавить в наименование собственную информацию (например, номер подъезда);
· регистрационный номер лифта;
· номер подъезда здания, в котором установлен лифт;
· скорость движения лифта;
· дата последней замены лифта;
· грузоподъемность;
· примечание (дополнительные сведения).

На вкладке «Дополнительно» вводятся данные:

Рис. 1.24

· группа объекта (классификатор групп объектов – группировка элементов зданий). При выборе группы объекта лифт помещается внутрь вложенной группировки элементов здания (Рис. 1.11);
· состояние объекта (по справочной таблице состояний объекта);
· класс объекта (по классификатору объектов);
· расположена в: - принадлежность лифта конкретному зданию (строению). Пользователь должен выбрать здание – владелец лифта в окне выбора объектов;
· сменяемый элемент – устанавливается для сменяемых конструктивных элементов;
· удельный вес лифта в составе здания;
· срок службы лифта (лет).

На вкладке «Мониторинг техсостояния» (Рис. 1.25) отображаются данные о проведенных обследованиях технического состояния конструктивного элемента.

Рис. 1.25

Это информационная панель, данные для которой автоматически отображаются из связанных актов обследования технического состояния.


Земельный участок

Объект "Земельный участок"

Объект «Земельный участок» может существовать как самостоятельно, так и в составе других объектов жилищного фонда. Более того, для различных объектов жилищного фонда он может выступать в различных ролях:
· в качестве корневого объекта (например, земельный участок домовладения);
· в качестве вложенного объекта (например, придомовая территория жилого здания).

Правила использования объекта «Земельный участок» должны быть выработаны и согласованы в управляющей организации до начала эксплуатации системы. Этот момент является важным для последующего формирования отчетов.
Добавить новый земельный участок пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки [image] на панели инструментов. После выбора класса создаваемого объекта (Земельный участок) из классификатора на экран будет выведена форма ввода Рис. 1.26.
На вкладке «Общие сведения» вводятся данные, необходимые для заполнения раздела технического паспорта «Экспликация площади земельного участка»:

· наименование участка;
· инвентарный номер;
· кадастровый номер;
· номер кадастрового квартала;
· момент времени, на который актуальны данные об участке;
· сведения о площадях земельного участка.

Рис. 1.26

На вкладке «Замощения» Рис. 1.27 вводятся данные, необходимые для заполнения разделов технического паспорта «Экспликация площади земельного участка» и «Уборочная площадь». Для ввода информации об использовании незастроенной площади земельного участка используется особый объект «Замощение», который будет рассмотрен в следующем параграфе.

Рис. 1.27
Работа с составными элементами земельного участка аналогична рассмотренной нами на вкладке «Помещения и конструктивные элементы» здания (Рис. 1.11).

На вкладке «Дополнительно» вводятся данные:

Рис. 1.28

· группа объекта (по классификатору групп объектов);
· состояние объекта (по справочной таблице состояний объекта);
· класс объекта (по классификатору объектов);
· код на карте (поле, используемое для поиска земельного участка на электронной карте. Необходимость заполнения этого поля возникает при интеграции системы с ГИС-приложением.).
· принадлежит: - принадлежность участка другому объекту (например, земельному кварталу или зданию). Пользователь должен выбрать объект – владелец участка в окне выбора объектов;
· адрес земельного участка.


Замощение

Объект "Замощение (Покрытие)"

Объект «Замощение» используется для ввода информации об использовании незастроенной площади земельного участка. Эти данные, необходимы для заполнения разделов технического паспорта «Экспликация площади земельного участка» и «Уборочная площадь». Кроме того, эти сведения могут быть использованы для расчета численности работников, занятых содержанием жилищного фонда. Нормативы численности и нормы обслуживания на ручную уборку территорий устанавливаются дифференцированно, в зависимости от класса территории и типа покрытий.

В соответствии с Правилами и нормами технической эксплуатации жилищного фонда, в зависимости от интенсивности пешеходного движения территории разбиваются на 3 класса:

· I класс - до 50 чел./час (территории дворов следует относить к I классу);
· II класс - от 50 до 100 чел./час;
· III класс - свыше 100 чел./час.

Типы покрытий приняты следующие: усовершенствованные (асфальтобетонные, брусчатые), неусовершенствованные (щебеночные, булыжные) и территории без покрытий. Отдельно выделяются территории газонов.

На вкладке «Общие сведения» вводятся данные:

Рис. 1.29
· наименование покрытия;
· площадь (кв.м);
· класс проходимости (класс по интенсивности пешеходного движения);
· класс покрытия (тип - усовершенствованные, неусовершенствованные).

На вкладке «Дополнительно» вводятся данные:

Рис. 1.30

· группа объекта (по классификатору групп объектов);
· состояние объекта (по справочной таблице состояний объекта);
· элемент как часть - принадлежность покрытия другому объекту (например, земельному участку). Пользователь должен выбрать объект – владелец участка в окне выбора объектов.


Список квартир

При выделении мышью конкретного здания на левой панели рабочего окна и нажатии кнопки [image] вызывается диалоговая форма.

В этом окне отображаются только квартиры выбранного здания. Здесь пользователь может добавлять новые квартиры, редактировать существующие, либо удалять ненужные (в том случае, если объект - здание создавался путем копирования - вставки).

Основным преимуществом работы в окне списка квартир является то, что созданная квартира автоматически получает принадлежность к текущему зданию и группе "Квартиры" этого здания.

Аналогичной функциональностью обладает вкладка "Помещения и конструктивные элементы" здания.
Здесь можно посмотреть порядок работы с диалоговой формой "Квартира".


Список конструктивных элементов

При выделении мышью конкретного здания на левой панели рабочего окна и нажатии кнопки [image] вызывается диалоговая форма.

В этом окне отображаются только конструктивные элементы и элементы благоустройства выбранного здания. Здесь пользователь может добавлять новые элементы, редактировать существуюшие, либо удалять ненужные (в том случае, если объект - здание создавался путем копирования - вставки).

Основным преимуществом работы в окне списка конструктивных элементов является то, что созданный конструктивный элемент автоматически получает принадлежность к текущему зданию.

Аналогичной функциональностью обладает вкладка "Помещения и конструктивные элементы" здания.
Здесь можно посмотреть порядок работы с диалоговой формой "Конструктивный элемент".

Не менее важной особенностью использования этого окна является возможность проверить и исправить сумму удельных весов всех конструктивных элементов здания, которая должна быть равна 100%. Удельные веса конструктивных элементов используются при моделировании нормативного физического износа здания и расчета стоимости замены отдельных элементов.

Для удобства работы конструктивные элементы и элементы благоустройства могут быть сгруппированы в отдельные группы. Для этого необходимо внутри окна со списком элементов щелкнуть правой кнопкой мыши и в контекстном меню выбрать "Группировка - Сгруппировать".

В этом случае окно списка элементов примет вид:

Как видно на рисунке, в случае группировки сумма удельных весов подсчитывается для групп элементов и недоступна для здания в целом.


Моделирование износа

Моделирование нормативного износа

Определение физического износа приведено в основных терминах и определениях сферы ЖКХ. В конфигурации "Управление недвижимостью" реализована возможность моделирования нормативного физического износа, т.е. износа с учетом истечения нормативных сроков службы отдельных конструктивных элементов (КЭ) и элементов благоустройства здания (сооружения).

Для проведения моделирования должны выполняться следующие условия:

1. Исходной точкой отсчета для начала моделирования износа здания является дата его постройки. Если дата постройки точно неизвестна (есть только год), то следует выбрать любую конкретную дату в пределах этого года (мы рекомендуем выбирать 1 января). В том случае, если дата постройки здания не будет указана, моделирование выполняться не будет;
2. В процессе моделирования износа участвуют КЭ и элементы благоустройства здания. Следовательно, в состав здания должны быть добавлены все конструктивные элементы;
3. Для правильного моделирования у каждого КЭ должны быть заполнены основные характеристики:
· наименование (автоматически присваивается имя класса КЭ);
· удельный вес КЭ в составе здания - используется при моделировании снижения износа здания при замене КЭ и для расчета стоимости его замены;
· срок службы КЭ (лет) - используется при моделировании плановых замен;
· класс КЭ (по классификатору объектов);
· сменяемый элемент – устанавливается для сменяемых элементов. В процессе моделирования износа участвуют только сменяемые КЭ здания;
· дата последней замены элемента - если КЭ уже подвергался замене, то моделирование его износа будет вестись от этой даты;
· площадь (объем и пр.) – в процессе моделирования используется для расчета стоимости замены или ремонта элемента;
· единица измерения для предыдущего пункта – выбирается из классификатора единиц измерений.

Для проведения моделирования необходимо выделить мышью конкретное здание на левой панели рабочего окна и нажать кнопку [image] на панели инструментов. При этом на экран вызывается диалоговая форма (Рис.1.3.1).

Рис. 1.3.1

Форма состоит из нескольких закладок:

· График - собственно график нормативного износа, на котором по горизонтальной оси измеряется срок службы здания, а по вертикальной его износ;

· Таблицы данных - рассчитываемые программой данные для построения графика;

· Сменяемые элементы - КЭ и элементы благоустройства, участвующие в процессе моделирования (Рис.1.3.2);

Рис. 1.3.2
В этом окне пользователь управляет составом КЭ, участвующих в процессе моделирования износа здания. Добавленные в окно КЭ в ходе моделирования подвергаются плановым заменам и оказывают влияние на общий износ здания, что визуально отображается на графике нормативного физического износа.
До начала построения графика износа необходимо выбрать КЭ, которые будут участвовать в процессе моделирования. Для этого на панели "Сменяемые элементы" необходимо нажать кнопку [image]. При этом на экран будет вызвана форма Рис.1.3.3.

Рис. 1.3.3
При этом, если в предыдущей форме (Рис.1.3.2) уже имелись добавленные КЭ, то в форме выбора будут показаны только оставшиеся (не выбранные для моделирования) элементы здания. Добавлять элементы для моделирования можно как по одному, выделяя их в окне выбора и нажимая кнопку ОК, так и массовым способом. Так, для того, чтобы выбрать все элементы здания, необходимо выделить мышью самый верхний элемент, нажать и удерживать кнопку "Shift", а затем щелкнуть мышью по самому нижнему элементу. Если Вам необходимо выбрать отдельные элементы здания, то выделять их в окне выбора необходимо удерживая кнопку "Ctrl".
После нажатия кнопки ОК выбранные элементы будут добавлены в окно панели "Сменяемые элементы".

После подготовки набора КЭ, участвующих в процессе моделирования, необходимо перейти на вкладку "График" (Рис.1.3.1) и нажать кнопку "Построить". Если после этого вернуться на вкладку "Сменяемые элементы" и изменить их состав, то нажав кнопку "Обновить", Вы получите измененный график износа здания (Рис.1.3.4).

Рис. 1.3.4
Красная линия графика покзывает, как ведет себя нормативный износ здания без замены КЭ от момента его постройки до максимального срока службы. Физический износ при этом, согласно нормативным документам, не может превышать 80% (для жилых зданий).
Серая (зигзагообразная) линия графика показывает изменение нормативного износа при "правильной" эксплуатации здания, т.е. при своевременной плановой замене выбранных для анализа КЭ. Скачкообразное снижение износа говорит о том, в это момент времени проведена полная замена одного или нескольких КЭ.
Синяя вертикальная линия графика показывает, что в данный момент времени проводилось обследование технического состояния здания, в ходе которого был оформлен Акт обследования и оценен реальный физический износ здания в соответствии с действующими техническими регламентами (ВСН 53-86р).

· Акты обследования - наличие Актов обследования технического состояния для выбранного здания (Рис1.3.5).

Рис. 1.3.5
Акты обследования появляются на этой вкладке в ходе построения графика и выбираются из связанных с выбранным зданием документов. При этом можно увидеть дату и номер Акта, фактический износ, отраженный в этом документе, а также нормативный износ, полученный в ходе моделирования.

· Плановые замены (таблица) - таблица плановых замен КЭ в зависимости от их сроков службы;

Рис. 1.3.6
Как видно на Рис.1.3.6 плановые замены существуют только для сменяемых КЭ. В данном случае моделирования КЭ "Водопровод" подвергался (или подлежит) замене каждые 15 лет (в 1985, 2000 и 2015 годах).

· Плановые замены (диаграмма) - сетевой график плановых замен КЭ (Рис.1.3.7).

Рис. 1.3.7
На сетевом графике видны промежутки времени, в течение которых необходимо провести плановые замены КЭ.

На вкладке "Диаграмма" для пользователя доступны дополнительные возможности:

· Если навести указатель мыши на конкретный элемент диаграммы (при этом он принимает вид ладони), то в нижней части окна будет показан этот промежуток времени в текстовом виде, а также указана примерная стоимость замены КЭ (Рис.1.3.7). Стоимость замены КЭ рассчитывается в зависимости от восстановительной стоимости здания и удельного веса КЭ в его составе.

· Если навести указатель мыши на конкретный элемент диаграммы (при этом он принимает вид ладони) и нажать левую кнопку мыши, то в нижней части окна будет показан этот промежуток времени в текстовом виде, а также указана примерная стоимость ремонта КЭ. Стоимость ремонта КЭ рассчитывается в зависимости от рыночной стоимости единицы измерения данного КЭ и его общего объема (площадь, штука и пр.). Для последней возможности в системе предусмотрена справочная таблица "Средняя стоимость ремонта элементов" (Рис.1.3.8).

Рис. 1.3.8
В этой таблице пользователем ведется список региональных рыночных цен для конкретных КЭ (за единицу измерения) на конкретную дату и в выбранной валюте. Данная возможность позволяет произвести быстый подсчет ремонта, скажем, кровли здания по рыночной цене.

· Параметры - настройка параметров графика;

Рис. 1.3.9

· Показывать все износы здания - если включено, то отображаются фактические износы из актов обследования технического состояния;
· Оси как в ВСН 86-89 - оси Х и У меняются местами;
· Трехмерный график - график износа представляется в объемном виде.


Группировка элементов зданий

Пример создания вложенной группировки элементов зданий

Для создания структуры группировки элементов здания и ее привязки к конкретному классу объектов необходимо выполнить следующие действия:

· в классификаторе групп объектов создать необходимую Вам группировку;

· в справочной таблице типов загрузки объектов создать новый тип загрузки и указать для него в качестве класса пользовательской группы объектов класс созданной Вами группировки элементов зданий с кодом 3;

· в классификаторе объектов выбрать класс объекта, для которого создается структура группировки, открыть его для редактирования и ввести в поле «Тип загрузки подклассов» номер созданного Вами типа загрузки (1).

В последующем при создании нового объекта этого класса в нем автоматически создается вложенная группировка элементов.
Таким образом, средства системы позволяют пользователю вести структурированное накопление информации и легко ориентироваться среди множества разнородных объектов.


Документы

Описание рабочего окна

На рисунке (Рис. 2.1) представлен внешний вид рабочего окна «Документы», а также его основные элементы управления. Основные элемента окна ничем не отличаются от описанных в документации АИС «Дока».

Рис. 2.1

В дальнейшем в документации будут описаны лишь те окна, которые специфичны для описываемой конфигурации.


Акт обследования

Документ "Акт обследования технического состояния"

При визуальном обследовании жилых зданий экспертом составляется акт обследования, в котором отражаются те или иные повреждения и дефекты, обследованных конструкций зданий, а также оценивается их физический износ в соответствии с действующими техническими регламентами (ВСН 53-86р).

Для фиксации полученных сведений в единой базе данных служит внешняя форма «Акт обследования технического состояния» (Рис. 2.3). Эта форма может быть использована также при осенне-весеннем осмотре зданий и сооружений. Полученная таким образом информация служит для оценки технического состояния обслуживаемого жилого фонда, прогнозирования его изменения, требуемых финансовых затрат на восстановление, а также моделирования различных вариантов эксплуатации жилого фонда.

При создании акта, необходимо указать для какого строения будет производиться обследование (Рис. 2.2). Выбор здания должен быть произведен обязательно, так как при вводе информации будут указываться конструктивные элементы выбранного здания. После выбора строения, будет автоматически сформирован акт, в котором буду перечислены все конструктивные элементы строения, включая вложенные, а также вычислены их нормативные износы (для правильного определения нормативного износа необходимо правильно указывать дату акта обследования).

Рис. 2.2

В акте обследования Вы можете описать повреждения и дефекты для любого конструктивного элемента и инженерного оборудования здания, а также определить их физический износ. Для более корректного ввода информации об износе элементов здания, осуществляется автоматический контроль корректности введенной информации в соответствии с ВСН 53-86р. Например, если Вы указываете физический износ несменяемого конструктивного элемента (например, стены, фундамента, лестниц или перекрытий) ниже, чем нормативный, система подсвечивает такие данные красным цветом.

Вы можете вносить в акт информацию о техническом состоянии не только конструктивных элементов, но и их составляющих (на рисунке – Отопление центральное состоит из арматуры, стояков, магистральных трубопроводов и радиаторов). Вы может и эти элементы разбить на еще более мелкие, вплоть до винтов и т.п. Глубина вложений зависит лишь от Вашего желания и здравого смысла.

Рис. 2.3

Если у Вас задана группировка элементов здания (см. выше), то Вы можете сгруппировать элементы и в окне «Акта обследования», выбрав соответствующий пункт контекстного меню (Рис. 2.4).

Рис. 2.4

Рис. 2.5

Сгруппированные элементы показаны на рисунке (Рис. 2.5). В акте автоматически считаются износы группы, что иногда полезно для выявления наиболее изношенной инфраструктуры строения.

На закладке «Дополнительно» указываются такие характеристики акта, как эксперт, составивший акт и его комментарии, при этом «Акт обследования» остается документом, со всеми вытекающими отсюда последствиями. Вы можете определять состояние документа, дату смены состояния, приоритет, группу, класс, даты начала и окончания действия и местонахождение акта (№ папки или дела, ящик и пр.). Все эти характеристики позволяют осуществлять быстрый поиск технических документов, а также отслеживать сроки их действия.

Рис. 2.6

При необходимости акт обследования может быть выведен на печать (Рис. 2.7). При этом элементы, имеющие физический износ выше 60% будут выделены цветом.

Рис. 2.7


Акт выполнения работ

Документ "Акт выполнения работ"

Для внесения информации о ремонтных работах, выполненных на объектах, служит форма «Акт выполненных работ» (Рис. 2.8). При вводе акта указывается объект, на котором проводились работы, заказчик и исполнитель работ, а также общая сумма акта и краткий перечень элементов, на которых проводились работы (если необходимо).

Рис. 2.8

Перечень работ привязывается к выбранному объекту, поэтому для ввода перечня работ, естественно обязательно необходимо выбрать непосредственно объект. При вводе перечня работ для каждого элемента, можно задать стоимость ремонта, объемы работ, тип ремонта (текущий ремонт, содержание, капитальный ремонт и т.п.), а также вид работ, выбираемый из классификатора ремонтов.

Рис. 2.9

Кроме того, Вы можете описать работы, выполненные на объекте и указать период производства работ, гарантийный срок, а также являются ли работ непредвиденными и проведена ли по ним авансовая оплата. Все эти сведения могут быть использованы при формировании отчетов по выполненным работам.

На закладке «Дополнительно» указываются те же сведения что и у стандартной формы документов (состояние, язык, приоритет и т.п.).


Жалоба

Документ "Жалоба"

Одним из важных элементов анализа состояния жилищного фонда являются жалобы. Для ввода жалобы служит форма, показанная на рисунке (Рис. 2.10).

Рис. 2.10

На вкладке «Общая информация» указывается: кому адресована жалоба, от кого она исходит и кому отправлена копия (если необходимо), тип жалобы по классификатору жалоб, также такие характеристики как дата обращения и входящая дата, входящий номер, сроки рассмотрения и исполнения и комментарии к жалобе.

Рис. 2.11

На вкладке «Резолюции» (Рис. 2.11) могут быть добавлены распоряжения (резолюции, согласования и т.п.) руководства. Резолюции к жалобе являются вложенными документами и могут быть введены отдельно, но могут быть введены непосредственно в форме жалобы, что упрощает работу пользователя.

Вкладка «Объекты жалобы» служит для создания ссылок на объекты жалоб. Так как это именно ссылки на объекты, а не сами объекты, в базе данных они должны быть созданы заранее (или Вы можете их создать в окне выбора). Эта информация может быть использована для более тщательного анализа причин жалоб или проведенных ремонтов.

Вкладка «Перечень мероприятий» (Рис. 2.12) описывает мероприятия, которые требует провести жалующийся или организация, передавшая жалобу на рассмотрение (например, Администрация района) и сроки их исполнения.

Рис. 2.12

Для удобства ответа на жалобу или ее анализа Вы можете сослаться на нормативные акты, хранящиеся в базе. Для этого достаточно на вкладке «Ссылки на нормативные документы» сослаться на соответствующий документ.

Примечание: Нормативные документы не поставляются с АИС «Дока», но Вы можете самостоятельно ввести карточки таких документов в базу данных. А если есть электронный вариант этих документов, то Вы можете хранить сами документы прямо в базе данных. Это необходимо проделать лишь один раз при настройке системы. В дальнейшем достаточно лишь связывать с ними другие документы.

На закладке «Дополнительно» указываются те же сведения что и у стандартной формы документов (состояние, язык, приоритет и т.п.).


Резолюция

Документ "Резолюция"

Форма документа «Резолюции» служит для регистрации резолюций, согласований, виз и т.п. Как правило резолюция является вложенным документом и не может существовать без самого документа к которому она прилагается. Однако это не является ограничением для АИС «Дока». Вы можете создавать и резолюции или распоряжения, не относящиеся к конкретным документам, общий принцип работы с ними от этого не изменится.

На вкладке «Общие сведения» вводятся дата и номер (если есть) резолюции, а также указывается сама резолюция и сроки ее передачи и исполнения (Рис. 2.13).

Рис. 2.13

На вкладке «Исполнение» приводятся данные об исполнении резолюции: дата исполнения, ответ исполнителя и исполнена ли резолюция (Рис. 2.14).

Рис. 2.14

На закладке «Дополнительно» указываются те же сведения что и у стандартной формы документов (состояние, язык, приоритет и т.п.).

Примечание: Вы можете наложить ограничения на создание резолюций. Например, резолюции директора сможет вносить в базу данных только директор. В этом случае система позволит осуществлять и контроль за исполнением распоряжений, так как удалить или изменить революцию сможет только пользователь с соответствующими правами.


Отчеты

Отчеты являются обычными документами, созданными на основании соответствующих классов «Классификатора документов» (Рис. 2.15).

Рис. 2.15

Определенным классам отчетов соответствует одна или несколько печатных форм, которые должны быть выбраны пользователем перед просмотром отчета и печатью документа.
Созданные отчеты визуально отображаются в окне «Документы» (Рис. 2.16).

Рис. 2.16
С отчетами, как с обычными документами, можно проводить все доступные действия, описанные в Руководстве пользователя АИС «Дока».

В частности, для подготовки какого-либо отчета надо предварительно создать его в окне "Документы":
· Документ -> Создать -> Новый документ;
· Выбрать класс документа по классификатору (Документы основные -> Отчет -> Жилфонд -> Нормативный износ строений (Рис.2.15).
· Заполнить требуемые поля в новом документе (См. Создание документа);
· Если отчет предусматривает выдачу данных за определенный период времени, то необходимо также заполнить поля начала и окончания периода;
· Сохранить созданный отчет.

Перед подготовкой отчета для него должна быть установлена связь с объектом (зданием), для которого будет сформирован этот отчет (Рис. 2.16, правая панель рабочего окна).

Если отчет связан с несколькими объектами, то информация будет представлена только по связанным объектам. Если связанные с отчетом объекты не указаны, то информация будет представлена по всем объектам, зарегистрированным в базе данных. Порядок установления связи документа с объектом рассмотрен нами ранее (См. связь Документ-Объект).
В качестве класса связи документа с объектом следует выбирать "Отчет по объекту".

В дальнейшем, при подготовке отчетов этого класса, нет необходимости создавать новый документ. Достаточно воспользоваться ранее созданным отчетом, изменив состав связанных с ним объектов (удалить или добавить нужные связанные объекты).

Для подготовки отчета необходимо:

· Выделить нужный отчет на левой панели окна "Документы";
· Задать набор связанных с ним объектов на правой панели (удалить или добавить нужные связанные объекты);
· Нажать кнопку [image] "Предварительный просмотр" на панели инструментов.


Лицевой счет жилого дома

Конфигурация "Лицевой счет жилого дома"

Настоящее руководство описывает особенности реализации конфигурации АИС "Дока" для предприятий и организаций ЖКХ. Все базовые принципы работы с системой и ее основные понятия описаны в документации «Руководство пользователя АИС «Дока».

Автоматизированная информационная система «Лицевой счет жилого дома» предоставляет возможности обеспечения информацией предприятий муниципальных городских служб, управляющих компаний сферы ЖКХ, руководящих органов ТСЖ-ЖСК. Система предусматривает учет начислений и платежей населения за пользование коммунальными услугами, сведений о взаиморасчетах с поставщиками услуг и многое другое.

Варианты распространения АИС «Лицевой счет жилого дома»

В зависимости от потребностей Заказчика, АИС «Информационно-Расчетный Центр» планируется к распространению в двух вариантах:

· Подомовой учет , предполагающий использование многоквартирного Здания (строения) в качестве основной единицы для учета сведений о коммунальных услугах;
· Поквартирный учет , предполагающий использование Квартиры (лицевого счета собственника жилья) в качестве основной единицы для учета сведений о коммунальных услугах.


Назначение системы

Основные функциональные возможности системы

Автоматизированная система «Лицевой счет жилого дома» может использоваться как дополнение к конфигурации «Управление недвижимостью», так и в виде самостоятельного приложения.

В случае использования АИС «Лицевой счет жилого дома» в виде самостоятельного приложения, для пользователя будет доступна возможность работы с конфигурацией «Управление недвижимостью», за исключением следующих функциональных модулей:

· техническое состояние жилищного фонда;
· конструктивные элементы и их сроки службы;
· учет ремонтов;
· учет актов обследования;
· учет жалоб и резолюций.

Назначение системы:

· Накопление, хранение и выдача информации:

· о коммунальных услугах, предоставляемых населению;
· о начисленных объемах услуг;
· о начисленных денежных средствах за пользование коммунальными услугами;
· о платежах населения за пользование коммунальными услугами;
· о стоимости оказанных услуг;
· о стоимости недопоставленных услуг;
· о стоимости услуг, оказанных за счет экономии;
· о взаиморасчетах с поставщиками услуг.

· Хранение информации о платежах с учетом цен на услуги на конкретный момент времени;
· Хранение информации о поставщиках услуг;
· Хранение связей между объектами жилищного фонда, документами и поставщиками услуг;
· Подготовка отчетов об информации, накопленной в базе данных;
· Печать и экспорт полученных отчетов с поддержкой форматов MS Word, MS Excel, PDF, HTML, текстовых, текстовых с разделителями (csv), графических форматов (BMP, JPG, GIF).


Основные термины ЖКХ

Основные термины и определения

Жилищно-коммунальные услуги - действия или деятельность исполнителя по поддержанию и восстановлению надлежащего технического и санитарно-гигиенического состояния зданий, сооружений, оборудования, коммуникаций и объектов жилищно-коммунального назначения, вывозу бытовых отходов и подаче потребителям электрической энергии, питьевой воды, газа, тепловой энергии и горячей воды.

Примечание: Под объектами жилищно-коммунального назначения понимают объекты внешнего благоустройства территории городов и населенных пунктов (зеленые насаждения, городские дороги и элементы их благоустройства, пешеходные и велосипедные дорожки, объекты инженерной защиты территории, уличное освещение, объекты санитарной уборки и др.), а также обустроенные площадки, стоянки, участки, устройства и конструкции из различных материалов, размещенные на придомовой территории.

Вид жилищно-коммунальных услуг - совокупность однородных жилищно-коммунальных услуг, характеризующихся общими технологическими признаками.

Содержание здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - комплекс услуг по техническому обслуживанию, уборке, диагностике, испытаниям и обследованиям здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) и техническому надзору за его состоянием.

Техническое обслуживание здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) - операция или комплекс операций по поддержанию работоспособности или исправности здания (сооружения, оборудования, коммуникаций, объектов жилищно-коммунального назначения) при использовании по назначению, ожидании, хранении и транспортировании (ГОСТ Р 51929-2002).

Техническое обслуживание жилого здания - комплекс работ по поддержанию исправного состояния элементов здания и заданных параметров, а также режимов работы его технических устройств (ВСН 58-88(р)).

Услуги по санитарной очистке жилищного фонда и придомовых территорий - услуги исполнителя по поддержанию и восстановлению надлежащего санитарно-гигиенического состояния жилищного фонда и придомовых территорий.

Услуги по содержанию и уходу за зелеными насаждениями придомовых территорий - услуги исполнителя по посеву газонов, устройству цветников, дорожек и площадок, подготовке участков для озеленения, заготовке, посадке деревьев и кустарников, а также по уходу за ними на придомовых территориях.

Ценообразование - формирование органами государственной власти и органами местного самоуправления, предприятиями, обслуживающими жилищный фонд и предоставляющими услуги, тарифов на жилищно-коммунальные услуги (размера платы за услуги).

Регулируемая цена (тариф) - цена товара, услуг, складывающаяся на товарном рынке при государственном воздействии на эту цену, в том числе путем установления ее предельной или фиксированной величины.

Тарифы на жилищные и коммунальные услуги - система ценовых ставок за единицу материального носителя услуг (ставка оплаты за содержание и ремонт жилья, ставка оплаты за найм жилья, тарифы на вывоз твердых бытовых отходов (ТБО), жидких бытовых отходов (ЖБО), тарифы на услуги водоснабжения и водоотведения, услуги теплоснабжения, электроснабжения, газоснабжения), по которым осуществляются расчеты за услуги.

Себестоимость услуг - выраженные в денежной форме затраты предприятий, оказывающих услуги, на единицу материального носителя услуг. Является составной частью тарифа.

Норматив потребления услуг - минимальный для поддержания жизнедеятельности суточный уровень потребления услуг населением, в зависимости от степени благоустройства жилья, утвержденный органом местного самоуправления, обоснованный нормативными документами и (или) научно-техническими исследованиями.

Размер платы за услуги - ставка оплаты с одного человека в месяц, рассчитанная исходя из тарифов на услуги и действующих нормативов потребления услуг населением.

Период регулирования - временной интервал (квартал, полугодие, год), принимаемый для расчета показателей, включаемых в предложения по установлению тарифов (размера платы за услуги).

Потребитель - физическое или юридическое лицо, приобретающее жилищно-коммунальные услуги в соответствии с заключенными договорами.

Служба "заказчика" - предприятия (учреждения), осуществляющие функции управления муниципальным имуществом, переданным или в полное хозяйственное ведение или оперативное управление.

Подрядчик - предприятия, осуществляющие функции обслуживания жилищного фонда и предоставление услуг по договору со службой "Заказчика" (ЖЭУ, ЖРЭУ, ЖКК, ЖКО и др.).

Хозяйствующие субъекты (подрядчики) - коммерческие организации и их объединения, занятые содержанием и ремонтом жилищного фонда.

Государственный жилищный фонд - фонд, состоящий в собственности Российской Федерации или субъектов Российской Федерации, а также ведомственный фонд, находящийся в полном хозяйственном ведении предприятий или оперативном управлении учреждений, относящихся к соответствующему виду собственности.

Муниципальный жилищный фонд - фонд, находящийся в собственности района, города, входящих в них административно-территориальных образований, а также ведомственный фонд, находящийся в полном хозяйственном ведении муниципальных предприятий или оперативном управлении муниципальных учреждений.

Стандарты жилища - группы жилых зданий, классифицированные по совокупности различных показателей, характеризующих конструктивные и объемно-планировочные решения, потребительские качества, срок эксплуатации, степень износа, а также местные особенности.

Стандарт эксплуатации - перечень, состав и периодичность работ по содержанию и ремонту жилищного фонда.

Социальная норма площади - это размер жилья, приходящегося на одного человека, в пределах которого осуществляется предоставление субсидий по оплате жилья и коммунальных услуг. Социальная норма площади эквивалентна минимальному размеру предоставления жилых помещений, который устанавливается в кв. метрах общей площади квартиры в зависимости от достигнутого уровня жилищной обеспеченности, состава семьи и др.

Норматив водопотребления включает внутриквартирные расходы воды для удовлетворения физиологических, санитарно-гигиенических, хозяйственных потребностей населения, а также неквартирные расходы в пределах жилищного фонда и потери воды в системах внутреннего сантехоборудования и внутриквартирных сетях.

Норматив водоотведения следует принимать на уровне норматива водопотребления за вычетом 5-10 л/чел., теряющихся при приготовлении пищи, уборке помещений и территорий, поливке зеленых насаждений и т.д., и не попадающих в канализацию.

Норматив теплопотребления включает расчет количества теплоэнергии, необходимого для отопления и горячего водоснабжения благоустроенного жилищного фонда. Уровень норматива должен обеспечивать нормативный температурный режим различных помещений внутри жилых домов и санитарно-гигиенические потребности населения.

Электроснабжение. Основными направлениями использования электроэнергии в пределах жилищного фонда являются: освещение, мелкобытовые и мелкомоторные нагрузки, пищеприготовление; в некоторых районах электроэнергия используется для отопления, горячего водоснабжения населения, а также кондиционирования воздуха в жилых зданиях.

Газоснабжение. Основными направлениями использования газа в жилых домах является пищеприготовление (газовые плиты), горячее водоснабжение (газовые колонки) и прямое отопление с помощью газовых печей, которыми оборудована часть малоэтажной застройки.

Общая площадь квартиры - определяется как сумма площадей ее помещений, встроенных шкафов, а также площадей лоджий, балконов, веранд, террас и холодных кладовых, подсчитываемых со следующими понижающими коэффициентами:
· для лоджий - 0,5
· для балконов, террас - 0,3
· для веранд и холодных кладовых - 1,0
Приведенное определение может быть применено к определению общей площади жилья индивидуального дома.

Определение платы за отопление - в расчете на 1 кв.м. жилья площадь квартиры, индивидуального дома определяется как суммарная площадь жилых комнат и подсобных помещений без учета лоджий, балконов, веранд, террас и холодных кладовых, тамбуров.

Калькуляционные единицы услуг по видам деятельности жилищно-коммунального хозяйства:

Жилищное хозяйство
1 кв. м
общей площади жилья
Водоснабжение
1 куб. м
отпущенной воды
Водоотведение
1 куб. м
отведенной сточной жидкости
Теплоснабжение
1 Гкал
отпущенной тепловой энергии
Горячее водоснабжение
1 куб. м
отпущенной горячей воды
Электроснабжение
1 кВт-час.
отпущенной электроэнергии
Вывоз ТБО и ЖБО
1 куб. м
бытовых отходов
Уличная уборка
1 кв. м
убираемой площади
Газоснабжение
1
угазоснабжение
- природный газ
1 куб. м
отпущенного газа
- сжиженный газ
1 кг
отпущенного газа

Примечание: Основные термины и определение приведены на основании:

· ГОСТ Р 51929-2002 «Услуги жилищно-коммунальные. Термины и определения»;
· ГОСТ Р 51617-2000 «Жилищно-коммунальные услуги. Общие технические условия»;
· ВСН 58-88(р) «Положение об организации и проведении реконструкции, ремонта и технического обслуживания жилых зданий, объектов коммунального и социально-культурного назначения»;
· Закон РФ "Об основах федеральной жилищной политики";
· Приказ Роскоммунхоза от 22 ноября 1993 г. № 60 «Методика определения нормативов потребления жилищно-коммунальных услуг»;
· Постановление Госстроя РФ от 23 февраля 1999 г. № 9 «Методика планирования, учета и калькулирования себестоимости услуг жилищно-коммунального хозяйства».
· Приказ Госстроя РФ от 28 декабря 2000 г. № 303 «Методические рекомендации по финансовому обоснованию тарифов на содержание и ремонт жилищного фонда».
· Постановление Главы администрации Ростовской области от 30 декабря 1998 г. № 555 «Об установлении единого порядка расчета и утверждения тарифов на жилищно-коммунальные услуги в Ростовской области»


Описание работы с приложением

Учитывая специфику настоящей конфигурации, в систему добавлен новый классификатор «Классификатор услуг».

Классификатор услуг предназначен для структурирования информации об услугах, предоставляемых населению. Содержание классификатора услуг может редактироваться в соответствии с нормативной базой региона. Подробно работа с классификаторами описана в Руководстве пользователя АИС «Дока» - Классификаторы системы.

В зависимости от потребностей Заказчика, АИС «Лицевой счет жилого дома» планируется к распространению в двух вариантах:

· Подомовой учет;
· Поквартирный учет.


Подомовой учет (Лицевой счет дома)

Суть и содержание подомового учета состоит в том, что организация, обеспечивающая управление жилищным фондом, с заранее определенной периодичностью (например, 1 раз в месяц), ведет учет:

· начислений по коммунальным услугам;
· оплат населением за пользование услугами;
· оказания услуг;
· расчетов с поставщиками и подрядчиками;
применительно к такой минимальной единице учета жилищного фонда, как Здание (Дом).

Для ускорения ввода информации о платежах населения и взаиморасчетах с поставщиками и подрядчиками в системе предусмотрено использование наборов услуг.Содержание наборов может отличаться в зависимости от состава услуг и их тарифов на текущий момент времени.

При дальнейшем учете платежей пользователь имеет возможность работать со списками оплат за услуги, выбранными из заранее подготовленного набора, подходящего на текущий момент времени.


Описание рабочего окна

На Рис. 1.1 представлен внешний вид рабочего окна «Объекты», специфичного для описываемой конфигурации, а также его основные элементы управления. Подробно описание рабочего окна рассмотрено нами ранее в документации «Руководстве пользователя АИС «Дока».

Рис. 1.1

На левой панели окна располагается список объектов жилищного фонда. Каждый из объектов помимо названия обозначен соответствующим значком (иконкой), показывающим его функциональное назначение.
С активным (выделенным) объектом жилищного фонда (зданием) динамически связаны кнопки панели управления [image] «Наборы коммунальных услуг» и [image] «Платежи за услуги». «Наборы…» и «Платежи…» хранятся в базе данных индивидуально для каждого здания.


Наборы услуг и услуги

Работа с наборами коммунальных услуг и услугами в наборе

Для работы с наборами коммунальных услуг необходимо выбрать здание, для которого предполагается создать набор, выделить его на левой панели рабочего окна «Объекты» и нажать кнопку [image] панели управления. В результате на экране будет открыто диалоговое окно «Наборы коммунальных услуг».

Создание (редактирование) набора услуг
Создание (редактирование) коммунальной услуги в наборе


Создание набора услуг

Создание (редактирование) набора услуг

Для работы с наборами коммунальных услуг необходимо выбрать здание, для которого предполагается создать набор, выделить его на левой панели рабочего окна «Объекты» и нажать кнопку [image] панели управления. В результате на экране будет открыто диалоговое окно «Наборы коммунальных услуг».

Рис. 1.2

Для создания нового набора услуг необходимо в открывшемся окне выбрать пункт меню «Услуги – Добавить набор услуг» (Рис. 1.3). Откроется окно набора услуг (Рис. 1.4).

Рис. 1.3

В поле «Название набора» необходимо ввести какое-либо название, однозначно определяющее набор, а в поле «Дата» - выбрать дату, с которой этот набор будет действовать.

Рис. 1.4

В результате этих действий в окне наборов услуг появится новый набор с введенными Вами характеристиками (Рис. 1.5).

Рис. 1.5

Имеющиеся наборы услуг могут быть отредактированы (изменены). Для этого в окне наборов услуг необходимо выбрать пункт меню «Услуги – Изменить», либо выделить мышью нужный Вам набор, щелкнуть на нем правой кнопкой мыши и в контекстном меню выбрать пункт «Изменить».

Кроме того, в конкретном наборе возможно добавлять, редактировать или удалять существующие в нем комунальные услуги, пользуясь пунктами главного меню или кнопками панели инструментов.

Устаревшие или ошибочно введенные наборы услуг могут быть удалены.


Создание услуги в наборе

Создание (редактирование) коммунальной услуги в наборе

Для создания (добавления) коммунальной услуги в наборе необходимо в окне наборов коммунальных услуг выделить нужный набор, затем выбрать пункт меню «Услуги – Добавить услугу», либо выделить мышью нужный Вам набор, щелкнуть на нем правой кнопкой и в контекстном меню выбрать пункт «Добавить – Добавить услугу». После этого откроется окно создания коммунальной услуги (Рис. 1.6).

Рис. 1.6

В окне создания (редактирования) коммунальной услуги необходимо заполнить поля:

· Услуга – выбирается из классификатора услуг (например, Наем жилья Рис. 1.7 а);
· Стоимость услуги – стоимость предоставленной услуги за определенный период времени (например, за 1 месяц) в рублях;
· Объем услуги – натуральное выражение предоставленной услуги за этот же период времени;
· Единица измерения – единица измерения объема услуги;
· Поставщик услуги – субъект (организация), осуществляющая поставку услуги (выбирается из списка доступных субъектов-поставщиков Рис. 1.7 б).

После заполнения всех полей и нажатия кнопки ОК услуга будет сохранена в выбранном наборе. Наименование набора, к которому будет принадлежать услуга, можно проконтролировать по самому верхнему полю формы – «Набор услуг».

_
а)__________________________________б)
Рис. 1.7
После создания набора коммунальных услуг, характерных для здания типовой серии, окно наборов услуг будет выглядеть следующим образом (Рис. 1.8).

Рис. 1.8

Используя пункты главного или контекстного меню, пользователь может добавлять, удалять или редактировать содержание услуг, входящих в текущий набор.


Платежи за услуги

Работа с платежами за услуги

Для работы с оплатами услуг необходимо выбрать здание, для которого предполагается вводить сведения об оплате, выделить его на левой панели рабочего окна «Объекты» и нажать кнопку [image] панели управления. В результате на экране будет открыто диалоговое окно «Оплата услуг».

Рис. 1.9

При выборе пункта главного или контекстного меню «Услуги – Добавить набор услуг» необходимо в окне наборов выбрать нужный Вам набор и нажать кнопку ОК. После этого в окне формы «Оплата услуг» будет добавлен подготовленный набор услуг с начислениями на текущую дату (Рис. 1.10). Причем, на текущую дату можно создать только один набор услуг.

В настоящем окне можно как вручную ввести данные о нужных услугах, так и воспользоваться заранее подготовленным набором.

Рис. 1.10
В этом окне по каждой услуге представитель управляющей компании вводит данные об оплатах и взаиморасчетах с поставщиками и жильцами.

Помимо услуг, добавленных из заранее подготовленного набора, пользователь может в окне «Оплата услуг» добавить новую услугу (пункт меню «Услуги – Добавить услугу»), изменить конкретную услугу, выделив ее в наборе (пункт меню «Услуги – Изменить»), либо удалить услугу из списка.

Редактирование (изменение) строки оплаты за коммунальную услугу возможно производить двумя способами:

Создание (редактирование) оплаты за коммунальную услугу в форме
Создание (редактирование) оплаты за коммунальную услугу в редакторе

В окне «Оплата услуг» пользователю доступны некоторые возможности, позволяющие структурировать услуги по различным критериям.

Так, в главном меню пользователь может выбрать пункт главного меню "Вид - Группировка» (Рис. 1.13) и сгруппировать услуги, например, по поставщикам.

Рис. 1.13

По окончании ввода данных обо всех оплатах и взаиморасчетах, пользователь может получить промежуточный отчет на выбранную дату платежей, выбрав пункт главного меню «Услуги – Печать отчета – Предварительный просмотр», либо нажать кнопку [image] панели инструментов. Причем содержание отчета будет сформировано в зависимости от выбранной группировки услуг.

Например, отчет по всем услугам (Рис. 1.14) или отчет по поставщику «ЖЭУ № 8 УК МУ МПП ЖКХ Ворошиловского района» (Рис. 1.15).

Рис. 1.14

Рис. 1.15


Редактирование услуги в форме

Создание (редактирование) оплаты за коммунальную услугу в форме

Если в окне Оплаты услуг будет выбрана строка с конкретной услугой (например, Наем жилья, см рис.) и открыта для редактирования, то форма для ввода данных выглядит, как на Рис. 1.11.

Рис. 1.11

В окне создания (редактирования) оплаты коммунальной услуги необходимо заполнить поля:

· Начислено – стоимость предоставленной услуги за определенный период времени (например, за 1 месяц) в рублях, автоматически заполняется из набора услуг (Стоимость услуги);
· Объем - натуральное выражение предоставленной услуги за этот же период времени, автоматически заполняется из набора услуг (Объем услуги);
· Оказано поставщиком – Стоимостное выражение оказанной поставщиком услуги, заполняется пользователем по факту оказания услуги поставщиком;
· Оплачено населением – Платежи населения за пользование услугой за определенный период времени (например, за 1 месяц) в рублях, заполняется пользователем по факту получения оплат от населения;
· Единица измерения - единица измерения объема услуги, автоматически заполняется из набора услуг;
· Выполнено за счет экономии – Стоимостное выражение услуги, предоставленной за счет экономии, заполняется пользователем по факту;
· Недопоставка - Стоимостное выражение услуги, недопоставленной населению поставщиком услуг, заполняется пользователем по факту недопоставки (согласно подписанным актам недопоставки);
· Выставлено поставщиком – Денежные средства, выставленные поставщиком для оплаты, заполняется пользователем по выставленным счетам поставщиков;
· Оплачено поставщику – Платежи управляющей компании поставщику, заполняется пользователем по факту оплат поставщикам.


Редактирование услуги в редакторе

Создание (редактирование) оплаты за коммунальную услугу в редакторе

Если в окне Оплаты услуг будет выбрана вся группа на конкретную дату (как на рисунке) и открыта для редактирования (изменения), то форма для ввода данных будет представлена в виде табличного редактора, как на Рис. 1.12.

Рис. 1.12

При этом данные по всем услугам одновременно можно редактировать в одном окне, а также добавлять услуги, отсутствующие в наборе, и удалять услуги, ненужные на текущую дату.

После завершения редактирования необходимо сохранить данные, нажав ОК для подтверждения, или отменить изменения.


Работа с отчетами

Отчеты в АИС «Лицевой счет жилого дома» являются обычными документами, созданными на основании соответствующих классов «Классификатора документов» (Рис. 1.16).

Рис. 1.16

Определенным классам отчетов соответствует одна или несколько печатных форм, которые должны быть выбраны пользователем перед просмотром отчета и печатью документа.
Отчеты визуально отображаются в окне «Документы» (Рис. 1.17).

Рис. 1.17
С отчетами, как с обычными документами, можно проводить все доступные действия, описанные в Руководстве пользователя АИС «Дока».

Перед подготовкой отчетов по платежам за коммунальные услуги или взаиморасчетов с поставщиками для соответствующего отчета должна быть установлена связь с объектом (зданием), для которого будет сформирован этот отчет (Рис. 1.17). Если отчет связан с несколькими объектами, то информация будет представлена по всем связанным объектам.

Выбор периода отчета.

Кроме того, в соответствующем отчете необходимо выбрать период, за который пользователь желает получить запрашиваемые сведения о платежах и взаиморасчетах (Рис. 1.18).

Рис. 1.18

При выводе отчета для предварительного просмотра пользователь получит нужную информацию.

Рис. 1.19

Отчет может быть напечатан на принтере или экспортирован для последующей обработки в один из нескольких форматов.


Поквартирный учет

Находится в разработке


Транспортно-экспедиционное обслуживание

Конфигурация "Транспортно-экспдиционное обслуживание"предоставляет возможности обеспечения информацией транспортных компаний, осуществляющих перевозки грузов автомобильным транспортом. Система предусматривает учет клиентов, перевозчиков, подвижного состава, формирование договорных документов, подготовку отчетов и многое другое.

Создание договора-заявки (заявки)
Подвижной состав


Создание договора-заявки

Форма договора-заявки (заявки) показана на рисунке 6.1

Рис. 6.1
Закладка "Общие" служит для заполнения основных данных, связанных с договором: номера, даты, названия документа, указания Перевозчика (Клиента) по договору и т.п. Маршрут перевозки может быть заполнен вручную, но также возможно формирование маршрута автоматически после заполнения раздела "Груз" (рис. 6.2).

Рис. 6.2
Раздел "Груз" заполняется в соответствии с предполагаемым маршрутом движения и с перевозимыми грузами. Для заполнения данного раздела необходимо добавить грузы нажатием кнопки [image] или с помощью комбинации "горячих клавиш" Ctrl+N. В открывшемся диалоговом окне (рис. 6.3) заполняются данные о грузе, местах и времени погрузки и разгрузки, грузоотправителях и грузополучателях и контактных лицах на погрузке (разгрузке). Заполняя данные о грузе, Вы можете использовать классификатор грузов, который позволит, при необходимости проанализировать работу компании с точки зрения объемов и видов перевозимых грузов. Выбор вида тары и способов погрузки производится из справочников, которые можно дополнить, что снижает риск опечаток и повышает скорость ввода информации.

Рис. 6.3
С помощью кнопок [image] и [image] Вы можете поменять порядок следования и, соответственно, порядок разгрузки груза, что будет учтено при печати договора-заявки (заявки).
Раздел "Подвижной состав" (рис. 6.4.) заполняется с использованием данных о подвижном составе, как об объекте, хранящемся в базе данных. Это позволяет избежать повторного ввода характеристик состава при формировании заявок и ускорить процесс подготовки данных для них. Заполняются разделы требуемого и выделенного подвижного состава. В случае несоответствия выделенного состава требуемым характеристикам (груоподъемности, объему), несоответствия будут подсвечены красным цветом.

Рис. 6.4
В разделе "Ставка, штрафы" (рис.6.5) заполняются данные о стоимости услуг, порядке расчетов, штрафах и их исчислении

Рис. 6.5
В разделе "Дополнительно" (рис.6.6) заполняются данные, аналогичные разделу "Дополнительно" стандартной формы документа.

Рис.6.6


Подвижной состав

Подвижной состав хранится в базе данных как объект с определенными свойствами: маркой тягача и его номерным знаком, типом (маркой) полуприцепа и его номерным знаком, грузоподъемностью, объемом (рис. 6.7)

Рис. 6.7
Подвижной состав используется при формировании договоров-заявок и заявок к договорам транспортной экспедиции и договорам на организацию перевозок. Добавление нового подвижного состава аналогично созданию нового объекта. Создание заявок и договоров-заявок описано в соответствующем разделе настоящей документации.


Администрирование системы

Внимание! Администрирование системы должно осуществляться системным администратором или ОЧЕНЬ квалифицированным пользователем!

Для поддержания АИС "Дока" в работоспособном состоянии разработан набор сервисных утилит, вызываемых из главного окна приложения (см. рис.).

Набор включает в себя:
· Утилиту администратора, предназначенную для запуска и настройки набора сервисных приложений;
· Менеджер пользователей, предназначенный для управления списком пользователей сервера Firebird (Interbase);
· Менеджер групп пользователей, предназначенный для управления группами пользователей и назначением прав доступа к объектам базы данных для каждой группы;
· Утилиту сервисного обслуживания, предназначенную для резервного копирования базы данных и ее восстановления из резервной копии;
· Редакторы внешних классификаторов, внешних справочников и помощников, предназначенных для подключения дополнительных модулей системы и расширения ее функциональности;
· Менеджер пользователей Коммуникатора, предназначенный для управления списком пользователей специальной утилиты - Коммуникатор;
· Менеджер наблюдений, предназначенный для контроля за любыми таблицами структуры базы данных (например, классификаторами или справочными таблицами) и используется в системе, как Служба Безопасности;
· Менеджер наборов, предназначенный для подготовки наборов данных, позволяющих впоследствии с их помощью автоматически создавать заданное количество новых Объектов (Субъектов, Документов, Адресов), включая в них вложенные;
· Редактор скриптов, предназначенный для прямого изменения структуры базы данных.


Утилита администратора

Утилита администратора предназначена для настройки и запуска набора сервисных приложений АИС "Дока". Рабочее окно утилиты содержит список сервисных приложений, имеет строку меню и панель инструментов, предоставляющих доступ к управлению каждым приложением (Рис.1.1).

Рис.1.1

Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, утилита администратора позволяет добавлять различные сервисные приложения без участия разработчиков путем подключения к системе форм ввода информации, отличных от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы необходимо в окне утилиты администратора выбрать пункт меню "Модули - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.2).

Рис.1.2
В форме диалога необходимо правильно заполнить поля:

· Наименование модуля - Имя, под которым сервисное приложение появится в списке утилиты администратора;
· Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма;
· Форма (класс Delphi) – название класса формы в среде Delphi;
· Значок - выбирается из списка;
· Описание модуля - произвольный текст, описывающий назначение приложения.

После нажатия кнопки "Сохранить" новое сервисное приложение появится в списке утилиты администратора.

Нажатие кнопки [image] панели инструментов вызывает окно Свойств сервисного приложения, выделенного в утилите администрирования и содержащее две закладки (Рис.1.3).

___
Рис.1.3
Подробно работа с окном свойств описана нами ранее. В качестве особенности следует отметить, что если на закладке "Безопасность" для какого-либо пользователя будут отсутствовать разрешения на сервисное приложение, то этот пользователь либо вообще не увидит его в списке утилиты администрирования, либо не будет иметь возможности запустить его на выполнение.

Нажатие кнопки [image] панели инструментов позволяет запустить (Выполнить) выбранное сервисное приложение.


Сервисное обслуживание

Сервисное обслуживание базы данных АИС "Дока"

Сервисное приложение "Сервисное обслуживание базы данных АИС "Дока" предназначено для выполнения таких задач, как:
· создание резервной копии базы данных (копирование базы данных);
· восстановление базы данных из резервной копии.

Для того, чтобы открыть "Сервисное обслуживание", необходимо запустить утилиту администратора, выделить в ней строку "Сервисное обслуживание" и нажать кнопку [image] ("Запустить"). Сервисное обслуживание будет доступно для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

Примечание: утилиту "Сервисное обслуживание" необходимо запускать на том компьютере, где находится база данных АИС "Дока", предоставленная в коллективное пользование.

На экран будет выведена форма (Рис.1.10).

Рис.1.10
При запуске утилита "Сервисное обслуживание" использует подключение к базе данных, назначенное в ярлыке для запуска АИС "Дока" (см. настройку ярлыков для работы с различными базами данных).

Если на закладке "Подключение" ввести имя и пароль администратора базы данных и нажать кнопку "Тест", то в окне информации сервера будут доступны сведения об SQL-сервере и подключенной базе данных (Рис.1.10).

Закладка "Упаковка" предназначена собственно для создания резервной копии базы данных системы (Рис.1.11).

Рис.1.11
Назначение полей закладки:
· "Имя базы для упаковки" - автоматически подставляется путь к базе данных, к которой было выполнено подключение при запуске АИС "Дока";
· "Имя упакованной базы" - местоположение и имя резервной копии базы данных. Местоположение может быть выбрано администратором самостоятельно. Имя содержит наименование базы данных, текущие дату и время создания копии базы данных.
· "Сборка мусора" - удаление устаревших записей и освобождение пространства, занимаемого ими. Это часто уменьшает размер базы данных и улучшает производительность;
· "Показывать отчет" - показывать/не показывать отчет о том, что происходит во время создания копии базы данных;
· "Игнорировать контрольную сумму" - контрольная сумма игнорируется в процессе копирования. Этот переключатель может использоваться при повторном запуске копирования, которое аварийно завершилось из-за ошибки контрольных сумм;
· "Сохранять только метаданные" - копируются только метаданные, данные не сохраняются. Этот переключатель может использоваться для быстрого получения "пустой" базы данных.

Нажатие кнопки "Начать" запускает операцию копирования базы данных и переключает форму на закладку "Отчет". Возможно проведение операции копирование во время работы пользователей с базой данных ("горячее" копирование).

Закладка "Восстановление" предназначена для восстановления базы данных из резервной копии (Рис.1.12).

Рис.1.12
Назначение полей закладки:
· "Восстановить в ..." - возможные параметры: создать новую базу и восстановить поверх существующей базы данных. Исходя из соображений сохранности данных в настоящей утилите возможно восстановление только в новую базу данных. Перезаписывание базы данных, чья жизнеспособность Вас сильно волнует, не рекомендуется ни при каких условиях.
СОВЕТ: "Горячее" копирование - нормально. "Горячее" восстановление - большая глупость.
· "Имя базы данных, куда производить восстановление" - местоположение и имя базы данных, в которую будут восстановлены данные из резервной копии (может быть выбрано администратором самостоятельно);
· "Имя резервной копии базы" - имя и местоположение резервной копии базы данных, из которой будет производиться восстановление;
· "Деактивировать индексы" - делает неактивными индексы в восстанавливаемой базе данных. Полезно при повторной попытке восстановления, когда первая попытка оказалась неудачной из-за ошибки индекса;
· "Подтверждать транзакцию после распаковки каждой таблицы" - восстанавливает одну таблицу за один раз. Может быть использовано при частичном восстановлении, если база данных содержит разрушенные данные;
· "Показывать отчет" - показывать/не показывать отчет о том, что происходит во время восстановления базы данных.

Нажатие кнопки "Начать" запускает операцию восстановления базы данных и переключает форму на закладку "Отчет".


Менеджер групп пользователей

Сервисное приложение "Менеджер групп пользователей" предназначено для управления списком пользовательских групп сервера Firebird (Interbase). Для того, чтобы открыть менеджер групп пользователей, необходимо запустить утилиту администратора, выделить в ней строку "Менеджер групп пользователей" и нажать кнопку [image] ("Запустить"). Менеджер групп пользователей будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма со списком пользовательских групп сервера Firebird (Interbase) того компьютера, на котором находится подключенная база данных АИС "Дока" (Рис.1.8).

Рис.1.8
В этом окне администратор системы может добавлять новые группы пользователей, редактировать или удалять существующие. При добавлении или редактировании группы пользователей на экран выводится форма (Рис.1.9).

Рис.1.9
В форме диалога необходимо правильно заполнить поля:

· Имя группы - Имя, под которым новая группа появится в списке пользовательских групп;
· Описание - произвольный текст, описывающий назначение группы;
· Скрипт назначения прав - создаваемый (редактируемый) администратором системы скрипт на языке SQL, назначающий данной группе пользователей права доступа к таблицам базы данных АИС "Дока". Скрипт назначения прав может быть загружен из файла или сохранен во внешнем файле при нажатии на кнопки [image] соответственно.

При создании (редактировании) текста скрипта администратор должен хорошо знать структуру базы данных, а также сам язык SQL.

После нажатии кнопки ОК новая группа пользователей будет добавлена в список Менеджер групп пользователей.


Менеджер пользователей

Сервисное приложение "Менеджер пользователей" предназначено для управления списком пользователей SQL-сервера Firebird (Interbase). Для того, чтобы открыть менеджер пользователей, необходимо запустить утилиту администратора, выделить в ней строку "Менеджер пользователей" и нажать кнопку [image] ("Запустить"). Менеджер пользователей будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма со списком пользователей сервера Firebird (Interbase) того компьютера, на котором находится подключенная база данных АИС "Дока" (Рис.1.4).

Рис.1.4
В этом окне администратор системы может добавлять новых пользователей, редактировать или удалять существующих. При добавлении или редактировании пользователя на экран выводится форма (Рис.1.5).

В форме диалога необходимо правильно заполнить поля:
На закладке "Информация":

Рис.1.5

· Имя - произвольное имя пользователя (вводится ТОЛЬКО латинскими буквами);
· Пароль - комбинация буквенных, цифровых и специальных символов, назначаемых каждому пользователю для подтверждения его подлинности. Пароль чувствителен к регистру ввода, т.е. Password, PassWord и Pa$$w0rd – это три разных пароля. Если Вы уверены, что вводите пароль правильно, а система выдает ошибку регистрации, то необходимо также проверить, на каком языке Вы его вводите;
· Повторить пароль - необходимо повторно ввести пароль для проверки правильности ввода;
· Поля из раздела "Личная информация" - являются описательными и необязательны для ввода.

На закладке "Членство в группах":

Рис.1.6
Необходимо выбрать принадлежность пользователя к стандартным группам пользователей (Рис.1.6):

· Ограниченный доступ - обычные пользователи;
· Обычный доступ - опытные пользователи;
· Другой - администраторы, либо по выбору.

При выборе принадлежности пользователя к той или иной группе для него создаются или удаляются права на доступ к классам документов, объектов, субъектов и адресов.

Примечание: Несмотря на то, что администраторы получают полные права на доступ ко всем ресурсам АИС "Дока", необходимо после установки принадлежности пользователя к группе администраторов назначить для него права доступа к конкретным классам документов, объектов, субъектов и адресов. Для этого необходимо открыть соответствующий классификатор, выделить нужный класс и нажать кнопку "Изменить". Далее см. описание работы с закладкой "Безопасность".

После нажатии кнопки ОК новый пользователь будет добавлен в список Менеджера пользователей.

Если флажок "Добавить права пользователя в классификаторы" был включен, то операция по добавлению прав пользователя во все классификаторы выполнится автоматически. Это означает, что данный пользователь получит полный доступ ко всем объектам, субъектам, документам, адресам и связям в базе данных. Если же Вам необходимо ограничить даного пользователя в правах, сделайте это в соответствующих классификаторах, как это описано выше.

Если при вызове имеющегося пользователя на редактирование Вы изменяете ему имя, либо личную информацию, то при сохранении изменений система может выдать сообщение (Рис.1.7).

Рис.1.7
В этом случае при нажатии кнопки ОК в системе сохранится старый пароль.


Менеджер пользователей Коммуникатора

Сервисное приложение "Менеджер пользователей Коммуникатора" предназначено для управления списком пользователей встроенного средства связи системы "Коммуникатор".

С помощью него осуществляется:
· сопоставление имен пользователей SQL-сервера Firebird (Interbase) со списком пользователей Коммуникатора. Это значит, что и на SQL-сервере и в Коммуникаторе должна присутствовать запись о пользователе с ОДНИМ И ТЕМ ЖЕ логином;
· управление списком событий, выполняемых для каждого пользователя Коммуникатора.

Главное окно Менеджера пользователей Коммуникатора представлено на рис.1.20.1.

Рис.1.20.1
В левом окне представлен список пользователей Коммуникатора, на правой панели - список событий, выполняемых для этого пользователя. Здесь можно добавлять, изменять или удалять пользователей, а так же разрешать выполнение тех или иных событий для них.

При добавлении пользователя появляется предупреждающее сообщение (Рис.1.20.2).

Рис.1.20.2
Куда добавлять пользователя первым - в список SQL-сервера или Коммуникатора не важно. Главное, чтобы их логины в обоих списках совпадали.

Для добавление (редактирования) пользователя вызывается диалоговая форма (Рис.1.20.3).

Рис.1.20.3
Заполняемые поля:
· Логин - имя для регистрации на SQL-сервере;
· Фамилия, имя, отчество - данные о пользователе, используемые в Коммуникаторе при оповещениях;
· Уведомлять о событиях - список выполняемых для конкретного пользователя событий. При установке маркера событие будет выполняться, при снятии - нет:
· Сообщения от пользователей АИС "Дока" - разрешение (запрещение) приема сообщений;
· Заметки с активным таймером - разрешение (запрещение) отслеживания списка запланированных пользователем задач;
· Слежение за структурой АИС "Дока" - разрешение (запрещение) отслеживания изменений объектов базы данных.
· Дополнительно - записи о пользователях, используемых для специальных целей:
· Зарезервирован системой - специальные пользователи. Например, ALLUSERS - системный пользователь, предназначенный для отправки сообщений ВСЕМ пользователям одновременно, AISDOKA - системный пользователь, предназначенный для отслеживания событий изменения объектов базы данных (служба безопасности АИС "Дока").
· Примечание - произвольное описание.

Добавить пользователей в список Коммуникатора можно также путем импортирования их из списка SQL-сервера. Для этого необходимо выбрать пункт меню "Пользователи - Заполнить таблицу пользователей". Из диалогового окна (Рис.1.20.4) выбрать нужных пользователей (допускается множественный выбор) и нажать кнопку ОК.

Рис.1.20.4
Информация о пользователях SQL-сервера будет перенесена в список пользователей Коммуникатора. Если импортируемый пользователь уже имеется в списке Коммуникатора, то информация о нем будет заменена. После этого следует заполнить для каждого нового пользователя раздел "Уведомлять о событиях" (Рис.1.20.3).


Менеджер наблюдений

Менеджер наблюдений является встроенным средством контроля системного администратора, либо другого пользователя, которому это будет поручено, за объектами базы данных (БД), а также любыми таблицами ее структуры (например, классификаторами или справочными таблицами) и используется в системе, как Служба Безопасности.

В отличие от Мониторинга, с помощью Службы безопасности можно контролировать изменения ЛЮБЫХ таблиц или просмотров БД, совершенные ЛЮБЫМИ пользователями, а также фиксировать результаты этого контроля в журнале наблюдений.

Рабочее окно Менеджера наблюдений представлено на рис.1.21.1. Оно состоит из двух закладок:

· Список триггеров наблюдения:

Рис.1.21.1
На этой закладке отображается имя пользователя, имя контролируемой таблицы, тип операции (Изменение, Удаление или Вставка), а также список полей таблицы, значения которых будут записаны в журнал наблюдений.
С помощью главного меню или кнопок панели инструментов можно совершать стандартные действия со списком триггеров - создавать либо удалять их.

Создание триггера наблюдения.

· Журнал наблюдений:

Рис.1.21.2
На этой закладке отображаются записи журнала о действиях, произведенных с объектами БД. В частности, на рис.1.21.2 видно что 15.12.2007 г. Системный администратор удалил из таблицы "Объекты" объект OBJ_397 и изменил в таблице "Документы" документ DOC_11. Таким образом, с помощью журнала наблюдений можно всегда установить пользователя, совершившего несанкционированные действия с объектами БД.
В отличие от закладки со списком триггеров, отдельные записи в журнале наблюдений удалить нельзя, его можно полностью очистить, нажав на кнопку [image].

Если Вы получили уведомление от Службы безопасности о совершенных манипуляциях с объектами структуры БД после того, как журнал наблюдений был открыт, то новые сообщения появятся в нем после нажатия кнопки "Обновить" (F5).


Создание триггера

Для создания нового триггера необходимо выбрать пункт главного меню "Смотритель - Добавить", либо нажать кнопку панели инструментов [image].
На экран будет выведена диалоговая форма (Рис.1.22.1), в которой пользователь заполняет:

Рис.1.22.1
· Объект (таблица или просмотр) - таблица базы данных, изменения которой необходимо контролировать. Выбирается в диалоговом окне рис.1.22.2 а);
· Поля для документирования - список полей выбранной таблицы, значения которых будут записаны в журнал наблюдений. Выбирается в диалоговом окне рис.1.22.2 б);
· Отслеживаемые действия - выбирается вид действий, совершаемых с контролируемыми таблицами базы данных.

__
а)________________________________________б)
Рис.1.22.2


Менеджер наборов

Менеджер наборов предназначен для подготовки наборов данных для Объектов (Субъектов, Документов, Адресов), позволяющих впоследствии с их помощью автоматически создавать заданное количество новых Объектов, включая в них вложенные.

Например, с помощью набора "Здание" (Рис.1.24.1) в рабочем окне "Объекты" будет автоматически создано 3 здания с вложенными конструктивными элементами, помещенными во вложенную группу "Конструктивные элементы". С помощью набора "Квартиры" в выбранном здании будет автоматически создано 20 квартир, помещенных во вложенную группу "Квартиры" и пронумерованных "Квартира № 1", "Квартира № 2" и т.д.

Рис.1.24.1
Рассмотрим пример создания набора "Квартиры".
Для создания нового набора необходимо установить курсор (выделить) на нужном списке наборов - Наборы объектов, документов, субъектов или адресов. В нашем случае выделяем "Наборы объектов", выбираем пункт главного меню "Наборы - Добавить", либо нажимаем кнопку панели инструментов [image]. В диалоговом окне (Рис.1.24.2) заполняем:

Рис.1.24.2
· Наименование - присваиваем наименование набору;
· Класс - выбираем из классификатора наборов объектов. При желании можно в классификаторе создать класс "Квартира", но на работе системы это не отразится.

После нажатия кнопки ОК набор "Квартиры" появится в списке наборов объектов (Рис.1.24.1).

Далее устанавливаем курсор (Выделяем) созданный набор "Квартиры" и нажимаем кнопку панели инструментов [image]. В диалоговом окне (Рис.1.24.3) заполняем:

Рис.1.24.3
· Класс элемента - выбираем из классификатора объектов класс помещения "Квартира";
· Количество в наборе - вводим количество квартир, которые будут автоматически создаваться с использованием этого набора;
· Необходим владелец - устанавливается в том случае, если создаваемым с помощью набора объектам необходим объект-владелец. В нашем случае квартирам необходим объект-владелец Здание. Для создаваемого объекта Здание владелец не нужен, поэтому это поле можно оставить пустым.

После нажатия кнопки ОК элемент набора "Квартира" появится в списке набора "Квартиры" (Рис.1.24.4). Кроме этого, внутри этого элемента появится папка "Метаданные".

Рис.1.24.4
Далее устанавливаем курсор (выделяем) папку "Метаданные", выбираем пункт главного меню "Наборы - Загрузить метаданные", либо нажимаем кнопку панели инструментов [image]. Внутрь папки "Метаданные" будет загружена структура объекта "Квартира" (VWFLATEDIT). Если выделить эту структуру в окне дерева объектов (на левой панели), то в правом окне мы увидим поля таблицы, ее описывающие (Сравните с описанием заполнения формы "Квартира"). Все заполненные в этом окне поля таблиц будут автоматически заполняться во вновь создаваемых квартирах здания. Для заполнения поля выделяем его левой кнопкой мыши, нажимаем Enter и вводим нужные данные.

В диалоговом окне (Рис.1.24.5) выделяем нужные поля и заполняем:

Рис.1.24.5
· FULLNAME - Обязательное для заполнения поле. Под этим названием создаваемый объект появится в окне "Объекты". Обратите внимание на веденное на рис.1.24.5 значение: "Квартира № <IDX>". Служебный оператор <IDX> (Индекс) означает, что на его месте в создаваемых объектах появятся порядковые номера от 1 до количества элементов в наборе, заданные Вами (см. рис.1.24.3). Таким образом, квартиры автоматически будут пронумерованы от 1 до 20;
· ID_USERGROUP - код пользовательской группы. При его вводе все квартиры будут сгруппированы во вложенной группировке элементов здания "Квартиры". Если бы мы создавали набор конструктивных элементов, то в этом поле следовало бы прописать код 3.0. Для любых других объектов в это поле вводятся значения из классификатора групп объектов;
· ID_STATE - это поле рекомендуется оставлять пустым, т.е. значение 0 (Ноль) следует удалить;
· все остальные поля заполняются по желанию пользователя. Следует учитывать, что при создании объектов из этого набора значения всех полей квартир будут заполнены одинаково (кроме FULLNAME) и далее каждую созданную квартиру необходимо будет редактировать вручную.

На этом создание набора завершено.

Аналогично создаются наборы, например, для зданий (Рис.1.24.1). Конструктивные элементы здания должны быть вложены в объект-владелец (Здание), метаданные создаются и заполняются как для самого здания, так и каждого конструктивного элемента.

Использование наборов.


Использование наборов

С использованием наборов можно создавать заданное количество объектов (субъектов, документов, адресов). Это значительно облегчает работу по созданию, например, большого количества однотипных зданий с вложенными конструктивными элементами, элементами благоустройства, квартирами, помещениями и пр. В дальнейшем пользователю необходимо открыть на редактирование каждое здание и изменить его индивидуальные характеристики (например, адрес).

Для создания объекта с использованием наборов необходимо выбрать пункт меню "Объект - Создать - Добавить из набора" (Рис.1.25.1), либо нажать кнопку [image] панели инструментов главного окна приложения "Мастер регистрации - Создание из набора".

1.25.1
В появившемся диалоговом окне Мастера (Помощника) - Первый шаг - необходимо выбрать название нужного набора (в нашем случае "Здание") и нажать кнопку "Далее" (Рис.1.25.2).

1.25.2
Второй шаг Мастера предлагает выбираем владельца элементов набора (Рис.1.25.3). При использовании набора "Квартиры" здесь следует выбрать конкретное здание, в котором эти квартиры будут созданы. В нашем случае оставляем это поле пустым.

1.25.3
Третий шаг Мастера информирует о том, какие объекты и в каком количестве будут созданы (Рис.1.25.4). Из рисунка видно, что создаются 3 здания указанного класса с перечисленными конструктивными элементами.

1.25.4
Четвертый шаг Мастера информирует о том, что элементы, перечисленные на предыдущем шаге, уже созданы (Рис.1.25.5). При нажатии кнопки "Подтвердить" работа Мастера завершится и созданные объекты появятся в рабочем окне Объекты (Рис.1.25.6).

1.25.5
Если на этом шаге нажать кнопку "Назад" и затем "Далее", то в последнем окне Мастера количество создаваемых объектов удвоится, т.е. будет создано 6 зданий с вложенными КЭ.

Для отмены работы Мастера и удаления созданных объектов необходимо на последнем шаге (Четвертом) закрыть диалоговое окно Мастера нажатие на кнопку "Закрыть" (Х), расположенную в области заголовка окна.

1.25.6
В рабочем окне Объекты (Рис.1.25.6) созданы 3 здания с названием "5-этажное здание 1-3". Нумерация зданий задана в поле FULLNAME (Название) при описании метаданных этого объекта вводом строки "5-этажное здание <IDX>".


Переменные набора

При создании элементов наборов, Вы можете использовать встроенные переменные. Эти переменные могут быть использованы для автоматической нумерации создаваемых объектов или именования этих объектов по заданным правилам. Имена переменных должны быть вложены в угловые скобки. Ошибочно написанные имена не обрабатываются системой. Список переменных приводится ниже.

<IDX> номер по-порядку создания элементов одного класса
<IDXGLOBAL> номер по-порядку создания всех элементов одного класса одного уровня
<Classname> название класса создаваемого элемента
<NOW> текущие дата-время (может быть использована без угловых скобок - NOW)
<DATE> текущая дата (в формате дд.мм.гггг)
<YEAR> текущий год
<MONTH> текущий месяц цифрой
<MONTHTEXT> текущий месяц словами в именительном падеже
<MONTHTEXT:1> текущий месяц словами в нужном падеже (1-именительный падеж, 2-родительный, 3-винительный, 4-дательный, 5-творительный, 6-предложный)

Примеры использования переменных:
Все переменные могут быть использованы при создании элементов наборов документов, объектов, субъектов, адресов. На основе метаданных с участием перменных набора Вы можете определить порядок формирования и заполнения значений соответствующих элементов.
1. В разделе "Использование наборов" приведен пример создания зданий с вложенными квартирами. Здания и квартиры нумеруются в порядке создания с помощью переменной <IDX>, которая включена в название создаваемого элемента (здания или квартиры). Вложенные элементы (в примере квартиры) нумеруются в пределах вложения, т.е. квартиры, вложенные в здание №1, также как и квартиры, создаваемые в зданиях №2 и №3 будут нумероваться с цифры 1, так как принадлежат разным зданиям. При использовании переменной <IDXGLOBAL> квартиры будут нумероваться также в пределах одного здания, но в отличие от переменной <IDX> подряд будут пронумерованы все квартиры в пределах здания одно, двух и трехкомантные. При использовании <IDX> однокомантные пронумеруются отдельно, двухкомнатные отдельно и т.д.
2. Использование переменной <Classname> позволяет формировать название элемента в зависимости от его класса. Переменные, формирующие время или дату, позволяют автоматически заполнять поля соответствующего формата при создании элемента (например, дату документа). В приведеном ниже примере создается набор документов для формирования договора аренды: договор и приложения к договору - фотографии и схемы. На рисунке (1.26.1) показано, что название создаваемого документа будет сформировано как название класса документа (переменная <Classname>), в качестве даты документа будет использована дата и время создания (переменная <NOW>), кроме того будут заданы даты начала действия документа и дата изменения его состояния.

1.26.1
Схемы и фотографии, являющиеся вложением в данный документ нумеруются в порядке их создания (рис.1.26.2, 1.26.3)

1.26.2

1.26.3

Результат создания пакета документов показан на рисунке 1.26.4

1.26.4


Редактор внешних классификаторов

Сервисное приложение "Редактор внешних классификаторов" предназначено для подключения к системе дополнительных классификаторов, созданных самостоятельно без участия разработчиков и отсутствующих в стандартной поставке АИС "Дока". Для того, чтобы открыть редактор внешних классификаторов, необходимо запустить утилиту администратора, выделить в ней строку "Редактор внешних классификаторов" и нажать кнопку [image] ("Запустить"). Редактор внешних классификаторов будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма (Рис.1.13).

Рис.1.13
Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, редактор внешних классификаторов позволяет добавлять дополнительные внешние классификаторы, созданные самостоятельно без участия разработчиков. Для подключения нового классификатора необходимо в окне редактора внешних классификаторов выбрать пункт меню "Редактор - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.14).

Рис.1.14
В форме диалога необходимо правильно заполнить поля:
· Заголовок меню - наименование пункта меню, под которым новый классификатор появится в списке Редактора внешних классификаторов, а также в главном меню АИС "Дока" "Сервис - Классификаторы";
· Таблица классификатора - наименование таблицы базы данных, содержащей структуру и данные нового классификатора. Структура таблицы классификаторов описана в Руководстве администратора;

После нажатия кнопки "Сохранить" новый классификатор появится в появится в списке редактора внешних классификаторов, а также в главном меню АИС "Дока" "Сервис - Классификаторы" (Рис.1.15).

Рис.1.15


Редактор внешних справочников

Сервисное приложение "Редактор внешних справочников" предназначено для подключения к системе дополнительных справочников, созданных самостоятельно без участия разработчиков и отсутствующих в стандартной поставке АИС "Дока". Для того, чтобы открыть редактор внешних справочников, необходимо запустить утилиту администратора, выделить в ней строку "Редактор внешних справочников" и нажать кнопку [image] ("Запустить"). Редактор внешних справочников будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма (Рис.1.16).

Рис.1.16
Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, редактор внешних справочников позволяет добавлять дополнительные справочники без участия разработчиков путем подключения к системе форм ввода информации, отличных от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы необходимо в окне редактора внешних справочников выбрать пункт меню "Редактор - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.17).

Рис.1.17
В форме диалога необходимо правильно заполнить поля:

· Наименование модуля - Имя, под которым сервисное приложение появится в списке Редактора внешних справочников;
· Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма;
· Форма (класс Delphi) – название класса формы в среде Delphi.

После нажатия кнопки "Сохранить" новый справочник появится в списке редактора внешних справочников, а также в главном меню АИС "Дока" "Сервис - Справочные таблицы".


Редактор помощников

Редактор внешних помощников

Сервисное приложение "Редактор внешних Помощников" предназначено для подключения к системе Помощников регистраци (Wizard), созданных самостоятельно без участия разработчиков и отсутствующих в стандартной поставке АИС "Дока". Для того, чтобы открыть редактор внешних Помощников, необходимо запустить утилиту администратора, выделить в ней строку "Редактор Помощников" и нажать кнопку [image] ("Запустить"). Редактор внешних Помощников будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма (Рис.1.18).

Рис.1.18
Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, редактор внешних Помощников позволяет добавлять Помощники регистрации без участия разработчиков путем подключения к системе форм ввода информации, отличных от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы необходимо в окне редактора внешних Помощников выбрать пункт меню "Редактор - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.19).

Рис.1.19
В форме диалога необходимо правильно заполнить поля:

· Наименование модуля - Имя, под которым сервисное приложение появится в списке Редактора внешних Помощников;
· Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма;
· Форма (класс Delphi) – название класса формы в среде Delphi.
· Пользователь, для которого доступен помощник - имя пользователя SQL-сервера.

После нажатия кнопки "Сохранить" новый внешний Помощник регистрации появится в списке редактора внешних Помощников.


Редактор скриптов

Редактор скриптов является встроенным средством системы, предназначенным для прямого изменения структуры базы данных. С помощью него можно создавать (изменять, удалять) таблицы БД, поля таблиц, триггеры, процедуры и просмотры, а также, минуя приложение, изменять (удалять) данные, хранящиеся в таблицах БД.

ВАЖНО: При использовании редактора скриптов администратор должен хорошо знать структуру базы данных, а также язык SQL. Кроме этого, существует ограничение на использование оператора SELECT: собственно выборка будет выполнена, но выдача ее результата не предусмотрена (пока).

В редакторе используется стандартная подсветка синтаксиса (см. рис.1.23.1).

Рис.1.23.1

Скрипт может быть загружен из файла (сохранен в файл), а также вставлен из буфера обмена. Результаты выполнения скрипта отображаются в окне отчета.


Нумераторы документов

Нумераторы документов используются для автоматического формирования номера нового документа. С помощью данной утилиты Вы сможете описывать правила нумерации для любого класса документов, находящихся в базе данных. Кроме того, Вы также сможете изменить текущее значение любого счетчика (сбросить в 0, или задать новый номер), изменить шаг нумерации, задать маску для номера, создать новый счетчик в базе данных и многое другое. При создании документов автоматически формируется необходимая процедура в базе данных, с помощью которой создаются и формируются номера документов.
Окно, содержащее список созданных нумераторов показано на рисунке

Основные элементы окна позволяют создавать новые нумераторы, изменять или удалять существующие. Кроме того, Вы можете обновить список для просмотра нумераторов, созданных другими пользователями системы, а также обновить процедуру, осуществляющую создание номеров документов.


Создание нумератора

Для создания нумератора выберите пункт меню Нумератор-Создать или нажмите кнопку [image]. После выполнения указанных действий вызывается форма, показанная на рисунке

В поле Название введите название нового нумератора. Название может быть введено на любом языке (русском или английском) и будет использовано при отображении нумератора в списке в окне нумераторов.
Маска используется для формирования номера с преопределенными свойствами. Например, номера, содержащего год создания документа или какой-либо символ, либо номер документа-владельца и т.п. Подробне о масках Вы можете узнать в соотвествующем разделе данной справочной системы.
Класс документа - класс или классы документов, которые будут нумероваться в соответствии с создаваемым нумератором. Условие позволяет указать список классов или один класс будут использовать создаваемый (изменяемый) нумератор для формирования номера документа. Например, при условии starting with, с помощью содаваемого нумератора будут нумероваться документы, классы которых начинаются с указанных символов. Таким образом Вы можете указывать всю ветку классов документов (например, "Договоры"), а не каждый класс в отдельности.
Название счетчика (генератора) - счетчик, хранящийся в базе данных и используемый для генерации очередного номера. Вы можете выбрать счетчик из списка. Если Вы хотите создать новый счетчик для нумерации, нажмите соответствующую кнопку - Новый счетчик (генератор).

После ввода имени счетчика (генератора) и подтверждения операции нажатием кнопки ОК, он будет добавлен в базу данных и в список доступных счетчиков в окне создания (изменения) нумератора.
Внимание! Название счетчика вводится только латинскими символами! При использовании других языков не гарантируется корректная работа нумератора и создание счетчика.
Шаг счетчика - позволяет изменить шаг генерации номера.
Вы можете установить текущее значение счетчика, вписав его в соответствущее поле и нажав кнопку "Установить значение равное"
Описание - служит для ввода любой информации, позволяющей Вам описать работу нумератора и иной справочной информации.
Закладка "Нестандартный код" используется для формирования специфичного кода, используемого для создания специфичного номера документа.

При нажатии на кнопку [image] будет сформирован стандартный код тела процедуры, относящийся к редактируемому нумератору. Если Вы знаете, как должен быть сформирован номер документа и владеете минимальными знаниями языка DDL SQL, Вы сможете сами создать код для создания номера. В этом случае при формировании процедуры будет использован написанный Вами код. Для отказа от нестандартного подхода, нажмите кнопку [image] или очистите текст в поле кода.
Внимание! В случае ошибки в написанном Вами коде, скрипт изменения процедуры сформирован не будет и процедура формирования номера документа останется без изменений.


Маски номеров

Для формирования номера документа Вы можете использовать маски. Типы масок, которые Вы можете использовать описаны ниже:
%g - вместо данной комбинации символов будет вставлен номер, сгенерированный выбранным счетчиком (генератором).
%n - данная комбинация символов будет заменена номером документа-владельца. Например, заявки, создаваемые как часть договора могут нумероваться с использованием номера договора с помощью маски %n/%g - где %n - номер договора, %g - очередной номер заявки (1/1, 1/2, 1/3 и т.д.)
%y - последняя цифра года создания документа
%yy - две последних цифры года создания документа
%yyyy - год создания документа (4 цифры)
%mm - месяц создания документа в виде порядкового номера
%mmmm - месяц создания документа в текстовом виде (январь, февраль и т.п.)


Коммуникатор

Коммуникатор, в первую очередь, является встроенным средством связи между пользователями приложения, работающими с общей базой данных и используется в системе, как Служба Сообщений.

Назначение Коммуникатора:
· Отправка (прием) сообщений пользователям базы данных;
· Отслеживание списка задач, запланированных пользователем;
· Отслеживание изменений объектов базы данных;
· Информирование пользователя при наступлении перечисленных событий.

Внимание! Для выполнения заявленных функций Коммуникатор должен быть запущен при подключении пользователя к базе данных и не закрываться до завершения работы с системой.

Запуск коммуникатора в зависимости от настроек производится автоматически, нажатием кнопки панели инструментов (Рис.2.1.1), либо выбором пункта меню "Сервис - Коммуникатор".

Рис.2.1.1

Рабочее окно коммуникатора показано на Рис.2.1.2.

Рис.2.1.2

Список пользователей

На левой панели в нижнем окне находится список пользователей базы данных, управление которым осуществляется с помощью Менеджера пользователей Коммуникатора. Подключившиеся к базе данных пользователи отмечаются в списке значком [image] (при условии, что у них запущен Коммуникатор). При подключении новых (отключении зарегистрированных) пользователей все, работающие в этот момент с базой данных пользователи, получают системные сообщения с указанием имен подключившихся (отключившихся ) и в окне списка видят изменение их статуса (значка).

Если в окне списка выбрать конкретного пользователя, нажать на нем правой кнопкой мыши, то появится контекстное меню, из которого можно отправить этому пользователю сообщение. Отправка сообщения возможна любому пользователю, в т.ч. "неактивному" (не подключенному к базе данных). Подключенный пользователь получит сообщение немедленно. "Неактивный" пользователь при следующем подключении к базе данных получит системное сообщение о том, что у него имеются непрочтенные сообщения. После этого он должен открыть папку "Входящие" и найти принятое сообщение.

Отправка сообщения.

Панель задач

На левой панели в верхнем окне находится панель задач со списком папок, реализующих основные функции Коммуникатора:

· Входящие - папка для хранения принятых сообщений;
· Исходящие - папка для хранения отправленных сообщений;
· Задачи - папка со списком задач, запланированных пользователем;
· Мониторинг - папка со списком объектов базы данных, взятых на контроль пользователем.

На правой панели рабочего окна Коммуникатора отображается список объектов папки, выбранной в окне панели задач.


Отправка сообщения

Для отправки сообщения необходимо:
· Выбрать в списке нужного пользователя, нажать на нем правой кнопкой мыши и в контекстном меню выбрать "Отправить сообщение этому пользователю"; Или
· В окне коммуникатора выбрать пункт меню "Оповещение - Создать - Новое сообщение"; Или
· Выделить папку "Исходящие" и нажать кнопку [image] панели инструментов.
На экран будет выведена диалоговая форма (Рис.2.2.1), в которой пользователь заполняет:

Рис.2.2.1
· Кому - выбирается пользователь - получатель, которому отправляется сообщение. Если сообщение создается путем выбора пользователя из списка Коммуникатора, то он автоматически подставляется в это поле. В ходе создания сообщения получатель может быть изменен. Отправка сообщения может быть осуществлена всем пользователям одновременно. Для этого в качестве получателя необходимо выбрать "Все пользователи АИС "Дока";
· Текст сообщения - собственно то, что Вы хотите сообщить получателю;
· Ожидается ответ - уведомляет получателя о том, что отправитель хочет получить ответ на свое сообщение. При этом и у отправителя в папке "Исходящие" и у получателя в папке "Входящие" сообщению присваивается статус "Важно" и оно помечается значком [image].
· Вложения - в сообщении имеется возможность передать получателю информацию о том, к какому объекту базы данных она имеет отношение. Например, на рис.2.2.1 отправитель сообщает получателю, что он зарегистрировал в системе здание. Для присоединения вложения необходимо нажать на кнопку выбора объекта базы данных [image], соответствующую тому, что Вы хотите передать во вложении - Объект, Субъект или Документ и выбрать его. Информация о соответствующем объекте будет присоединена к сообщению. При этом и у отправителя в папке "Исходящие" и у получателя в папке "Входящие" в сообщении появляется пометка о вложении значком [image].

Обязательными для заполнения полями диалоговой формы являются "Кому" и "Текст сообщения".
Нажатие кнопки "Отправить" приведет к передаче сообщения.


Входящие

Папка "Входящие" предназначена для хранения принятых сообщений (Рис.2.3.1).

См. также Назначение Коммуникатора.

Рис.2.3.1
Если во входящем сообщении имеется вложенный объект базы данных, то при двойном щелчке левой кнопки мыши на нам будет открыто соответствующее рабочее окно (в случае, показанном на рис.2.3.1 - окно "Объекты") и курсор будет установлен на объекте-вложении.

Сообщения в окне списка автоматически группируются в зависимости от даты получения: "Сегодня", "Три дня назад", "Семь дней назад" и "Давно".

Прочтенные и непрочтенные сообщения маркируются разными значками, по которым их легко различить (Рис.2.3.2).

Рис.2.3.2
Если сообщение не видно в списке, а Вы знаете, что оно должно быть, то нажмите кнопку "Обновить" (или клавишу F5).

В окне списка сообщениями можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши (Рис.2.3.3), либо из главного меню "Оповещение". Для совершения каких-либо действий с сообщением его необходимо выделить левой кнопки мыши.

Рис.2.3.3
Просмотр сообщения.

Ответ на сообщение.

Конкретное сообщение удаляется выбором пункта "Удалить", а все сообщения - из главного меню "Оповещение - Удалить все входящие".


Просмотр сообщения

При выборе пункта меню "Изменить" и "Просмотреть" вызывается обозреватель сообщений (Рис.2.3.4.).

Рис.2.3.4
В этом окне пользователь может только просматривать полученные сообщения.


Ответ на сообщение

При выборе пункта "Ответить" создается новое сообщение, в котором в качестве получателя подставляется пользователь, чье сообщение Вы выбрали в папке "Входящие", а в тексте сообщения появляются слова: "Ответ на сообщение <Цитата>" (Рис.2.3.5).

Рис.2.3.5
Действия пользователя в этом диалоговом окне такие же, как и при отправке нового сообщения.


Исходящие

Папка "Исходящие" предназначена для хранения отправленных сообщений (Рис.2.4.1).

См. также Назначение Коммуникатора.

Рис.2.4.1
Если в исходящем сообщении имеется вложенный объект базы данных, то при двойном щелчке левой кнопки мыши на нам будет открыто соответствующее рабочее окно и курсор будет установлен на объекте-вложении.

Сообщения в окне списка автоматически группируются в зависимости от даты получения: "Сегодня", "Три дня назад", "Семь дней назад" и "Давно".

В окне списка сообщениями можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши, либо из главного меню "Оповещение". Для совершения каких-либо действий с сообщением его необходимо выделить левой кнопки мыши.

При выборе пункта меню "Изменить" и "Просмотреть" вызывается обозреватель сообщений (Рис.2.3.4.).

Конкретное сообщение удаляется выбором пункта "Удалить", а все сообщения - из главного меню "Оповещение - Удалить все исходящие".


Мониторинг

Папка "Мониторинг" предназначена для хранения списка объектов базы данных, взятых на контроль пользователем (Рис.2.6.1). Пользователь может контролировать объекты базы данных - Объекты, Субъекты, Документы, Адреса.

См. также Назначение Коммуникатора.

Смысл контроля состоит в том, что если кто-либо из других пользователей создал, изменил или удалил какой либо объект базы данных, то пользователь, поставивший этот объект на контроль, получит уведомляющее сообщение о действиях, произведенных с контролируемым объектом, а также имени пользователя, совершившего эти действия.

Уведомляющие сообщения сохраняются в папке "Входящие" того пользователя, который контролирует выбранные им объекты базы данных.

2.6.1
В окне списка элементами мониторинга можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши, либо из главного меню "Оповещение". Для совершения каких-либо действий с элементом мониторинга его необходимо выделить левой кнопки мыши.

Создание (изменение) элемента мониторинга

Ненужные элементы мониторинга удаляется выбором пункта меню "Удалить".


Создание элемента мониторинга

При выборе пункта меню "Создать (измененить) элемент мониторинга" вызывается диалоговая форма (Рис.2.6.2), в которой пользователь заполняет:

__
а)______________________________________б)
2.6.2
· Объект базы данных - объект контроля - Объект, Субъект, Документ или Адрес. В зависимости от выбранного здесь элемента изменяется следующий пункт "Наблюдать за...". Т.е. при выборе "Объект" следующий пункт будет выглядеть "Наблюдать за Объектом или Классом объекта;
· Наблюдать за - выбирается конкретный объект базы данных, либо его класс (сравните рис.2.6.2 а) и б). Т.е. при выборе, как на рис.2.6.2 а), пользователю будет предложено выбрать для контроля конкретный документ ("Акт завершения работ №2") и контроль будет осуществляться ТОЛЬКО ЗА ЭТИМ документом. При выборе же класса документа "Акт завершения работ" (рис.2.6.2 б) - контроль будет осуществляться за ВСЕМИ документами этого класса, т.е. за всеми "Актами завершения работ".
· Отслеживаемые действия - выбирается вид действий, совершаемых с контролируемыми объектами базы данных, которые пользователь желает отслеживать. Конкретный объект базы данных (например Документ) может быть либо изменен, либо удален. Для класса доступен пункт "Вставка" (Создание). Т.е. при выборе как на рис.2.6.2 б) пользователь получит уведомляющее сообщение о каждом вновь создаваемом документе "Акт завершения работ".
· Наименование элемента - выбирается конкретный элемент для осуществления контроля. В случае, как на рис.2.6.2 а), будет открыто окно выбора документов, а при выборе, как на рис.2.6.2 б) - открывается классификатор документов.
· Пользовательское сообщение - произвольное сообщение, относящееся к контролируемому объекту базы данных:
· Если пользовательское сообщение будет выглядеть, как на рис.2.6.2 а), то служба сообщений передаст пользователю: "Кто изменил Акт №2 Документ изменен пользователем "Системный администратор ";
· Если пользовательское сообщение не заполнять (оставить пустым), то уведомляющее сообщение выглядит как: "Изменен документ класса "Акт завершения работ". Наименование документа "Акт завершения работ №2 от 13.11.2007". Документ изменен пользователем "Системный администратор ".


Задачи

Папка "Задачи" предназначена для хранения списка задач, запланированных пользователем. По своей сути это простой планировщик для напоминания пользователю о личных мероприятиях (Рис.2.5.1).

При наступлении времени выполнения Задачи системой выдается уведомляющее сообщение. Если в окне системного сообщения нажать левой кнопкой мыши на ссылке "Перейти", то будет открыта соответствующая папка Коммуникатора.

См. также Назначение Коммуникатора.

Рис.2.5.1
В окне списка задачами можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши, либо из главного меню "Оповещение". Для совершения каких-либо действий с задачей ее необходимо выделить левой кнопки мыши.

Создание (изменение) задачи.

Ненужные задачи удаляется выбором пункта меню "Удалить".


Создание задачи

При выборе пункта меню "Создать (измененить) задачу" вызывается диалоговая форма, состоящая из двух закладок:
· Закладка "Задача" - запись о задаче (напоминании) Рис.2.5.2, где:

Рис.2.5.2
· Название - имя, под которым напоминание появится в списке задач;
· Дата записи - по-умолчанию подставляется текущая дата;
· Собственно текст задачи (напоминания).

· Закладка "Оповещение" - настройка оповещения задачи (напоминания) Рис.2.5.3, где:

Рис.2.5.3
· Включить - включение (отключение) оповещения о наступлении события "Задача";
· Дата, время - когда напомнить о наступлении события "Задача";
· Проиграть звук - вызывается звуковое оповещение для привлечения внимания. Звук можно выбрать;
· Повторять - включение (отключение) режима повтора оповещения, а также его периодичности;
· Дата окончания действия повторного оповещения - дата, после которой режим повтора оповещения снимается.


О проекте

Что такое Актуарий

Актуарий

Actuary (actuarius - latin)

Протоколист, регистратор. Специалист по технике страхования, делающий математические расчеты для обоснования страховых взносов, премий и т.п.

(Словарь иностранных слов)


Основные положения

Основная идея проекта "Актуарий" состоит в создании системы (ядра), позволяющей на основе единого интерфейса строить приложения (программы), настроенные под различные задачи.

Система предполагает, что она является настраиваемой и может быть настроена для работы с различными базами данных и позволять решать различные задачи.

АИС "Дока" - одна из первых задач, решенных с помощью ядра системы "Актуарий". Выбор именно этой задачи связан с тем, что документооборот лежит в основе большинства решений.


.topic 2

Объект – любые здания, сооружения, комплексы зданий  и сооружений, объекты инфраструктуры (железная дорога, автодорога, трамвайный путь, проезд, квартал), объекты коммуникаций (узел связи, линия связи), объекты кадастрового учета (земельный участок), всевозможные сети (ЛЭП, газопровод, нефтепровод, канализация), гидротехнические сооружения (плотина, дамба, пристань, док, пруд), объекты зеленых насаждений (парк, сад, сквер, цветник, лесополоса), отдельные помещения или встроенные объекты (цех, офис, квартира, комната) (в АИС могут являться неотъемлемой частью одного из перечисленных выше объектов и не существовать самостоятельно). Проще говоря, объектом в системе может быть абсолютно любой объект реального мира – товар, оборудование, склад, здание и т.п.

Субъект – любые субъекты. Примеры субъектов: организации, физические лица, предприниматели без образования юридического лица (может быть как организацией, так и отдельным субъектом) и т.д. и т.п.

Документ – любой документ (нормативно-правовой акт, правоприменительный акт, документ, удостоверяющий личность, технический или финансовый документ).

Класс объекта (субъекта, документа) – основной (базовый) признак объекта (субъекта, документа). Например, классы субъектов – юридические или физические лица; классы документов – нормативно-правовые акты, технические или финансовые документы; классы объектов – жилые здания, общественные здания, инженерные сети, дороги и дорожные сооружения и пр. Классы могут иметь подклассы, т.е. допускается вложенность.

Группа объектов (субъектов, документов) – дополнительный признак группировки, предназначенный для визуального структурирования информации. Как и классы, могут иметь вложенные группы (подгруппы).

Классификатор – это способ упорядочивания информация, иерархически систематизированный перечень названий классов, групп и объектов классификации, отобранных по основополагающему признаку;

Внешняя форма - это форма для ввода информации, специфичной для предметной области организации. АИС "Дока" является настраиваемой системой и может быть адаптирована (перестроена) под требования организации, в которой она эксплуатируется.

Печатная форма - это форма для вывода документа определенного класса на печать с автоматической подстановкой в нее реквизитов связанных объектов базы данных.

.topic 1

АИС "Дока" базируется на SQL-сервере InterBase (FireBird). Выбор этой платформы обусловлен такими ее отличительными качествами, как:

высокая производительность и надежность сервера при минимальных требованиях к техническим средствам;
поддержка стандарта SQL-92, обеспечивающая переносимость приложений;
относительно низкая стоимость продукта (FireBird разрабатывается по лицензии MPL);
простота установки и поддержки сервера. Удобный и требующий минимальной специальной подготовки механизм администрирования базы данных.

АИС построена в архитектуре "клиент-сервер", основными особенностями которой являются возможность многопользовательской работы с базой данных, перенос вычислительной нагрузки на сервер баз данных и максимальная разгрузка приложения клиента от вычислительной работы, а также существенное укрепление безопасности данных как от преднамеренных, так и просто ошибочных изменений за счет переноса большей части бизнес-правил на сервер.

Как было сказано выше, АИС не просто предоставляет возможность вести накопление и хранение документов. Наряду с этим она обеспечивает управления связями, обработкой и выводом трех основных объектов реального мира "Объект",  "Субъект" и "Документ".
Вместе с тем, объекты, субъекты, документы и связи между ними сами по себе являются объектами базы данных.

Учитывая понятия перечисленных нами терминов, АИС "Дока" позволяет накапливать данные не только о документах, но и об объектах и субъектах, как участниках хозяйственной, финансовой и прочих видах деятельности предприятий и организаций.

Все объекты, субъекты, документы и связи между ними, структурированные и сортированные по классам, группам, статусу, состоянию и другим характеристикам, хранятся в базе данных. При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева объектов и панели списка объектов. Эти сортировки являются виртуальными и настраиваются пользователем по собственному вкусу с помощью классификаторов и справочников. Классификаторы и справочники являются самостоятельными объектами базы данных и могут быть отредактированы под собственные нужды организации.

В АИС разработана и применяется система безопасности данных, позволяющая присваивать конкретным объектам, субъектам, документам и связям между ними права на их использование (по аналогии с правами пользователей на объекты операционной системы Windows NT™). Система назначения прав позволяет сделать "невидимыми" документы, скажем, бухгалтерии для всех остальных сотрудников компании, несмотря на то, что хранятся они в единой базе данных. В зависимости от имеющихся прав пользователь может получить полный доступ к объекту базы данных (изменять, удалять, сохранять), либо лишь возможность просматривать его. В случае отсутствия прав на просмотр, объект базы данных становится невидимым для пользователя.

Разветвленная и гибкая система управления связями между объектами, субъектами и документами позволяет просматривать и отслеживать такие моменты, как, например, наличие у основного договора дополнительного соглашения к нему либо технического задания. В случае установления связей между документом и субъектом становится возможным автоматизировать, например, процесс ведения договоров компании. При этом у конкретного документа "Договор" визуально видны связанные с ним субъекты с их конкретным статусом ("Арендатор" - "Арендодатель" или "Продавец" - "Покупатель"), а при выводе договора на печать реквизиты субъектов автоматически будут подставлены в текст договора. Причем, фамилии, имена и отчества субъектов печатаются в нужном падеже ("Организация" в лице Иванова Александра Петровича). Установив связь документа "Договор" с объектом "Офис" и заполнив необходимые характеристики последнего (площадь, стоимость аренды за 1 кв.м.), получим подставленную в договор сумму за аренду помещения. Зарегистрировав в системе все помещения (объекты), сдаваемые в аренду, легко отслеживать сданные и свободные для арендаторов объекты.

Учитывая такую важную особенность некоторых видов документов, как наличие срока действия (договор, распоряжение и пр.), в системе предусмотрен режим контроля и предупреждения пользователя об истечении срока действия такого документа. В этом случае в строке состояния (статус - строке) приложения выводится информация о наличии таких документов, а у пиктограммы (иконки) самого документа появляется дополнительный значок, привлекающий внимание. В том случае, если пользователь в свойствах документа назначит собственную группу, куда документ должен будет помещен по истечении срока его действия, документ автоматически появится в этой группе (например, "Просроченные"). Об истечении срока действия документа пользователь может быть предупрежден заранее, установив необходимые параметры в настройках приложения.

Для того, чтобы сделать пользователей системы максимально независимыми от разработчиков, предусмотрен режим самостоятельного создания печатных форм для различных классов и типов документов. В АИС "Дока" используется генератор отчетов FastReport™, предоставляющий пользователю удобные средства для разработки внешнего вида печатных форм. Впоследствии эту форму можно сохранить в базе данных и использовать для печати документов. Кроме этого, есть возможность импортировать печатные формы, разработанные другими пользователями, а также экспортировать собственные.

Таким образом, с использованием АИС "Дока" без затруднений могут быть построены различные приложения, предназначенные для централизованного хранения и контроля документов предприятий, накопления информации для подразделений технической инвентаризации, кадастров и ЖКХ и пр. Модульная структура позволяет на общем ядре системы в короткий срок создать приложения необходимого функционального назначения.

.topic 3

Для запуска программы "Дока" необходимо в Проводнике Windows найти исполняемый файл Doka.exe и дважды щелкнуть на нем левой кнопкой мыши (или меню «Пуск – Программы – АИС "Дока"»). После этого на экране появляется окно регистрации пользователя базы данных.

Рис. 1.1

 В соответствующие поля окна необходимо ввести имя пользователя, его пароль и роль (если необходимо) в базе данных. Эту информацию можно получить у администратора системы.
После запуска приложения на экране появляется главное окно системы (Рис. 1.2). Вверху главного окна  находится область заголовка, которая содержит иконку и название программы. Кроме того, в области заголовка расположены стандартные для всех Windows-приложений кнопки управления окном программы: восстановить, свернуть, закрыть.

Рис. 1.2

Под областью заголовка отображается строка главного меню. Для выполнения определенной команды меню сначала следует щелкнуть мышью на имени меню, а затем в открывшемся меню выбрать необходимую команду.

Под строкой главного меню находится панель инструментов. Щелчок мышью на кнопке панели инструментов приводит к выполнению определенной команды. Кнопки на панели инструментов дублируют некоторые, наиболее часто используемые, пункты меню.

В нижней части главного окна приложения Вы найдете строку состояния (статус-строку), которая, как правило, содержит информацию справочного характера.
После выполнения какой-либо команды меню, на экране появляется рабочее окно. Размер рабочего окна, в большинстве случаев, может изменяться по желанию пользователя как посредством стандартных кнопок управления окном, так и с помощью мыши. Для этого подведите указатель к верхней или нижней границе окна (если требуется изменить высоту окна) или к правой или левой границе окна (если требуется изменить ширину окна). После того как указатель примет форму двунаправленной стрелки, нажмите левую кнопку мыши и, не отпуская ее, «растягивайте» окно до нужного размера. Можно изменить и высоту, и ширину окна одновременно. Для этого подведите указатель мыши к любому из углов окна и, когда указатель примет форму двунаправленной стрелки, «растягивайте» окно, как было описано выше.

Работая с системой, Вы можете допустить ошибку, т.е. попытаться выполнить какое-то недопустимое действие. Например, не введете значение в обязательное поле или введете значение несоответствующее типу поля. Подобных ошибок может быть много, и предугадать (учесть) их все Вы не сможете. Поэтому система сама контролирует выполнение всех необходимых ограничений в работе, т.е. сама «страхует» себя от появления ошибок.

Каждый раз, когда Вы допускаете ошибку, система выдает звуковой сигнал и выводит на экран сообщение об ошибке (Рис. 1.3).

Рис. 1.3

После того, как выведено сообщение, система переходит в режим «ожидания ответа». Т.е. пока Вы не закроете сообщение, система не позволит Вам выполнять никакие другие действия. Чтобы вернуться к работе, закройте сообщение, нажав кнопку «ОК». А затем попытайтесь выполнить соответствующее действие правильно.

Приложение организовано на основе стандартного оконного интерфейса Windows. При выборе пункта главного меню или активизации соответствующей кнопки панели инструментов (Рис. 1.4) открывается соответствующее окно программы.

Рис. 1.4

В зависимости от установленных настроек это окно может быть стыковано (докировано) с главным окном программы, либо открыто независимо от него (Рис. 1.5).

Рис. 1.5
Докированное (слева) и независимое (справа) окна программы.

 Стыковать (отстыковать) окно можно вручную. Для стыковки необходимо подвести указатель мыши к области заголовка независимого окна, нажать левую кнопку и, не отпуская ее, переместить это окно на главное окно приложения. Для расстыковки указатель мыши устанавливается на вкладку докированного окна и оно выводится за пределы главного окна программы, либо по вкладке окна производится двойной щелчок левой кнопкой мыши.

С помощью пункта главного меню «Окно» Вы можете активизировать необходимое открытое окно приложения. При этом текущее активное окно помечается «галочкой» (Рис. 1.6).

Рис. 1.6
Меню «Окна»

.topic 4

Главное окно содержит основные элементы управления приложением (Рис. 2.1).

Рис. 2.1

Отсюда осуществляется доступ к рабочим окнам основных объектов базы данных, изменениям параметров системы, настройкам классификаторов и справочных таблиц, а также управление внешним видом панелей главного окна.

В левой части главного окна приложения расположена панель с деревом объектов базы данных. При выборе одного из них (на Рис. 2.1 выбраны Документы) на правой панели отображается список открытых рабочих окон. Система позволяет открывать одновременно несколько таких окон, перемещение по которым осуществляется из главного окна приложения путем двойного щелчка левой кнопки мыши на выбранной пиктограмме (Документы2). Кроме этого, по щелчку правой кнопки мыши на выбранном элементе открывается контекстное меню, из которого возможно открыть новое окно, перейти к выбранному либо закрыть рабочее окно из главного окна приложения (Рис. 2.1).

Рис. 2.2

В том случае, если рабочие окна докированы (пристыкованы) к главному окну приложения (Рис. 2.2), они отображаются на главном окне закладками. Открывать ту или иную закладку можно щелчком левой кнопки мыши на ней. Кроме того, перемещаться по закладкам также возможно нажатием комбинации клавиш <Ctrl+Tab> (удерживая нажатой клавишу <Ctrl> нажимать клавишу <Tab> до момента открытия нужной закладки) или <Shift+Ctrl+Tab>.

Если произвести щелчок правой кнопки мыши на ярлыке активной (открытой) закладки, то в открывшемся контекстном меню можно осуществлять навигацию по закладкам, либо закрыть текущую (Рис. 2.2).
Еще одной особенностью работы с докированными окнами является то, что при стыковке рабочего окна с главным окном приложения их главные меню объединяются и при выборе той или иной закладки в главном меню появляются пункты меню соответствующего рабочего окна (сравните меню на Рис. 2.1 и Рис. 2.2).

В левой части строки состояния главного окна приложения находится панель индикации. Появление на этой панели пиктограммы   означает, что в системе имеются документы, у которых закончился срок действия. Действия пользователя в этом случае будут описаны в главе «Работа с документами». Двойной щелчок мышью по иконке откроет окно документов (или перейдет к первому открытому  окну), переведет это окно в режим поиска документов, после чего будут найдены все документы, у которых закончился срок их действия.

На правой панели строки состояния отображается путь к базе данных, работа с которой ведется в текущий момент.

.topic 5

Меню "Сервис" (Рис. 2.3) предоставляет доступ к настройке основных элементов системы. Рассмотрим работу с настройками параметров приложения.

Рис. 2.3

С помощью этой команды задаются настройки для пользователя базы данных АИС "Дока".

Рис. 2.4

Для настройки параметров пользователя выберите пункт меню «Сервис–Параметры» (Рис. 2.3). В результате будет вызвано диалоговое окно, показанное на рисунке (Рис. 2.4). Окно настроек содержит в левой части дерево объектов настройки. При выборе каждого из объектов можно задавать или изменять различные настройки пользователя.

.topic 6
На этой вкладке устанавливаются параметры, применяемые для всех пользователей базы данных (Рис. 2.4), за исключением пункта «Месторасположение базы данных системы». Этот пункт определяет, с какой базой данных будет работать приложение. Однако и в этом случае подразумевается, что с этой базой данных будут работать все пользователи, запустившие программу на этом компьютере и в этой сессии.

Месторасположение базы данных системы. Пользователь может воспользоваться этим пунктом в нескольких случаях:
если ему понадобиться подключится к другой базе данных, не заканчивая работу с приложением. В этом случае он должен нажать кнопку    справа от поля ввода пути к базе данных. В открывшемся стандартном диалоговом окне необходимо найти новый файл базы данных, выбрать его левой кнопкой мыши и нажать кнопку «Открыть». В поле ввода появится путь к новой базе данных. После нажатия кнопок «ОК» или «Применить» появится окно регистрации пользователя базы данных (Рис. 1.1), в котором необходимо ввести имя пользователя и пароль. В случае, если данные введены правильно, система подключится к новой базе данных;
если при регистрации введены неправильные имя пользователя или пароль. В этом случае система выводит предупреждающее сообщение (Рис. 1.3) и после нажатия кнопки «ОК» открывает главное окно приложения.

Рис. 2.5
Блокированные пункты меню

При этом в главном меню и на панели инструментов пункты и кнопки открытия рабочих окон объектов базы данных недоступны (Рис. 2.5). В этом случае пользователь должен открыть окно настройки параметров системы и произвести действия в соответствии с предыдущим подпунктом.

.topic 7

 На этой вкладке устанавливаются следующие параметры (Рис. 2.6):

Рис. 2.6

периодичность проверки времени действия (минут) – числовое значение, устанавливающее промежуток времени, через который система просматривает документы для проверки срока их действия и информирования пользователя об истечении этого срока.

.topic 8

 На этой вкладке устанавливаются параметры адресной системы (Рис. 2.7). Наряду с тремя основными объектами базы данных «Документы», «Субъекты» и «Объекты» в системе используется т.н. «Адресная система» (рабочее окно «Адреса»). Ее назначение – правильное формирование адресов, на которые ссылаются основные объекты БД. Структура адреса основывается на классификаторе адресов, который представляет собой систематизированный перечень названий объектов административно-территориального деления,  созданный на основе соответствующего общероссийского классификатора (ОКАТО).

Рис. 2.7
 Параметры адресной системы

Данные параметры задаются для облегчения настройки адресной системы. Вы можете использовать собственный классификатор адресов, если Вас по каким-то причинам не устраивает предложенный. Для корректного функционирования системы необходимо указать, какие именно классы адресов относятся к населенным пунктам, улицам и т.п. В стандартной поставке используется следующая интерпретация настроек: например, населенными пунктами являются те классы, которые вложены в указанный класс, не являются папками и лежат на уровне на один ниже указанного.

Как это выглядит в реальности? В пункте «Виды населенных пунктов» выбран класс 1.02.01 – «Населенные пункты» (уровень 2 классификатора, является папкой)
При создании населенного пункта для выбора его типа будут отобраны классы, начинающиеся с 1.02.01., не являющиеся папками, лежащие на уровне 3. Таковыми являются: класс 1.02.01.04 – «город», 1.02.01.14 – «деревня» и т.д. Классы, относящиеся к этому уровню (3) и являющиеся папками будут проигнорированы, например, класс 1.02.01.02 – «Геоним» не будет отнесен к населенным пунктам.
Таким образом, данная вкладка служит для выбора и сопоставления соответствующих классов адресной системы.

Примечание: Геоним (geoname) – в буквальном переводе географическое название. В данном контексте название типов улиц или площадей и т.п.: улицы, переулки, проспекты, проезды, площади и т.п.

При нажатии кнопки   открывается диалоговое окно выбора класса объекта адресной системы (Рис. 2.8). Необходимо найти нужный параметр и нажать кнопку «Выбрать».

Рис. 2.8

.topic 9

 На этой вкладке устанавливаются параметры, связанные с особенностями создания уникальных кодов субъектов, хранимых в базе данных (Рис. 2.9).

Рис. 2.9
Параметры субъектов

Установленные пользователем параметры не влияют на режим отображения субъектов в рабочих окнах либо их взаимосвязи с остальными объектами базы данных. Они определяют внутреннюю организацию структуры хранения субъектов в базе данных, а именно обеспечивают уникальность записи о субъекте

Генерировать код автоматически – уникальный код формируется системой;
Генерировать код на основе ИНН (КПП) – уникальный код формируется на основе ИНН (КПП) субъекта;
Генерировать код с помощью DLL – уникальный код формируется во внешней форме (используется только в версиях «Профессиональная» или «Разработчик») и может быть сформирован по любому желаемому алгоритму
Использовать «Личный код» - уникальный код формируется на основе личного кода физического лица (если таковой имеется…, см. например, паспорт гражданина РФ).

.topic 10

 На этой вкладке устанавливаются параметры классификаторов основных объектов базы данных (Рис. 2.10).

Рис. 2.10
Параметры классификаторов

Разделитель классификатора – может использоваться только для визуального представления разделителя. По умолчанию в классификаторах как разделитель используется точка.
Корневой класс – параметр, влияющий на особенности отображения элементов классификатора при работе с объектами базы данных. Например, если необходимо работать только с финансовыми документами, то может быть установлен в качестве корневого класса класс «Финансовые документы» (Рис. 2.11).

Рис. 2.11
Выбор корневого класса документов

Впоследствии при создании новых документов пользователям будут доступны только финансовые документы, т.е. не будет необходимости искать требуемый класс документа по всему классификатору. Если не указано никакого класса, будет загружаться весь классификатор. То же самое относится к остальным классификаторам.

.topic 101

 На этой вкладке администратор может назначить собственные переменные, используемые для тонкой настройки системы (Рис. 2.12).

Рис. 2.12

Настройка этих параметров требует знаний внутренней структуры базы данных и не может быть выполнена неподготовленным пользователем. Если Вы не вполне понимаете назначение этих параметров, то не изменяйте настройки системы, установленные по-умолчанию.

.topic 11

Все параметры, относящиеся к этой вкладке и вложенным уровням, определяют настройки для конкретного пользователя, работающего с базой данных. То есть, для остальных пользователей эти параметры могут отличаться. Непосредственно на этой вкладке устанавливается всего один параметр – «Язык по умолчанию».

Рис. 2.13
Настройка языка по умолчанию

Система может использоваться в многоязычной среде, и этот параметр следует выбирать исходя из наиболее часто используемых языков, на котором исполняется документ. Параметр информационный и не влияет на отображение, как документов, так и внешнего вида приложения. При создании нового документа язык документа будет установлен в зависимости от языка, выбранного и установленного пользователем на этой вкладке.

Язык документа выбирается из выпадающего списка путем прокрутки его с помощью мыши или стрелок управления курсором <Вверх> и <Вниз>. Для ускорения поиска можно набрать на клавиатуре первые буквы языка и нажать клавишу <Enter>. Если поиск по списку не производится, проверьте текущую раскладку клавиатуры.

.topic 12

Это параметры настройки внешнего вида приложения (Рис. 2.14).

Рис. 2.14
Настройка внешнего вида приложения

Показывать архивы, как вложенные папки – в данной версии не используется. Предполагается использование данной настройки в будущем;
Стыкуемые окна – этот параметр определяет возможность стыковки рабочих окон с главным окном программы. При необходимости пользователь может вручную изменять этот параметр для любого конкретного рабочего окна приложения. Для этого на любом рабочем (не главном) окне программы необходимо произвести щелчок левой кнопкой мыши на иконке в области заголовка окна (Рис. 2.15).

Рис. 2.15
Системное меню окна программы

В открывшемся системном меню необходимо снять «галочку» с пункта «Стыкуемое». После этого рабочее окно не может быть стыковано с главным окном.

Автоматически стыковать окна – при установке этого параметра все вновь открываемые рабочие окна приложения будут автоматически стыкованы с главным окном программы, как на Рис. 2.2.
Стиль отображения – это установка внешнего вида по умолчанию отображения объектов базы данных в рабочих окнах приложения. По аналогии с «Проводником» Windows так же может быть установлен из панели инструментов любого окна программы (Рис. 2.16).

Рис. 2.16

.topic 13

 Это параметры настройки рабочего окна «Объекты».

Рис. 2.17

Показать – параметр устанавливает возможность показа связанных объектов базы данных;
Загрузка объектов – устанавливает режим группировки объектов, который будет установлен при открытии рабочего окна;
Объект по умолчанию – устанавливает, какой объект будет выделен при открытии рабочего окна;
Класс объекта по умолчанию – параметр устанавливает класс объекта, который будет активен в окне классификатора при создании нового объекта.

.topic 14

 На этой вкладке производится настройка рабочего окна «Субъекты» для текущего пользователя.

Показать – параметр устанавливает возможность показа связанных объектов базы данных.
Загрузка субъектов – устанавливает режим группировки субъектов, который будет установлен при открытии рабочего окна.
Субъект по умолчанию – устанавливает какой субъект будет выделен при открытии рабочего окна.
Класс субъекта по умолчанию – параметр устанавливает класс субъекта, который будет активен в окне классификатора при создании нового субъекта.

Рис. 2.18

.topic 15

На этой вкладке производится настройка рабочего окна «Документы» для текущего пользователя:

Рис. 2.19

Показать – параметр устанавливает возможность показа связанных объектов базы данных. Панель просмотра OLE – это панель показа внедренного внешнего объекта (документа, рисунка и пр.).
Документ по умолчанию – устанавливает какой документ будет выделен при открытии рабочего окна.
Класс документа по умолчанию – параметр устанавливает класс документа, который будет активен в окне классификатора при создании нового документа.
Уведомлять об истечении срока действия за …  – при включении параметра указывается количество дней, оставшееся до завершения срока действия документов, для заблаговременного информирования пользователя.
Переводить просроченный документ в состояние – устанавливает состояние документа, в которое он будет автоматически переведен по окончании срока действия (действующий, отменен, просроченный и пр.).
Загрузка документов – устанавливает режим группировки документов, который будет установлен при открытии рабочего окна.

.topic 16

Вкладка параметров настройки связей объектов базы данных.

Применять строгие правила для связей – устанавливает, что при создании связей между объектами базы данных будет применяться система ограничений, основанная на строгом использовании допустимых связей между объектами базы данных.

Рис. 2.20
Настройка параметров связей документов

Далее вводятся предпочтительные настройки для выбора классов связей при их создании. Если в настройках не указано никакого класса, то при создании связи в окне выбора класса будет выведен весь классификатор связей. Если указан предпочтительный класс связи, то в окне классификатора будут загружены только вложенные классы, начиная с указанного класса.

Документ – Субъект – предпочтительные классы для связи документов с субъектами;
Документ – Объект – предпочтительные классы для связи документов с объектами;
Документ – Документ – предпочтительные классы для связи документов (в данной версии не используется, предполагается использовать в будущем);

Рис. 2.21
Настройка параметров связей субъектов

Субъект – Документ – предпочтительные классы для связи субъектов с документами
Субъект – Субъект – предпочтительные классы для связи субъектов;
Субъект – Объект – предпочтительные классы для связи субъектов с объектами (в данной версии не используется, предполагается использовать в будущем);

Рис. 2.22
Настройка параметров связей объектов

Объект – Документ – предпочтительные классы для связи объектов с документами;
Объект – Субъект – предпочтительные классы для связи объектов с субъектами (в данной версии не используется, предполагается использовать в будущем);
Объект – Объект – предпочтительные классы для связи объектов (в данной версии не используется, предполагается использовать в будущем).

.topic 17

 Вкладка параметров настройки рабочего окна «Адреса» (Рис. 2.23).

Наряду с тремя основными объектами базы данных «Документы», «Субъекты» и «Объекты» в системе используется т.н. «Адресная система» (рабочее окно «Адреса»). Ее назначение – правильное формирование адресов, на которые ссылаются основные объекты БД. Структура адреса основывается на классификаторе адресов, который представляет собой систематизированный перечень названий объектов административно-территориального деления,  созданный на основе соответствующего общероссийского классификатора (ОКАТО)

Рис. 2.23

Корневой адрес – параметр, влияющий на особенности отображения адресов при работе с адресами в окне выбора. Выбранным значением будет ограничен верхний уровень, доступный пользователю. В случае выбора пункта «Все адреса» в меню «Вид» адресной системы или окна выбора адресов, этот параметр игнорируется.
Адрес по умолчанию - параметр устанавливает адрес, который будет активен при открытии окна «Адреса»;
Загрузка адресов - устанавливает режим группировки адресов, который будет установлен при открытии рабочего окна.
Показать – устанавливает режим отображения объектов или субъектов, расположенных по адресу, выделенному в дереве адресов.

.topic 102

 Этот раздел настройки параметров используется для создания в рабочих окнах приложения дополнительных панелей инструментов, предназначенных для быстрого вызова форм создания новых объектов, субъектов, документов и адресов, наиболее часто используемых пользователем.

Все вкладки имеют единый интерфейс и элементы управления, поэтому рассмотрим настройку панели быстрого старта для рабочего окна "Объекты" (Рис. 2.25).

Рис. 2.25

Вкладка имеет окно со списком классов объектов (субъектов, документов, адресов) и кнопки управления списком (  - Добавить,   - Изменить,   - Удалить,  /  - Вверх/Вниз). Нажатие кнопки "Добавить" вызывает окно выбора классов, в котором пользователь должен выбрать нужный ему класс объектов. Этот класс появляется в окне списка. При необходимости добавления новых классов операцию необходимо повторить.

После сохранения параметров в рабочем окне "Объекты" ("Субъекты", "Документы", "Адреса") появится новая панель инструментов с кнопками быстрого вызова форм создания соответствующих классов объектов (Рис. 2.24). Если соответствующее окно уже было открыто, для появления панелей (или их обновления) необходимо закрыть окно и затем снова открыть.

Рис. 2.24

Примечание: настройки панелей быстрого вызова сохраняются в базе данных индивидуально для каждого пользователя.

.topic 18
 Пункт меню «Сервис - Классификаторы» (или кнопка панели инструментов  )  открывает доступ к настройке классификаторов системы (Рис. 2.26).

Согласно принятым нами терминам, классификатор - это иерархически систематизированный перечень названий классов, групп и объектов классификации, отобранных по основополагающему признаку. Классификаторы предназначены для структурирования информации, накапливаемой в базе данных.

Рис. 2.26
Выбор пункта меню "Классификаторы"

В системе разработаны стандартные классификаторы:

«Документы» - систематизированный перечень документов, созданный на основе общероссийского классификатора управленческой документации (ОКУД);
«Объекты» - систематизированный перечень объектов. Заполняется в соответствии с направлением деятельности организации. Например, классификатор "Здания и сооружения", созданный на основе  СНиП «Здания и сооружения»;
«Субъекты» - систематизированный перечень типов субъектов;
«Адресный» - систематизированный перечень названий объектов административно-территориального деления,  созданный на основе соответствующего общероссийского классификатора (ОКАТО);
«Связей» - систематизированный перечень типов связей;
«ОКВЭД» - систематизированный перечень видов экономической деятельности, созданный на основе соответствующего общероссийского классификатора (ОКВЭД);
«Группы документов» - перечень групп документов системы;
«Группы субъектов» - перечень групп субъектов системы;
«Группы объектов» - перечень групп объектов системы;
«Единицы измерения» - систематизированный перечень единиц измерения, созданный на основе соответствующего общероссийского классификатора (ОКЕИ).

Рабочее окно классификатора предназначено для его настройки под конкретную реализацию системы в соответствии с требованиями пользователя.

Все рабочие окна классификаторов имеют единообразный интерфейс, поэтому рассмотрим порядок работы с окном классификатора на примере классификатора «Документы» (Рис. 2.27).

.topic 19

Рабочее окно классификатора "Документы"

Рис. 2.27

Рабочее окно классификатора имеет стандартный интерфейс, который включает в себя строку главного меню, панель инструментов, панели дерева классов (левая панель) и списка классов (правая панель), а также строку состояния. Дерево классов, в отличие от «Проводника» операционной системы Windows, имеет табличный вид и содержит колонки «Код» и «Уровень», в которых соответственно отображаются код текущего класса и его уровень в классификаторе. Кроме того, при последовательных щелчках левой кнопкой мыши на заголовках столбцов таблицы можно отсортировать в них данные либо по возрастанию, либо по убыванию (для каждого столбца своя сортировка – Рис. 2.28). Направление сортировки показывается рядом с именем столбца. Сортировка производится в пределах текущей ветви дерева.

Рис. 2.28
Сортировка дерева классов

Кнопки панели инструментов дублируют основные пункты главного меню и при задержке на них указателя мыши показывают всплывающие подсказки с их назначением. Кнопки    хранят историю действий пользователя при перемещении по классификатору. Кнопка   позволяет показывать/скрывать допустимые связи класса в панели списка.

При щелчке правой кнопкой мыши на выбранном классе документов или на пустом месте списка объектов классификации открывается контекстное меню, из которого можно получить доступ к разрешенным действиям над объектами (Рис. 2.27).

В строке состояния показывается наименование выделенного класса документов, если выделен один класс на правой панели, количество выделенных классов, если выделено более одного класса или количество подклассов в классе, который выбран на левой панели (в дереве классов).

При выделении класса в левой панели (дереве классов) в пункте меню «Классификатор» появляется наименование текущего выделенного объекта (Рис. 2.46).

Рис. 2.46
Меню «Классификатор – Текущий (класс) уровень»

Аналогичное контекстное меню появляется при щелчке правой кнопкой мыши на выделенном объекте в дереве классов. При выборе пункта меню «Свернуть»(«Развернуть») текущий уровень классификатора сворачивается (раскрывается) (Рис. 2.47).

Рис. 2.47

Пункт меню «Изменить» открывает диалоговое окно создания (изменения) класса (Рис. 2.30).

При работе с классами в панели списка (правая панель) пользователь может вызвать контекстное меню выбранного объекта (Рис. 2.47). Пункт меню «Открыть» раскрывает текущий уровень, а для самого нижнего уровня – раскрывает текущий класс, показывая имеющиеся у него допустимые связи, внешние и печатные формы. Пункт меню «Свойства» открывает информационное окно свойств класса.

С помощью кнопки   или пункта меню «Вид–Показать/скрыть связи» Вы можете управлять отображением допустимых связей на правой панели окна.

Кнопка   или пункт меню «Классификатор–Метаданные–Метаданные класса» вызывает окно редактирования метаданных выбранного класса.

При выборе пункта меню «Удалить» открывается диалоговое окно удаления класса документов (Рис. 2.49).

Рис. 2.49
Диалог удаления класса

Будьте внимательны при удалении данных из классификатора!
Удаление класса приводит к необратимым последствиям. Восстановление ошибочно удаленного класса возможно либо путем полного восстановления базы данных из резервной копии, либо созданием нового класса, в зависимости от удаленного элемента. Например, удаление класса документов «Договор» приведет к удалению всех вложенных подклассов (договор аренды, договор банковского счета, договор дарения и пр.), допустимых, связей между классами, разработанных для документов печатных форм, а также всех документов этих классов и их связей.

.topic 24
Пункт меню «Классификатор - Создать» открывает выбор для пользователя по созданию нового класса, нового подкласса, печатной и внешней формы документа (Рис. 2.29).

Рис. 2.29
Меню «Классификатор - Создать»

Выбор пункта «Новый класс» приводит к созданию корневого класса в дереве классификатора, «Новый подкласс» создается внутри текущего класса (текущим считается класс, выделенный в дереве). «Печатная форма» предназначена для вывода класса документа на печать на основе разработанных пользователем правил. «Новая внешняя форма» – подключение новых форм (просмотров и панелей поиска) документов, созданных пользователями или разработчиками.

При выборе пункта меню «Создать – Новый класс (подкласс)» открывается форма, состоящая из двух закладок – «Общие» и «Безопасность» (Рис. 2.30).

Закладка «Общие» содержит:
Наименование – название нового класса – назначается пользователем;
Код по классификатору – система автоматически подставляет в поле первый свободный код в текущем уровне. На Рис. 2.30а создается новый класс верхнего (корневого) уровня классификатора, на Рис. 2.30б – новый подкласс внутри класса «Документы основные», имеющего код 2. Как видно на рисунке, код класса – владельца (2) не может быть изменен, 69 – это первый свободный код подкласса, доступный пользователю.

а)__________________________________б)
Рис. 2.30
Создание нового класса (а) или подкласса (б)

Наименование кратко – краткое название нового класса;
Символы кода – могут быть использованы при формировании кодов объектов (субъектов, документов, адресов)
Является папкой – флажок, устанавливаемый в том случае, если создаваемый класс может иметь подклассы. Используется для визуализации и при выборе класса – например, папки не могут  быть выбраны в качестве класса адреса. Папки выделяются в окне жирным шрифтом;
Значок – пиктограмма класса, которой он будет показан в панелях классификатора в обычном состоянии и выделенным мышью. Выбирается пользователем из встроенного набора значков системы. Значки класса также используются при загрузке элементов, соответствующих данному классу. Например, документы данного класса в окне документов отображаются соответствующими значками.
Тип загрузки подклассов – вариант загрузки дочерних документов, вложенных в документ данного класса. Данное поле позволяет сгруппировать дочерние документы, предварительно создав необходимые подгруппы и описав в соответствующих справочниках (Рис. 2.65), какие именно подгруппы будут использованы при загрузке вложенных документов.

Примечание: Параметр «Тип загрузки подклассов» используется не во всех классификаторах идентично. Так же как и для документов, этот параметр используется только для объектов и субъектов. Для адресного классификатора это  параметр используется несколько иначе – он описывает, какие именно классы адресов загружаются при выборе адреса редактируемого класса. Например, при загрузке субъектов Российской Федерации можно загрузить населенные пункты и муниципальные образования (тип загрузки подклассов = 0 – по умолчанию), находящиеся в выбранном субъекте. Но Вы можете загрузить только населенные пункты или только муниципальные образовании, задав тип загрузки для класса субъекта РФ равным 1 или 2. Таким образом, тип загрузки для адресной системы выполняет такие же функции, как и для документов (группировку вложенных подклассов), но несколько иным способом. Вариант загрузки адресов определяется в хранимой процедуре Addressses.

Закладка «Безопасность» содержит список пользователей, для которых устанавливаются разрешения на доступ к создаваемому классу (Рис. 2.31).

Рис. 2.31

Управление правами, как правило, осуществляет администратор сервера, который создает новых пользователей системы и производит смену паролей существующих.

 Работа с разрешениями для классов описана в разделе "Классификаторы - Безопасность"

.topic 23
Классификатор «Документы», в отличие от всех остальных классификаторов, имеет пункт меню «Создать новую печатную форму» (Рис. 2.29). Для создания печатных форм в системе используется визуальный генератор отчетов FastReport™, который позволяет построить большинство отчетов пользуясь только мышью.

При выборе пункта меню «Создать – Новая печатная форма» открывается форма отчета (Рис. 2.35).
Форма отчета представляет собой набор элементов, описывающих то, как должен выглядеть готовый отчет. Для построения формы отчета используется визуальная среда разработки - дизайнер. В FastReport™ дизайнер - это средство разработки отчетов, сочетающее мощь, простоту и удобство использования. Интерфейс дизайнера выполнен на современном уровне с использованием панелей инструментов, расположение которых можно изменять по своему вкусу. В нашей документации мы не описываем порядок работы с генератором отчетов FastReport™. Оригинал документация включается в состав поставки АИС «Дока».

Рис. 2.35
Разработка печатной формы документа

Печатные формы создаются для каждого класса документов, который необходимо выводить на печать. Для того, чтобы создать печатную форму для конкретного класса документов, необходимо выделить его в левой панели рабочего окна (Рис. 2.36).

При этом, в правой панели (панель списка) будут показаны все печатные формы, ранее созданные для этого класса. Щелчок правой кнопки мыши на свободном месте панели списка откроет контекстное меню, из которого необходимо выбрать пункт создания новой печатной формы (Рис. 2.36). Аналогичное меню можно вызвать из главного меню рабочего окна (Рис. 2.29). После этого откроется форма отчета, описанная нами ранее (Рис. 2.35).

Рис. 2.36

После разработки новой формы отчета пользователю необходимо сохранить ее в базе данных, выбрав в дизайнере отчетов пункт меню «Файл - Сохранить». Система выведет диалоговое окно сохранения печатной формы документа, в которой необходимо ввести ее название (Рис. 2.37).

Рис. 2.37
Диалог сохранения печатной формы

При установке флажка «Использовать по умолчанию» эта печатная форма будет использована для вывода документа на печать. В панели списка форма, используемая по умолчанию для вывода на печать, отмечается специальным значком   (по аналогии с текущим принтером операционной системы Windows). После этого дизайнер отчетов может быть закрыт.

Ранее подготовленные пользователем печатные формы могут быть изменены. Для работы с имеющейся печатной формой необходимо выделить ее в панели списка и нажать правую кнопку мыши. При этом появится контекстное меню (Рис. 2.38).

Рис. 2.38
Контекстное меню печатной формы

Выбор пунктов меню «Открыть» или «Изменить» приводит к появлению запроса системы (Рис. 2.39).

Рис. 2.39
Диалог открытия печатной формы

При выборе переключателя «Изменить…» будет вызван дизайнер отчетов, в котором можно произвести изменения текущей печатной формы и сохранить ее. Выбор переключателя «Переименовать…» приведет к вызову диалога сохранения формы (Рис. 2.37), в котором можно изменить имя печатной формы.
Выбор пункта меню «Удалить» вызывает диалоговое окно подтверждения удаления печатной формы. После удаления восстановить форму невозможно.

 Из контекстного меню можно также назначить печатную форму по умолчанию, загрузить из файла или сохранить в файл на диске. Подготовленные формы сохраняются на диске компьютера в специальном формате FastReport™ (*.fr3).

.topic 103
Пункт меню «Классификатор – Создать  - Новая внешняя форма» предоставляет возможность использовать в системе формы ввода информации, отличные от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы редактирования класса документа (объекта, субъекта, адреса) необходимо в окне классификатора выделить нужный класс и выбрать пункт меню создания новой внешней формы. На экран будет вызван диалог вида Рис. 2.40

Рис. 2.40

В форме диалога необходимо правильно заполнить поля:

Наименование класса – автоматически подставляется имя класса, выделенного в классификаторе;
Описание формы – имя формы, которое появится в панели списка классификатора для класса "Паспорт гражданина РФ";
Форма (класс Delphi) – название класса формы в среде Delphi;
Фрейм поиска (класс Delphi) – название класса фрейма поиска в среде Delphi;
Форма (класс Delphi) для просмотра – название класса формы просмотра в среде Delphi; форма будет использоваться при просмотре класса, запрещенного для редактирования;
Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма.

После подключения внешней формы "Паспорт гражданина РФ" операция создания нового документа класса "Паспорт" или вызова на редактирование существующего будет вызывать не стандартную форму документа (Рис. 3.5), а новую форму (Рис. 2.41).

Рис. 2.41

С новой формой можно совершать стандартные действия изменять, удалять и т.п. (Рис. 2.42)

Рис. 2.42

Например, выбор пунктов меню «Открыть» и «Изменить» вызовет диалог (Рис. 2.40). Кроме этого, внешнюю форму можно скопировать и вставить для другого класса документа (объекта, субъекта).

.topic 112
Пункт меню «Классификатор – Создать  - Новая внешняя форма свойств» предоставляет возможность использовать в системе формы ввода информации, отличные от стандартных и позволяющие вводить дополнительную многострочную информацию об объектах (субъектах, документах, адресах, связях), например, факты оплаты за услуги, телефоны, сайты и т.п. То есть, такие формы необходимы для ввода информации вида "один-ко многим": для одного дома - много записей об оплате услуг, для одного субъекта - много записей телефонов и пр. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы редактирования класса свойств документа (объекта, субъекта, адреса) необходимо в окне классификатора выделить нужный класс и выбрать пункт меню создания новой внешней формы свойств. На экран будет вызван диалог

Рис. 2.40а
В форме диалога необходимо правильно заполнить поля:

Наименование класса – автоматически подставляется имя класса, выделенного в классификаторе;
Форма (класс Delphi) – название класса формы в среде Delphi;
Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма.
Название пункта меню, связанного с формой - заголовок пункта меню, помещаемого в раздел меню «Документ–Характеристики документа» при выделении в рабочем окне "Документы" документа соответствующего класса. Для остальных документов эти формы остаются недоступными, и пункт меню и кнопка на соответствующей панели инструментов не появляется.

С новой формой можно совершать стандартные действия изменять, удалять и т.п. Например, выбор пунктов меню «Изменить» вызовет диалог (Рис. 2.40а). Кроме этого, внешнюю форму свойств можно скопировать и вставить для другого класса документа (объекта, субъекта, связи).

.topic 27
Пункт меню «Классификатор - Связи» дает возможность добавить для выбранного класса допустимые связи с другими объектами базы данных (Рис. 2.43).

Рис. 2.43

 В системе предусмотрен режим, предназначенный для ограничения некорректных действий пользователя при создании связей между объектами базы данных. Этот режим позволяет для заданного класса документа определить допустимый класс связываемых объектов базы данных. Например, для класса «Договор аренды» допустимыми связями могут быть классы субъектов «Арендатор» и «Арендодатель». Применение режима допустимых связей позволит пользователю связать, например, субъекта – физическое лицо с документом «Паспорт», как документом, удостоверяющим личность, и не позволит связать его с документом «Технический паспорт объекта». Для того, чтобы назначить для класса допустимую связь, ее надо предварительно создать в классификаторе взаимосвязей.

При выборе пункта меню «Добавить допустимые связи…» открывается диалоговое окно выбора класса связываемого объекта базы данных (Рис. 2.44).

Рис. 2.44
Выбор класса допустимой связи

Пользователь должен выбрать нужный класс из списка. После закрытия формы выбора класса допустимая связь появляется на панели списка (Рис. 2.36). Классы допустимых связей выглядят в виде пиктограмм соответствующих классов объектов базы данных с добавлением символа ярлыка  .

При выборе пункта меню «Добавить допустимые связи документ – документ (владелец)» откроется диалоговое окно, аналогичное описанному выше, за исключением того, что Вам будет предложено выбрать класс документа, а не класс связи. Этот тип допустимых связей создается для обеспечения корректности создания вложенных документов при включенном режиме «Применять строгие правила для связей» (см. 2.1.12), а также может быть использован для заполнения меню «быстрого создания» вложенных документов. Во втором случае, необходимо, выбрав созданную связь на правой панели, вызвать контекстное меню и выбрать пункт «Показывать связь в меню» (Рис. 2.45). Класс документа, которому назначаются допустимые связи, будет добавлен в меню «Документ–Создать» рабочего окна «Документы», а также в меню кнопки   (см. раздел 3.1.2).

Рис. 2.45

Если установлен режим строгих правил для связей, то при создании документа, вложенного в другой документ, в качестве документа-владельца (т.е. документа в который будет вложен создаваемый документ) можно будет выбрать только документ, имеющий класс, указанный в допустимой связи. Если класс документа не указан как допустимый (т.е. не создана допустимая связь), то Вы не сможете выбрать данный документ в качестве владельца создаваемого документа.

.topic 26
В системе используется система безопасности данных, позволяющая присваивать конкретным объектам, субъектам, документам и связям между ними права на их использование (по аналогии с правами пользователей на объекты операционной системы Windows NT™). Права доступа применяются для пользователей, зарегистрированных на сервере Interbase.

Управление правами, как правило, осуществляет администратор сервера, который создает новых пользователей системы и производит смену паролей существующих.

Для установки разрешений необходимо выделить нужного пользователя (например, USER на Рис. 2.31) и отметить для него в нижней панели, разрешаемые или запрещаемые действия с новым классом, установив соответствующий флажки. После сохранения изменений пользователь, в нашем случае USER, не будет иметь возможности изменять документы, данного класса и удалять их. При установке запрета прав на чтение класса документы данного класса становятся невидимыми для пользователя. Если установить флажок «Применять права ко всем вложенным уровням», то разрешения распространятся на все подклассы редактируемого класса.

Рис. 2.31

Если пользователь, для которого необходимо установить права доступа, отсутствует в списке разрешений, то система предоставляет возможность добавить пользователя в этот список. Для этого надо на закладке «Безопасность» нажать кнопку «Добавить». При этом открывается диалоговое окно выбора пользователя (Рис. 2.32).

Рис. 2.32
Добавление нового пользователя

После ввода имени пользователя и нажатии кнопки «ОК» система выводит окно проверки наличия введенного имени в списке пользователей сервера InterBase (Рис. 2.33).

Рис. 2.33
Проверка имени пользователя

 Если отказаться от проверки, то пользователь будет добавлен в список разрешений в любом случае. В том случае, если нажата кнопка «Да», система проверяет список зарегистрированных пользователей сервера InterBase на предмет наличия введенного имени в этом списке. Если введенное имя зарегистрировано на сервере, то оно будет добавлено в список разрешений, в противном случае система выводит предупреждающее сообщение (Рис. 2.34).

Рис. 2.34
 Ошибка при добавлении нового пользователя

При этом имеется возможность исправить имя пользователя, если оно было введено неправильно, либо удалить пользователя из списка.

Если имя пользователя, добавленного в список разрешений без проверки, отсутствует в списке пользователей сервера InterBase, то назначенные для него права на доступ к объектам базы данных не будут использоваться в системе до тех пор, пока он не будет зарегистрирован в списке пользователей сервера.

Примечание:

Если у пользователя есть права на добавление, изменение, удаление документов вообще (т.е. права в базе данных администратор предоставил полные), но не задано никаких прав на класс документа, то это означает, что пользователь не сможет работать с документами данного класса.

При изменении прав на класс, автоматически изменяются права на все объекты (документы, субъекты, связи) данного класса в соответствии с правами на класс. Это означает, что если были установлены индивидуальные права на некоторые объекты (документы, связи, субъекты), отличные от прав на класс этих объектов (документов, связей, субъектов), то после изменения прав на классы, права на эти объекты (документы, связи, субъекты) будут переназначены на права класса для всех пользователей.

Пользователи, не добавленные в список, не имеют никаких прав на класс.

.topic 28
Окно «Свойства» содержит две закладки (Рис. 2.48). Закладка «Общие» (а) выводит информацию о классе (наименование, тип, код класса, владелец). Закладка «Безопасность» (б) содержит список пользователей, для которых установлены разрешения на доступ к текущему классу. Подробно действия пользователя с закладкой «Безопасность» рассмотрены в разделе "Классификаторы - Безопасность".

а)___________________________б)
Рис. 2.48
Свойства класса «Договор»

.topic 104
При создании различных внешних форм в базу данных, как правило, вносятся некоторые изменения, связанные с созданием новых таблиц и просмотров. Для корректной работы с такими таблицами (просмотрами) в системе должна присутствовать информация о них. Так, например, копирование документа (объекта, субъекта, связи, адреса) и последующая его вставка без описания структуры этого документа приведет к копированию и вставке лишь стандартной части документа (объекта, субъекта, связи, адреса). Такая ситуация часто неприемлема, так как пользователю придется заполнять «нестандартную часть» документа вручную. Чтобы избежать такой ситуации, в АИС «Дока» предусмотрена возможность описания структуры добавленных просмотров (таблиц) – метаданных. Кроме того, метаданные служат также для описания дополнительных свойств документов (объектов, субъектов, адресов).

 Для описания метаданных класса документа (объекта, субъекта, связи, адреса), выделите класс на любой из панелей окна классификатора и выберите пункт меню «Классификатор–Метаданные–Метаданные класса» или нажмите кнопку   на панели инструментов окна. В открывшемся окне (Рис. 2.51) необходимо добавить описание метаданных (дерево метаданных расположено на левой панели окна), выбрав пункт меню «Метаданные-Добавить тип метаданных».

 Метаданные могут быть двух типов:
Описывающие реляционные отношения вида «один-к-одному»;
Описывающие реляционные отношения вида «один-ко-многим».

Метаданные, описывающие отношения вида «один-к-одному» могут быть созданы только как первый элемент в списке метаданных. Метаданные, описывающие реляционные отношения вида «один-ко-многим» могут быть описаны в любом элементе списка метаданных. Для изменения типа метаданных выберите пункт меню (или аналогичный пункт контекстного меню) «Метаданные–Изменить тип метаданных» и выберите необходимый тип метаданных в открывшемся диалоговом окне (Рис. 2.50).
Выберите метаданные, которые Вы хотите описать (на рисунке «Метаданные») в дереве метаданных на левой панели окна щелчком левой кнопки мыши. В поле «Источник» необходимо описать, откуда (из какой таблицы или просмотра) будут получены данные для копирования в буфер документа выбранного класса, а в поле «Приемник», – в какую таблицу (просмотр) будут эти данные вставлены. В таблице задается соответствие полей таблиц источника и приемника данных. Если количество полей в источнике больше количества полей в приемнике, то при копировании в буфер будут скопированы все поля источника, а при вставке из буфера в базу данных будут вставлены только те данные, которые связаны с данными приемника. Другие скопированные данные могут быть вставлены только в текстовый документ.

Рис. 2.50

Вы можете также задать псевдоним поля источника данных, в том числе на русском языке. Этот псевдоним будет использован при вставке скопированных данных как текста, например, в текстовые документы. Необходимо также выбрать ключевое поле приемника данных. Это необходимо сделать во избежание ошибки при вставке. Ключевое поле генерируется автоматически и если не указать, какое поле является ключевым, то будет вставлен документ с точно таким же кодом, что и скопированный, а это в свою очередь приведет к ошибке сервера – не уникальности ключа. При работе с метаданными типа «один-к-одному» достаточно указать лишь первичный ключ таблицы. При работе с метаданными типа «один-ко-многим» кроме первичного ключа необходимо указывать и вторичный ключ для корректной вставки информации.

Рис. 2.51
 Описание метаданных документа (пример: паспорт гражданина РФ)

В поле «Скрипт генерации кода» Вы можете задать скрипт на языке SQL для формирования кода ключевого поля документа. Если это поле не заполнено, при вставке документа из буфера его код будет сгенерирован автоматически по алгоритму АИС «Дока».
В поле «Примечание» может быть занесена любая вспомогательная информация о метаданных. Эта информация используется только для описания и не используется ни при копировании, ни при вставке документа.
Метаданные класса могут быть скопированы и перенесены на другой класс, а также удалены. Для копирования метаданных выберите пункт меню «Классификатор –Метаданные–Копировать метаданные». Для вставки метаданных используется стандартная вставка из буфера (кнопка  , если до этого в буфер обмена были скопированы метаданные). Для удаления метаданных класса выберите пункт меню «Классификатор–Метаданные–Удалить метаданные».

.topic 29
Для удобства работы пользователя в системе предусмотрена возможность объединения нескольких классификаторов в одном рабочем окне с помощью технологии drag&drop. Для этого пользователь должен открыть два классификатора, которые он хочет объединить и убедиться, что их рабочие окна являются стыкуемыми (Рис. 2.15). Затем подвести указатель мыши к области заголовка одного из рабочих окон классификатора, нажать левую кнопку мыши и не отпуская ее переместить это окно на рабочее окно другого классификатора в область панели «Папки». При этом вокруг панели «Папки» появляется серая рамка, показывающая место стыковки окон. После отпускания левой кнопки мыши система выводит диалог подтверждения (Рис. 2.59).

Рис. 2.59
Подтверждение объединения классификаторов

 При положительном ответе на запрос системы два классификатора будут показаны в одном рабочем окне (Рис. 2.60). Дальнейшая работа с объединенными классификаторами ничем не отличается от описанной нами ранее. Таким образом, можно объединить в одном окне сколько угодно классификаторов, причем порядок объединения не имеет значения (один классификатор добавить к группе или наоборот). Однако, если Вы попытаетесь добавить к группе уже имеющийся там классификатор, то после подтверждения стыковки рабочее окно добавляемого классификатора останется изолированным и классификатор не будет добавлен вторично.

Рис. 2.60
Объединенные классификаторы «Субъекты» и «Документы»

.topic 92
Для выбора классов в системе используется окно, показанное на Рис. 2.61.

Рис. 2.61

 Окно выбора классов имеет стандартные элементы управления, доступные через строку главного меню, контекстное меню или панель инструментов. Работа с этими элементами аналогична действиям, описанным в разделе Руководства Классификатор «Документы».

 Выбор классов производится выделением требуемого класса (или нескольких классов, если это допускается) в дереве классификатора и нажатием кнопки «Выбрать». Выделение класса в дереве происходит лишь в том случае, когда установлены соответствующие настройки. Например, снят флажок «Применять строгие правила для связей» в настройках пользователя, или, если этот флажок установлен, и класс связи соответствует допустимой связи. В противном случае выделения (и соответственно выбора) класса не происходит.

 Поиск требуемого класса можно производить путем просмотра дерева, отсортировав его по столбцу поиска, либо с помощью строки адреса и нажатии кнопки   (Рис. 2.62 а).

а)______________________________б)
Рис. 2.62

 В строке «Адрес» введите путь к искомому классу (не чувствительно к регистру) или код класса в формате ::xx.xx, где xx искомые коды, а :: служебные символы. Например, класс 3.1.1 «Вид на жительство» можно найти, набрав в строке поиска: «Документы, удостоверяющие личность\Личные документы\Вид на жительство\», или набрав в этой же строке его код: ::3.1.1.
Кроме этого, при нажатии на кнопку   панели инструментов окна выбора классов открывается панель поиска Рис. 2.62 б. Здесь необходимо задать поисковые характеристики и нажать кнопку «Найти». Найденный класс будет отображен в окне выбора.

.topic 30
Пункт меню «Сервис – Справочные таблицы» (или кнопка панели инструментов  ) открывает доступ к настройке справочных таблиц системы. При работе с приложением используется ряд справочников, описывающих отдельные свойства основных объектов базы данных. Перечень таблиц включает в себя:

Языки;
Валюты;
Национальности;
Организационно-правовые формы;
Типы телефонных номеров;
Состояние документа;
Состояние субъекта;
Состояние объекта;
Фамилии;
Имена;
Отчества;
Приоритеты документов;
Типы загрузки объектов;
Типы загрузки субъектов;
Типы загрузки документов.

С учетом конкретной реализации базы данных или других условий реальной жизни, пользователь может добавлять, изменять, либо удалять данные в этих таблицах. Работа с таблицами интуитивно понятна и не требует специального описания. Исключение составляют таблицы «Фамилии», «Имена» и «Отчества».

.topic 31

Работа со справочными таблицами интуитивно понятна и не требует специального описания. Остановимся лишь на основных моментах.
Добавление нового элемента производится путем нажатия на кнопку   панели инструменто или выбором соответствующего пункта меню (на рисунке "Язык-Добавить")
Изменение элемента производится путем нажатия на кнопку   панели инструменто или выбором соответствующего пункта меню (на рисунке "Язык-Изменить").
Удаление элемента производится путем нажатия на кнопку   панели инструменто или выбором соответствующего пункта меню (на рисунке "Язык-Удалить").
Для обновления информации содержащейся в таблице, необходимо нажать кнопку на панели инструментов или выбрать пункт меню "Обновить" (на рисунке "Язык-Обновить")

При активном окне можно осуществлять контестный инкрементный поиск путем набора на клавиатуре первых символов искомого слова. Например, при поиске русского языка, начните набирать на клавиатуре "р"-"у"-"с"... Курсор автоматически переместится к искомому языку - "Русский".

.topic 32

Система поставляется с заранее подготовленным набором наиболее распространенных фамилий (около 4500), имен (около 900) и отчеств (около 1300), которые используются в работе с субъектами – физическими лицами. Каждая из фамилий, имен или отчеств хранится в базе данных системы в виде набора данных, заполненных с учетом падежей русского языка (мужские и женские). Это сделано для того, чтобы при выводе на печать подготовленной формы документа реквизиты субъектов подставлялись в выходной документ в удобочитаемом виде. Обычно при работе с базами данных фамилия, имя и отчество физического лица заполняется в именительном падеже, например, Соколов Виктор Александрович. При таком виде хранения данных при последующем выводе на печать и автоматической подстановке в текст документа реквизитов субъекта мы можем получить выражение вида «Организация «Комплекс Софт» в лице сотрудника Соколов Виктор Александрович». В нашем же случае мы получим подставленные в текст реквизиты в родительном падеже (в лице сотрудника  Соколова Виктора Александровича).

 Внешний вид форм справочных таблиц единообразен. При выборе в меню «Сервис – Справочные таблицы - Фамилии» на экране будет представлена форма (Рис. 2.63).

 Список фамилий показывается на форме в двух цветах: красном – женские, синим – мужские. Разделение по полу субъекта используется в связи с тем, что мужские и женские фамилии склоняются по-разному (сравните склонение фамилий – Бабурин (муж.) и Бабурина (жен.) или Акопян). Исключениями являются некоторые фамилии, которые для мужчин и женщин склоняются одинаково (например, Бабенко).

Рис. 2.63

 Для добавления новой фамилии пользователь должен нажать кнопку   панели инструментов, изменения -  , удаления  . При добавлении или изменении фамилии на экран выводится форма (Рис. 2.64).

Рис. 2.64
Изменение фамилии

 Пользователь должен ввести фамилию в поле «Именительный». Заполнение остальных полей формы производится автоматически специальной процедурой.

 Внимание! В том случае, если фамилия не является распространенной, проставленные системой окончания фамилий могут оказаться неправильными. Пользователь должен ввести правильные значения в поля формы и сохранить изменения.

.topic 105

Справочные таблицы «Типы загрузки объектов» (субъектов, документов) определяют вариант загрузки дочерних объектов (субъектов, документов), вложенных в другой объект (субъект, документ). Данные таблицы позволяют описать группировку дочерних объектов (субъектов, документов), назначив корневой класс загрузки подгрупп дочерних объектов (субъектов, документов) (Рис. 2.65), который определит, какие именно подгруппы будут использованы при загрузке вложенных объектов (субъектов, документов).

Рис. 2.65

 Например, Вы можете сгруппировать конструктивные элементы и квартиры, входящие в состав объекта здание как дочерние по разным группам. Без группировки все вложенные объекты будут загружены в порядке создания, что часто неинформативно. Сгруппировав вложенные объекты по группам, Вы получите более удобный (и логичный) способ описания здания. Подробнее о создании вложенной группировки описано в разделе "Создание вложенной группировки"

.topic 106
Для создания структуры группировки элементов здания и ее привязки к конкретному классу объектов необходимо выполнить следующие действия:

в классификаторе групп объектов создать необходимую Вам группировку (Рис. 1.2);
в справочной таблице типов загрузки объектов создать новый тип загрузки и указать для него в качестве класса пользовательской группы объектов класс созданной Вами группировки элементов зданий с кодом 3 (Рис. 1.3);

Рис. 1.2

Рис. 1.3

в классификаторе объектов выбрать класс объекта, для которого создается структура группировки, открыть его для редактирования и ввести в поле «Тип загрузки подклассов» номер созданного Вами типа загрузки (Рис. 1.4).

Рис. 1.4

В последующем при создании нового объекта этого класса в нем автоматически создается вложенная группировка элементов.

Таким образом, средства системы позволяют пользователю вести структурированное накопление информации и легко ориентироваться среди множества разнородных объектов.

.topic 33
Меню «Регистрация» (Рис. 3.1) предназначено для открытия рабочих окон основных объектов базы данных.

Рис. 3.1

Система обеспечивает структурированное накопление информации об основных участниках хозяйственной или иной деятельности предприятия и содержит описания объектов реального мира "Объект", "Документ", "Субъект" в соответствии с принятыми нами терминами.  Для открытия требуемого рабочего окна необходимо выбрать соответствующий пункт меню «Регистрация», либо нажать аналогичную кнопку панели инструментов главного окна.

.topic 34
На Рис. 3.2 представлен внешний вид рабочего окна «Документы», а также его основные элементы управления.

Рис. 3.2
Элементы управления окна "Документы"

1.	Создать новый документ;
2.	Изменить документ;
3.	Удалить документ;
4.	Свойства документа;
5.	Предварительный просмотр;
6.	Печать;
7.	Показать дерево документов;
8.	Поиск документов;
9.	История;
10.	Настройка стиля отображения панели списка;
11.	Включить фильтр;
12.	Отключить фильтр;
13.	Задать условия фильтрации;
14.	Изменить OLE объект;
15.	Показывать связи с объектами;
16.	Показывать связи с субъектами;
17.	Показывать связи с документами;
18.	Связать с объектом;
19.	Связать с субъектом;
20.	Связать с документом;
21.	Перейти к предыдущему;
22.	Вверх на один уровень;
23.	Название столбца (панель сортировки);
24.	Количество документов в группе;
25.	Дополнительные характеристики документа;
26.	Текст документа
27.	Панель быстрого запуска.

Левая панель рабочего окна содержит дерево документов базы данных. Если активировать конкретный документ в левой панели, то в правой будет выведен список связанных с ним объектов, субъектов и других документов. Отображаемые элементы зависят от режима отображения. Возможно задавать раздельное отображение связанных документов (меню «Вид – Показать/скрыть связи – Показывать связи с документами»), связанных субъектов («Вид – Показать/скрыть связи – Показывать связи с субъектами») или связанных объектов («Вид – Показать/скрыть связи – Показывать связи с объектами»).

 Режим отображения документов при запуске приложения определяется настройками системы (Рис. 2.19).

Кнопки панели инструментов рабочего окна не являются статичными. Их состояние и состав динамически изменяются в зависимости от активности документа и связанных с ним объектов базы данных.

При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил документ в базу данных, а у другого пользователя отсутствует информация  об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (F5) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка документов с сервера и обновит ее в рабочем окне. При этом обновятся и все связи.

Для перемещения по списку документов используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки   и  .

На панелях рабочего окна пользователю доступны контекстные меню, вызываемые щелчком правой кнопки мыши (Рис. 3.3).

а)_________________________________б)
Рис. 3.3
Контекстные меню окна "Документы"

Из контекстного меню панели дерева документов (рис.3.3а) пользователь получает возможность изменить активный документ, удалить его или просмотреть и изменить его свойства.

Пункт меню «Группировка документов» дает возможность сортировать документы:

 По классу – в соответствии с классами, назначенными в классификаторе документов, при этом значки классов документов всегда отображаются как папки, а значки документов отображаются в соответствии с классом;
По группе – в соответствии с пользовательскими группами, назначенными в классификаторе групп документов;
По состоянию – в соответствии с состояниями документа, назначенными в справочнике состояний документа;
Отсутствует – без группировки.

При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева объектов и панели списка объектов. Наименования групп выбираются из соответствующих классификаторов и справочников системы.
На Рис. 3.2 в левой панели документы отсортированы по пользовательским группам.

Пункт меню «Свойства» открывает информационное окно свойств документа. Для документов, объектов и субъектов в этом окне содержится информация о владельце – пользователе, создавшем данный объект базы данных.

Контекстное меню панели списка объектов базы данных (Рис. 3.3б) дает возможность:

 Открыть – открыть рабочее окно объекта базы данных, на который указывает связь и перейти в него. Тот же результат будет достигнут, если на связи с объектом БД произвести двойной; щелчок левой кнопкой мыши;
Изменить – изменить класс связи или связь объекта базы данных;
Удалить – удалить документ или его связь с объектом базы данных;
Скрыть/показать панель просмотра внедренного объекта (OLE);
просмотреть и изменить свойства документа или связи с объектом базы данных.

Панель дерева документов имеет табличную структуру. Щелчком левой кнопки мыши на выбранном столбце можно отсортировать в нем данные по возрастанию, либо по убыванию (выноска 23 Рис. 3.2). В столбце «Номер» показывается номер текущего документа. Для группы документов в этом столбце в угловых скобках указывается количество документов в соответствующей группе (выноска 24 Рис. 3.2).

Документ с истекшим сроком действия маркируется специальным значком  , привлекающим внимание пользователя (см. активный документ на Рис. 3.2). Наличие этого значка в строке состояния рабочего окна означает, что в системе имеются документы, у которых истек срок действия. Быстрый доступ к таким документам можно получить, дважды щелкнув кнопкой мыши на этом значке, либо отсортировав документы «По состоянию» (Рис. 3.3). Все документы с истекшим сроком действия будут автоматически сгруппированы в группе «Просроченные», если это задано в параметрах пользователя.

На панели инструментов окна «Документы» расположена адресная строка. В строке редактирования «Адрес» показан текущий уровень документа в виде строки,  в которой уровни документов перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» строку, описывающую путь к другому документу, и, нажав кнопку «Перейти», Вы попадете на заданный документ. В случае ошибки во введенной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому документу не произойдет.

.topic 36
Добавить новый документ пользователь может выбором пункта меню рабочего окна «Документ – Создать – Новый документ» либо нажатием кнопки   на панели инструментов. Пользователю будет предложено выбрать класс создаваемого документа по классификатору (Рис. 3.4).

Рис. 3.4
Выбор класса документа

 После выбора класса документа на экран будет вызвано соответствующее диалоговое окно. Это же окно будет вызвано при изменении документа. Если нет внешних форм для  данного класса документа, то будет вызвано стандартное диалоговое окно (Рис. 3.5), состоящее из трех закладок.

Рис. 3.5
Новый документ – Общие сведения

 На закладке «Общие» пользователь должен ввести в соответствующие поля окна сведения о дате и номере документа, его полном и кратком наименовании, определить тип документа по классификатору, а также период его действия.

 Если поля периода действия документа не будут заполнены, то система не будет отслеживать истечение срока действия документа и предупреждать об этом пользователя. Флажок «Завершен» устанавливается в том случае, когда пользователь принимает решение снять просроченный документ с контроля (например, завершенный договор).

 Использование поля «Документ является неотъемлемой частью документа» производится в том случае, когда регистрируемый документ не может существовать самостоятельно (например, приложение к договору). В этом случае необходимо нажать кнопку   и выбрать главный документ (владелец).

 Примечание. Использование подчиненных документов влечет за собой некоторые ограничения. Например, нельзя выбрать разные группы для главного и подчиненного документов, при сортировке по классу документа, сортировка всегда производится только по классу главного документа и т.п. Если Вам необходимо, чтобы два документа были в разных группах (например, группа «Документы 2005 года» и «Документы 2006 года»), то не подчиняйте документы друг другу, а воспользуйтесь возможностью сослаться на документ. С помощью ссылок Вы всегда сможете найти связанный документ.

Рис. 3.6
Подчиненный документ

  Подчиненный документ будет отображен в дереве документов и «привязан» к главному документу (Рис. 3.6).

 Закладка «Дополнительно» (Рис. 3.7) предоставляет возможность:

Рис. 3.7
Новый документ – Дополнительно

 Установить состояние документа путем выбора из выпадающего списка. Новое состояние документа можно создать, вызвав справочник состояний документа нажатием кнопки  ;
Установить принадлежность документа к пользовательской группе. Для этого необходимо нажать кнопку   и в открывшемся окне выбрать группу из классификатора групп документов (Рис. 3.8);

Рис. 3.8
Выбор группы документов

 Для удаления принадлежности документа к группе необходимо установить курсор в поле «Принадлежит к группе» и нажать клавишу <Delete>;

 Установить язык документа. В том случае, если язык документа установлен в параметрах системы (Рис. 2.13), то это поле заполняется автоматически;
Установить приоритет документа. Новый приоритет документа можно создать, вызвав справочник приоритетов документа нажатием кнопки  ;
Местонахождение документа – текстовое поле, в котором указывается место хранения оригинала документа;
Комментарий – поле для заметок пользователя.

 Закладка «Безопасность» позволяет установить права доступа к создаваемому документу.

Создавать документы можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.

.topic 116
В случае, когда Вам необходимо изменить параметры сразу нескольких документов, выделите их на правой панели рабочего окна (рис. 3.2) с помощью мыши и клавиш клавиатуры (Shift, Ctrl). Затем, нажмите кнопку   или выберите пукнт меню "Документ - Изменить". В открывшемся диалоговом окне, Вы можете изменить сразу несколько параметров, имеющихся у всех документов: класс, группу, дату, приоритет, состояние или принадлежность какому-либо документу, даты начала и окончания и т.п.

Вы можете изменить только одно свойство или сразу несколько. Для того, чтобы значение параметра было изменено на заданное Вами, необходимо включить флажок "Заменить" напротив изменяемого параметра. В качестве эталонного свойства принимается свойство одного из изменяемых документов,  загруженного в базу данных раньше остальных выделенных. Как правило, это первый по алфавиту документ. В любом случае, Вы можете изменить значение свойства по своему усмотрению.
Если Вы ошиблись и выбрали больше, чем требовалось субъектов, это можно сделать на закладке "Список изменяемых документов".

Для удаления из списка, выделите в списке документ, который необходимо удалить и нажмите кнопку   на панели инструментов диалогового окна. После предупреждения, документ будет удален из списка изменяемых.
Внимание!
1. Документ не удаляется при этом из базы данных. Удаление из списка не влечет за собой никаких последствий, кроме того, что свойства этого документа не будут изменены.
2. Если у пользователя отсутсвовали права на изменение одного из документов, свойства этого документа не будут изменены, несмотря на то, что он присутствовал в списке изменяемых.

.topic 107
Любой выделенный пользователем документ может быть скопирован в буфер обмена и затем вставлен в базу данных. Эта возможности системы полезна в тех случаях, когда пользователь обрабатывает множество однотипных документов, мало отличающихся друг от друга.

 Примечание: Если Вы используете нестандартные формы документов (Паспорт, Диплом и пр.), то перед использованием этой возможности Вам необходимо создать метаданные для этих классов документов (подробно см. соответствующий раздел Руководства).

Режим копирования/вставки ничем не отличается от действия пользователя при работе с приложением «Проводник» (Explorer) операционной системы Windows. Для копирования (вырезания) документа необходимо выделить его в панели дерева или списка документов и в контекстном меню или панели инструментов выбрать кнопку «Копировать» («Вырезать») Рис. 3.10.

Рис. 3.10
Копирование документа в буфер обмена

 Вставка документа происходит аналогичным образом, однако имеет некоторые особенности:

При примененной группировке документов «по группе» или «по состоянию» и выборе пользователем конкретной группы в качестве нового местоположения документа он будет вставлен в выбранную группу и автоматически получит принадлежность к новой группе или новое состояние;
Если перед вставкой был выделен какой-либо документ, то новый документ будет вставлен в виде вложенного в него документа;
Если документ был вырезан, то при вставке в новое местоположение он удаляется с прежнего места.
При вставке документа вставляется не только копия документа, но и копии его характеристик и связей.

Вы можете ограничить вставку только необходимыми элементами. Например, Вам необходимо вставлять только сам документ, но нет необходимости копировать все его связи, или, наоборот, Вам необходимо вставить только связи документа и т.п. Для этого служит пункт меню «Правка–Специальная вставка…». При выборе названного пукнта меню Вам будут предложены варианты вставки (Рис. 3.11).

Рис. 3.11

Выбор варианта «Всё» приведет к вставке копии документа, его связей и характеристик (полностью аналогичен выбору пункта меню «Правка–Вставить»);
При выборе пункта «Документ» будет вставлена только копия документа;
Выбор пунктов «Связи» и «Характеристики» приведет к вставке только связей или только харакетристик соотвественно;
При выборе пункта «Свойства документа» свойства скопированного документа будут полностью перенесены на текщий, выделенный документ. Если были описаны метаданные класса, то все свойства будут полностью перенесены с учетом метаданных.

Внимание!
При переносе свойств документа на другой документ будьте внимательны! Если документы имеют разные классы и, тем более, разные метаданные, это может привести к некорректной работе программы. Результат такого действия может существенно отличаться от того, что Вы ожидали увидеть. Если Вы хотите изменить свойства документа, сначала измените его класс на требуемый, после чего можете вставлять скопированные свойства.

.topic 38
Документ, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить документ, нужно выполнить следующие действия:

 Выделить документ, который Вы хотите удалить, в дереве документов на левой панели рабочего окна;
Нажать кнопку   на панели инструментов, выбрать пункт меню «Документ – <Текущий документ> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном документе);
После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Возможно также удаление группы документов, когда они сгруппированы по какому-либо из параметров - состоянию, классу или пользовательской группе. Для удаления, выделите группу документов на левой панели рабочего окна и нажмите кнопку  , в результате чего будет выведено диалоговое окно

Если вы хотите только вывести документы из группы, не удаляя самих документов, выберите пункт "Удалить только группу". Если же Вы хотите удалить и группу и все документы, находящиеся в ней, выберите пункт "Удалить группу и все документы в группе". Если Вы передумали удалять группу документов, нажмите кнопку "Отменить".

 Внимание!
После удаления, восстановление документа(ов) будет невозможно. Кроме того, удалятся все связи этого документа с объектами, субъектам и другими документами. Если Вы не уверены в правильности Ваших действий, не удаляйте документ.

.topic 37
Закладка «Безопасность» (Рис. 3.9) позволяет установить права доступа к создаваемому документу.

Рис. 3.9
Новый документ – Безопасность

 Подробно установка параметров безопасности для класса документа рассмотрена нами в  разделе "Классификаторы - Безопасность". Права на текущий документ выставляются абсолютно идентично правам на классы.

При создании документа для его создателя (т.е. пользователя, создавшего документ) предоставляются все права на этот документ. Для остальных пользователей права на созданный  документ будут предоставлены в соответствии с правами на класс документа. Вы можете предоставлять индивидуальные права на документ, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права документа этого класса полностью заменяются правами на класс.

.topic 35

Закладка «Общие» выводит информацию о документе (наименование, тип (класс документа), владелец).

 Закладка «Безопасность» содержит список пользователей, для которых установлены разрешения на доступ к текущему документу. Подробно действия пользователя с закладкой «Безопасность» рассмотрены в разделе "Документы-Безопасность".

.topic 39
Система позволяет хранить оригиналы документов в базе данных с использованием стандартной технологии Windows – OLE 2.0. В качестве OLE-объекта в документ может быть вставлен любой объект – рисунок, документ Word или Excel, документ САПР или ГИС и пр. Для вставки OLE-объекта пользователь должен активизировать нужный документ щелчком левой кнопки мыши, выбрать пункт меню «Документ – изменить объект (OLE)» или нажать соответствующую кнопку панели инструментов (выноска 14 рис.Рис. 3.2). На экран будет выведен диалог выбора типа внедряемого объекта (Рис. 3.11).

Рис. 3.11

 Пользователь имеет возможность выбрать тип объекта:

 Внедрить OLE-объект – объект, ассоциированный с каким-либо приложением операционной системы. Одной из «неприятных» особенностей внедрения такого типа объектов является то, что они будут недоступны на компьютере, не имеющем установленного приложения, с которым были ассоциированы;
Внедрить графический объект – графические файлы форматов: jpg, bmp, ico, emf, wmf;
Внедрить файл – любой файл.

Для вставки OLE-объекта на экран выводится форма (Рис. 3.12).

Рис. 3.12
Панель вставки OLE-объекта

 Выбор пункта меню «OLE объект - Вставить» или нажатие кнопки    панели инструментов вызывает форму вставки объекта (Рис. 3.13).

Рис. 3.13
Вставка OLE-объекта

 Для выбора нужного объекта, сохраненного на диска компьютера, необходимо включить флажок «Создать из файла», нажав кнопку «Обзор», найти в диалоге выбора необходимый объект (например, документ Word), выбрать его и нажать кнопку «ОК». Объект будет открыт в ассоциированном приложении (Рис. 3.14).

Рис. 3.14

 После выбора пункта меню «OLE объект – Завершить редактирование» и подтверждения сохранить изменения объект будет сохранен в базе данных и появится в панели просмотра OLE (Рис. 3.2).

 Для вставки графического объекта на экран выводится форма (Рис. 3.15).

Рис. 3.15

 Графический объект может быть загружен из файла или вставлен из буфера обмена. После нажатия кнопки «Сохранить» он появится в панели просмотра OLE. В отличие от внедренного OLE – объекта графический объект может быть сохранен (выгружен) в файл.

В качестве альтернативы внедренным объектам пользователь может использовать дополнительное свойство "Текст документа".

.topic 40
Для установления связей между документами базы данных пользователь должен произвести следующие действия:

 На левой панели дерева документов найти документ, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
Выбрать пункт меню рабочего окна «Документ – Связи – Связать с документом» или нажать кнопку   на панели инструментов (выноска 20 Рис. 3.2);
В открывшемся окне «Выбор документа» найти документ, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Связанный документ будет отображен в правой панели списка среди других связанных объектов БД. Если связываемый документ еще не был внесен в базу данных, то в окне «Выбор документа» можно создать новый документ, а затем выбрать его вышеописанным способом.

 Прямые и обратные связи документов отображаются в панели списка различными значками. На Рис. 3.2 у активного документа «Договор аренды» установлена связь с документом «Доп. соглашение к договору» («Договор аренды» ссылается на «Доп. соглашение» - прямая связь).

 Если в панели дерева документов сделать активным документ «Доп. соглашение к договору», то на Рис. 3.6 можно увидеть отличие в отображении связей (на «Доп. соглашение» ссылается «Договор аренды» - обратная связь).

 Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Документ – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между документами будет разорвана. Сами документы при этом не удаляются.

 Если Вы хотите быстро найти документ, связанный с активным документом, то выделите связь с искомым документом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». Связанный документ будет открыт и выделен в панели дерева документов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным документом все необходимые действия (изменение, удаление и пр.).

.topic 41
Для установления связей между документами и субъектами базы данных пользователь должен произвести следующие действия:

 На левой панели дерева документов найти документ, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
Выбрать пункт меню рабочего окна «Документ – Связи – Связать с субъектом» или нажать кнопку   на панели инструментов (выноска 19 Рис. 3.2);
В открывшемся окне «Выбор класса – Связь документа с субъектом» выбрать статус субъекта по отношению к документу, с которым происходит связывание. Добавление класса связей (статуса) субъектов производится в классификаторе взаимосвязей;
В открывшемся окне «Выбор субъекта» найти конкретного субъекта, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска  в данном окне можно отсортировать данные. Если связываемый субъект еще не был внесен в базу данных, то в окне «Выбор субъекта» можно создать нового субъекта, а затем выбрать его вышеописанным способом;
Связанный субъект будет отображен в правой панели списка среди других связанных объектов БД.

 Внимание!
Один и тот же субъект может быть неоднократно связан с документом, но только при условии, что его статус будет различным для каждой из связей. Если же субъект с таким статусом уже связан с данным документом, никаких действий не будет произведено, т.е. повторная связь не будет образована.
Связь документ-субъект является универсальной, т.е. название связи со стороны документа звучит так же, как и со стороны субъекта. Например, связь «Документ, удостоверяющий личность» будет так называться и в окне документов и в окне субъектов.

 Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Документ – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между документом и субъектом будет разорвана. Сами документ и субъект при этом не удаляются.

 Если Вы хотите быстро найти субъект, связанный с активным документом, то выделите связь с искомым субъектом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Субъекты», в котором связанный с документом субъект будет открыт и выделен в панели дерева субъектов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным субъектом все необходимые действия (изменение, удаление и пр.).

.topic 42
Для установления связей между документами и объектами базы данных пользователь должен произвести следующие действия:

 На левой панели дерева документов найти документ, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
Выбрать пункт меню рабочего окна «Документ – Связи – Связать с объектом» или нажать кнопку   на панели инструментов (выноска 18 Рис. 3.2);
В открывшемся окне «Выбор класса – Связь документа с объектом» выбрать статус объекта по отношению к документу, с которым происходит связывание. Добавление класса связей (статуса) объектов производится в классификаторе взаимосвязей;
В открывшемся окне «Выбор объекта» найти конкретный объект, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска  в данном окне можно отсортировать данные. Если связываемый объект еще не был внесен в базу данных, то в окне «Выбор объекта» можно создать новый объект, а затем выбрать его вышеописанным способом;
Связанный объект будет отображен в правой панели списка среди других связанных объектов БД.

 Внимание!
 Один и тот же объект может быть неоднократно связан с документом, но только при условии, что его статус будет различным для каждой из связей. Если же объект с таким статусом уже связан с данным документом, никаких действий не будет произведено, т.е. повторная связь не будет образована.
Связь документ-объект является универсальной, т.е. название связи со стороны документа звучит так же, как и со стороны объекта. Например, связь «Предмет договора» будет так называться и в окне документов и в окне объектов.

 Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Документ – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между документом и объектом будет разорвана. Сами документ и объект при этом не удаляются.

 Если Вы хотите быстро найти объект, связанный с активным документом, то выделите связь с искомым объектом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Объекты», в котором связанный с документом объект будет открыт и выделен в панели дерева объектов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным объектом все необходимые действия (изменение, удаление и пр.). При удалении документа (или связанного с ним объекта) связи удаляются автоматически.

.topic 43
На печать можно отправить только документы, для которых созданы печатные формы (см. п. Работа с печатными формами). По этой причине при выделении документа, для которого нет доступных печатных форм, пункты меню и кнопки панели инструментов, связанные с печатью документа, становятся неактивными.

 Для того чтобы напечатать документ, выделите его в панели дерева документов или панели списка рабочего окна, нажмите кнопку   на панели инструментов или выберите пункт главного меню «Документ–Печать…». При нажатии кнопки на панели инструментов документ будет отправлен на печать с использованием печатной формы, установленной по умолчанию. В том случае, если для документа разработано несколько печатных форм, необходимо воспользоваться пунктом главного меню «Документ – Печать…» (Рис. 3.16).

Рис. 3.16
Выбор печатной формы документа

 Сначала необходимо выбрать печатную форму, которую мы будем использовать для печати, из списка доступных (будет помечена «галочкой»), затем отправить документ на печать.

 Кроме того, Вы можете также напечатать внедренный (OLE) документ. Для этого откройте окно редактирования OLE-объекта и выберите пункт меню "OLE объект - Изменить". Будет вызвано приложение, ассоциированное с внедренным документом, и Вы сможете с его помощью напечатать этот документ. Естественно приложение, с которым ассоциирован внедренный документ, должно быть установлено на Вашем компьютере.

.topic 44
Окно предварительного просмотра показывает внешний вид документа, выводимого на печать (Рис. 3.17).

Рис. 3.17
Окно предварительного просмотра документа

Для просмотра документа пользователь должен нажать кнопку   на панели инструментов рабочего окна либо выбрать пункт главного меню «Документ – Печать - Предварительный просмотр». Окно предварительного просмотра интуитивно понятно. В нем можно вести поиск текста, изменять параметры страницы, добавлять и удалять страницы выходного документа, изменять режим просмотра. Наряду с прочими возможностями, отсюда возможно экспортировать документ в один из доступных форматов (Рис. 3.17). При нажатии кнопки   окна просмотра выводимый на печать документ может быть дополнительно отредактирован. Для редактирования вызывается дизайнер FastReport™, в котором на изменение вызывается текущая страница документа. После завершения редактирования, нажатия кнопки   дизайнера и подтверждения сохранения измененный документ может быть напечатан. Подробнее смотрите документацию FastReport™.

.topic 45
При большом количестве документов поиск необходимого документа в списке существенно затруднен. Для того, чтобы найти нужный документ, в программе предусмотрены развитые средства поиска. Для поиска документа нажмите клавишу <F3>  (или <Ctrl+F>) на клавиатуре или нажмите кнопку   на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.18), в которой необходимо задать требуемые параметры поиска.

а)________________________________б)
Рис. 3.18
Панель поиска документов

 Панель поиска состоит из двух закладок: общие (Рис. 3.18а) и дополнительно (Рис. 3.18б).

 На панели поиска имеются поля, формирующие условия поиска:

Начальные:
Равно;
Не равно;
Меньше;
Меньше/равно;
Больше;
Больше/равно;
Похожее на;
Начинается с;

 Промежуточные:
«И»;
«ИЛИ».

 Для поиска документа необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

 Формирование поисковой строки по текстовому или числовому полю.
В поле поиска необходимо ввести текст или число, которые Вы желаете найти в этом поле документа. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы (см. рис.3.16а).

 Начальные условия поиска имеют следующие значения:

 Равно – найти значения, точно соответствующие поисковой строке;
Не равно – найти любые значения, не равные поисковой строке;
Меньше – найти значения, меньшие, чем указаны в поисковой строке;
Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
Больше – найти значения, большие, чем указаны в поисковой строке;
Больше/равно - найти значения, большие или равные указанным в поисковой строке;
Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа % (см. рис.3.16а);
Начинается с – найти значения, с которых начинается поисковая строка.

 Промежуточные условия поиска применяются в том случае, когда необходимо найти документ более чем по одному полю. Например: Название ПОХОЖЕЕ НА Акт обслед% И дата БОЛЬШЕ/РАВНО 07.12.2005 (см. рис.3.16а).

 Формирование поисковой строки по полю типа «Дата»

 Выбрать из выпадающего календаря поисковое значение и задать начальное и промежуточное условия. Для того, чтобы очистить поле поиска типа «Дата», необходимо снять флажок в ячейке, находящейся рядом с поисковой датой.

 Для поля «Класс документа» поисковое значение выбираются из классификатора документов и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска).

 Для поиска документов «Завершенные» или «Незавершенные» (закладка «Дополнительно») установите флажок в соответствующем поле.

 Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти документы, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Документ», «документ», «ДОКУМЕНТ», «дОкумент» и т.п.

 После того, как документ будет найден, Вы можете перейти к нему, дважды щелкнув по документу на правой панели или выбрав пункт контекстного меню «Открыть».

.topic 46
Это дополнительное свойство документа, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Например, в договоре аренды обычно оговаривается арендная плата за 1 кв.м., стоимость коммунальных услуг, плата за пользование телефоном и пр. Указанные характеристики могут быть добавлены, как дополнительная информация, и использованы в печатной форме для детализации условий договора аренды. Для добавления дополнительных характеристик пользователь должен найти в панели дерева документов нужный документ, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку   на панели инструментов (выноска 25 Рис. 3.2). На экран будет выведена форма дополнительных характеристик выбранного документа (Рис. 3.19).

Рис. 3.19
Дополнительная информация о документе

 Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретный документ. При выборе добавления или изменения характеристики на экран выводится окно редактирования (Рис. 3.20).

Рис. 3.20
Добавление характеристики

 Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).

.topic 1999
Это дополнительное свойство документа, которое предназначено для хранения текста. Его можно использовать в качестве альтернативы внедренным объектам, а также для дополнительного описания связанных объектов базы данных.

 Для добавления текста документа пользователь должен найти в панели дерева документов нужный документ, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку   на панели инструментов (выноска 26 Рис. 3.2). На экран будет выведена форма ввода текста документа.

Она представляет из себя простой редактор для ввода форматированного текста со стандартной строкой меню и панелью инструментов (в Windows используется аналогичный текстовый редактор WorkPad). Текст документа может быть вставлен из буфера обмена, размер текста не ограничен.

.topic 93
При создании связей субъектов, объектов с документами или документов с другими документами, используется окно «Выбор документов» (Рис. 3.21). Выбор документа происходит путем выделения искомого документа в дереве документов. В случае группировки, группы документов не выделяются!  Вы можете выделить только непосредственно документ или несколько документов (если это возможно по условиям выбора). Однако Вы можете входить в группы и выделять документы в них.

Для выделения более чем одного документа, можно использовать клавиши <Ctrl> и <Shift>.  Действия с этими клавишами абсолютно идентичны действиям при работе с программой «Проводник» Windows™. Например, нажав и удерживая на клавиатуре клавишу <Ctrl> , Вы  можете выделить документы, расположенные в разных частях списка (через один, или первый и последний).

Строка «Адрес» предназначена для быстрого поиска документов по их вложенности. Например, Вы знаете, что Ваш документ класса «Акт обследования жилого дома». Сгруппируйте документы по классу, а затем наберите в строке «Адрес»: Технические документы\Акт\Акт обследования технического состояния\Акт обследования жилого дома. Откроется папка «Акт обследования технического состояния»  в которой и будет находиться искомый документ.

Рис. 3.21

 Кроме этого, при нажатии на кнопку   панели инструментов окна выбора классов открывается панель поиска. Здесь необходимо задать поисковые характеристики и нажать кнопку «Найти». Найденный класс будет отображен в окне выбора.

 Для ускорения поиска документов определенного класса в окне выбора так же удобно использовать фильтры документов ( ). Работа с фильтрами подробно описана в разделе "Использование фильтров документов".

 В окне выбора документов с текущим документом можно производить все действия, описанные ранее (т.е создание, изменение, удаление, поиск, фильтрация).

 Внимание!

Будьте внимательны при обновлении списка. Если был выделен хотя бы один документ и после этого была перегруппировка документам по группе (документы сгруппированы или перегруппированы по другой группе), будет выделен не только документ(ы), но и группы в которых они расположены! Для снятия выделения, просто щелкните по любому документу (клавиши <Ctrl> и <Shift> должны быть отжаты)

.topic 109
В системе имеется возможность применения ограничений для показа в панелях дерева и списка объектов базы данных, а также в окнах выбора документов определенного класса, назначаемых пользователем (т.н. фильтрация, см. выноски 11-13 Рис. 3.2). Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна Рис. 3.22.

Рис. 3.22

В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации». Если для рабочего окна не было задано ни одного фильтра, то нажатие на первую и третью кнопки панели инструментов будут приводить к вызову окна диалога фильтров документов (Рис. 3.23). Если какие-либо фильтры были назначены ранее, то нажатие на первую кнопку приведет к включению фильтра и, соответственно, к изменению отображения в дереве и списке объектов.

Рис. 3.23

При нажатии на кнопку,   «Добавить фильтр» Рис. 3.23 пользователю будет предложено задать название для нового фильтра (Рис. 3.24).

Рис. 3.24

 После нажатия кнопки «ОК» вызывается окно фильтра документов (Рис. 3.25).

Рис. 3.25

 При нажатии на кнопку   «Добавить в фильтр» будет открыто окно выбора классов документов, в котором пользователь должен выбрать документы, для которых будет применяться фильтрация (допускается множественный выбор с использованием клавиш «Ctrl» или «Shift»). Выбранные документы будут добавлены в окно фильтра.

 Переключатель «Фильтрация объектов» окна Рис. 3.25 позволяет выбрать способ отображения отфильтрованных объектов после включения фильтра:

 Показывать выбранные – в окне дерева объектов будут показаны только объекты, добавленные в окно фильтра;
Не показывать выбранные - в окне дерева объектов будут показаны все объекты за исключением добавленных в окно фильтра.

 При выборе закладки «Текст фильтра» пользователь может вручную отредактировать SQL-запрос (Рис. 3.26).

Рис. 3.26

 После задания фильтров окно Рис. 3.23 приобретет вид (Рис. 3.27).

Рис. 3.27

 Нажатие кнопки «Выбрать» приведет к выбору фильтра «Договоры аренды» и его включению. Состояние отображения объектов в панели дерева изменится в соответствии с изложенными выше правилами.

 В окне фильтров пользователь может добавлять новые фильтры, удалять и переименовывать существующие, задавать или изменять условия фильтрации для выбранных фильтров. Кроме этого, возможно сохранить набор фильтров в базе данных и загрузить его.

 После назначения нескольких фильтров пользователь может динамически переключаться между ними в ходе работы с объектами (Рис. 3.28).

 После выбора фильтра «Документы, удостоверяющие личность» произойдет его включение, что приведет к изменению отображения объектов, выбранных для этого фильтра.

Рис. 3.28

.topic 108
Дополнительные свойства могут быть добавлены для класса документа. Добавление дополнительных свойств документа производится по аналогии с внешними формами:

 создается форма свойств документа в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и  «Разработчик»);
Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);
После загрузки документа выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна документов, на панели инструментов «Свойства документа» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств пункт в меню «Документ–Характеристики документа». Для остальных документов эти формы остаются недоступными, и кнопка на соответствующей панели не появляется.

.topic 110
Как правило, в организациях, использующих компьютерную технику, всегда имеется множество документов, созданных различными сотрудниками (обычно в формате MS Office – Word, Excel, рисунки, схемы и пр.). В этом случае для быстрого наполнения базы данных АИС «Дока» удобно использовать такую функцию, как «Импорт документов» (Рис. 3.29). Импортированные документы помещаются в базу данных в виде OLE-объектов. По своей сути импорт документов – это автоматизированнный процесс создания новых документов и внедрения в них вложенных (OLE) объектов (см. Вставка внедренного объекта).

Рис. 3.29

Для импорта документов необходимо открыть рабочее окно «Документы» и выбрать пункт главного меню «Документ – Импортировать документы».

Импорт осуществляется с помощью Мастера (Wizard), помогающего пользователю правильно осуществить эту операцию. Начальное окно Мастера импорта показано на Рис. 3.30. На диалоговом окне находится панель списка файлов документов. С помощью кнопок «Добавить...» и «Удалить» пользователь управляет списком документов для импорта.

Рис. 3.30

 Флажок «Обрабатывать каждый документ отдельно» позволяет пользователю назначить индивидуальные свойства для каждого импортируемого документа. Если этот флажок не установлен, то для всей группы документов, выбранной в панели списка, будут установлены одинаковые свойства.
Для продолжения импорта необходимо нажать кнопку «Далее».

Рис. 3.31

На втором окне Мастера импорта пользователю дается возможность установить или изменить стандартные свойства конкретного импортируемого документа (наименование документа не может быть изменено, оно формируется из имени файла документа).

 Если пользователь на предыдущем шаге импорта установил флажок «Обрабатывать каждый документ отдельно», то нажатие кнопки «Далее» выводит на окно мастера следующий документ из списка выбранных файлов, а общий ход импорта отображается в нижней части окна.

Нажатие кнопки «Пропустить» позволяет пользователю исключить из импорта текущий отображенный в окне документ.

Если флажок индивидуальной обработки файлов не был установлен, то для всех файлов списка будут установлены одни и те же свойства, а нажатие кнопки «Далее» приведет к завершению импорта.

.topic 47
На Рис. 3.32 представлен внешний вид рабочего окна «Субъекты», а также его основные элементы управления.

Рис. 3.32
Элементы управления окна "Субъекты"

 1.	Создать нового субъекта;
2.	Изменить субъекта;
3.	Удалить субъекта;
4.	Свойства субъекта;
5.	Показать панель дерева субъектов;
6.	Поиск субъектов;
7.	История;
8.	Настройка стиля отображения панели списка;
9.	Обновить;
10.	Включить фильтр;
11.	Отключить фильтр;
12.	Задать условия фильтрации;
13.	Показывать связи с объектами;
14.	Показывать связи с документами;
15.	Показывать связи с субъектами;
16.	Связать с документом;
17.	Связать с субъектом;
18.	Телефоны субъекта;
19.	Электронная почта субъекта;
20.	ОКВЭД субъекта;
21.	Расчетные счета субъекта;
22.	Перейти к предыдущему (следующему);
23.	Вверх на один уровень;
24.	Название столбца (панель сортировки);
25.	Количество субъектов в группе;
26.	Дополнительные характеристики субъекта;
27.	Панель быстрого запуска.

 Левая панель рабочего окна содержит дерево субъектов базы данных. Если активировать конкретный субъект в левой панели, то в правой будет выведен список связанных с ним объектов, документов и других субъектов. Отображаемые элементы зависят от режима отображения. Возможно задавать раздельное отображение связанных документов (меню «Вид – Показать/скрыть связи – Показывать связи с документами»), связанных субъектов («Вид – Показать/скрыть связи – Показывать связи с субъектами») или связанных объектов («Вид – Показать/скрыть связи – Показывать связи с объектами»).

 Режим отображения субъектов при запуске приложения определяется настройками системы.

Кнопки панели инструментов рабочего окна не являются статичными. Их состояние и состав динамически изменяются в зависимости от активности субъекта и связанных с ним объектов базы данных.

 При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил субъекта в базу данных, а у другого пользователя отсутствует информация  об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (F5) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка субъектов с сервера и обновит ее в рабочем окне. При этом обновятся и все связи.
Для перемещения по списку субъектов используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки   и  .

 На панелях рабочего окна пользователю доступны контекстные меню, вызываемые щелчком правой кнопки мыши (Рис. 3.33).

а)____________________________________б)
Рис. 3.33
Контекстные меню окна "Субъекты"

 Из контекстного меню панели дерева субъектов (Рис. 3.33 а) пользователь получает возможность изменить регистрационные данные активного субъекта, удалить его или просмотреть и изменить его свойства. Кроме этого, субъект может быть скопирован в буфер обмена и вставлен из буфера в базу данных (по аналогии с копированием/вставкой документов).

 Пункт меню «Группировка субъектов» дает возможность сортировать субъектов:

 По классу – в соответствии с классами, назначенными в классификаторе субъектов;
По группе – в соответствии с пользовательскими группами, назначенными в классификаторе групп субъектов;
По состоянию – в соответствии с состояниями субъектов, назначенными в справочной таблице состояний субъектов;
Отсутствует – без группировки;

 При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева и панели списка объектов базы данных. Наименования групп выбираются из соответствующих классификаторов и справочников системы.
На Рис. 3.32 в левой панели субъекты отсортированы по пользовательским группам.

 Пункт меню «Свойства» открывает информационное окно свойств субъекта. Для документов, объектов и субъектов в этом окне содержится информация о владельце – пользователе, создавшем данный объект базы данных.

 Контекстное меню панели списка объектов базы данных (Рис. 3.33б) дает возможность:

 Открыть – открыть рабочее окно объекта базы данных, на который указывает связь и перейти в него. Тот же результат будет достигнут, если на связи с объектом БД произвести двойной; щелчок левой кнопкой мыши;
Изменить – изменить класс связи или связь объекта базы данных;
Удалить – удалить субъекта или его связь с объектом базы данных;
просмотреть и изменить свойства субъекта или его связи с объектом базы данных.

 Панель дерева субъектов имеет табличную структуру. Щелчком левой кнопки мыши на выбранном столбце можно отсортировать в нем данные по возрастанию, либо по убыванию (выноска 24 Рис. 3.32). В столбце «Количество в группе» показывается количество субъектов в соответствующей группе (выноска 25 Рис. 3.32).

 Особое внимание необходимо обратить на связи объектов с субъектами в панели списка. Если взглянуть на свойства такой связи, то можно увидеть одну особенность (Рис. 3.34).

Рис. 3.34
Свойства связи Субъект – Объект

 В строке «Информация» указано, что это опосредованная связь субъекта с объектом через документ. Такая связь назначается автоматически и вручную не может быть ни изменена, ни удалена. Т.е. эта связь только для чтения.

 На панели инструментов окна «Субъекты» расположена адресная строка. В строке редактирования «Адрес» показан текущий уровень субъекта в виде строки,  в которой уровни субъектов перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» строку, описывающую путь к другому субъекту, и, нажав кнопку «Перейти», Вы попадете на заданный субъект. В случае ошибки во введенной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому субъекту не произойдет.

.topic 48
Добавить нового субъекта пользователь может выбором пункта меню рабочего окна «Субъект – Создать – Новый субъект» либо нажатием кнопки   на панели инструментов. Пользователю будет предложено выбрать класс создаваемого субъекта по классификатору (Рис. 3.35).

Рис. 3.35
Выбор класса субъекта

 Правильный выбор класса создаваемых субъектов важен для последующей корректной организации взаимосвязей между ними. Кроме того, для различных классов субъектов заполняются разные реквизиты. Далее будут описаны формы, входящие в поставку во всех вариантах, за исключением демонстрационной версии.

 Такая же диалоговая форма, как и при создании субъекта, будет вызвана при его изменении (кнопка   на панели инструментов или пункт меню "Субъект-Изменить"). Для субъектов, у которых отсутствует внешняя форма  при добавлении и изменении субъекта вызывается стандартное диалоговое окно:

Рис. 3.40
Субъект – стандартное диалоговое окно

 Форма состоит из двух закладок и интуитивно понятна. Обратим внимание лишь на пункт «Субъект является неотъемлемой частью субъекта». Здесь Вы можете указать на другой субъект, который будет для создаваемого  (изменяемого) субъекта – главным. Т.е. созданный таким образом субъект будет подчиненным субъектом и не может существовать самостоятельно.  Работа с вкладкой «Безопасность» идентична работе с такой же вкладкой в окне «Документ - безопасность».

 Закладка «Безопасность» позволяет установить права доступа к создаваемому субъекту. Подробно установка параметров безопасности для классов рассмотрена нами ранее . По аналогии с документами, при создании субъекта для его создателя (т.е. пользователя, создавшего субъект) предоставляются все права на этот субъект. Для остальных пользователей права на созданный  субъект будут предоставлены в соответствии с правами на класс субъекта. Вы можете предоставлять индивидуальные права на субъект, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права субъекта этого класса полностью заменяются правами на класс

 Примечание. Использование подчиненных субъектов влечет за собой некоторые ограничения. Например, нельзя выбрать разные группы для главного и подчиненного субъектов, при группировке по классу субъекта, группировка всегда производится только по классу главного субъекта и т.п. Если Вам необходимо, чтобы два субъекта были в разных группах (например, группа «Партнеры» и «Дочерние предприятия партнеров»), то не подчиняйте субъекты друг другу, а воспользуйтесь возможностью сослаться на субъект. С помощью ссылок Вы всегда сможете найти связанный субъект.

Создавать субъектов можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.

.topic 50
Для субъекта – физическое лицо пользователю необходимо заполнить форму показанную на Рис. 3.36.

Форма состоит из четырех закладок, на которых логически сгруппированы реквизиты физического лица. При заполнении полей «Фамилия», «Имя» и «Отчество» данные автоматически подставляются из базы данных  из списков фамилий, имен и отчеств. Если вводимая фамилия (имя, отчество) отсутствует в списке, система выдает запрос (Рис. 3.37).

Рис. 3.36
Субъект – физическое лицо

Рис. 3.37
Запрос на добавление фамилии

 Добавление новой фамилии рассмотрено ранее (см. Работа со справочными таблицами). На закладке «Адреса» вводятся регистрационные данные субъекта о месте рождения, регистрации и жительства.

 Закладка «Документы» позволяет выбрать документ, удостоверяющий личность субъекта (как правило, паспорт гражданина РФ). Документ «Паспорт» является стандартным документом системы и должен быть создан и заполнен самостоятельно. После выбора паспорта и сохранения формы физического лица с документом «Паспорт» автоматически создается связь типа «Субъект – Документ».

 На закладке «Дополнительно» вводятся данные о национальности и гражданстве субъекта, его принадлежности к группе, а также личные коды (ИНН, ПФР и т.п.).

.topic 51
Для субъекта – юридическое лицо пользователю необходимо заполнить форму, показанную на Рис. 3.38.

Форма состоит из пяти закладок, на которых логически сгруппированы реквизиты юридического лица. Дополнительного описания работа с данной формой не требует, отметим лишь, что обязательными полями для заполнения являются «Полное наименование» и «Хранить как…».

Рис. 3.38
Субъект – юридическое лицо

 На закладке "Коды" вводятся регистрационные коды юридического лица.

 На закладке "ИФНС" вводится информация о налоговом органе, в котором состоит на учете предприятие.

 На закладке "Учредительные сведения" вносится информация об уставном фонде предприятия.

 На закладке "Дополнительно" вводится информация о группе субъекта, его состоянии, юридическом и почтовом адресе.

.topic 111
Для субъекта – предпринимателя без образования юридического лица пользователю необходимо заполнить форму показанную на Рис. 3.39. Форма состоит из пяти закладок, на которых логически сгруппированы реквизиты ПБОЮЛ.

Рис. 3.39
Субъект – ПБОЮЛ

 Добавление новой фамилии рассмотрено ранее (см. Работа со справочными таблицами). На закладке «Адреса» вводятся регистрационные данные субъекта о месте рождения, регистрации и жительства.

 Закладка «Документы» позволяет выбрать документ, удостоверяющий личность субъекта (как правило, паспорт гражданина РФ). Документ «Паспорт» является стандартным документом системы и должен быть создан и заполнен самостоятельно. После выбора паспорта и сохранения формы физического лица с документом «Паспорт» автоматически создается связь типа «Субъект – Документ». Здесь же заполняются данные о персональных кодах ПБОЮЛ: ИНН, ОГРН, регистрация в фондах.

 На закладке «ИФНС» вводятся данные о реквизитах документов, подтверждающих регистрацию субъекта в качестве предпринимателя, а также налоговом органе.

 На закладке «Дополнительно» вводятся данные о национальности и гражданстве субъекта, его принадлежности к группе, а также состоянии.

.topic 52
Для субъекта – банк пользователю необходимо заполнить форму показанную на Рис. 3.40.

Рис. 3.40
Субъект – банк

Форма состоит из двух закладок, на которых логически сгруппированы реквизиты банка. Субъект «Банк» используется при хранении данных юридического лица о расчетных счетах.

 Если Вам необходимо работать с банком как с юридическим лицом, Вы можете воспользоваться формой "Субъект - Юрдическое лицо", либо создать новую форму.

.topic 117
В случае, когда Вам необходимо изменить параметры сразу нескольких субъектов, выделите их на правой панели рабочего окна (рис. 3.32) с помощью мыши и клавиш клавиатуры (Shift, Ctrl). Затем, нажмите кнопку   или выберите пукнт меню "Субъект - Изменить". В открывшемся диалоговом окне, Вы можете изменить сразу несколько параметров, имеющихся у всех субъектов: класс, группу, дату, адреса, приоритет, состояние или принадлежность какому-либо документу.

Вы можете изменить только одно свойство или сразу несколько. Для того, чтобы значение параметра было изменено на заданное Вами, необходимо включить флажок "Заменить" напротив изменяемого параметра. В качестве эталонного свойства принимается свойство одного из изменяемых субъектов,  загруженного в базу данных раньше остальных выделенных. Как правило, это первый по алфавиту субъект. В любом случае, Вы можете изменить значение свойства по своему усмотрению.
    Если Вы ошиблись и выбрали больше, чем требовалось субъектов, это можно сделать на закладке "Список изменяемых субъектов".

Для удаления из списка, выделите в списке субъект, который необходимо удалить и нажмите кнопку   на панели инструментов диалогового окна. После предупреждения, субъект будет удален из списка изменяемых.
Внимание!
1. Субъект не удаляется при этом из базы данных. Удаление из списка не влечет за собой никаких последствий, кроме того, что свойства этого субъекта не будут изменены.
2. Если у пользователя отсутсвовали права на изменение одного из субъектов, свойства этого субъекта не будут изменены, несмотря на то, что он присутствовал в списке изменяемых.

.topic 53
Дополнительные реквизиты предназначены для хранения данных субъекта о телефонах, электронной почте, ОКВЭДах и расчетных счетах. Для заполнения дополнительных реквизитов необходимо выбрать нужный субъект, сделать его активным щелчком левой кнопки мыши и выбрать соответствующую кнопку панели инструментов   (выноски 18-21 Рис. 3.32).

.topic 54
Для работы со списком телефонов субъекта на экран выводится форма (Рис. 3.41).

Рис. 3.41
Список телефонов субъекта

 Здесь можно добавить или редактировать все телефоны, используемы субъектом. Для добавления или изменения телефона на экран выводится форма (Рис. 3.42).

Рис. 3.42
Добавление телефона

 Пользователь должен заполнить соответствующие поля и сохранить изменения.

.topic 55
Для работы с электронной почтой субъекта на экран выводится форма (Рис. 3.43).

Рис. 3.43
Электронная почта субъекта

 Здесь можно добавить или редактировать названия всех электронных почтовых ящиков, используемы субъектом. Работа по добавлению или изменению электронной почты аналогична работе с телефонами Руководства.

.topic 56
Для работы со списком ОКВЭД субъекта на экран выводится форма (Рис. 3.44).

Рис. 3.44

 Здесь можно добавлять или удалять виды экономической деятельности, используемые субъектом. Виды экономической деятельности добавляются в список из классификатора ОКВЭД. При добавлении нового вида на экран выводится форма (Рис. 3.45).

Рис. 3.45
Выбор ОКВЭД

 После поиска и выделения нужного кода в списке необходимо нажать кнопку «Выбрать». Новый код ОКВЭД будет добавлен в список.

.topic 57
Для работы со списком расчетных счетов субъекта на экран выводится форма (Рис. 3.46).

Рис. 3.46
Список расчетных счетов субъекта

 Здесь можно добавить или редактировать расчетные счета, используемы субъектом. Для добавления или изменения расчетного счета на экран выводится форма (Рис. 3.47).

Рис. 3.47

 Пользователь должен заполнить соответствующие поля формы, а также выбрать банк, в котором открыт счет. Банк выбирается из списка субъектов. Если такой субъект в списке отсутствует, то он должен быть создан и сохранен.

 При наличии у субъекта нескольких расчетных счетов можно установить флажок «Счет по умолчанию». В этом случае в выходные документы автоматически будет подставляться выбранный счет (в списке расчетных счетов счет по умолчанию выделяется синим цветом).

.topic 59
Субъект, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить субъект, нужно выполнить следующие действия:

 Выделить субъект, который Вы хотите удалить, в дереве субъектов на левой панели рабочего окна;
Нажать кнопку   на панели инструментов, выбрать пункт меню «Субъект – <Текущий субъект> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном субъекте);
После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Возможно также удаление группы субъектов, когда они сгруппированы по какому-либо из параметров - состоянию, классу или пользовательской группе. Для удаления, выделите группу субъектов на левой панели рабочего окна и нажмите кнопку  , в результате чего будет выведено диалоговое окно

Если вы хотите только вывести субъекты из группы, не удаляя самих субъектов, выберите пункт "Удалить только группу". Если же Вы хотите удалить и группу и все субъекты, находящиеся в ней, выберите пункт "Удалить группу и все субъекты в группе". Если Вы передумали удалять группу субъектов, нажмите кнопку "Отменить".

 Внимание!

 После удаления, восстановление субъекта будет невозможно. Кроме того, удалятся все связи этого субъекта с объектами, субъектами и документами. Если Вы не уверены в правильности Ваших действий, не удаляйте субъект.

.topic 60
Для установления связей между субъектами и документами базы данных пользователь должен произвести следующие действия:

На левой панели дерева субъектов найти субъект, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
Выбрать пункт меню рабочего окна «Субъект – Связи – Связать с документами» или нажать кнопку   на панели инструментов (выноска 16 Рис. 3.32);
В открывшемся окне «Выбор класса – Связь Субъект - Документ» выбрать класс связи. Добавление классов связей документов производится в классификаторе взаимосвязей;
В открывшемся окне «Выбор документа» найти конкретный документ, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска  в данном окне можно отсортировать данные. Если связываемый документ еще не был внесен в базу данных, то в окне «Выбор документа» можно создать новый документ, а затем выбрать его вышеописанным способом;
Связанный документ будет отображен в правой панели списка среди других связанных объектов БД.

 Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Субъект – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между субъектом и документом будет разорвана. Сами субъект и документ при этом не удаляются.

 Если Вы хотите быстро найти документ, связанный с активным субъектом, то выделите связь с искомым документом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Документы», в котором связанный с субъектом документ будет открыт и выделен в панели дерева документов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным документом все необходимые действия (изменение, удаление и пр.).

 Связь субъект-документ является универсальной, т.е. название связи со стороны субъекта звучит так же, как и со стороны документа. Например, связь «Арендатор» будет так называться и в окне субъектов  и в окне документов.

 Примечание:

 1.	Выбор класса связи можно осуществить в зависимости от настроек пользователя. Если флажок "Применять строгие правила для связей" установлен, то выбрать можно только класс, для которого создана допустимая связь. Если флажок сброшен возможен выбор любого класса связи.

 2.	В окне выбора класса связи корневым классом будет класс, установленный в настройках пользователя в строке "Субъект-Документ".

.topic 62
Для установления связей между субъектами базы данных пользователь должен произвести следующие действия:

 На левой панели дерева субъектов найти субъект, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
Выбрать пункт меню рабочего окна «Субъект – Связи – Связать с субъектами» или нажать кнопку   на панели инструментов (выноска 17 Рис. 3.32);
В открывшемся окне «Выбор класса – Связь Субъект - Субъект» выбрать класс связи. Добавление класса связей субъектов производится в классификаторе взаимосвязей;
В открывшемся окне «Выбор субъекта» найти конкретный субъект, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска  в данном окне можно отсортировать данные. Если связываемый субъект еще не был внесен в базу данных, то в окне «Выбор субъекта» можно создать новый субъект, а затем выбрать его вышеописанным способом;
Связанный субъект будет отображен в правой панели списка среди других связанных объектов БД.

 Внимание!

 Один и тот же субъект может быть неоднократно связан с другим субъектом, но только при условии, что его статус будет различным для каждой из связей. Если же субъект с таким статусом уже связан с данным субъектом, никаких действий не будет произведено, т.е. повторная связь не будет образована.

 Связь субъект-субъект является двунаправленной, т.е. связь субъекта 1 с субъектом 2 отличается от связи субъекта 2 с субъектом 1. Например, если Вы сделали активным субъект «Иванов» и есть связь с субъектом «Петрова»  класса «жена». При выделении субъекта «Петрова» эта связь будет отображена специальным значком (зеленая стрелка), тип связи будет также «жена», однако название связи будет «Иванов» при подсветке (Hint) будет выведено сообщение «Ссылается объект: Иванов (жена)». Что означает: на субъект «Петрова" ссылается субъект «Иванов», тип ссылки «жена»,т.е. Петрова является женой Иванова. Если Вам нужна ссылка «муж», то Вы должны создать такую ссылку, естественно выделив сначала субъект «Петрова», создав связь касса «муж» и указав на субъект «Иванов».

 Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Субъект – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между субъектами будет разорвана. Сами субъекты при этом не удаляются.

 Если Вы хотите быстро найти связанный субъект, то выделите связь с искомым субъектом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Субъекты» (если Вы находитесь в этом окне, то новое окно не открывается), в котором связанный субъект будет открыт и выделен в панели дерева субъектов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным субъектом все необходимые действия (изменение, удаление и пр.). При удалении субъектов их связи также удаляются.

 Примечание:

 1.	Выбор класса связи можно осуществить в зависимости от настроек пользователя. Если флажок "Применять строгие правила для связей" установлен, то выбрать можно только класс, для которого создана допустимая связь. Если флажок сброшен возможен выбор любого класса связи.

 2.	В окне выбора класса связи корневым классом будет класс, установленный в настройках пользователя в строке "Субъект-Субъект".

.topic 63
При большом количестве субъектов поиск необходимого субъекта в списке существенно затруднен. Для того, чтобы найти субъект, в программе предусмотрены развитые средства поиска. Для поиска документа нажмите клавишу <F3> на клавиатуре или нажмите кнопку   на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.53), в которой необходимо задать требуемые параметры поиска.

 На панели поиска имеются поля, формирующие условия поиска:

 Начальные:
Равно;
Не равно;
Меньше;
Меньше/равно;
Больше;
Больше/равно;
Похожее на;
Начинается с;

 Промежуточные:
«И»;
«ИЛИ».

Рис. 3.53
Панель поиска субъектов

 Для поиска субъекта необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

 Формирование поисковой строки по текстовому полю.

  В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле субъекта. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

 Начальные условия поиска имеют следующие значения:

 Равно – найти значения, точно соответствующие поисковой строке;
Не равно – найти любые значения, не равные поисковой строке;
Меньше – найти значения, меньшие, чем указаны в поисковой строке;
Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
Больше – найти значения, большие, чем указаны в поисковой строке;
Больше/равно - найти значения, большие или равные указанным в поисковой строке;
Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
Начинается с – найти значения, с которых начинается поисковая строка.

 Промежуточные условия поиска применяются в том случае, когда необходимо найти субъекта более чем по одному полю. Например: Наименование ПОХОЖЕЕ НА Петров% И группа РАВНО Сотрудники.
Для полей «Класс субъекта» и «Адреса» поисковые значения выбираются из соответствующих классификаторов и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска).

 Для полей юридический адрес и фактический адрес строка поиска формируется в отдельном окне после нажатия на соответствующую кнопку. После формирования строки поиска по юридическому (фактическому) адресу в поле поиска «Юридический адрес» («Фактический адрес») будет описано это условие.  Поиск субъектов будет осуществляться по всем адресам, соответствующим заданным условиям.

 Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти субъекты, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Комплекс Софт», «комплекс софт», «КОМПЛЕКС СОФТ», «Комплекс софт» и т.п.

 После того, как субъект будет найден, Вы можете перейти к нему, дважды щелкнув по документу на правой панели или выбрав пункт контекстного меню «Открыть».

.topic 64
Это дополнительное свойство субъекта, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Дополнительные характеристики могут быть добавлены, как вспомогательная информация, и использованы в печатных формах. Для добавления дополнительных характеристик пользователь должен найти в панели дерева субъектов нужного субъекта, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку   на панели инструментов (выноска 12 Рис. 3.32). Работа с дополнительными характеристиками описана в разделе  Руководства (Дополнительные характеристики документа).

 Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретного субъекта. Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).

.topic 94
При создании связей документов, объектов с субъектами или субъектов  с другими субъектами, используется окно «Выбор субъекта» (Рис. 3.55).

Рис. 3.55

 Выбор субъектов, а также другие действия в окне выбора субъекта производятся также как и в окне «Выбор документа». В окне выбора субъектов с текущим субъектом можно производить все действия, описанные ранее (т.е создание, изменение, удаление, поиск, фильтрация, заполнение свойств).
    Основное отличие заключается в возможности показа субъектов, связанных с выделенным в дереве. Субъекты связанные с выделенным в дереве субъектом показываются как вложенные субъекты с дополнительным значком  . Данный значок служит отличительным знаком, указывающим на то, что субъект с таким значком является не вложенным, а связанным с выделенным субъектом. Это позволяет быстро находить необходимые субъекты, если, например, Вы знаете название организации, но не помните ее директора, а Вам необходимо выбрать именно директора.

.topic 113
Дополнительные свойства могут быть добавлены для класса субъекта. Добавление дополнительных свойств субъекта производится по аналогии с внешними формами:

Создается форма свойств субъекта в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и  «Разработчик»);
Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);

 После загрузки субъекта выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна субъектов, на панели инструментов «Свойства субъекта» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств и пункт в меню «Субъект–Реквизиты субъекта». Для остальных субъектов эти формы остаются недоступными, и кнопка на соответствующей панели и пункт в меню не появляется.

.topic 65
На Рис. 3.57 представлен внешний вид рабочего окна «Объекты», а также его основные элементы управления.

Особенности рабочего окна конфигурации "Управление недвижимостью" описано здесь.

Особенности рабочего окна конфигурации "Лицевой счет жилого дома" описано здесь.

Рис. 3.57
Элементы управления окна "Объекты"

 1.	Создать новый объект;
2.	Изменить объект;
3.	Удалить объект;
4.	Свойства объекта;
5.	Показать панель дерева объектов;
6.	Поиск объектов;
7.	История;
8.	Настройка стиля отображения панели списка;
9.	Обновить;
10.	Включить фильтр;
11.	Отключить фильтр;
12.	Задать условия фильтрации;
13.	Показывать связи с документами;
14.	Показывать связи с субъектами;
15.	Выбрать объект - владелец;
16.	Связать с документом;
17.	Перейти к предыдущему (следующему);
18.	Вверх на один уровень;
19.	Название столбца (панель сортировки);
20.	Количество объектов в группе;
21.	Дополнительные характеристики объекта;
22.	Панель быстрого запуска объектов.

 Левая панель рабочего окна содержит дерево объектов базы данных. Если активировать конкретный объект в левой панели, то в правой будет выведен список связанных с ним субъектов, документов и других объектов. Отображаемые элементы зависят от режима отображения. Можно задавать раздельное отображение связанных документов (меню «Вид – Показать/скрыть связи – Показывать связи с документами»), связанных субъектов («Вид – Показать/скрыть связи – Показывать связи с субъектами»). Режим отображения объектов при запуске приложения определяется настройками системы.

 Кнопки панели инструментов рабочего окна динамически изменяются в зависимости от активности субъекта и связанных с ним объектов базы данных.

 При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил объект в базу данных, а у другого пользователя отсутствует информация  об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (<F5>) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка объектов с сервера и обновит ее в рабочем окне. При этом обновятся и все связи.

 Для перемещения по списку объектов используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки   и  .

 На панелях рабочего окна пользователю доступны контекстные меню, вызываемые щелчком правой кнопки мыши (Рис. 3.58).

а)____________________________________________________б)
Рис. 3.58
Контекстные меню окна "Объекты"

 Из контекстного меню панели дерева объектов (Рис. 3.58а) пользователь получает возможность изменить регистрационные данные активного объекта, удалить его или просмотреть и изменить его свойства.

 Кроме этого, объект может быть скопирован в буфер обмена и вставлен из буфера в базу данных (по аналогии с копированием / вставкой документов).

 Пункт меню «Группировка объектов» дает возможность сортировать субъектов:

По классу – в соответствии с классами, назначенными в классификаторе объектов;
По группе – в соответствии с пользовательскими группами, назначенными в классификаторе групп объектов;
По состоянию – в соответствии с состояниями объектов, назначенными в справочной таблице состояний объектов;
По адресу - в соответствии с адресами, назначенными в адресной системе;
Отсутствует – без группировки.

 При применении той или иной сортировки объекты базы данных автоматически попадают в самоорганизующиеся группы, появляющиеся на панели дерева и панели списка объектов базы данных. Наименования групп выбираются из соответствующих классификаторов и справочников системы.

 На Рис. 3.51 в левой панели объекты отсортированы по пользовательским группам.

 Пункт меню «Свойства» открывает информационное окно (Рис. 2.48). Для документов, объектов и субъектов в этом окне содержится информация о владельце – пользователе, создавшем данный объект базы данных.

 Контекстное меню панели списка объектов базы данных (Рис. 3.58б) дает возможность:

Открыть – открыть рабочее окно объекта базы данных, на который указывает связь и перейти в него. Тот же результат будет достигнут, если на связи с объектом БД произвести двойной щелчок левой кнопкой мыши;
Изменить – изменить класс связи или связь объекта базы данных;
Удалить – удалить объект или его связь с объектом базы данных;
Просмотреть и изменить свойства объекта или его связи с объектом базы данных.

 Панель дерева объектов имеет табличную структуру. Щелчком левой кнопки мыши на выбранном столбце можно отсортировать в нем данные по возрастанию, либо по убыванию (выноска 19 Рис. 3.57). В столбце «Количество в группе» показывается количество объектов в соответствующей пользовательской группе (выноска 20 Рис. 3.57).

 Особое внимание необходимо обратить на связи объектов с объектами в панели списка. Если взглянуть на свойства такой связи, то можно увидеть одну особенность (Рис. 3.59).

Рис. 3.59
Свойства связи Объект – Субъект

 В строке «Информация» указано, что это опосредованная связь объекта с субъектом через документ. Такая связь создается автоматически и вручную не может быть ни изменена, ни удалена. Т.е. данная связь только для чтения.

 На панели инструментов окна «Объекты» расположена адресная строка. В строке редактирования «Адрес» показан текущий уровень объекта в виде строки,  в которой уровни объектов перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» строку, описывающую путь к другому объекту, и, нажав кнопку «Перейти», Вы попадете на заданный объект. В случае ошибки во введенной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому объекту не произойдет.

.topic 66
Добавить новый объект пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки   на панели инструментов. Пользователю будет предложено выбрать класс создаваемого объекта по классификатору (Рис. 3.60).

Рис. 3.60

После выбора класса объекта на экран будет вызвано соответствующее диалоговое окно. Реквизиты уже введенного объекта можно изменить. Для того чтобы изменить объект, нужно выполнить следующие действия: выделить объект, который Вы хотите изменить, в дереве объектов на левой панели рабочего окна, нажать кнопку   на панели инструментов или выбрать пункт меню «Объект – <Текущий объект> - Изменить» или выбрать пункт контекстного меню «Изменить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте). Для изменения объекта будет вызвано такое же диалогове окно, как и для добавления.

Если внешние формы для данного класса объектов не заданы, то будет вызвано стандартное диалоговое окно (Рис. 3.61), состоящее из двух закладок.

Рис. 3.61

 На закладке «Общие» пользователь должен ввести в соответствующие поля окна сведения о полном и кратком наименовании объекта, его принадлежность к пользовательской группе и адресе.
 Использование поля «Объект является неотъемлемой частью объекта» производится в том случае, когда регистрируемый объект не может существовать самостоятельно (например, квартира или офис в здании). В этом случае необходимо нажать кнопку   и выбрать главный объект (владелец).

Рис. 3.62

 Подчиненный объект будет отображен в дереве объектов на уровень ниже главного объекта (Рис. 3.62).

 Примечание. Использование подчиненных объектов влечет за собой некоторые ограничения. Например, нельзя выбрать разные группы для главного и подчиненного объектов, при группировке по классу объекта, группировка всегда производится только по классу главного объекта и т.п. Если Вам необходимо, чтобы два объекта были в разных группах (например, группа «Продажа» и «Проданы»), то не подчиняйте объекты друг другу.

 Закладка «Безопасность» позволяет установить права доступа к создаваемому объекту. Подробно установка параметров безопасности для классов рассмотрена нами ранее. По аналогии с документами и субъектами, при создании объекта для его создателя (т.е. пользователя, создавшего объект) предоставляются все права на этот объект. Для остальных пользователей права на созданный  объект будут предоставлены в соответствии с правами на класс объекта. Вы можете предоставлять индивидуальные права на объект, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права объекта этого класса полностью заменяются правами на класс.

Создавать объекты можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.

.topic 118
В случае, когда Вам необходимо изменить параметры сразу нескольких объектов, выделите их на правой панели рабочего окна (рис. 3.57) с помощью мыши и клавиш клавиатуры (Shift, Ctrl). Затем, нажмите кнопку   или выберите пукнт меню "Объект - Изменить". В открывшемся диалоговом окне, Вы можете изменить сразу несколько параметров, имеющихся у всех объектов: класс, группу, дату, адрес, приоритет, состояние или принадлежность какому-либо объекту (например, дому).

Вы можете изменить только одно свойство или сразу несколько. Для того, чтобы значение параметра было изменено на заданное Вами, необходимо включить флажок "Заменить" напротив изменяемого параметра. В качестве эталонного свойства принимается свойство одного из изменяемых объектов,  загруженного в базу данных раньше остальных выделенных. Как правило, это первый по алфавиту объект. В любом случае, Вы можете изменить значение свойства по своему усмотрению.
Если Вы ошиблись и выбрали больше, чем требовалось объектов, это можно сделать на закладке "Список изменяемых объектов".

Для удаления из списка, выделите в списке объект, который необходимо удалить и нажмите кнопку   на панели инструментов диалогового окна. После предупреждения, объект будет удален из списка изменяемых.
Внимание!
1. Объект не удаляется при этом из базы данных. Удаление из списка не влечет за собой никаких последствий, кроме того, что свойства этого объекта не будут изменены.
2. Если у пользователя отсутсвовали права на изменение одного из объектов, свойства этого объекта не будут изменены, несмотря на то, что он присутствовал в списке изменяемых

.topic 67
Объект, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить объект, нужно выполнить следующие действия:

 Выделить объект, который Вы хотите удалить, в дереве объектов на левой панели рабочего окна или в панели списка;
Нажать кнопку   на панели инструментов, выбрать пункт меню «Объект – <Текущий объект> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте);
После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

Возможно также удаление группы объектов, когда они сгруппированы по какому-либо из параметров - состоянию  или пользовательской группе. Для удаления, выделите группу объектов на левой панели рабочего окна и нажмите кнопку  , в результате чего будет выведено диалоговое окно

Если вы хотите только вывести объекты из группы, не удаляя самих объектов, выберите пункт "Удалить только группу". Если же Вы хотите удалить и группу и все объекты, находящиеся в ней, выберите пункт "Удалить группу и все объекты в группе". Если Вы передумали удалять группу объектов, нажмите кнопку "Отменить".

 Внимание!

 После удаления, восстановление объекта будет невозможно. Кроме того, удалятся все связи этого объекта с объектами, субъектам и документами. Если Вы не уверены в правильности Ваших действий, не удаляйте объект.

.topic 70
Для установления связей между объектами и документами базы данных пользователь должен произвести следующие действия:

 На левой панели дерева объектов найти объект, для которого устанавливается связь, и сделать его активным, щелкнув на нем левой кнопкой мыши;
Выбрать пункт меню рабочего окна «Объект – Связи – Связать с документами» или нажать кнопку   на панели инструментов (выноска 16 Рис. 3.57);
В открывшемся окне «Выбор класса – Связь Объект - Документ» выбрать класс связи. Добавление классов связей документов производится в классификаторе взаимосвязей;
В открывшемся окне «Выбор документа» найти конкретный документ, с которым устанавливается связь, сделать его активным и нажать кнопку «Выбрать». Для облегчения поиска  в данном окне можно отсортировать данные. Если связываемый документ еще не был внесен в базу данных, то в окне «Выбор документа» можно создать новый документ, а затем выбрать его вышеописанным способом;
Связанный документ будет отображен в правой панели списка среди других связанных объектов БД.

 Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Объект – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между объектом и документом будет разорвана. Сами объект и документ при этом не удаляются.

 Если Вы хотите быстро найти документ, связанный с активным объектом, то выделите связь с искомым документом в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Документы», в котором связанный с объектом документ будет открыт и выделен в панели дерева документов. Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным документом все необходимые действия (изменение, удаление и пр.).

 Внимание!

Один и тот же объект может быть неоднократно связан с документом, но только при условии, что его статус будет различным для каждой из связей. Если же объект с таким статусом уже связан с данным документом, никаких действий не будет произведено, т.е. повторная связь не будет образована.

Связь документ-объект является универсальной, т.е. название связи со стороны документа звучит так же, как и со стороны объекта. Например, связь «Техническая документация» будет так называться и в окне документов и в окне объектов.

Примечание:

1.	Выбор класса связи можно осуществить в зависимости от настроек пользователя. Если флажок "Применять строгие правила для связей" установлен, то выбрать можно только класс, для которого создана допустимая связь. Если флажок сброшен возможен выбор любого класса связи.

2.	В окне выбора класса связи корневым классом будет класс, установленный в настройках пользователя в строке "Объект-Документ".

.topic 71
Этот тип связи нельзя создать. Эта связь по сути является просмотром опосредованных связей объектов с субъектами - через документы. Т.е. если есть связь объекта с документом и этот же документ, связан с какими либо субъектами, то будет показана связь объекта сэтими субъектами. Такая связь создается автоматически и вручную не может быть ни изменена, ни удалена. Таким образом, данная связь только для чтения.

Свойства связи Объект – Субъект

Например, объект "Офис" связан с документом "Договор купли-продажи". Договор в свою очередь связан с субъектами "Иванов" и "Петров". При просмотре связей объекта с субъектами с объектом "Офис" будут связаны субъекты "Иванов" и "Петров".

.topic 72
При большом количестве объектов поиск необходимого объекта в списке существенно затруднен. Для того чтобы найти нужный объект, в программе предусмотрены развитые средства поиска. Для поиска объекта нажмите клавишу <F3> на клавиатуре или нажмите кнопку   на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.63), в которой необходимо задать требуемые параметры поиска.

В том случае, если для объекта создана нестандартная формы ввода, то при вызове панели поиска на ней появляется еще одна кнопка «Дополнительно» (Рис. 3.63). При нажатии на эту кнопку появляется расширенная панель поиска с полями, описывающими свойства этого объекта (на Рис. 3.64 показана панель поиска для объекта «Здание»).

Рис. 3.63
Стандартная панель поиска объектов

Рис. 3.64
Расширенная панель поиска объектов

 На панели поиска имеются поля, формирующие условия поиска:

 Начальные:
Равно;
Не равно;
Меньше;
Меньше/равно;
Больше;
Больше/равно;
Похожее на;
Начинается с;

 Промежуточные:
«И»;
«ИЛИ».

 Для поиска объекта необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

 Формирование поисковой строки по текстовому полю.

 В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле объекта. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

 Начальные условия поиска имеют следующие значения:
Равно – найти значения, точно соответствующие поисковой строке;
Не равно – найти любые значения, не равные поисковой строке;
Меньше – найти значения, меньшие, чем указаны в поисковой строке;
Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
Больше – найти значения, большие, чем указаны в поисковой строке;
Больше/равно - найти значения, большие или равные указанным в поисковой строке;
Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
Начинается с – найти значения, с которых начинается поисковая строка.

 Промежуточные условия поиска применяются в том случае, когда необходимо найти объект более чем по одному полю. Например: Наименование ПОХОЖЕЕ НА %дом% И название группы РАВНО Продажа.

 Для поля «Класс объекта» поисковые значения выбираются из соответствующего классификатора и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска «Класс объекта»).

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти объекты, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Объект», «объект», «ОБЪЕКТ», «ОбъЕкт» и т.п.

 После того, как объект будет найден, Вы можете перейти к нему, дважды щелкнув по объекту на правой панели или выбрав пункт контекстного меню «Открыть».

.topic 73
Это дополнительное свойство объекта, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Дополнительные характеристики могут быть добавлены, как вспомогательная информация, и использованы в печатных формах. Для добавления дополнительных характеристик пользователь должен найти в панели дерева объектов нужный объект, сделать его активным, щелкнув на нем левой кнопкой мыши и нажать кнопку   на панели инструментов (выноска 21 Рис. 3.57). Работа с дополнительными характеристиками описана ранее (Рис. 3.19).

 Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретный объект. Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).

.topic 95
При создании связей документов или субъектов с объектами, используется окно «Выбор объекта» (Рис. 3.65).

Рис. 3.65

 Выбор объектов, а также другие действия в окне выбора объекта производятся также как и в окне выбора документов.

.topic 114
Дополнительные свойства могут быть добавлены для класса объекта. Добавление дополнительных свойств объекта производится по аналогии с внешними формами:

 Создается форма свойств объекта в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и  «Разработчик»);
Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);

 После загрузки объекта выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна объектов, на панели инструментов «Свойства объекта» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств пункт в меню «Объект–Характеристики объекта». Для остальных объектов эти формы остаются недоступными, и кнопка на соответствующей панели не появляется.

.topic 74
 На рисунке представлен внешний вид рабочего окна «Адреса», а также его основные элементы управления.

Рис. 3.67
 Элементы управления окна "Адреса"

Адреса выводятся на просмотр в виде дерева объектов. Верхний уровень устанавливается в настройке параметров системы.

Настройки адресной системы существенно зависят от внешних форм и настроек, описанных в разделе «Параметры – «Общие –  Адресная система».

В зависимости от уровня дерева адресов Вы можете добавить различные элементы – субъект Российской Федерации, населенный пункт, геоним, адрес и т.п.

Все Ваши действия по добавлению элементов адресов будут связаны с уровнем, выделенным на дереве (левая панель окна). Например, если Вы добавляете геоним (улицу, переулок, проспект и т.п.), он будет добавлен в населенный пункт, выделенный в дереве объектов на левой панели. В поставке без внешних форм необходимо выбирать класс адреса, вводить его название и адрес-родитель (например, для геонимов адресом-родителем может быть населенный пункт). В поставке с внешними формами вызываются соответствующие формы, в которых необходимо правильно заполнять соответствующие поля.

На панели инструментов окна «Адреса» расположена адресная строка. В строке редактирования «Адрес» показан текущий адресный уровень в виде строки,  в которой уровни адреса перечислены по порядку, начиная с верхнего, разделенные символом «\». Вы можете написать в строке «Адрес» адресную строку, описывающую путь к другому адресу, и, нажав кнопку «Перейти», Вы попадете в заданный адрес. В случае ошибки во введенной адресной строке перемещение произойдет только до последнего правильно описанного уровня. Т.е. если строка введена неправильно начиная с первого уровня, то перемещения к новому адресу не произойдет.

Кнопки   и   перемещают Вас по списку сохраненных адресов назад и вперед соответственно. Кнопка   или пункт меню «Вид–Перейти–Вверх на один уровень» позволяет подняться на предыдущий уровень.

Кнопка   панели инструментов позволяет добавлять и редактировать синонимы адресов. Синонимы можно использовать в том случае, когда какой-либо элемент адреса описывается неоднозначно, либо наряду с официальным имеется исторически сложившееся название и т.д.  Например, официальное название улицы: «Веры Пановой». Но существует второе официальное название «В. Пановой», а также часто употребляется «Пановой»  – в системе эти названия могут быть записаны как синонимы адреса улица «Веры Пановой». Впоследствии возможно вести поиск этого адреса не только по его названию, но и по его синонимам.

.topic 75
В окне «Адреса» Вы можете добавить любые элементы адресной системы, выбрав соответствующий класс адреса. Возможный вариант добавления адреса существенно зависят от внешних форм, настроек, описанных в разделе «Параметры – «Общие –  Адресная система», а также от классификатора адресов. В справочной системе описаны настройки, соответствующие стандартной поставке АИС «Дока» (варианты «Персональная», «Стандартная», «Профессионал», «Разработчик»). В демонстрационной версии отсутствует несколько внешних форм. Если Вы самостоятельно настроили адресную систему, дальнейшее описание может отличаться от Ваших настроек

.topic 76
Варианты создания нового адреса зависят от классификатора адресов и от того, какой именно адрес выделен в момент создания. Рассмотрим некоторые из них.

Если не выделено ни одного адреса, ни в дереве адресов на панели слева (точнее, дерево адресов не активно), ни в  списке адресов на панели справа, то при создании адреса сначала будет вызвано диалоговое окно выбора класса адреса (Рис. 3.68). После выбора класса адреса будет вызвано диалоговое окно, соответствующее классу. Если не задано внешних форм для выбранного класса адреса, будет вызвано стандартное диалоговое окно адреса (Рис. 3.69). В этом окне необходимо ввести код адреса (система автоматически формирует код исходя из поля «символы кода» классификатора адресов и адреса-родителя, но Вы можете ввести любой другой код), название адреса, его краткое наименование (если есть),  класс адреса (Вы уже выбрали класс, однако можете изменить свой выбор), адрес-родитель (если есть), а также второй адрес-родитель. После ввода всех параметров адреса и нажатия кнопки <ОК>, адрес будет записан в базу данных и автоматически выделен в дереве адресов на левой панели.

Если выделен адрес на левой панели окна «Адреса», а также дерево адресов на этой панели активно, выбор варианта создания нового адреса зависит от классификатора адресов.

Рис. 3.68

Рис. 3.69

Возможные варианты создаваемых адресов будут перечислены в меню «Адреса–Создать» и в выпадающем меню выбора кнопки  . В качестве вариантов адресов загружаются классы адресов, находящиеся на одном уровне  с классом выделенного адреса и являющиеся при этом папками. Например, в дереве объектов выделен субъект РФ «Ростовская область»). Тогда меню создания адреса будет выглядеть так, как показано на Рис. 3.70. Если Вы обратите внимание на классификатор адресов (Рис. 3.68), то Вы увидите, что перечисленные в меню классы находятся на том же уровне, что и класс «область» (уровень 2), но являются папками (выделены жирным шрифтом). Исключение составляет пункт меню «Новый адрес». Его в классификаторе, естественно, нет. Выбор этого пункта меню означает автоматический выбор первого варианта и соответствует нажатию кнопки  .

Рис. 3.70

Дальнейшие действия зависят от настроек системы.

 Закладка «Безопасность» позволяет установить права доступа к создаваемому адресу. Подробно установка параметров безопасности для классов рассмотрена нами ранее. По аналогии с документами и субъектами, при создании адреса для его создателя (т.е. пользователя, создавшего адрес) предоставляются все права на этот адрес. Для остальных пользователей права на созданный  адрес будут предоставлены в соответствии с правами на класс адреса. Вы можете предоставлять индивидуальные права на адрес, вне зависимости от его класса. Однако следует помнить, что при изменении прав на класс, все права адреса этого класса полностью заменяются правами на класс.

Создавать адреса можно также с использованием наборов данных, подготовленных с помощью Менеджера наборов.

.topic 78
Если Вами выбраны классы, находящиеся на 1 уровне классификатора и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) страны (государства), показанная на Рис. 3.71.

Рис. 3.71

Код страны формируется автоматически, однако может быть на любой другой код и служит для идентификации страны в адресной системе (код должен быть уникальным для всех адресов, а не только для стран).
Тип страны, по сути, является классом адреса. Варианты типов стран загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".
Название страны может быть не уникальным (но обязательно для заполнения).
Краткое название может быть не заполнено.
Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это название уже не существующего государства (к таковому можно отнести СССР…), но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.

.topic 79
Если Вами выбраны классы, находящиеся на 2 уровне классификатора, класс который начинается с «1.02.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) субъекта РФ, показанная на Рис. 3.72

Рис. 3.72

Код субъекта РФ формируется автоматически на основе кода страны (Российская Федерация), кодов символов класса субъекта государства и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации субъекта РФ в адресной системе (код должен быть уникальным для всех адресов, а не только для субъектов РФ).
Тип субъекта РФ, по сути, является классом адреса. Варианты типов субъектов (т.е. возможные классы субъектов РФ) загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".
Название субъекта РФ может быть не уникальным (но обязательно для заполнения). Краткое название может быть не заполнено.
Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это название уже не существующего субъекта, но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.

.topic 80
Если Вами выбраны классы, находящиеся на 3 уровне классификатора, класс который начинается с «1.02.02.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) муниципального образования, показанная на Рис. 3.73

Рис. 3.73

Код муниципального образования формируется автоматически на основе кода субъекта РФ, кодов символов класса муниципального образования и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации муниципального образования в адресной системе (код должен быть уникальным для всех адресов, а не только для муниципальных образований).
Тип муниципального образования, по сути, является классом адреса. Возможные классы муниципальных образований загружаются в зависимости от настроек, описанных в разделе "Параметры - "Общие" - Адресная система".
Название муниципального образования может быть не уникальным (но обязательно для заполнения).
Краткое название может быть не заполнено.
Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это название уже не существующего муниципального образования, но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.

.topic 81
Если Вами выбраны классы, находящиеся на 3 уровне классификатора, класс который начинается с «1.02.03.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) адреса субъекта РФ, показанная на Рис. 3.74

Рис. 3.74

К адресам субъекта РФ можно отнести объекты, которые не имеют точного адреса или привязки в населенном пункте, однако требуют идентификации в пределах субъекта РФ, например, пикеты дорог федерального значения, железнодорожные дома,  протяженные объекты (газопроводы, электросети и т.п.).

Действия по заполнению полей формы адреса субъекта РФ абсолютно идентичны действиям, описанным в предыдущем разделе "Создание (изменение) муниципального образования".

.topic 82
Если Вами выбраны классы, находящиеся на 3 уровне классификатора, класс который начинается с «1.02.01.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) населенного пункта, показанная на рисунке

Действия по заполнению полей формы населенного пункта абсолютно идентичны действиям, описанным в разделе Создание (изменение) муниципального образования.

Отметим лишь поле «Мунцип. образование». Это поле может быть выбрано из списка доступных муниципальных образований указанного субъекта РФ. Вы можете не указывать принадлежности населенного пункта к муниципальным образованиям. Если Вы уже выбрали муниципальное образование, но хотите отказаться от этого, нажмите клавишу <DELETE> на активном списке выбора муниципальных образований.

.topic 83
Если Вами выбраны классы, находящиеся на 4 уровне классификатора, код которых начинается с «1.02.01.02.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) геонима (улицы, переулка, проспекта и т.п.), показанная на Рис. 3.75

Рис. 3.75

Код геонима формируется автоматически на основе кода населенного пункта, кодов символов класса геонима и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации геонима в адресной системе (код должен быть уникальным для всех адресов, а не только для геонимов). Тип геонима, по сути, является классом адреса. Возможные классы геонимов загружаются в зависимости от настроек, описанных в разделе  "Параметры - "Общие" - Адресная система".

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код геонима», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Название геонима может быть не уникальным (но обязательно для заполнения). Краткое название может быть не заполнено.

Флажок «Официальное название» по умолчанию установлен. Однако, Вы может сбросить его, если, например, это уже не существующее название улицы, но при этом Вам возможно понадобится этот адрес.

После нажатия кнопки <ОК> данные будут сохранены в базе. Нажатие кнопки <Отмена> приведет к отмене проведенных действий и проведенные изменения будут утеряны.

.topic 84
Если Вами выбраны классы, находящиеся на 4 уровне классификатора, код которых начинается с «1.02.01.01.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) района населенного пункта, показанная на рисунке 3.76

Рис. 3.76

Действия по заполнению полей формы района абсолютно идентичны действиям, описанным в разделе Создание (изменение) геонима.

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код района», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Поле «Название кратко» можно не заполнять.

.topic 85
Если Вами выбраны классы, находящиеся на 4 уровне классификатора, код которых начинается с «1.02.01.03.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) адреса населенного пункта, показанная на Рис. 3.77

Рис. 3.77

К адресам населенных пунктов можно отнести адреса, которые нельзя описать традиционным способом, например, абонентские ящики или описательный адрес (южная окраина города) и т.п.

Действия по заполнению полей формы адреса идентичны действиям, описанным в разделе Создание (изменение) геонима.

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код адреса», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Поле «Почтовый индекс» можно не заполнять.

.topic 86
Если Вами выбраны классы, находящиеся на 5 уровне классификатора, код которых начинается с «1.02.01.02.01.» и не являющиеся папками, то при добавлении  (изменении) адреса будет вызвана форма добавления (изменения) традиционного адреса, показанная на рисунке

Рис. 3.78

Код адреса формируется автоматически на основе кода геонима, кодов символов класса адреса и автоматически сформированного уникального кода адреса, однако может быть изменен на любой другой код и служит для идентификации геонима в адресной системе (код должен быть уникальным для всех элементов - геонимов, населенных пунктов и т.п., а не только адресов).

Действия по заполнению полей формы адреса идентичны действиям, описанным в разделе Создание (изменение) геонима.

Необходимо выбрать субъект РФ, населенный пункт (выбираются в зависимости от субъекта РФ), заполнить поля «Код адреса», «Название», выбрать тип (класс адреса) и установить (или снять) флажок «Официальный». Поле «Почтовый индекс» можно не заполнять. Дополнительно можно выбрать район населенного пункта в котором расположен адрес.

Для удаления выбранного района, нажмите клавишу <Delete> на активном списке выбора района.

.topic 87
Адрес, введенный ошибочно или ненужный, можно удалить из базы данных. Для того чтобы удалить адрес, нужно выполнить следующие действия:

Выделить элемент адреса, который Вы хотите удалить, в дереве адресов на левой панели рабочего окна;
Нажать кнопку   на панели инструментов, либо выбрать пункт меню «Адреса – <Текущий адрес> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном адресе);
После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

 Внимание!

 После удаления, восстановление адреса будет невозможно. Кроме того, удалятся все связи этого адреса с объектами и субъектами, а также вложенные адреса (например, удаление населенного пункта приведет к удалению всех улиц, районов и адресов этого населенного пункта). Если Вы не уверены в правильности Ваших действий, не удаляйте адрес.

.topic 90
В системе предусмотрена возможность просмотра объектов и субъектов, имеющих адреса,  в окне «Адреса».
Для просмотра связей адресов с объектами и субъектами базы данных пользователь должен произвести следующие действия:

Нажать кнопку   или выбрать пункт меню «Вид – Показать/скрыть связи  – Показать связанные объекты»  для просмотра объектов, находящихся по выделенному адресу.
Нажать кнопку   или выбрать пункт меню «Вид – Показать/скрыть связи  – Показать связанные субъекты»  для просмотра субъектов, находящихся по выделенному адресу

Для того, чтобы разорвать созданную ранее связь, необходимо выбрать ее в панели списка щелчком левой кнопки мыши, выбрать пункт главного меню «Адреса – Удалить»  или контекстного меню «Удалить», либо нажать кнопку   на панели инструментов. После подтверждения удаления, связь между объектом (субъектом) и адресом будет разорвана. Сам объект (субъект) при этом не удаляются, очищается адрес в свойствах объекта (субъекта). Изменение связи из окна «Адреса» невозможно. Для изменения связи объекта с адресом (по сути адреса объекта), найдите объект, откройте его на редактирование (изменение) и измените адрес объекта. В случае с субъектом, измените требуемый адрес субъекта (почтовый или адрес регистрации).

Если Вы хотите быстро найти объект (субъект), находящийся по выбранному адресу, то выделите связь с искомым объектом (субъектом) в панели списка, вызовите контекстное меню и выберите пункт меню «Открыть». При этом откроется рабочее окно «Объекты» («Субъекты»), в котором искомый объект (субъект) будет открыт и выделен в панели дерева объектов (субъектов). Тот же результат можно получить, если произвести двойной щелчок левой кнопкой мыши на интересующей Вас связи. После этого Вы сможете осуществить с найденным объектом (субъектом) все необходимые действия (изменение, удаление и пр.).

.topic 91
При большом количестве адресов поиск необходимого адреса в списке существенно затруднен. Для того чтобы найти нужный адрес, в программе предусмотрены развитые средства поиска. Для поиска адреса нажмите клавишу <F3>  (или <CTRL+F>) на клавиатуре или нажмите кнопку   на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.79), в которой необходимо задать требуемые параметры поиска.

Рис. 3.79

На панели поиска имеются поля, формирующие условия поиска:

 Начальные:
Равно;
Не равно;
Меньше;
Меньше/равно;
Больше;
Больше/равно;
Похожее на;
Начинается с;

 Промежуточные:
«И»;
«ИЛИ».

Для поиска адреса необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие.

Формирование поисковой строки по текстовому полю.

В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле адреса. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

 Начальные условия поиска имеют следующие значения:
Равно – найти значения, точно соответствующие поисковой строке;
Не равно – найти любые значения, не равные поисковой строке;
Меньше – найти значения, меньшие, чем указаны в поисковой строке;
Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
Больше – найти значения, большие, чем указаны в поисковой строке;
Больше/равно - найти значения, большие или равные указанным в поисковой строке;
Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
Начинается с – найти значения, с которых начинается поисковая строка.

Промежуточные условия поиска применяются в том случае, когда необходимо найти адрес более чем по одному полю.

Для поля «Класс адреса» поисковое значение выбираются из классификатора адресов и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле «Класс адреса»).

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти адреса, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Ростов», «ростов», «РОСТОВ», «РостоВ» и т.п.

При выставленном флажке «Искать в синонимах», поиск будет осуществлен также среди синонимов адресов. Например, Вы ищете адрес с названием «Веры Пановой», но не уверены, что именно так называется улица. Если в синонимах улицы есть различные варианты названия улицы (например «В. Пановой»), то можно выставив флажок «Искать в синонимах», попытаться найти эту улицу, набрав «В. Пановой». Использование синонимов адресов может существенно сократить время, поиска адресов.

После того, как адрес будет найден, Вы можете перейти к нему, дважды щелкнув по документу на правой панели или выбрав пункт контекстного меню «Открыть».

.topic 96
 При создании адресов, при выборе адреса месторасположения объектов или субъектов используется окно «Выбор адреса» (рис. 3.80).

Рис. 3.80

Выбор адреса, а также другие действия в окне выбора адреса производятся также как и в окне выбора документов.

.topic 115
 Дополнительные свойства могут быть добавлены для класс адреса. Добавление дополнительных свойств адреса производится по аналогии с внешними формами:

 создается форма свойств адреса в среде Delphi 7 (подробнее правила создания дополнительных форм описаны в документации «Руководство разработчика АИС «Дока» в версиях «Профессионал» и  «Разработчик»);
Форма регистрируется в базе данных (подробнее процесс регистрации описан в документации «Руководство администратора АИС «Дока»);
После загрузки адреса выбранного класса и выделения его в дереве или в списке на правой панели рабочего окна документов, на панели инструментов «Свойства документа» будет добавлена кнопка, связанная с зарегистрированной формой дополнительных свойств пункт в меню «Адрес–Характеристики Адреса». Для остальных адресов эти формы остаются недоступными, и кнопка на соответствующей панели не появляется.

.topic 200
Рабочее окно связей предназначено для отображения связей между основными элементами системы (документы, субъекты, объекты), создания, изменения и удаления их, а также для ввода дополнительных характеристик связей (рис.3.81).

Рис. 3.81
В окне связей более удобно осуществлять поиск связанных субъектов и документов  по классу связи или её состоянию. Например, если необходимо найти директора предприятия, можно в окне субъектов просмотреть связи с этим предприятием и найти среди них необходимую, либо открыть окно связей и найти связи класса "директор" и среди них найти необходимую.
Левая панель рабочего окна содержит дерево связей базы данных. Если активировать конкретную связь в левой панели, то в правой будет выведен список связанных с ней субъектов, документов или объектов.

 Кнопки панели инструментов рабочего окна динамически изменяются в зависимости от активности связи и связанных с нею объектов базы данных.

При многопользовательской работе с базой данных часто возникает ситуация, когда один из пользователей уже добавил связь в базу данных, а у другого пользователя отсутствует информация  об этих действиях. Для того, чтобы увидеть обновленную информацию, нажмите кнопку «Обновить» (<F5>) на панели инструментов или выберите пункт меню «Вид–Обновить». Программа загрузит последнюю версию списка связей с сервера и обновит ее в рабочем окне. При этом обновятся и все ссылки связи.

 Для перемещения по списку связей используются клавиши управление курсором (стрелка вверх, стрелка вниз, Home, End), а также кнопки   и  .

.topic 201
Добавить новую связь пользователь может выбором пункта меню рабочего окна «Связи – Создать – Связь» либо нажатием кнопки   на панели инструментов. Пользователю будет предложено выбрать класс создаваемой связи по классификатору (Рис. 3.82).

Рис.3.82
После выбора класса связи на экран будет вызвано соответствующее диалоговое окно. Реквизиты уже введенной связи можно изменить. Для того чтобы изменить связь, нужно выполнить следующие действия: выделить связь, которую Вы хотите изменить, в дереве связей на левой панели рабочего окна, нажать кнопку   на панели инструментов или выбрать пункт меню «Связи – <Текущая связь> - Изменить» или выбрать пункт контекстного меню «Изменить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте). Для изменения связи будет вызвано такое же диалогове окно, как и для добавления.

Если внешние формы для данного класса связей не заданы, то будет вызвано стандартное диалоговое окно (Рис. 3.83), состоящее из двух закладок. При этом, будет учтено, в какой группе содается новая связь, т.е. к какому типу она относится: документ->объект, документ->субъект, документ->документ, субъект->субъект или документ->адрес.

Рис. 3.83
На рисунке 3.83 в качестве примера показано создание связи типа документ->субъект. На закладке «Общие» пользователь с помощью кнопок   должен будет выбрать документ и субъект, между которыми создается связь. Кроме того, возможно изменение класса содаваемой связи, а также задать состояние связи.
 Закладка «Безопасность» позволяет установить права доступа к создаваемой связи. Подробно установка параметров безопасности для классов рассмотрена нами ранее. По аналогии с документами, объектами и субъектами, при создании связи для её создателя (т.е. пользователя, создавшего связь) предоставляются все права на эту связь. Для остальных пользователей права на созданную  связь будут предоставлены в соответствии с правами на класс связи. Вы можете предоставлять индивидуальные права на связь, вне зависимости от её класса. Однако следует помнить, что при изменении прав на класс, все права связи этого класса полностью заменяются правами на класс.

.topic 202
Любая выделенная пользователем связь может быть скопирована в буфер обмена и затем вставлена в базу данных. Режим копирования/вставки подробно описан ранее.

Примечание: Если Вы используете нестандартные формы связей, то перед использованием этой возможности Вам необходимо создать метаданные для этих классов связей (см. подробно).

Возможность копирования удобно использовать для создания однотипных связей (связей, отличающихся друг от друга, например, только документом).

Для копирования связи необходимо:
выбрать её в списке дерева связей (левая панель);
нажать правую кнопку мыши и в контекстном меню выбрать пункт "Копировать", или нажать кнопку на панели инструментов рабочего окна связей

Для вставки связи необходимо:
правой кнопкой мыши нажать на объекте, субъекте или документе (в зависимости от типа скопированной ранее связи), с которым должна быть создана аналогичная связь, в контекстном меню выбрать пункт "Вставить".

.topic 203
Связь, созданную ошибочно или ненужную, можно удалить из базы данных. Для того чтобы удалить связь, нужно выполнить следующие действия:

 Выделить связь, которую Вы хотите удалить, в дереве объектов на левой панели рабочего окна или в панели списка;
Нажать кнопку   на панели инструментов, выбрать пункт меню «Связи – <Текущий объект> - Удалить» или выбрать пункт контекстного меню «Удалить» (контекстное меню появляется после щелчка правой кнопкой мыши на выделенном объекте);
После того, как откроется диалоговое окно, подтвердите удаление, нажав кнопку «Да» (или отмените удаление, нажав кнопку «Нет», если Вы передумали).

 Внимание!

 После удаления, восстановление связи будет невозможно.  Если Вы не уверены в правильности Ваших действий, не удаляйте связь.

.topic 204
При большом количестве связей поиск необходимой в списке существенно затруднен. Для того чтобы найти нужную связь, в программе предусмотрены развитые средства поиска. Для поиска объекта нажмите клавишу <F3> на клавиатуре или нажмите кнопку   на панели инструментов. Левая панель рабочего окна сменится на панель поиска (Рис. 3.84), в которой необходимо задать требуемые параметры поиска.

В том случае, если для связи создана нестандартная формы ввода, то при вызове панели поиска на ней появляется еще одна кнопка «Дополнительно». При нажатии на эту кнопку появляется расширенная панель поиска с полями, описывающими свойства этой связи (аналогично поиску объектов или документов и т.п.).

Рис. 3.84

 На панели поиска имеются поля, формирующие условия поиска:

 Начальные:
Равно;
Не равно;
Меньше;
Меньше/равно;
Больше;
Больше/равно;
Похожее на;
Начинается с;

 Промежуточные:
«И»;
«ИЛИ».

 Для поиска связи необходимо задать начальное условие поиска, поисковую строку и, при необходимости, промежуточное условие. Кроме того, при поиске связей необходимо однозначно указать какой тип связи мы ищем: документ->объект, документ->субъект, документ->документ, субъект->субъект или документ->адрес. Тип выбирается из списка "Искать в связях типа".

 Формирование поисковой строки по текстовому полю.

 В поле поиска необходимо ввести текст, который Вы желаете найти в этом поле связи. Здесь возможно использование замещающего символа %. Если в строке используется такой символ, это означает, что вместо него могут быть записаны любые символы.

 Начальные условия поиска имеют следующие значения:
Равно – найти значения, точно соответствующие поисковой строке;
Не равно – найти любые значения, не равные поисковой строке;
Меньше – найти значения, меньшие, чем указаны в поисковой строке;
Меньше/равно - найти значения, меньшие или равные указанным в поисковой строке;
Больше – найти значения, большие, чем указаны в поисковой строке;
Больше/равно - найти значения, большие или равные указанным в поисковой строке;
Похожее на – найти значения, встречающиеся в поисковой строке. Требуется введение замещающего символа %;
Начинается с – найти значения, с которых начинается поисковая строка.

 Промежуточные условия поиска применяются в том случае, когда необходимо найти объект более чем по одному полю. Например: Название класса ПОХОЖЕЕ НА %исполнит% И класс связи 00.01 (Договорные отношения), включая вложенные классы.

 Для поля «Класс связи» поисковые значения выбираются из соответствующего классификатора и поиск ведется на точное соответствие типу по классификатору. Для очистки условия поиска, нажмите клавишу <DEL> (DELETE) на клавиатуре (курсор должен находиться в поле поиска «Класс связи»).

Флажок «Не учитывать регистр» выставляется в том случае, если Вы хотите найти связи, например, в названии которых могут быть буквы в разном регистре (заглавные и строчные), но Вы не знаете точно, как именно написано название. При выставленном флажке одинаковыми будут считаться название «Исполнитель», «исполнитель», «ИСПОЛНИТЕЛЬ», «ИсПоЛнИтЕлЬ» и т.п.

 После того, как связь будет найдена, Вы можете перейти к ней, дважды щелкнув по связи на правой панели или выбрав пункт контекстного меню «Открыть».

.topic 205
Это дополнительное свойство связи, которое предназначено для хранения характеристик, отсутствующих в стандартной реализации системы. Дополнительные характеристики могут быть добавлены, как вспомогательная информация, и использованы в печатных формах. Для добавления дополнительных характеристик пользователь должен найти в панели дерева связей нужную связь, сделать его активной, щелкнув на ней левой кнопкой мыши и нажать кнопку   на панели инструментов.Работа с дополнительными характеристиками описана ранее (Рис. 3.19).

Здесь пользователь может добавлять, изменять или удалять дополнительные данные, характеризующие конкретную связь. Для новой характеристики необходимо ввести ее наименование и количественные или описательные параметры, помещаемые соответственно в поля «Значение (число)» и «Значение (строка)». При необходимости можно выбрать также единицы измерения добавляемой характеристики (из классификатора единиц измерения).

.topic 206
В системе имеется возможность применения ограничений для показа в панелях дерева и списка связей базы данных связей определенного класса, назначаемых пользователем. Для этого используется пункт меню «Вид - Фильтр» или соответствующая панель инструментов рабочего окна Рис. 3.85.

Рис. 3.85
 В соответствии с порядком расположения на панели кнопок они имеют значения: «Включить фильтр», «Отключить фильтр» и «Задать условия фильтрации».

 Подробно работа по настройке фильтров описана в п. "Использование фильтров документов".

Примечание. В версии 2.5 данный функционал заложен, однако до конца не реализован. Реализация данного функционала в ближайших планах компании "Комплекс Софт"

.topic 1001
Здание является основным объектом учета жилищного фонда управляющей компании.
Добавить новое здание пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки   на панели инструментов. После выбора класса создаваемого объекта (здания) из классификатора на экран будет выведена форма ввода Рис. 1.5.

На вкладке «Общие сведения» вводятся данные:

Рис. 1.5
наименование объекта (при выборе пользователем адреса объекта на вкладке «Дополнительно» в поле автоматически помещается его адрес);
тип или серия проекта;
литера;
год постройки (дата);
группа капитальности здания;
принадлежности строения к памятникам архитектуры;
данные о переоборудовании с указанием даты;
наличие дополнительных составных частей здания;
особенности конструкции здания.

На вкладке «Характеристики» Рис. 1.6 вводятся данные:

Рис. 1.6
количество этажей;
строительный объем;
количество подъездов;
средняя высота помещений;
количество лестниц;

На вкладке «Площади» Рис. 1.7 вводятся данные:

Рис. 1.7

сведения об основных и иных площадях здания;

уборочная площадь лестниц;
уборочная площадь мест общего пользования;
сведения о площадях нежилых помещений.

На вкладке «Экономические показатели» Рис. 1.8 вводятся данные:

Рис. 1.8

сведения о стоимостях здания и моменте времени проведенной оценки;
сведения о муниципальной доле в составе здания.

На вкладке «Дополнительно» Рис. 1.9 вводятся данные:

Рис. 1.9

группа объекта (по классификатору групп объектов);
состояние объекта (по справочной таблице состояний объекта);
класс объекта (по классификатору объектов);
адрес строения;
код на карте (поле, используемое для поиска здания (строения) на электронной карте. Необходимость заполнения этого поля возникает при интеграции системы с ГИС-приложением.

На вкладке «Распределение площадей» Рис. 1.10 вводятся данные:

сведения о распределении площадей здания.

Рис. 1.10

Вкладка представляет собой редактор с древовидно-табличной структурой и автоматическим суммированием введенных данных по группам.

Вкладка «Помещения и конструктивные элементы» Рис. 1.11 предоставляет пользователю возможность управления составом и структурой здания. Эти действия пользователь может проводить как на данной вкладке, так и в рабочем окне «Объекты», а так же в окнах "Список квартир" и "Список конструктивных элементов".

На этой вкладке можно добавлять составляющие элементы здания: помещения, конструктивные элементы, элементы благоустройства, земельные участки (дворовая и уличная территории), замощения и пр.

Рис. 1.11

В верхней части вкладки расположена стандартная для системы панель инструментов, позволяющая добавить, изменить или удалить объект, обновить дерево объектов и просмотреть (изменить) их свойства. Кнопки панели инструментов дублированы в контекстном меню, вызываемом щелчком правой кнопки мыши на том или ином объекте.

Одной из особенностей добавления новых объектов здания является то, что при нажатии на стрелку, расположенную справа от значка  , пользователю будет предложен список доступных для ввода объектов, состав которых динамически изменяется в зависимости от того, какой текущий объект здания выделен. Так, например, при выделении, показанном на Рис. 1.11, пользователь увидит выпадающее меню, представленное на Рис. 1.12 (перечислены помещения, которые могут входить в состав квартиры).

Рис. 1.12

Нажатие на кнопку «Добавить» вызовет общий классификатор объектов, в котором пользователь должен будет найти нужный объект.
Настройка описанной выше возможности осуществляется в классификаторе объектов (см. «Руководство пользователя АИС «Дока», Классификатор «Документы» - Работа с допустимыми связями).

.topic 1002
Объект «Квартира» («Офис») используется для учета составляющих объектов здания, имеющих в своем составе встроенные помещения.
Добавить новую квартиру (офис) пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки   на панели инструментов. После выбора класса создаваемого объекта (квартира) из классификатора на экран будет выведена форма ввода Рис. 1.13.
Сведения, заполняемые в представленной форме, необходимы для формирования технического паспорта квартиры.

На вкладке «Общие сведения» Рис. 1.13 вводятся данные:

Рис. 1.13

    наименование (номер квартиры);
    этаж;
    количество комнат;
    высота помещений;
    физический износ;
    особенности квартиры;
    примечание (дополнительные сведения).

На вкладке «Площади» Рис. 1.14 вводятся данные:

Рис. 1.14

 сведения об основных площадях квартиры.

На вкладке «Стоимость» Рис. 1.15 вводятся данные:

Рис. 1.15

    сведения о стоимости квартиры и моменте времени проведенной оценки;
    сведения о муниципальной доле в составе квартиры.

На вкладке «Дополнительно» Рис. 1.16 вводятся данные:

Рис. 1.16
группа объекта (классификатор групп объектов – группировка элементов зданий). При выборе группы объекта квартира помещается внутрь вложенной группировки элементов здания (Рис. 1.11);
состояние объекта (по справочной таблице состояний объекта);
класс объекта (по классификатору объектов);
адрес квартиры (создается и выбирается);
расположена в:  - принадлежность квартиры конкретному зданию (строению).  Пользователь должен выбрать здание – владелец квартиры в окне выбора объектов.

Вкладка «Помещения и конструктивные элементы» Рис. 1.17 предоставляет пользователю возможность управления составом и структурой квартиры. Эти действия пользователь может проводить как на данной вкладке, так и в рабочем окне «Объекты».

Рис. 1.17

Работа с элементами квартиры аналогична рассмотренной нами на вкладке «Помещения и конструктивные элементы» здания (Рис. 1.11).
Наряду с помещениями, в состав квартиры могут быть добавлены и конструктивные элементы (Рис. 1.17).

.topic 1003
Добавить новое помещение пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки   на панели инструментов. После выбора класса создаваемого объекта (квартира) из классификатора на экран будет выведена форма ввода Рис. 1.18.
Сведения, заполняемые в представленной форме, необходимы для формирования технического паспорта квартиры.

На вкладке «Общие сведения» вводятся данные:

наименование помещения (автоматически присваивается имя класса помещения);
формула расчета (длина и ширина помещения);
площадь помещения;
высота помещения;
сведения об аренде или выкупе.

Рис. 1.18

На вкладке «Дополнительно» Рис. 1.19 вводятся данные:

Рис. 1.19

группа объекта (по классификатору групп объектов);
состояние объекта (по справочной таблице состояний объекта);
класс объекта (по классификатору объектов);
расположена в:  - принадлежность помещения конкретной квартире (офису).  Пользователь должен выбрать квартиру – владелец помещения в окне выбора объектов.

.topic 1004
Добавить новый конструктивный элемент пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки   на панели инструментов. После выбора класса создаваемого объекта (конструктивный элемент) из классификатора на экран будет выведена форма ввода Рис. 1.20.

 На вкладке «Общие сведения» вводятся данные:

наименование (автоматически присваивается имя класса конструктивного элемента);
удельный вес конструктивного элемента в составе здания;
срок службы конструктивного элемента (лет);
класс конструктивного элемента (по классификатору объектов);
сменяемый элемент – устанавливается для сменяемых конструктивных элементов (например, дверные или оконные заполнения);
дата последней замены элемента;
площадь (объем и пр.) – абсолютная величина измеряемого элемента (например, площадь кровли);
единица измерения для предыдущего пункта – выбирается из классификатора единиц измерений.

Рис. 1.20

На вкладке «Дополнительно» вводятся данные:

Рис. 1.21

группа объекта (классификатор групп объектов – группировка элементов зданий). При выборе группы объекта конструктивный элемент помещается внутрь вложенной группировки элементов здания (Рис. 1.11);
состояние объекта (по справочной таблице состояний объекта);
элемент как часть  - принадлежность конструктивного элемента конкретному зданию, квартире или помещению.  Пользователь должен выбрать здание – владелец элемента в окне выбора объектов;

На вкладке «Мониторинг техсостояния» (Рис. 1.22) отображаются данные о проведенных обследованиях технического состояния конструктивного элемента.

Рис. 1.22

Это информационная панель, данные для которой автоматически отображаются из связанных актов обследования технического состояния.

.topic 1005
Лифт является специфическим конструктивным элементом с особыми свойствами.

На вкладке «Общие сведения» Рис. 1.23 вводятся данные:

Рис. 1.23

наименование (автоматически присваивается имя класса конструктивного элемента). При необходимости пользователь может добавить в наименование собственную информацию (например, номер подъезда);
регистрационный номер лифта;
номер подъезда здания, в котором установлен лифт;
скорость движения лифта;
дата последней замены лифта;
грузоподъемность;
примечание (дополнительные сведения).

На вкладке «Дополнительно» вводятся данные:

Рис. 1.24

группа объекта (классификатор групп объектов – группировка элементов зданий). При выборе группы объекта лифт помещается внутрь вложенной группировки элементов здания (Рис. 1.11);
состояние объекта (по справочной таблице состояний объекта);
класс объекта (по классификатору объектов);
расположена в:  - принадлежность лифта конкретному зданию (строению).  Пользователь должен выбрать здание – владелец лифта в окне выбора объектов;
сменяемый элемент – устанавливается для сменяемых конструктивных элементов;
удельный вес лифта в составе здания;
срок службы лифта (лет).

На вкладке «Мониторинг техсостояния» (Рис. 1.25) отображаются данные о проведенных обследованиях технического состояния конструктивного элемента.

Рис. 1.25

Это информационная панель, данные для которой автоматически отображаются из связанных актов обследования технического состояния.

.topic 1006
Объект «Земельный участок» может существовать как самостоятельно, так и в составе других объектов жилищного фонда. Более того, для различных объектов жилищного фонда он может выступать в различных ролях:
в качестве корневого объекта (например, земельный участок домовладения);
в качестве вложенного объекта (например, придомовая территория жилого здания).

Правила использования объекта «Земельный участок» должны быть выработаны и согласованы в управляющей организации до начала эксплуатации системы. Этот момент является важным для последующего формирования отчетов.
Добавить новый земельный участок пользователь может выбором пункта меню рабочего окна «Объект – Создать – Новый объект» либо нажатием кнопки   на панели инструментов. После выбора класса создаваемого объекта (Земельный участок) из классификатора на экран будет выведена форма ввода Рис. 1.26.
На вкладке «Общие сведения» вводятся данные, необходимые для заполнения раздела технического паспорта «Экспликация площади земельного участка»:

наименование участка;
инвентарный номер;
кадастровый номер;
номер кадастрового квартала;
момент времени, на который актуальны данные об участке;
сведения о площадях земельного участка.

Рис. 1.26

На вкладке «Замощения» Рис. 1.27 вводятся данные, необходимые для заполнения разделов технического паспорта «Экспликация площади земельного участка» и «Уборочная площадь». Для ввода информации об использовании незастроенной площади земельного участка используется особый объект «Замощение», который будет рассмотрен в следующем параграфе.

Рис. 1.27
Работа с составными элементами земельного участка аналогична рассмотренной нами на вкладке «Помещения и конструктивные элементы» здания (Рис. 1.11).

На вкладке «Дополнительно» вводятся данные:

Рис. 1.28

группа объекта (по классификатору групп объектов);
состояние объекта (по справочной таблице состояний объекта);
класс объекта (по классификатору объектов);
код на карте (поле, используемое для поиска земельного участка на электронной карте. Необходимость заполнения этого поля возникает при интеграции системы с ГИС-приложением.).
принадлежит:  - принадлежность участка другому объекту (например, земельному кварталу или зданию).  Пользователь должен выбрать объект – владелец участка в окне выбора объектов;
адрес земельного участка.

.topic 1007
Объект «Замощение» используется для ввода информации об использовании незастроенной площади земельного участка. Эти данные, необходимы для заполнения разделов технического паспорта «Экспликация площади земельного участка» и «Уборочная площадь». Кроме того, эти сведения могут быть использованы для расчета численности работников, занятых содержанием жилищного фонда. Нормативы численности и нормы обслуживания на ручную уборку территорий устанавливаются дифференцированно, в зависимости от класса территории и типа покрытий.

В соответствии с Правилами и нормами технической эксплуатации жилищного фонда, в зависимости от интенсивности пешеходного движения территории разбиваются на 3 класса:

I класс    - до 50 чел./час (территории дворов следует относить к I классу);
II класс  - от 50 до 100 чел./час;
III класс - свыше 100 чел./час.

Типы покрытий приняты следующие: усовершенствованные (асфальтобетонные, брусчатые), неусовершенствованные (щебеночные, булыжные) и территории без покрытий. Отдельно выделяются территории газонов.

На вкладке «Общие сведения» вводятся данные:

Рис. 1.29
наименование покрытия;
площадь (кв.м);
класс проходимости (класс по интенсивности пешеходного движения);
класс покрытия (тип - усовершенствованные, неусовершенствованные).

 На вкладке «Дополнительно» вводятся данные:

Рис. 1.30

группа объекта (по классификатору групп объектов);
состояние объекта (по справочной таблице состояний объекта);
элемент как часть  - принадлежность покрытия другому объекту (например, земельному участку).  Пользователь должен выбрать объект – владелец участка в окне выбора объектов.

.topic 1020
При выделении мышью конкретного здания на левой панели рабочего окна и нажатии кнопки   вызывается диалоговая форма.

В этом окне отображаются только квартиры выбранного здания. Здесь пользователь может добавлять новые квартиры, редактировать существующие, либо удалять ненужные (в том случае, если объект - здание создавался путем копирования - вставки).

Основным преимуществом работы в окне списка квартир является то, что созданная квартира автоматически получает принадлежность к текущему зданию и группе "Квартиры" этого здания.

Аналогичной функциональностью обладает вкладка "Помещения и конструктивные элементы" здания.
Здесь можно посмотреть порядок работы с диалоговой формой "Квартира".

.topic 1021
При выделении мышью конкретного здания на левой панели рабочего окна и нажатии кнопки   вызывается диалоговая форма.

В этом окне отображаются только конструктивные элементы и элементы благоустройства выбранного здания. Здесь пользователь может добавлять новые элементы, редактировать существуюшие, либо удалять ненужные (в том случае, если объект - здание создавался путем копирования - вставки).

Основным преимуществом работы в окне списка конструктивных элементов является то, что созданный конструктивный элемент автоматически получает принадлежность к текущему зданию.

Аналогичной функциональностью обладает вкладка "Помещения и конструктивные элементы" здания.
Здесь можно посмотреть порядок работы с диалоговой формой "Конструктивный элемент".

Не менее важной особенностью использования этого окна является возможность проверить и исправить сумму удельных весов всех конструктивных элементов здания, которая должна быть равна 100%. Удельные веса конструктивных элементов используются при моделировании нормативного физического износа здания и расчета стоимости замены отдельных элементов.

Для удобства работы конструктивные элементы и элементы благоустройства могут быть сгруппированы в отдельные группы. Для этого необходимо внутри окна со списком элементов щелкнуть правой кнопкой мыши и в контекстном меню выбрать "Группировка - Сгруппировать".

В этом случае окно списка элементов примет вид:

Как видно на рисунке, в случае группировки сумма удельных весов подсчитывается для групп элементов и недоступна для здания в целом.

.topic 1022
Определение физического износа приведено в основных терминах и определениях сферы ЖКХ. В конфигурации "Управление недвижимостью" реализована возможность моделирования нормативного физического износа, т.е. износа с учетом истечения нормативных сроков службы отдельных конструктивных элементов (КЭ) и элементов благоустройства здания (сооружения).

Для проведения моделирования должны выполняться следующие условия:

1.	Исходной точкой отсчета для начала моделирования износа здания является дата его постройки. Если дата постройки точно неизвестна (есть только год), то следует выбрать любую конкретную дату в пределах этого года (мы рекомендуем выбирать 1 января). В том случае, если дата постройки здания не будет указана, моделирование выполняться не будет;
2.	В процессе моделирования износа участвуют КЭ и элементы благоустройства здания. Следовательно, в состав здания должны быть добавлены все конструктивные элементы;
3.	Для правильного моделирования у каждого КЭ должны быть заполнены основные характеристики:
наименование (автоматически присваивается имя класса КЭ);
удельный вес КЭ в составе здания - используется при моделировании снижения износа здания при замене КЭ и для расчета стоимости его замены;
срок службы КЭ (лет) - используется при моделировании плановых замен;
класс КЭ (по классификатору объектов);
сменяемый элемент – устанавливается для сменяемых элементов. В процессе моделирования износа участвуют только сменяемые КЭ здания;
дата последней замены элемента - если КЭ уже подвергался замене, то моделирование его износа будет вестись от этой даты;
площадь (объем и пр.) – в процессе моделирования используется для расчета стоимости замены или ремонта элемента;
единица измерения для предыдущего пункта – выбирается из классификатора единиц измерений.

Для проведения моделирования необходимо выделить мышью конкретное здание на левой панели рабочего окна и нажать кнопку   на панели инструментов. При этом на экран вызывается диалоговая форма (Рис.1.3.1).

Рис. 1.3.1

Форма состоит из нескольких закладок:

График - собственно график нормативного износа, на котором по горизонтальной оси измеряется срок службы здания, а по вертикальной его износ;

Таблицы данных - рассчитываемые программой данные для построения графика;

Сменяемые элементы - КЭ и элементы благоустройства, участвующие в процессе моделирования (Рис.1.3.2);

Рис. 1.3.2
В этом окне пользователь управляет составом КЭ, участвующих в процессе моделирования износа здания. Добавленные в окно КЭ в ходе моделирования подвергаются плановым заменам и оказывают влияние на общий износ здания, что визуально отображается на графике нормативного физического износа.
До начала построения графика износа необходимо выбрать КЭ, которые будут участвовать в процессе моделирования. Для этого на панели "Сменяемые элементы" необходимо нажать кнопку  . При этом на экран будет вызвана форма Рис.1.3.3.

Рис. 1.3.3
При этом, если в предыдущей форме (Рис.1.3.2) уже имелись добавленные КЭ, то в форме выбора будут показаны только оставшиеся (не выбранные для моделирования) элементы здания. Добавлять элементы для моделирования можно как по одному, выделяя их в окне выбора и нажимая кнопку ОК, так и массовым способом. Так, для того, чтобы выбрать все элементы здания, необходимо выделить мышью самый верхний элемент, нажать и удерживать кнопку "Shift", а затем щелкнуть мышью по самому нижнему элементу. Если Вам необходимо выбрать отдельные элементы здания, то выделять их в окне выбора необходимо удерживая кнопку "Ctrl".
После нажатия кнопки ОК выбранные элементы будут добавлены в окно панели "Сменяемые элементы".

После подготовки набора КЭ, участвующих в процессе моделирования, необходимо перейти на вкладку "График" (Рис.1.3.1) и нажать кнопку "Построить". Если после этого вернуться на вкладку "Сменяемые элементы" и изменить их состав, то нажав кнопку "Обновить", Вы получите измененный график износа здания (Рис.1.3.4).

Рис. 1.3.4
Красная линия графика покзывает, как ведет себя нормативный износ здания без замены КЭ от момента его постройки до максимального срока службы. Физический износ при этом, согласно нормативным документам, не может превышать 80% (для жилых зданий).
Серая (зигзагообразная) линия графика показывает изменение нормативного износа при "правильной" эксплуатации здания, т.е. при своевременной плановой замене выбранных для анализа КЭ. Скачкообразное снижение износа говорит о том, в это момент времени проведена полная замена одного или нескольких КЭ.
Синяя вертикальная линия графика показывает, что в данный момент времени проводилось обследование технического состояния здания, в ходе которого был оформлен Акт обследования и оценен реальный физический износ здания в соответствии с действующими техническими регламентами (ВСН 53-86р).

Акты обследования - наличие Актов обследования технического состояния для выбранного здания (Рис1.3.5).

Рис. 1.3.5
Акты обследования появляются на этой вкладке в ходе построения графика и выбираются из связанных с выбранным зданием документов. При этом можно увидеть дату и номер Акта, фактический износ, отраженный в этом документе, а также нормативный износ, полученный в ходе моделирования.

Плановые замены (таблица) - таблица плановых замен КЭ в зависимости от их сроков службы;

Рис. 1.3.6
Как видно на Рис.1.3.6 плановые замены существуют только для сменяемых КЭ. В данном случае моделирования КЭ "Водопровод" подвергался (или подлежит) замене каждые 15 лет (в 1985, 2000 и 2015 годах).

Плановые замены (диаграмма) - сетевой график плановых замен КЭ (Рис.1.3.7).

Рис. 1.3.7
На сетевом графике видны промежутки времени, в течение которых необходимо провести плановые замены КЭ.

На вкладке "Диаграмма" для пользователя доступны дополнительные возможности:

Если навести указатель мыши на конкретный элемент диаграммы (при этом он принимает вид ладони), то в нижней части окна будет показан этот промежуток времени в текстовом виде, а также указана примерная стоимость замены КЭ (Рис.1.3.7). Стоимость замены КЭ рассчитывается в зависимости от восстановительной стоимости здания и удельного веса КЭ в его составе.

Если навести указатель мыши на конкретный элемент диаграммы (при этом он принимает вид ладони) и нажать левую кнопку мыши, то в нижней части окна будет показан этот промежуток времени в текстовом виде, а также указана примерная стоимость ремонта КЭ. Стоимость ремонта КЭ рассчитывается в зависимости от рыночной стоимости единицы измерения данного КЭ и его общего объема (площадь, штука и пр.). Для последней возможности в системе предусмотрена справочная таблица "Средняя стоимость ремонта элементов" (Рис.1.3.8).

Рис. 1.3.8
В этой таблице пользователем ведется список региональных рыночных цен для конкретных КЭ (за единицу измерения) на конкретную дату и в выбранной валюте. Данная возможность позволяет произвести быстый подсчет ремонта, скажем, кровли здания по рыночной цене.

Параметры - настройка параметров графика;

Рис. 1.3.9

Показывать все износы здания - если включено, то отображаются фактические износы из актов обследования технического состояния;
Оси как в ВСН 86-89 - оси Х и У меняются местами;
Трехмерный график - график износа представляется в объемном виде.

.topic 1008
При визуальном обследовании жилых зданий экспертом составляется акт обследования, в котором отражаются те или иные повреждения и дефекты, обследованных конструкций зданий, а также оценивается их физический износ в соответствии с действующими техническими регламентами (ВСН 53-86р).

Для фиксации полученных сведений в единой базе данных служит внешняя форма «Акт обследования технического состояния» (Рис. 2.3). Эта форма может быть использована также при осенне-весеннем осмотре зданий и сооружений. Полученная таким образом информация служит для оценки технического состояния обслуживаемого жилого фонда, прогнозирования его изменения, требуемых финансовых затрат на восстановление, а также моделирования различных вариантов эксплуатации жилого фонда.

При создании акта, необходимо указать для какого строения будет производиться обследование (Рис. 2.2). Выбор здания должен быть произведен обязательно, так как при вводе информации будут указываться конструктивные элементы выбранного здания. После выбора строения, будет автоматически сформирован акт, в котором буду перечислены все конструктивные элементы строения, включая вложенные, а также вычислены их нормативные износы (для правильного определения нормативного износа необходимо правильно указывать дату акта обследования).

Рис. 2.2

В акте обследования Вы можете описать повреждения и дефекты для любого конструктивного элемента и инженерного оборудования здания, а также определить их физический износ. Для более корректного ввода информации об износе элементов здания, осуществляется автоматический контроль корректности введенной информации в соответствии с ВСН 53-86р. Например, если Вы указываете физический износ несменяемого конструктивного элемента (например, стены, фундамента, лестниц или перекрытий) ниже, чем нормативный, система подсвечивает такие данные красным цветом.

Вы можете вносить в акт информацию о техническом состоянии не только конструктивных элементов, но и их составляющих (на рисунке – Отопление центральное состоит из арматуры, стояков, магистральных трубопроводов и радиаторов). Вы может и эти элементы разбить на еще более мелкие, вплоть до винтов и т.п. Глубина вложений зависит лишь от Вашего желания и здравого смысла.

Рис. 2.3

 Если у Вас задана группировка элементов здания (см. выше), то Вы можете сгруппировать элементы и в окне «Акта обследования», выбрав соответствующий пункт контекстного меню (Рис. 2.4).

Рис. 2.4

Рис. 2.5

Сгруппированные элементы показаны на рисунке (Рис. 2.5). В акте автоматически считаются износы группы, что иногда полезно для выявления наиболее изношенной инфраструктуры строения.

На закладке «Дополнительно» указываются такие характеристики акта, как эксперт, составивший акт и его комментарии, при этом «Акт обследования» остается документом, со всеми вытекающими отсюда последствиями. Вы можете определять состояние документа, дату смены состояния, приоритет, группу, класс, даты начала и окончания действия и местонахождение акта (№ папки или дела, ящик и пр.). Все эти характеристики позволяют осуществлять быстрый поиск технических документов, а также отслеживать сроки их действия.

Рис. 2.6

При необходимости акт обследования может быть выведен на печать (Рис. 2.7). При этом элементы, имеющие физический износ выше 60% будут выделены цветом.

Рис. 2.7

.topic 1009
Для внесения информации о ремонтных работах, выполненных на объектах, служит форма «Акт выполненных работ» (Рис. 2.8). При вводе акта указывается объект, на котором проводились работы, заказчик и исполнитель работ, а также общая сумма акта и краткий перечень элементов, на которых проводились работы (если необходимо).

Рис. 2.8

Перечень работ привязывается к выбранному объекту, поэтому для ввода перечня работ, естественно обязательно необходимо выбрать непосредственно объект. При вводе перечня работ для каждого элемента, можно задать стоимость ремонта, объемы работ, тип ремонта (текущий ремонт, содержание, капитальный ремонт и т.п.), а также вид работ, выбираемый из классификатора ремонтов.

Рис. 2.9

Кроме того, Вы можете описать работы, выполненные на объекте и указать период производства работ, гарантийный срок, а также являются ли работ непредвиденными и проведена ли по ним авансовая оплата. Все эти сведения могут быть использованы при формировании отчетов по выполненным работам.

На закладке «Дополнительно» указываются те же сведения что и у стандартной формы документов (состояние, язык, приоритет и т.п.).

.topic 1010
Одним из важных элементов анализа состояния жилищного фонда являются жалобы. Для ввода жалобы служит форма, показанная на рисунке (Рис. 2.10).

Рис. 2.10

На вкладке «Общая информация» указывается: кому адресована жалоба, от кого она исходит и кому отправлена копия (если необходимо), тип жалобы по классификатору жалоб, также такие характеристики как дата обращения и входящая дата, входящий номер, сроки рассмотрения и исполнения и комментарии к жалобе.

Рис. 2.11

На вкладке «Резолюции» (Рис. 2.11) могут быть добавлены распоряжения (резолюции, согласования и т.п.) руководства. Резолюции к жалобе являются вложенными документами и могут быть введены отдельно, но могут быть введены непосредственно в форме жалобы, что упрощает работу пользователя.

Вкладка «Объекты жалобы» служит для создания ссылок на объекты жалоб. Так как это именно ссылки на объекты, а не сами объекты, в базе данных они должны быть созданы заранее (или Вы можете их создать в окне выбора). Эта информация может быть использована для более тщательного анализа причин жалоб или проведенных ремонтов.

Вкладка «Перечень мероприятий» (Рис. 2.12) описывает мероприятия, которые требует провести жалующийся или организация, передавшая жалобу на рассмотрение (например, Администрация района) и сроки их исполнения.

Рис. 2.12

Для удобства ответа на жалобу или ее анализа Вы можете сослаться на нормативные акты, хранящиеся в базе. Для этого достаточно на вкладке «Ссылки на нормативные документы» сослаться на соответствующий документ.

 Примечание: Нормативные документы не поставляются с АИС «Дока», но Вы можете самостоятельно ввести карточки таких документов в базу данных. А если есть электронный вариант этих документов, то Вы можете хранить сами документы прямо в базе данных. Это необходимо проделать лишь один раз при настройке системы. В дальнейшем достаточно лишь связывать с ними другие документы.

 На закладке «Дополнительно» указываются те же сведения что и у стандартной формы документов (состояние, язык, приоритет и т.п.).

.topic 1011
Форма документа «Резолюции» служит для регистрации резолюций, согласований, виз и т.п. Как правило резолюция является вложенным документом и не может существовать без самого документа к которому она прилагается. Однако это не является ограничением для АИС «Дока». Вы можете создавать и резолюции или распоряжения, не относящиеся к конкретным документам, общий принцип работы с ними от этого не изменится.

На вкладке «Общие сведения» вводятся дата и номер (если есть) резолюции, а также указывается сама резолюция и сроки ее передачи и исполнения (Рис. 2.13).

Рис. 2.13

На вкладке «Исполнение» приводятся данные об исполнении резолюции: дата исполнения, ответ исполнителя и исполнена ли резолюция (Рис. 2.14).

Рис. 2.14

На закладке «Дополнительно» указываются те же сведения что и у стандартной формы документов (состояние, язык, приоритет и т.п.).

Примечание: Вы можете наложить ограничения на создание резолюций. Например, резолюции директора сможет вносить в базу данных только директор. В этом случае система позволит осуществлять и контроль за исполнением распоряжений, так как удалить или изменить революцию сможет только пользователь с соответствующими правами.

.topic 2000
Для работы с наборами коммунальных услуг необходимо выбрать здание, для которого предполагается создать набор, выделить его на левой панели рабочего окна «Объекты» и нажать кнопку   панели управления. В результате на экране будет открыто диалоговое окно «Наборы коммунальных услуг».

Рис. 1.2

Для создания нового набора услуг необходимо в открывшемся окне выбрать пункт меню «Услуги – Добавить набор услуг» (Рис. 1.3). Откроется окно набора услуг (Рис. 1.4).

Рис. 1.3

В поле «Название набора» необходимо ввести какое-либо название, однозначно определяющее набор, а в поле «Дата» - выбрать дату, с которой этот набор будет действовать.

Рис. 1.4

В результате этих действий в окне наборов услуг появится новый набор с введенными Вами характеристиками (Рис. 1.5).

Рис. 1.5

Имеющиеся наборы услуг могут быть отредактированы (изменены). Для этого в окне наборов услуг необходимо выбрать пункт меню «Услуги – Изменить», либо выделить мышью нужный Вам набор, щелкнуть на нем правой кнопкой мыши и в контекстном меню выбрать пункт «Изменить».

Кроме того, в конкретном наборе возможно добавлять, редактировать или удалять существующие в нем комунальные услуги, пользуясь пунктами главного меню или кнопками панели инструментов.

Устаревшие или ошибочно введенные наборы услуг могут быть удалены.

.topic 2001
Для создания (добавления) коммунальной услуги в наборе необходимо в окне наборов коммунальных услуг выделить нужный набор, затем выбрать пункт меню «Услуги – Добавить услугу», либо выделить мышью нужный Вам набор, щелкнуть на нем правой кнопкой и в контекстном меню выбрать пункт «Добавить – Добавить услугу». После этого откроется окно создания коммунальной услуги (Рис. 1.6).

Рис. 1.6

В окне создания (редактирования) коммунальной услуги необходимо заполнить поля:

Услуга – выбирается из классификатора услуг (например, Наем жилья Рис. 1.7 а);
Стоимость услуги – стоимость предоставленной услуги за определенный период времени (например, за 1 месяц) в рублях;
Объем услуги – натуральное выражение предоставленной услуги за этот же период времени;
Единица измерения – единица измерения объема услуги;
Поставщик услуги – субъект (организация), осуществляющая поставку услуги (выбирается из списка доступных субъектов-поставщиков Рис. 1.7 б).

После заполнения всех полей и нажатия кнопки ОК услуга будет сохранена в выбранном наборе. Наименование набора, к которому будет принадлежать услуга, можно проконтролировать по самому верхнему полю формы – «Набор услуг».

 _
а)__________________________________б)
Рис. 1.7
После создания набора коммунальных услуг, характерных для здания типовой серии, окно наборов услуг будет выглядеть следующим образом (Рис. 1.8).

Рис. 1.8

Используя пункты главного или контекстного меню, пользователь может добавлять, удалять или редактировать содержание услуг, входящих в текущий набор.

.topic 2002
Для работы с оплатами услуг необходимо выбрать здание, для которого предполагается вводить сведения об оплате, выделить его на левой панели рабочего окна «Объекты» и нажать кнопку   панели управления. В результате на экране будет открыто диалоговое окно «Оплата услуг».

Рис. 1.9

При выборе пункта главного или контекстного меню «Услуги – Добавить набор услуг» необходимо в окне наборов выбрать нужный Вам набор и нажать кнопку ОК. После этого в окне формы «Оплата услуг» будет добавлен подготовленный набор услуг с начислениями на текущую дату (Рис. 1.10). Причем, на текущую дату можно создать только один набор услуг.

В настоящем окне можно как вручную ввести данные о нужных услугах, так и воспользоваться заранее подготовленным набором.

Рис. 1.10
В этом окне по каждой услуге представитель управляющей компании вводит данные об оплатах и взаиморасчетах с поставщиками и жильцами.

Помимо услуг, добавленных из заранее подготовленного набора, пользователь может в окне «Оплата услуг» добавить новую услугу (пункт меню «Услуги – Добавить услугу»), изменить конкретную услугу, выделив ее в наборе (пункт меню «Услуги – Изменить»), либо удалить услугу из списка.

Редактирование (изменение) строки оплаты за коммунальную услугу возможно производить двумя способами:

Создание (редактирование) оплаты за коммунальную услугу в форме
Создание (редактирование) оплаты за коммунальную услугу в редакторе

В окне «Оплата услуг» пользователю доступны некоторые возможности, позволяющие структурировать услуги по различным критериям.

Так, в главном меню пользователь может выбрать пункт главного меню "Вид - Группировка» (Рис. 1.13) и сгруппировать услуги, например, по поставщикам.

Рис. 1.13

По окончании ввода данных обо всех оплатах и взаиморасчетах, пользователь может получить промежуточный отчет на выбранную дату платежей, выбрав пункт главного меню «Услуги – Печать отчета – Предварительный просмотр», либо нажать кнопку   панели инструментов. Причем содержание отчета будет сформировано в зависимости от выбранной группировки услуг.

Например, отчет по всем услугам (Рис. 1.14) или отчет по поставщику «ЖЭУ № 8 УК МУ МПП ЖКХ Ворошиловского района» (Рис. 1.15).

Рис. 1.14

Рис. 1.15

.topic 2003
Если в окне Оплаты услуг будет выбрана строка с конкретной услугой (например, Наем жилья, см рис.) и открыта для редактирования, то форма для ввода данных выглядит, как на Рис. 1.11.

Рис. 1.11

В окне создания (редактирования) оплаты коммунальной услуги необходимо заполнить поля:

Начислено – стоимость предоставленной услуги за определенный период времени (например, за 1 месяц) в рублях, автоматически заполняется из набора услуг (Стоимость услуги);
Объем - натуральное выражение предоставленной услуги за этот же период времени, автоматически заполняется из набора услуг (Объем услуги);
Оказано поставщиком – Стоимостное выражение оказанной поставщиком услуги, заполняется пользователем по факту оказания услуги поставщиком;
Оплачено населением – Платежи населения за пользование услугой за определенный период времени (например, за 1 месяц) в рублях, заполняется пользователем по факту получения оплат от населения;
Единица измерения - единица измерения объема услуги, автоматически заполняется из набора услуг;
Выполнено за счет экономии – Стоимостное выражение услуги, предоставленной за счет экономии, заполняется пользователем по факту;
Недопоставка - Стоимостное выражение услуги, недопоставленной населению поставщиком услуг, заполняется пользователем по факту недопоставки (согласно подписанным актам недопоставки);
Выставлено поставщиком – Денежные средства, выставленные поставщиком для оплаты, заполняется пользователем по выставленным счетам поставщиков;
Оплачено поставщику – Платежи управляющей компании поставщику, заполняется пользователем по факту оплат поставщикам.

.topic 2004
Если в окне Оплаты услуг будет выбрана вся группа на конкретную дату (как на рисунке) и открыта для редактирования (изменения), то форма для ввода данных будет представлена в виде табличного редактора, как на Рис. 1.12.

Рис. 1.12

При этом данные по всем услугам одновременно можно редактировать в одном окне, а также добавлять услуги, отсутствующие в наборе, и удалять услуги, ненужные на текущую дату.

После завершения редактирования необходимо сохранить данные, нажав ОК для подтверждения, или отменить изменения.

.topic 3000

Находится в разработке

.topic 2100
Конфигурация "Транспортно-экспдиционное обслуживание"предоставляет возможности обеспечения информацией транспортных компаний, осуществляющих перевозки грузов автомобильным транспортом. Система предусматривает учет клиентов, перевозчиков, подвижного состава, формирование договорных документов, подготовку отчетов и многое другое.

Создание договора-заявки (заявки)
Подвижной состав

.topic 2101
Форма договора-заявки (заявки) показана на рисунке 6.1

Рис. 6.1
Закладка "Общие" служит для заполнения основных данных, связанных с договором: номера, даты, названия документа, указания Перевозчика (Клиента) по договору и т.п. Маршрут перевозки может быть заполнен вручную, но также возможно формирование маршрута автоматически после заполнения раздела "Груз" (рис. 6.2).

Рис. 6.2
Раздел "Груз" заполняется в соответствии с предполагаемым маршрутом движения и с перевозимыми грузами. Для заполнения данного раздела необходимо добавить грузы нажатием кнопки   или с помощью комбинации "горячих клавиш" Ctrl+N. В открывшемся диалоговом окне (рис. 6.3) заполняются данные о грузе, местах и времени погрузки и разгрузки, грузоотправителях и грузополучателях и контактных лицах на погрузке (разгрузке). Заполняя данные о грузе, Вы можете использовать классификатор грузов, который позволит, при необходимости проанализировать работу компании с точки зрения объемов и видов перевозимых грузов. Выбор вида тары и способов погрузки производится из справочников, которые можно дополнить, что снижает риск опечаток и повышает скорость ввода информации.

Рис. 6.3
С помощью кнопок   и    Вы можете поменять порядок следования и, соответственно, порядок разгрузки груза, что будет учтено при печати договора-заявки (заявки).
Раздел "Подвижной состав" (рис. 6.4.) заполняется с использованием данных о подвижном составе, как об объекте, хранящемся в базе данных. Это позволяет избежать повторного ввода характеристик состава при формировании заявок и ускорить процесс подготовки данных для них. Заполняются разделы требуемого и выделенного подвижного состава. В случае несоответствия выделенного состава требуемым характеристикам (груоподъемности, объему), несоответствия будут подсвечены красным цветом.

Рис. 6.4
В разделе "Ставка, штрафы" (рис.6.5) заполняются данные о стоимости услуг, порядке расчетов, штрафах и их исчислении

Рис. 6.5
В разделе "Дополнительно" (рис.6.6) заполняются данные, аналогичные разделу "Дополнительно" стандартной формы документа.

Рис.6.6

.topic 2102
Подвижной состав хранится в базе данных как объект с определенными свойствами: маркой тягача и его номерным знаком, типом (маркой) полуприцепа и его номерным знаком, грузоподъемностью, объемом (рис. 6.7)

Рис. 6.7
Подвижной состав используется при формировании договоров-заявок и заявок к договорам транспортной экспедиции и договорам на организацию перевозок. Добавление нового подвижного состава аналогично созданию нового объекта. Создание заявок и договоров-заявок описано в соответствующем разделе настоящей документации.

.topic 100000
Внимание! Администрирование системы должно осуществляться системным администратором или ОЧЕНЬ квалифицированным пользователем!

Для поддержания АИС "Дока" в работоспособном состоянии разработан набор сервисных утилит, вызываемых из главного окна приложения (см. рис.).

Набор включает в себя:
Утилиту администратора, предназначенную для запуска и настройки набора сервисных приложений;
Менеджер пользователей, предназначенный для управления списком пользователей сервера Firebird (Interbase);
Менеджер групп пользователей, предназначенный для управления группами пользователей и назначением прав доступа к объектам базы данных для каждой группы;
Утилиту сервисного обслуживания, предназначенную для резервного копирования базы данных и ее восстановления из резервной копии;
Редакторы внешних классификаторов, внешних справочников и помощников, предназначенных для подключения дополнительных модулей системы и расширения ее функциональности;
Менеджер пользователей Коммуникатора, предназначенный для управления списком пользователей специальной утилиты - Коммуникатор;
Менеджер наблюдений, предназначенный для контроля за любыми таблицами структуры базы данных (например, классификаторами или справочными таблицами) и используется в системе, как Служба Безопасности;
Менеджер наборов, предназначенный для подготовки наборов данных, позволяющих впоследствии с их помощью автоматически создавать заданное количество новых Объектов (Субъектов, Документов, Адресов), включая в них вложенные;
Редактор скриптов, предназначенный для прямого изменения структуры базы данных.

.topic 100001
Утилита администратора предназначена для настройки и запуска набора сервисных приложений АИС "Дока". Рабочее окно утилиты содержит список сервисных приложений, имеет строку меню и панель инструментов, предоставляющих доступ к управлению каждым приложением (Рис.1.1).

Рис.1.1

Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, утилита администратора позволяет добавлять различные сервисные приложения без участия разработчиков путем подключения к системе форм ввода информации, отличных от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы необходимо в окне утилиты администратора выбрать пункт меню "Модули - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.2).

Рис.1.2
В форме диалога необходимо правильно заполнить поля:

Наименование модуля - Имя, под которым сервисное приложение появится в списке утилиты администратора;
Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма;
Форма (класс Delphi) – название класса формы в среде Delphi;
Значок - выбирается из списка;
Описание модуля - произвольный текст, описывающий назначение приложения.

После нажатия кнопки "Сохранить" новое сервисное приложение появится в списке утилиты администратора.

Нажатие кнопки   панели инструментов вызывает окно Свойств сервисного приложения, выделенного в утилите администрирования и содержащее две закладки (Рис.1.3).

 ___
Рис.1.3
Подробно работа с окном свойств описана нами ранее. В качестве особенности следует отметить, что если на закладке "Безопасность" для какого-либо пользователя будут отсутствовать разрешения на сервисное приложение, то этот пользователь либо вообще не увидит его в списке утилиты администрирования, либо не будет иметь возможности запустить его на выполнение.

Нажатие кнопки   панели инструментов позволяет запустить (Выполнить) выбранное сервисное приложение.

.topic 100004
Сервисное приложение "Сервисное обслуживание базы данных АИС "Дока" предназначено для выполнения таких задач, как:
создание резервной копии базы данных (копирование базы данных);
восстановление базы данных из резервной копии.

Для того, чтобы открыть "Сервисное обслуживание", необходимо запустить утилиту администратора, выделить в ней строку "Сервисное обслуживание" и нажать кнопку   ("Запустить"). Сервисное обслуживание будет доступно для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

Примечание: утилиту "Сервисное обслуживание" необходимо запускать на том компьютере, где находится база данных АИС "Дока", предоставленная в коллективное пользование.

На экран будет выведена форма (Рис.1.10).

Рис.1.10
При запуске утилита "Сервисное обслуживание" использует подключение к базе данных, назначенное в ярлыке для запуска АИС "Дока" (см. настройку ярлыков для работы с различными базами данных).

Если на закладке "Подключение" ввести имя и пароль администратора базы данных и нажать кнопку "Тест", то в окне информации сервера будут доступны сведения об SQL-сервере и подключенной базе данных (Рис.1.10).

Закладка "Упаковка" предназначена собственно для создания резервной копии базы данных системы (Рис.1.11).

Рис.1.11
Назначение полей закладки:
"Имя базы для упаковки" - автоматически подставляется путь к базе данных, к которой было выполнено подключение при запуске АИС "Дока";
"Имя упакованной базы" - местоположение и имя резервной копии базы данных. Местоположение может быть выбрано администратором самостоятельно. Имя содержит наименование базы данных, текущие дату и время создания копии базы данных.
"Сборка мусора" - удаление устаревших записей и освобождение пространства, занимаемого ими. Это часто уменьшает размер базы данных и улучшает производительность;
"Показывать отчет" - показывать/не показывать отчет о том, что происходит во время создания копии базы данных;
"Игнорировать контрольную сумму" - контрольная сумма игнорируется в процессе копирования. Этот переключатель может использоваться при повторном запуске копирования, которое аварийно завершилось из-за ошибки контрольных сумм;
"Сохранять только метаданные" - копируются только метаданные, данные не сохраняются. Этот переключатель может использоваться для быстрого получения "пустой" базы данных.

Нажатие кнопки "Начать" запускает операцию копирования базы данных и переключает форму на закладку "Отчет". Возможно проведение операции копирование во время работы пользователей с базой данных ("горячее" копирование).

Закладка "Восстановление" предназначена для восстановления базы данных из резервной копии (Рис.1.12).

Рис.1.12
Назначение полей закладки:
"Восстановить в ..." - возможные параметры: создать новую базу и восстановить поверх существующей базы данных. Исходя из соображений сохранности данных в настоящей утилите возможно восстановление только в новую базу данных. Перезаписывание базы данных, чья жизнеспособность Вас сильно волнует, не рекомендуется ни при каких условиях.
СОВЕТ: "Горячее" копирование - нормально. "Горячее" восстановление - большая глупость.
"Имя базы данных, куда производить восстановление" - местоположение и имя базы данных, в которую будут восстановлены данные из резервной копии (может быть выбрано администратором самостоятельно);
"Имя резервной копии базы" - имя и местоположение резервной копии базы данных, из которой будет производиться восстановление;
"Деактивировать индексы" - делает неактивными индексы в восстанавливаемой базе данных. Полезно при повторной попытке восстановления, когда первая попытка оказалась неудачной из-за ошибки индекса;
"Подтверждать транзакцию после распаковки каждой таблицы" - восстанавливает одну таблицу за один раз. Может быть использовано при частичном восстановлении, если база данных содержит разрушенные данные;
"Показывать отчет" - показывать/не показывать отчет о том, что происходит во время восстановления базы данных.

Нажатие кнопки "Начать" запускает операцию восстановления базы данных и переключает форму на закладку "Отчет".

.topic 100003
Сервисное приложение "Менеджер групп пользователей" предназначено для управления списком пользовательских групп сервера Firebird (Interbase). Для того, чтобы открыть менеджер групп пользователей, необходимо запустить утилиту администратора, выделить в ней строку "Менеджер групп пользователей" и нажать кнопку   ("Запустить"). Менеджер групп пользователей будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма со списком пользовательских групп сервера Firebird (Interbase) того компьютера, на котором находится подключенная база данных АИС "Дока" (Рис.1.8).

Рис.1.8
В этом окне администратор системы может добавлять новые группы пользователей, редактировать или удалять существующие. При добавлении или редактировании группы пользователей на экран выводится форма (Рис.1.9).

Рис.1.9
В форме диалога необходимо правильно заполнить поля:

Имя группы - Имя, под которым новая группа появится в списке пользовательских групп;
Описание - произвольный текст, описывающий назначение группы;
Скрипт назначения прав - создаваемый (редактируемый) администратором системы скрипт на языке SQL, назначающий данной группе пользователей права доступа к таблицам базы данных АИС "Дока". Скрипт назначения прав может быть загружен из файла или сохранен во внешнем файле при нажатии на кнопки   соответственно.

При создании (редактировании) текста скрипта администратор должен хорошо знать структуру базы данных, а также сам язык SQL.

После нажатии кнопки ОК новая группа пользователей будет добавлена в список Менеджер групп пользователей.

.topic 100002
Сервисное приложение "Менеджер пользователей" предназначено для управления списком пользователей SQL-сервера Firebird (Interbase). Для того, чтобы открыть менеджер пользователей, необходимо запустить утилиту администратора, выделить в ней строку "Менеджер пользователей" и нажать кнопку   ("Запустить"). Менеджер пользователей будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма со списком пользователей сервера Firebird (Interbase) того компьютера, на котором находится подключенная база данных АИС "Дока" (Рис.1.4).

Рис.1.4
В этом окне администратор системы может добавлять новых пользователей, редактировать или удалять существующих. При добавлении или редактировании пользователя на экран выводится форма (Рис.1.5).

В форме диалога необходимо правильно заполнить поля:
 На закладке "Информация":

Рис.1.5

Имя - произвольное имя пользователя (вводится ТОЛЬКО латинскими буквами);
Пароль - комбинация буквенных, цифровых и специальных символов, назначаемых каждому пользователю для подтверждения его подлинности. Пароль чувствителен к регистру ввода, т.е. Password, PassWord и Pa$$w0rd – это три разных пароля. Если Вы уверены, что вводите пароль правильно, а система выдает ошибку регистрации, то необходимо также проверить, на каком языке Вы его вводите;
Повторить пароль - необходимо повторно ввести пароль для проверки правильности ввода;
Поля из раздела "Личная информация" - являются описательными и необязательны для ввода.

На закладке "Членство в группах":

Рис.1.6
Необходимо выбрать принадлежность пользователя к стандартным группам пользователей (Рис.1.6):

Ограниченный доступ - обычные пользователи;
Обычный доступ - опытные пользователи;
Другой - администраторы, либо по выбору.

При выборе принадлежности пользователя к той или иной группе для него создаются или удаляются права на доступ к классам документов, объектов, субъектов и адресов.

Примечание: Несмотря на то, что администраторы получают полные права на доступ ко всем ресурсам АИС "Дока", необходимо после установки принадлежности пользователя к группе администраторов назначить для него права доступа к конкретным классам документов, объектов, субъектов и адресов. Для этого необходимо открыть соответствующий классификатор, выделить нужный класс и нажать кнопку "Изменить". Далее см. описание работы с закладкой "Безопасность".

После нажатии кнопки ОК новый пользователь будет добавлен в список Менеджера пользователей.

Если флажок "Добавить права пользователя в классификаторы" был включен, то операция по добавлению прав пользователя во все классификаторы выполнится автоматически. Это означает, что данный пользователь получит полный доступ ко всем объектам, субъектам, документам, адресам и связям в базе данных. Если же Вам необходимо ограничить даного пользователя в правах, сделайте это в соответствующих классификаторах, как это описано выше.

Если при вызове имеющегося пользователя на редактирование Вы изменяете ему имя, либо личную информацию, то при сохранении изменений система может выдать сообщение (Рис.1.7).

Рис.1.7
В этом случае при нажатии кнопки ОК в системе сохранится старый пароль.

.topic 100008
Сервисное приложение "Менеджер пользователей Коммуникатора" предназначено для управления списком пользователей встроенного средства связи системы "Коммуникатор".

С помощью него осуществляется:
сопоставление имен пользователей SQL-сервера Firebird (Interbase) со списком пользователей Коммуникатора. Это значит, что и на SQL-сервере и в Коммуникаторе должна присутствовать запись о пользователе с ОДНИМ И ТЕМ ЖЕ логином;
управление списком событий, выполняемых для каждого пользователя Коммуникатора.

Главное окно Менеджера пользователей Коммуникатора представлено на рис.1.20.1.

Рис.1.20.1
В левом окне представлен список пользователей Коммуникатора, на правой панели - список событий, выполняемых для этого пользователя. Здесь можно добавлять, изменять или удалять пользователей, а так же разрешать выполнение тех или иных событий для них.

При добавлении пользователя появляется предупреждающее сообщение (Рис.1.20.2).

Рис.1.20.2
Куда добавлять пользователя первым - в список SQL-сервера или Коммуникатора не важно. Главное, чтобы их логины в обоих списках совпадали.

Для добавление (редактирования) пользователя вызывается диалоговая форма (Рис.1.20.3).

Рис.1.20.3
Заполняемые поля:
Логин - имя для регистрации на SQL-сервере;
Фамилия, имя, отчество - данные о пользователе, используемые в Коммуникаторе при оповещениях;
Уведомлять о событиях - список выполняемых для конкретного пользователя событий. При установке маркера событие будет выполняться, при снятии - нет:
Сообщения от пользователей АИС "Дока" - разрешение (запрещение) приема сообщений;
Заметки с активным таймером - разрешение (запрещение) отслеживания списка запланированных пользователем задач;
Слежение за структурой АИС "Дока" - разрешение (запрещение) отслеживания изменений объектов базы данных.
Дополнительно - записи о пользователях, используемых для специальных целей:
Зарезервирован системой - специальные пользователи. Например, ALLUSERS - системный пользователь, предназначенный для отправки сообщений ВСЕМ пользователям одновременно, AISDOKA - системный пользователь, предназначенный для отслеживания событий изменения объектов базы данных (служба безопасности АИС "Дока").
Примечание - произвольное описание.

Добавить пользователей в список Коммуникатора можно также путем импортирования их из списка SQL-сервера. Для этого необходимо выбрать пункт меню "Пользователи - Заполнить таблицу пользователей". Из диалогового окна (Рис.1.20.4) выбрать нужных пользователей (допускается множественный выбор) и нажать кнопку ОК.

Рис.1.20.4
Информация о пользователях SQL-сервера будет перенесена в список пользователей Коммуникатора. Если импортируемый пользователь уже имеется в списке Коммуникатора, то информация о нем будет заменена. После этого следует заполнить для каждого нового пользователя раздел "Уведомлять о событиях" (Рис.1.20.3).

.topic 100009
Менеджер наблюдений является встроенным средством контроля системного администратора, либо другого пользователя, которому это будет поручено, за объектами  базы данных (БД), а также любыми таблицами ее структуры (например, классификаторами или справочными таблицами) и используется в системе, как Служба Безопасности.

В отличие от Мониторинга, с помощью Службы безопасности можно контролировать изменения ЛЮБЫХ таблиц или просмотров БД, совершенные ЛЮБЫМИ пользователями, а также фиксировать результаты этого контроля в журнале наблюдений.

Рабочее окно Менеджера наблюдений представлено на рис.1.21.1. Оно состоит из двух закладок:

Список триггеров наблюдения:

Рис.1.21.1
На этой закладке отображается имя пользователя, имя контролируемой таблицы, тип операции (Изменение, Удаление или Вставка), а также список полей таблицы, значения которых будут записаны в журнал наблюдений.
С помощью главного меню или кнопок панели инструментов можно совершать стандартные действия со списком триггеров - создавать либо удалять их.

Создание триггера наблюдения.

Журнал наблюдений:

Рис.1.21.2
На этой закладке отображаются записи журнала о действиях, произведенных с объектами БД. В частности, на рис.1.21.2 видно что 15.12.2007 г. Системный администратор удалил из таблицы "Объекты" объект OBJ_397 и изменил в таблице "Документы" документ DOC_11. Таким образом, с помощью журнала наблюдений можно всегда установить пользователя, совершившего несанкционированные действия с объектами БД.
В отличие от закладки со списком триггеров, отдельные записи в журнале наблюдений удалить нельзя, его можно полностью очистить, нажав на кнопку  .

Если Вы получили уведомление от Службы безопасности о совершенных манипуляциях с объектами структуры БД после того, как журнал наблюдений был открыт, то новые сообщения появятся в нем после нажатия кнопки "Обновить" (F5).

.topic 100010
Для создания нового триггера необходимо выбрать пункт главного меню "Смотритель - Добавить", либо нажать кнопку панели инструментов  .
На экран будет выведена диалоговая форма (Рис.1.22.1), в которой пользователь заполняет:

Рис.1.22.1
Объект (таблица или просмотр) - таблица базы данных, изменения которой необходимо контролировать. Выбирается в диалоговом окне рис.1.22.2 а);
Поля для документирования - список полей выбранной таблицы, значения которых будут записаны в журнал наблюдений. Выбирается в диалоговом окне рис.1.22.2 б);
Отслеживаемые действия - выбирается вид действий, совершаемых с контролируемыми таблицами базы данных.

 __
а)________________________________________б)
Рис.1.22.2

.topic 100015
Менеджер наборов предназначен для подготовки наборов данных для Объектов (Субъектов, Документов, Адресов), позволяющих впоследствии с их помощью автоматически создавать заданное количество новых Объектов, включая в них вложенные.

Например, с помощью набора "Здание" (Рис.1.24.1) в рабочем окне "Объекты" будет автоматически создано 3 здания с вложенными конструктивными элементами, помещенными во вложенную группу "Конструктивные элементы". С помощью набора "Квартиры" в выбранном здании будет автоматически создано 20 квартир, помещенных во вложенную группу "Квартиры" и пронумерованных "Квартира № 1", "Квартира № 2" и т.д.

Рис.1.24.1
Рассмотрим пример создания набора "Квартиры".
Для создания нового набора необходимо установить курсор (выделить) на нужном списке наборов - Наборы объектов, документов, субъектов или адресов. В нашем случае выделяем "Наборы объектов", выбираем пункт главного меню "Наборы - Добавить", либо нажимаем кнопку панели инструментов  . В диалоговом окне (Рис.1.24.2) заполняем:

Рис.1.24.2
Наименование - присваиваем наименование набору;
Класс - выбираем из классификатора наборов объектов. При желании можно в классификаторе создать класс "Квартира", но на работе системы это не отразится.

После нажатия кнопки ОК набор "Квартиры" появится в списке наборов объектов (Рис.1.24.1).

Далее устанавливаем курсор (Выделяем) созданный набор "Квартиры" и нажимаем кнопку панели инструментов  . В диалоговом окне (Рис.1.24.3) заполняем:

Рис.1.24.3
Класс элемента - выбираем из классификатора объектов класс помещения "Квартира";
Количество в наборе - вводим количество квартир, которые будут автоматически создаваться с использованием этого набора;
Необходим владелец - устанавливается в том случае, если создаваемым с помощью набора объектам необходим объект-владелец. В нашем случае квартирам необходим объект-владелец Здание. Для создаваемого объекта Здание владелец не нужен, поэтому это поле можно оставить пустым.

После нажатия кнопки ОК элемент набора "Квартира" появится в списке набора "Квартиры" (Рис.1.24.4). Кроме этого, внутри этого элемента появится папка "Метаданные".

Рис.1.24.4
Далее устанавливаем курсор (выделяем) папку "Метаданные", выбираем пункт главного меню "Наборы - Загрузить метаданные", либо нажимаем кнопку панели инструментов  . Внутрь папки "Метаданные" будет загружена структура объекта "Квартира" (VWFLATEDIT). Если выделить эту структуру в окне дерева объектов (на левой панели), то в правом окне мы увидим поля таблицы, ее описывающие (Сравните с описанием заполнения формы "Квартира"). Все заполненные в этом окне поля таблиц будут автоматически заполняться во вновь создаваемых квартирах здания. Для заполнения поля выделяем его левой кнопкой мыши, нажимаем Enter и вводим нужные данные.

В диалоговом окне (Рис.1.24.5) выделяем нужные поля и заполняем:

Рис.1.24.5
FULLNAME - Обязательное для заполнения поле. Под этим названием создаваемый объект появится в окне "Объекты". Обратите внимание на веденное на рис.1.24.5 значение: "Квартира № <IDX>". Служебный оператор <IDX> (Индекс) означает, что на его месте в создаваемых объектах появятся порядковые номера от 1 до количества элементов в наборе, заданные Вами (см. рис.1.24.3). Таким образом, квартиры автоматически будут пронумерованы от 1 до 20;
ID_USERGROUP - код пользовательской группы. При его вводе все квартиры будут сгруппированы во вложенной группировке элементов здания "Квартиры". Если бы мы создавали набор конструктивных элементов, то в этом поле следовало бы прописать код 3.0. Для любых других объектов в это поле вводятся значения из классификатора групп объектов;
ID_STATE - это поле рекомендуется оставлять пустым, т.е. значение 0 (Ноль) следует удалить;
все остальные поля заполняются по желанию пользователя. Следует учитывать, что при создании объектов из этого набора значения всех полей квартир будут заполнены одинаково (кроме FULLNAME) и далее каждую созданную квартиру необходимо будет редактировать вручную.

На этом создание набора завершено.

Аналогично создаются наборы, например, для зданий (Рис.1.24.1). Конструктивные элементы здания должны быть вложены в объект-владелец (Здание), метаданные создаются и заполняются как для самого здания, так и каждого конструктивного элемента.

Использование наборов.

.topic 100017
С использованием наборов можно создавать заданное количество объектов (субъектов, документов, адресов). Это значительно облегчает работу по созданию, например, большого количества однотипных зданий с вложенными конструктивными элементами, элементами благоустройства, квартирами, помещениями и пр. В дальнейшем пользователю необходимо открыть на редактирование каждое здание и изменить его индивидуальные характеристики (например, адрес).

Для создания объекта с использованием наборов необходимо выбрать пункт меню "Объект - Создать - Добавить из набора" (Рис.1.25.1), либо нажать кнопку   панели инструментов главного окна приложения "Мастер регистрации - Создание из набора".

1.25.1
В появившемся диалоговом окне Мастера (Помощника) - Первый шаг -  необходимо выбрать название нужного набора (в нашем случае "Здание") и нажать кнопку "Далее" (Рис.1.25.2).

1.25.2
Второй шаг Мастера предлагает выбираем владельца элементов набора (Рис.1.25.3). При использовании набора "Квартиры" здесь следует выбрать конкретное здание, в котором эти квартиры будут созданы. В нашем случае оставляем это поле пустым.

1.25.3
Третий шаг Мастера информирует о том, какие объекты и в каком количестве будут созданы (Рис.1.25.4). Из рисунка видно, что создаются 3 здания указанного класса с перечисленными конструктивными элементами.

1.25.4
Четвертый шаг Мастера информирует о том, что элементы, перечисленные на предыдущем шаге, уже созданы (Рис.1.25.5). При нажатии кнопки "Подтвердить" работа Мастера завершится и созданные объекты появятся в рабочем окне Объекты (Рис.1.25.6).

1.25.5
Если на этом шаге нажать кнопку "Назад" и затем "Далее", то в последнем окне Мастера количество создаваемых объектов удвоится, т.е. будет создано 6 зданий с вложенными КЭ.

Для отмены работы Мастера и удаления созданных объектов необходимо на последнем шаге (Четвертом) закрыть диалоговое окно Мастера нажатие на кнопку "Закрыть" (Х), расположенную в области заголовка окна.

1.25.6
В рабочем окне Объекты (Рис.1.25.6) созданы 3 здания с названием "5-этажное здание 1-3". Нумерация зданий задана в поле FULLNAME (Название) при описании метаданных этого объекта вводом строки "5-этажное здание <IDX>".

.topic 100018
При создании элементов наборов, Вы можете использовать встроенные переменные. Эти переменные могут быть использованы для автоматической нумерации создаваемых объектов или именования этих объектов по заданным правилам. Имена переменных должны быть вложены в угловые скобки. Ошибочно написанные имена не обрабатываются системой. Список переменных приводится ниже.

<IDX> 			номер по-порядку создания элементов одного класса
<IDXGLOBAL>		номер по-порядку создания всех элементов одного класса одного уровня
<Classname> 		название класса создаваемого элемента
<NOW>		текущие дата-время (может быть использована без угловых скобок - NOW)
<DATE>		текущая дата (в формате дд.мм.гггг)
<YEAR>		текущий год
<MONTH>		текущий месяц цифрой
<MONTHTEXT>	текущий месяц  словами в именительном падеже
<MONTHTEXT:1>	текущий месяц  словами в нужном падеже (1-именительный падеж, 2-родительный, 3-винительный, 4-дательный, 5-творительный, 6-предложный)

Примеры использования переменных:
Все переменные могут быть использованы при создании элементов наборов документов, объектов, субъектов, адресов. На основе метаданных с участием перменных набора Вы можете определить порядок формирования и заполнения значений  соответствующих элементов.
1. В разделе "Использование наборов" приведен пример создания зданий с вложенными квартирами. Здания и квартиры нумеруются в порядке создания с помощью переменной <IDX>, которая включена в название создаваемого элемента (здания или квартиры). Вложенные элементы (в примере квартиры) нумеруются в пределах вложения, т.е. квартиры, вложенные в здание №1, также как и квартиры, создаваемые в зданиях №2 и №3 будут нумероваться с цифры 1, так как принадлежат разным зданиям. При использовании переменной <IDXGLOBAL> квартиры будут нумероваться также в пределах одного здания, но в отличие от переменной <IDX> подряд будут пронумерованы все квартиры в пределах здания одно, двух и трехкомантные. При использовании <IDX> однокомантные пронумеруются отдельно, двухкомнатные отдельно и т.д.
2. Использование переменной <Classname> позволяет формировать название элемента в зависимости от его класса. Переменные, формирующие время или дату, позволяют автоматически заполнять поля соответствующего формата при создании элемента (например, дату документа). В приведеном ниже примере создается набор документов для формирования договора аренды: договор и приложения к договору - фотографии и схемы. На рисунке (1.26.1) показано, что название создаваемого документа будет сформировано как название класса документа (переменная <Classname>), в качестве даты документа будет использована дата и время создания (переменная <NOW>), кроме того будут заданы даты начала действия документа и дата изменения его состояния.

1.26.1
Схемы и фотографии, являющиеся вложением в данный документ нумеруются в порядке их создания (рис.1.26.2, 1.26.3)

1.26.2

1.26.3

Результат создания пакета документов показан на рисунке 1.26.4

1.26.4

.topic 100005
Сервисное приложение "Редактор внешних классификаторов" предназначено для подключения к системе дополнительных классификаторов, созданных самостоятельно без участия разработчиков и отсутствующих в стандартной поставке АИС "Дока". Для того, чтобы открыть редактор внешних классификаторов, необходимо запустить утилиту администратора, выделить в ней строку "Редактор внешних классификаторов" и нажать кнопку   ("Запустить"). Редактор внешних классификаторов будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма (Рис.1.13).

Рис.1.13
Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, редактор внешних классификаторов позволяет добавлять дополнительные внешние классификаторы, созданные самостоятельно без участия разработчиков. Для подключения нового классификатора необходимо в окне редактора внешних классификаторов выбрать пункт меню "Редактор - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.14).

Рис.1.14
В форме диалога необходимо правильно заполнить поля:
Заголовок меню - наименование пункта меню, под которым новый классификатор появится в списке Редактора внешних классификаторов, а также в главном меню АИС "Дока" "Сервис - Классификаторы";
Таблица классификатора - наименование таблицы базы данных, содержащей структуру и данные нового классификатора. Структура таблицы классификаторов описана в Руководстве администратора;

После нажатия кнопки "Сохранить" новый классификатор появится в появится в списке редактора внешних классификаторов, а также в главном меню АИС "Дока" "Сервис - Классификаторы" (Рис.1.15).

Рис.1.15

.topic 100006
Сервисное приложение "Редактор внешних справочников" предназначено для подключения к системе дополнительных справочников, созданных самостоятельно без участия разработчиков и отсутствующих в стандартной поставке АИС "Дока". Для того, чтобы открыть редактор внешних справочников, необходимо запустить утилиту администратора, выделить в ней строку "Редактор внешних справочников" и нажать кнопку   ("Запустить"). Редактор внешних справочников будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма (Рис.1.16).

Рис.1.16
Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, редактор внешних справочников позволяет добавлять дополнительные справочники без участия разработчиков путем подключения к системе форм ввода информации, отличных от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы необходимо в окне редактора внешних справочников выбрать пункт меню "Редактор - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.17).

Рис.1.17
В форме диалога необходимо правильно заполнить поля:

Наименование модуля - Имя, под которым сервисное приложение появится в списке Редактора внешних справочников;
Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма;
Форма (класс Delphi) – название класса формы в среде Delphi.

После нажатия кнопки "Сохранить" новый справочник появится в списке редактора внешних справочников, а также в главном меню АИС "Дока" "Сервис - Справочные таблицы".

.topic 100007
Сервисное приложение "Редактор внешних Помощников" предназначено для подключения к системе Помощников регистраци (Wizard), созданных самостоятельно без участия разработчиков и отсутствующих в стандартной поставке АИС "Дока". Для того, чтобы открыть редактор внешних Помощников, необходимо запустить утилиту администратора, выделить в ней строку "Редактор Помощников" и нажать кнопку   ("Запустить"). Редактор внешних Помощников будет доступен для выполнения только в том случае, если у текущего пользователя имеются достаточные права на его использование.

На экран будет выведена форма (Рис.1.18).

Рис.1.18
Учитывая тот факт, что АИС "Дока" построена с использованием модульной структуры, редактор внешних Помощников позволяет добавлять Помощники регистрации без участия разработчиков путем подключения к системе форм ввода информации, отличных от стандартных. Формы разрабатываются в среде программной разработки Borland Delphi и сохраняются в специальных библиотеках – пакетах. Для подключения созданной формы необходимо в окне редактора внешних Помощников выбрать пункт меню "Редактор - Добавить (Редактировать)". На экран будет вызван диалог вида (Рис.1.19).

Рис.1.19
В форме диалога необходимо правильно заполнить поля:

Наименование модуля - Имя, под которым сервисное приложение появится в списке Редактора внешних Помощников;
Пакет, в котором содержится форма – имя подключаемой библиотеки, в которой была сохранена форма;
Форма (класс Delphi) – название класса формы в среде Delphi.
Пользователь, для которого доступен помощник - имя пользователя SQL-сервера.

После нажатия кнопки "Сохранить" новый внешний Помощник регистрации появится в списке редактора внешних Помощников.

.topic 100011
Редактор скриптов является встроенным средством системы, предназначенным для прямого изменения структуры базы данных. С помощью него можно создавать (изменять, удалять) таблицы БД, поля таблиц,  триггеры,  процедуры и просмотры, а также, минуя приложение, изменять (удалять) данные, хранящиеся в таблицах БД.

ВАЖНО: При использовании редактора скриптов администратор должен хорошо знать структуру базы данных, а также язык SQL. Кроме этого, существует ограничение на использование оператора SELECT: собственно выборка будет выполнена, но выдача ее результата не предусмотрена (пока).

В редакторе используется стандартная подсветка синтаксиса (см. рис.1.23.1).

Рис.1.23.1

Скрипт может быть загружен из файла (сохранен в файл), а также вставлен из буфера обмена. Результаты выполнения скрипта отображаются в окне отчета.

.topic 100020
Нумераторы документов используются для автоматического формирования номера нового  документа. С помощью данной утилиты Вы сможете  описывать правила нумерации для любого класса документов, находящихся в базе данных. Кроме того, Вы также сможете изменить текущее значение любого счетчика (сбросить в 0, или задать новый номер), изменить шаг нумерации, задать маску для номера, создать новый счетчик в базе данных и многое другое. При создании документов автоматически формируется необходимая процедура в базе данных, с помощью которой создаются и формируются номера документов.
Окно, содержащее список созданных нумераторов показано на рисунке

Основные элементы окна позволяют создавать новые нумераторы, изменять или удалять существующие. Кроме того, Вы можете обновить список для просмотра нумераторов, созданных другими пользователями системы, а также обновить процедуру, осуществляющую создание номеров документов.

.topic 100021
Для создания нумератора выберите пункт меню Нумератор-Создать или нажмите кнопку  . После выполнения указанных действий вызывается форма, показанная на рисунке

В поле Название введите название нового нумератора. Название может быть введено на любом языке (русском или английском) и будет использовано при отображении нумератора в списке в окне нумераторов.
Маска используется для формирования номера с преопределенными свойствами. Например, номера, содержащего год создания документа или какой-либо символ, либо номер документа-владельца и т.п. Подробне о масках Вы можете узнать в соотвествующем разделе данной справочной системы.
Класс документа - класс или классы документов, которые будут нумероваться в соответствии  с создаваемым нумератором. Условие позволяет указать список классов или один класс будут использовать создаваемый (изменяемый) нумератор для формирования номера документа. Например, при условии starting with,  с помощью содаваемого нумератора будут нумероваться документы, классы которых начинаются с указанных символов. Таким образом Вы можете указывать всю ветку классов документов (например, "Договоры"), а не каждый класс в отдельности.
Название счетчика (генератора) - счетчик, хранящийся в базе данных и используемый для генерации очередного номера. Вы можете выбрать счетчик из списка. Если Вы хотите создать  новый счетчик для нумерации, нажмите соответствующую кнопку - Новый счетчик (генератор).

После ввода имени счетчика (генератора) и подтверждения операции нажатием кнопки ОК, он будет добавлен в базу данных и в список доступных счетчиков в окне создания (изменения) нумератора.
Внимание! Название счетчика вводится только латинскими символами! При использовании других языков не гарантируется корректная работа нумератора и создание счетчика.
Шаг счетчика - позволяет изменить шаг генерации номера.
Вы можете установить текущее значение счетчика, вписав его в соответствущее поле и нажав кнопку "Установить значение равное"
Описание - служит для ввода любой информации, позволяющей Вам описать работу нумератора и иной справочной информации.
Закладка "Нестандартный код" используется для формирования специфичного кода, используемого для создания специфичного номера документа.

При нажатии на кнопку   будет сформирован стандартный код тела процедуры, относящийся к редактируемому нумератору. Если Вы знаете, как должен быть сформирован номер документа и владеете минимальными знаниями языка DDL SQL, Вы сможете сами создать код для создания номера. В этом случае при формировании процедуры будет использован написанный Вами код. Для отказа от нестандартного подхода,  нажмите кнопку   или очистите текст в поле кода.
Внимание! В случае ошибки в написанном Вами коде, скрипт изменения процедуры сформирован не будет и процедура формирования номера документа останется без изменений.

.topic 100022
Для формирования номера документа Вы можете использовать маски. Типы масок, которые Вы можете использовать описаны ниже:
%g - вместо данной комбинации символов будет вставлен номер, сгенерированный выбранным счетчиком (генератором).
%n - данная комбинация символов будет заменена  номером документа-владельца. Например, заявки, создаваемые как часть договора могут нумероваться с использованием номера договора с помощью маски %n/%g - где %n - номер договора, %g - очередной номер заявки (1/1, 1/2, 1/3 и т.д.)
%y - последняя цифра года создания документа
%yy - две последних цифры года создания документа
%yyyy - год создания документа (4 цифры)
%mm - месяц создания документа в виде порядкового номера
%mmmm - месяц создания документа в текстовом виде (январь, февраль и т.п.)

.topic 100301
Коммуникатор, в первую очередь, является встроенным средством связи между пользователями приложения, работающими с общей базой данных и используется в системе, как Служба Сообщений.

Назначение Коммуникатора:
Отправка (прием) сообщений пользователям базы данных;
Отслеживание списка задач, запланированных пользователем;
Отслеживание изменений объектов базы данных;
Информирование пользователя при наступлении перечисленных событий.

Внимание! Для выполнения заявленных функций Коммуникатор должен быть запущен при подключении пользователя к базе данных и не закрываться до завершения работы с системой.

Запуск коммуникатора в зависимости от настроек производится автоматически, нажатием кнопки панели инструментов (Рис.2.1.1), либо выбором пункта меню "Сервис - Коммуникатор".

Рис.2.1.1

Рабочее окно коммуникатора показано на Рис.2.1.2.

Рис.2.1.2

Список пользователей

На левой панели в нижнем окне находится список пользователей базы данных, управление которым осуществляется с помощью Менеджера пользователей Коммуникатора. Подключившиеся к базе данных пользователи отмечаются в списке значком  (при условии, что у них запущен Коммуникатор). При подключении новых (отключении зарегистрированных) пользователей все, работающие в этот момент с базой данных пользователи, получают системные сообщения с указанием имен подключившихся (отключившихся ) и в окне списка видят изменение их статуса (значка).

Если в окне списка выбрать конкретного пользователя, нажать на нем правой кнопкой мыши, то появится контекстное меню, из которого можно отправить этому пользователю сообщение. Отправка сообщения возможна любому пользователю, в т.ч. "неактивному" (не подключенному к базе данных). Подключенный пользователь получит сообщение немедленно. "Неактивный" пользователь при следующем подключении к базе данных получит системное сообщение о том, что у него имеются непрочтенные сообщения. После этого он должен открыть папку "Входящие" и найти принятое сообщение.

Отправка сообщения.

Панель задач

На левой панели в верхнем окне находится панель задач со списком папок, реализующих основные функции Коммуникатора:

Входящие - папка для хранения принятых сообщений;
Исходящие - папка для хранения отправленных сообщений;
Задачи - папка со списком задач, запланированных пользователем;
Мониторинг - папка со списком объектов базы данных, взятых на контроль пользователем.

На правой панели рабочего окна Коммуникатора отображается список объектов папки, выбранной в окне панели задач.

.topic 100303
Для отправки сообщения необходимо:
Выбрать в списке нужного пользователя, нажать на нем правой кнопкой мыши и в контекстном меню выбрать "Отправить сообщение этому пользователю"; Или
В окне коммуникатора выбрать пункт меню "Оповещение - Создать - Новое сообщение"; Или
Выделить папку "Исходящие" и нажать кнопку   панели инструментов.
На экран будет выведена диалоговая форма (Рис.2.2.1), в которой пользователь заполняет:

Рис.2.2.1
Кому - выбирается пользователь - получатель, которому отправляется сообщение. Если сообщение создается путем выбора пользователя из списка Коммуникатора, то он автоматически подставляется в это поле. В ходе создания сообщения получатель может быть изменен. Отправка сообщения может быть осуществлена всем пользователям одновременно. Для этого в качестве получателя необходимо выбрать "Все пользователи АИС "Дока";
Текст сообщения - собственно то, что Вы хотите сообщить получателю;
Ожидается ответ - уведомляет получателя о том, что отправитель хочет получить ответ на свое сообщение. При этом и у отправителя в папке "Исходящие" и у получателя в папке "Входящие" сообщению присваивается статус "Важно" и оно помечается значком .
Вложения - в сообщении имеется возможность передать получателю информацию о том, к какому объекту базы данных она имеет отношение. Например, на рис.2.2.1 отправитель сообщает получателю, что он зарегистрировал в системе здание. Для присоединения вложения необходимо  нажать на кнопку выбора объекта базы данных  , соответствующую тому, что Вы хотите передать во вложении - Объект, Субъект или Документ и выбрать его. Информация о соответствующем объекте будет присоединена к сообщению. При этом и у отправителя в папке "Исходящие" и у получателя в папке "Входящие" в сообщении появляется пометка о вложении значком .

Обязательными для заполнения полями диалоговой формы являются "Кому" и "Текст сообщения".
Нажатие кнопки "Отправить" приведет к передаче сообщения.

.topic 100308
Папка "Входящие" предназначена для хранения принятых сообщений (Рис.2.3.1).

См. также Назначение Коммуникатора.

Рис.2.3.1
Если во входящем сообщении имеется вложенный объект базы данных, то при двойном щелчке левой кнопки мыши на нам будет открыто соответствующее рабочее окно (в случае, показанном на рис.2.3.1 - окно "Объекты") и курсор будет установлен на объекте-вложении.

Сообщения в окне списка автоматически группируются в зависимости от даты получения: "Сегодня", "Три дня назад", "Семь дней назад" и "Давно".

Прочтенные и непрочтенные сообщения маркируются разными значками, по которым их легко различить (Рис.2.3.2).

Рис.2.3.2
Если сообщение не видно в списке, а Вы знаете, что оно должно быть, то нажмите кнопку "Обновить" (или клавишу F5).

В окне списка сообщениями можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши (Рис.2.3.3), либо из главного меню "Оповещение". Для совершения каких-либо действий с сообщением его необходимо выделить левой кнопки мыши.

Рис.2.3.3
Просмотр сообщения.

Ответ на сообщение.

Конкретное сообщение удаляется выбором пункта "Удалить", а все сообщения - из главного меню "Оповещение - Удалить все входящие".

.topic 100309
При выборе пункта меню "Изменить" и "Просмотреть" вызывается обозреватель сообщений (Рис.2.3.4.).

Рис.2.3.4
В этом окне пользователь может только просматривать полученные сообщения.

.topic 100310
При выборе пункта "Ответить" создается новое сообщение, в котором в качестве получателя подставляется пользователь, чье сообщение Вы выбрали в папке "Входящие", а в тексте сообщения появляются слова: "Ответ на сообщение <Цитата>" (Рис.2.3.5).

Рис.2.3.5
Действия пользователя в этом диалоговом окне такие же, как и при отправке нового сообщения.

.topic 100311
Папка "Исходящие" предназначена для хранения отправленных сообщений (Рис.2.4.1).

См. также Назначение Коммуникатора.

Рис.2.4.1
Если в исходящем сообщении имеется вложенный объект базы данных, то при двойном щелчке левой кнопки мыши на нам будет открыто соответствующее рабочее окно и курсор будет установлен на объекте-вложении.

Сообщения в окне списка автоматически группируются в зависимости от даты получения: "Сегодня", "Три дня назад", "Семь дней назад" и "Давно".

В окне списка сообщениями можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши, либо из главного меню "Оповещение". Для совершения каких-либо действий с сообщением его необходимо выделить левой кнопки мыши.

При выборе пункта меню "Изменить" и "Просмотреть" вызывается обозреватель сообщений (Рис.2.3.4.).

Конкретное сообщение удаляется выбором пункта "Удалить", а все сообщения - из главного меню "Оповещение - Удалить все исходящие".

.topic 100317
Папка "Мониторинг" предназначена для хранения списка объектов базы данных, взятых на контроль пользователем (Рис.2.6.1). Пользователь может контролировать объекты базы данных - Объекты, Субъекты, Документы, Адреса.

См. также Назначение Коммуникатора.

Смысл контроля состоит в том, что если кто-либо из других пользователей создал, изменил или удалил какой либо объект базы данных, то пользователь, поставивший этот объект на контроль, получит уведомляющее сообщение о действиях, произведенных с контролируемым объектом, а также имени пользователя, совершившего эти действия.

Уведомляющие сообщения сохраняются в папке "Входящие" того пользователя, который контролирует выбранные им объекты базы данных.

2.6.1
В окне списка элементами мониторинга можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши, либо из главного меню "Оповещение". Для совершения каких-либо действий с элементом мониторинга его необходимо выделить левой кнопки мыши.

Создание (изменение) элемента мониторинга

Ненужные элементы мониторинга удаляется выбором пункта меню "Удалить".

.topic 100318
При выборе пункта меню "Создать (измененить) элемент мониторинга" вызывается диалоговая форма (Рис.2.6.2), в которой пользователь заполняет:

 __
а)______________________________________б)
2.6.2
Объект базы данных - объект контроля - Объект, Субъект, Документ или Адрес. В зависимости от выбранного здесь элемента изменяется следующий пункт "Наблюдать за...". Т.е. при выборе "Объект" следующий пункт будет выглядеть "Наблюдать за Объектом или Классом объекта;
Наблюдать за - выбирается конкретный объект базы данных, либо его класс (сравните рис.2.6.2 а) и б). Т.е. при выборе, как на рис.2.6.2 а), пользователю будет предложено выбрать для контроля конкретный документ ("Акт завершения работ №2") и контроль будет осуществляться ТОЛЬКО ЗА ЭТИМ документом. При выборе же класса документа "Акт завершения работ" (рис.2.6.2 б) - контроль будет осуществляться за ВСЕМИ документами этого класса, т.е. за всеми "Актами завершения работ".
Отслеживаемые действия - выбирается вид действий, совершаемых с контролируемыми объектами базы данных, которые пользователь желает отслеживать. Конкретный объект базы данных (например Документ) может быть либо изменен, либо удален. Для класса доступен пункт "Вставка" (Создание). Т.е. при выборе как на рис.2.6.2 б) пользователь получит уведомляющее сообщение о каждом вновь создаваемом документе "Акт завершения работ".
Наименование элемента - выбирается конкретный элемент для осуществления контроля. В случае, как на рис.2.6.2 а), будет открыто окно выбора документов, а при выборе, как на рис.2.6.2 б) - открывается классификатор документов.
Пользовательское сообщение - произвольное сообщение, относящееся к контролируемому объекту базы данных:
Если пользовательское сообщение будет выглядеть, как на рис.2.6.2 а), то служба сообщений передаст пользователю: "Кто изменил Акт №2 Документ изменен пользователем "Системный администратор ";
Если пользовательское сообщение не заполнять (оставить пустым), то уведомляющее сообщение выглядит как: "Изменен документ класса "Акт завершения работ". Наименование документа "Акт завершения работ №2 от 13.11.2007".  Документ изменен пользователем "Системный администратор ".

.topic 100314
Папка "Задачи" предназначена для хранения списка задач, запланированных пользователем. По своей сути это простой планировщик для напоминания пользователю о личных мероприятиях (Рис.2.5.1).

При наступлении времени выполнения Задачи системой выдается уведомляющее сообщение. Если в окне системного сообщения нажать левой кнопкой мыши на ссылке "Перейти", то будет открыта соответствующая папка Коммуникатора.

См. также Назначение Коммуникатора.

Рис.2.5.1
В окне списка задачами можно управлять либо из контекстного меню, вызываемого правой кнопкой мыши, либо из главного меню "Оповещение". Для совершения каких-либо действий с задачей ее необходимо выделить левой кнопки мыши.

Создание (изменение) задачи.

Ненужные задачи удаляется выбором пункта меню "Удалить".

.topic 100315
При выборе пункта меню "Создать (измененить) задачу" вызывается диалоговая форма, состоящая из двух закладок:
Закладка "Задача" - запись о задаче (напоминании) Рис.2.5.2, где:

Рис.2.5.2
Название - имя, под которым напоминание появится в списке задач;
Дата записи - по-умолчанию подставляется текущая дата;
Собственно текст задачи (напоминания).

Закладка "Оповещение" - настройка оповещения задачи (напоминания) Рис.2.5.3, где:

Рис.2.5.3
Включить - включение (отключение) оповещения о наступлении события "Задача";
Дата, время - когда напомнить о наступлении события "Задача";
Проиграть звук - вызывается звуковое оповещение для привлечения внимания. Звук можно выбрать;
Повторять - включение (отключение) режима повтора оповещения, а также его периодичности;
Дата окончания действия повторного оповещения - дата, после которой режим повтора оповещения снимается.